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Chapter 1. Unica Plan  and Unica Campaign 
Integration Guide
Contains information about the Unica Plan  and Unica Campaign  integration.

Introduction to the integration
Unica Plan  and Unica Campaign  to use the marketing resource management features of 

Unica Plan  to create, plan, and approve campaigns.

After integration, you manage campaigns, projects, offers, and Target Cell Spreadsheets in 

Unica Plan, for use within Unica Campaign. You create and run the flowcharts within Unica 

Campaign. Integration eliminates the need to enter cell information in both products.

Integration with Unica Plan
Unica Campaign  can be integrated with Unica Plan  to use its marketing resource 

management features to create, plan, and approve campaigns.

When Unica Campaign  is integrated with Unica Plan, many of the tasks that were previously 

done in a stand-alone Unica Campaign  environment are done in Unica Plan. You do the 

following Unica Campaign  tasks in Unica Plan  when the products are integrated.

• Working with campaigns:

◦ Creating campaigns

◦ Viewing campaigns

◦ Deleting campaigns

◦ Working with campaign summary details

• Working with Target Cell Spreadsheets

• Assigning offers to cells

• Specifying control cells

• Creating and populating custom campaign attributes

• Creating and populating custom cell attributes

Only top-down cells are editable in Unica Plan. Bottom-up cells are not editable in 

Unica Plan.
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These tasks are explained in the Unica Plan  and Unica Campaign  Integration Guide.

The following tasks are done in Unica Campaign  in both stand-alone and integrated 

environments:

• Creating flowcharts

• Running flowcharts

• Detailed analysis of campaigns/offers/cells

• Reporting on Campaign performance (depending on the reporting pack installed)

If offer integration is also enabled, you do the following tasks in Unica Plan:

• Designing offers

◦ Defining offer attributes

◦ Creating offer templates

• Creating, approving, publishing, editing, and retiring offers

• Organizing offers into offer lists and offer folders

For information about enabling offer integration, see the chapter on "Managing offers and 

offer templates in an integrated system". For more information about offers, see the Unica 

Campaign  guides for administrators and users.

Overview of the data transfer between Unica Plan  and Unica 
Campaign
The three main areas of data transfer are campaign data, cell data (in the TCS), and offer 

data. The transfer of data between the products is primarily one way, from Unica Plan  to 

Unica Campaign.

When integration is enabled, the name and code of the campaign project in Unica Plan  are 

the same as the name and code as the campaign in Unica Campaign. The campaign project 

in Unica Plan  is automatically linked to the corresponding campaign in Unica Campaign.

Integration eliminates the need for duplicate data entry. Unica Plan  provides a single view 

of all data and a single location to enter and edit data. You can view and edit shared data 
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only in Unica Plan. You use Unica Plan  to control when data that is required for campaign 

execution is published.

The ongoing transfer of data must be initiated from Unica Plan  through publishing. Unica 

Campaign  responds to requests for data (for example, retrieval of cell status information or 

campaign metrics) and receives data from Unica Plan  (for example, campaign attributes or 

TCS®  data). However, Unica Campaign  cannot send data to Unica Plan  if the data was not 

requested.

Campaign data transfer

In Unica Plan, you can define any number of custom campaign attributes and place them on 

a campaign project template, along with standard campaign attributes. You enter data for 

these attributes in Unica Plan  and manually publish the data to Unica Campaign. In Unica 

Campaign, these campaign attributes are available as generated fields within the flowchart 

and for reporting and analytics. The Unica Plan  user controls when a campaign is created in 

Unica Campaign  and when campaign attribute data is published to Unica Campaign. Unica 

Campaign  always uses the last set of published campaign attributes.

Cell data transfer

The second major area of ongoing data transfer is the Target Cell Spreadsheet. The TCS® 

manages cell-level information for target and control cells, including cell names, cell 

codes, assigned offers, control cell linkages, and custom cell attributes. The transfer of cell 

definitions from Unica Plan  to Unica Campaign  and the transfer of cell status back to Unica 

Plan  can be iterative. Companies often require several cycles before cell definitions and 

counts are finalized, rows of the TCS®  are individually approved, and the campaign is ready 

to be run.

Offer data transfer

For systems that enable offer integration, the third major area of ongoing data transfer is 

offer data. Offers are created in Unica Plan. When a new offer is created in Unica Plan, the 

offer state is Draft. Changing the state of an offer to Published pushes the offer instance 

to Unica Campaign. The first publish creates the offer in Unica Campaign; subsequent 

publishing updates the offer instance in Unica Campaign.
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Similarly, changing the state of an offer template to Published pushes both the offer 

template and any offer attributes that you defined in Unica Plan  to Unica Campaign.

When you initially enable offer integration, you can import any pre-existing offer metadata 

and data into Unica Plan  from Unica Campaign. See Importing offers from Unica Campaign 

(on page 73).

Differences between integrated and stand-alone Unica Campaign
When Unica Campaign  is integrated with Unica Plan, the Unica Campaign  installation differs 

from a stand-alone installation.

• The only way to create or access campaigns (other than campaigns created before 

you enabled integration) is through the corresponding Unica Plan  project. The All 

Campaigns  page in Unica Campaign  displays only campaigns that were created 

before integration was enabled.

• The Target Cell Spreadsheet (TCS®) and custom cell attributes are created, viewed, 

and managed solely in Unica Plan. Custom cell attributes are defined in a "campaign 

project" template. As a result, each type of campaign can have different custom cell 

attributes, or present custom attributes in a different order. By contrast, in stand-alone 

Unica Campaign, all campaigns have the same cell attributes in the same order.

• The TCS®  can be top-down or bottom-up. Bottom-up cells are allowed for integrated 

Unica Plan-Unica Campaign  systems when the MO_UC_BottomUpTargetCells  setting 

is Yes (Settings > Configuration > Unica  > Unica Campaign  > partitions > partition[n] > 

server > internal).

• If the  Bottom-up TCS  setting is Yes, flowcharts can be run in production mode in 

Unica Campaign  even if they are not linked to top-down cells in the TCS®.

• The Summary tab for campaigns does not exist in Unica Campaign. To see summary 

information for a campaign, view the Campaign Summary section of the Summary tab 

in the campaign project in Unica Plan. The offer and segment information displays 

in a new Segments/Offers tab in Unica Campaign. Because you manage campaign 

project templates in Unica Plan, each campaign template can have a different set of 

campaign custom attributes. These custom attributes can be organized on one or 

more tabs within the project.
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You also can take advantage of the more robust attribute features in Unica Plan. 

These features include options for layout, identifying attributes as required versus 

optional, making lists conditional in the user interface, and dynamic data values 

from database tables. In stand-alone Unica Campaign, all campaigns have the same 

custom campaign attributes in the same order.

• When offer integration is enabled by setting  Unica Plan  - Offer integration  to Yes 

(Settings > Configuration > Unica  > Platform), you cannot create or work with offer 

templates or offers in Unica Campaign. Instead, you use Unica Plan  to create offer 

templates and to create, modify, approve, publish, or retire offers. Offer templates and 

approved offers can then be published to Unica Campaign  for use.

Note:  Offer integration is a separate option from campaign integration. When 

campaign integration is enabled, offer integration can also be enabled. For 

more information, see Enabling offer integration in Unica Plan  (on page 

72).

Differences between integrated and stand-alone Unica Plan
If Unica Campaign integration is enabled, you manage campaign projects in Unica Plan 

and take advantage of tightly coupled Unica Campaign  features. If offer integration is 

also enabled, you can manage offer lifecycles in Unica Plan  and publish offers to Unica 

Campaign.

Campaign project management

If Unica Campaign integration is enabled, users create projects in Unica Plan  from 

campaign project templates.

In a stand-alone Unica Plan  installation, campaign project templates are not available 

for creating new projects. In a stand-alone installation, you can create project templates 

to use for administering marketing campaigns. However, these objects do not link to 

a corresponding campaign or Target Cell Spreadsheet in Unica Campaign. There is no 

integration with offers, and no metrics are passed for campaign contacts and responders.
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With an integrated installation, campaign projects have icons and links that initiate data 

transfers with Unica Campaign  and that navigate to and from the corresponding campaign 

in Unica Campaign.

Offer lifecycle management

If campaign integration is enabled, then you can also enable offer integration. If offer 

integration is enabled (Settings  > Configuration  > HCL Unica  > HCL Unica Platform), you 

use Unica Plan  exclusively for offer lifecycle management. You use Unica Plan  to create 

offer templates and to create, modify, approve, publish, or retire offers. Approved offers can 

be published to Unica Campaign  for use.

License and permission issues for Unica Plan  and Unica 
Campaign  integration
When Unica Plan  and Unica Campaign  are integrated, every person who is involved in the 

design, creation, and execution of the campaign needs a Unica Plan  license.

The team members who work exclusively in Unica Campaign  such as flowchart developer, 

need a Unica Plan  license so they can receive workflow notifications and access 

campaigns. In an integrated environment, the only way to access a campaign is through 

Unica Plan.

Some actions in a Unica Plan  campaign project require a Unica Campaign  permission. 

You can create a role in Unica Campaign  that grants these permissions and assigns the 

role to users who work in Unica Plan. The following table lists the actions and the required 

permissions:

Table  1. Permissions required for campaign actions

The following two-columned table describes action in one column, and required 

Campaign permissions in the second column.

Action Required Unica Campaign  permission

Create linked campaign Create Campaign
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Table  1. Permissions required for campaign actions

The following two-columned table describes action in one column, and required 

Campaign permissions in the second column.

(continued)

Action Required Unica Campaign  permission

Update linked campaign Edit campaign

Publish TCS® Manage campaign target cells

Get cell run status Manage campaign target cells

Search for and assign offers in TCS® View offer summary

Import metrics Analyze campaign

Disable and re-enable integration
Although it is possible to disable integration after you enable it, it is best to avoid this action 

if possible.

Disabling Unica Plan-Unica Campaign  integration

If you disable Unica Plan  and Unica Campaign  integration, Unica Campaign  reverts to its 

stand-alone behavior and appearance. However, there are several important issues to keep 

in mind:

• To access flowcharts that are associated with integrated campaigns after you disable 

the integration, you must publish all campaigns in Unica Plan  before you turn off 

the integration. The campaigns are then available in the top-level folder in Unica 

Campaign.

• If you disable the integration, there is no navigation link between campaign projects 

and campaigns. Users can still access their campaign projects, but the icons for 

creating and updating campaigns are disabled. The options for publishing TCS®  data 

and getting cell status are not available. Campaign project templates are not included 

in the list of templates that users see.
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• If you want to re-enable integration, contact technical support to discuss the 

implications. Any changes that are made to campaigns while integration is disabled 

are overwritten the first time you update the campaign or publish the TCS®  from 

within Unica Plan  after you re-enable the integration.

Disabling offer integration

Try to avoid disabling offer integration, as this action can lead to inconsistent data. For 

example, an offer is created in Unica Plan  and published to Unica Campaign. After offer 

integration is turned off, that offer is modified in Unica Campaign. If offer integration is 

turned on again, the change that is made in Unica Campaign  is not synchronized with 

Unica Plan. Unica Plan  does not have the updated offer information, even if offer data is 

reimported from Unica Campaign. The transfer of data between the products is primarily 

one way, from Unica Plan  to Unica Campaign.

Integrating Unica Plan  and Unica Campaign
The workflow for integrating Unica Plan  and Unica Campaign  consists of the following 

steps.

Complete the following steps to integrate Unica Plan  and Unica Campaign.

1. Install both Unica Plan  and Unica Campaign. For details, see the Unica Plan 

Installation Guide  and the Unica Campaign  Installation Guide.

2. Adjust the configuration settings to support an integrated deployment. See 

Configuring property settings for integrated deployment  (on page 9).

3. Design the attributes, forms, and campaign project templates that you need.

If offer integration is enabled on your system, you also design offer templates by 

using offer attributes. See Offers and offer templates in an integrated system  (on 

page 70).

4. Create the shared attributes.

5. Create the forms and local attributes, including the form that contains the Target Cell 

Spreadsheet.
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6. Create a metrics map file that associates Unica Campaign  contact and response 

counts with Unica Plan  metrics.

7. Create the campaign project and offer templates.

Configuring property settings for integrated deployment
When Unica Plan  and Unica Campaign  are integrated, you use Unica Plan  to plan, create, 

and approve campaigns.

For systems that enable offer integration, features for offer lifecycle management are added 

to Unica Plan. See Enabling offer integration in Unica Plan  (on page 72).

To integrate Unica Plan  and Unica Campaign, set the following properties.

1. On the Settings  > Configuration  page, under HCL Unica, click Unica Platform.

2. Click Edit Settings  and set Plan - Campaign  integration to True. This setting enables 

integration so that you can use Unica Plan  to create, plan, and approve campaigns.

3. If your Unica Campaign  installation has multiple partitions, set the properties for 

each partition where you want to enable integration. Expand HCL Unica  > Campaign  > 

partitions  > partition[n]  > server  and click internal.

4. Click Edit Settings  and set MO_UC_integration  to Yes. This setting enables Unica 

Plan-Unica Campaign  integration for this partition.

Note:  To set either of the next two options to Yes, you must first set 

MO_UC_integration  to Yes. The following options apply only when 

MO_UC_integration  is enabled.

5. Optional:  Set MO_UC_BottomUpTargetCells  to Yes.

When MO_UC_integration  is enabled, TCS®  cells that are created from Unica Plan 

are always top-down. To allow for bottom-up Target Cell Spreadsheet cells for this 

partition, set this property to Yes. When set to Yes, both top-down and bottom-up 

target cells are visible, and a Get Bottom Up Cells  control is available in the Unica 

Plan  Target Cell Spreadsheet. This control gets bottom-up cells that are created in 

Unica Campaign  into Unica Plan. The bottom-up cells are read-only in Unica Plan, and 

cannot be published back to Unica Campaign  from Unica Plan.
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6. Optional:  Set Legacy_campaigns  to Yes.

This setting enables access to campaigns created before integration, including 

campaigns that were created in Affinium Campaign 7.x and linked to Affinium Plan 7.x 

projects.

7. Repeat steps 4-6 for other partitions as needed.

8. Expand HCL Unica  > Plan  > umoConfiguration  and click campaignIntegration.

9. Click Edit Settings  and set the defaultCampaignPartition.

When Unica Plan  and Unica Campaign  are integrated, this parameter specifies the 

default Unica Campaign  partition to use when the campaign-partition-id is not defined 

by the project template. The default is partition1.

10. Set the webServiceTimeoutInMilliseconds  for Web Services integration API calls.

This parameter is used as a timeout for web services API calls.

Continue with the steps for Enabling offer integration in Unica Plan  (on page 72).

Navigating from a linked legacy campaign to a Unica Plan  project
Legacy campaigns are campaigns that were created in Unica Campaign  before enabling 

integration with Unica Plan.

Follow this procedure if you are using an integrated system and you want to access 

campaigns that were created prior to the integration.

In an integrated environment, Unica Campaign  can be configured to access the following 

types of legacy campaigns:

• Campaigns that were created in stand-alone Unica Campaign  (whether in the current 

or a previous version of Unica Campaign) before integration was enabled. These 

campaigns cannot be linked to Unica Plan  projects.

• Campaigns that were created in Affinium Unica Campaign  7.x and linked to Affinium 

Plan 7.x projects. Functionality of these campaigns remains unchanged from 

version 7.x of these products, based on the data mapping between attributes in both 

products.
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You can use Unica Campaign  to access and work with both types of legacy campaigns, 

even after enabling the integration.

1. Select Campaign > Campaigns.

The All campaigns  page opens, displaying the folders or campaigns in the current 

partition. Only legacy campaigns are listed.

To view campaigns created with the Unica Plan-Unica Campaign  integration enabled, 

click the Campaign projects  folder. If there are no legacy campaigns or legacy 

campaigns have not been enabled in the configuration, this page is empty.

2. Click the name of the campaign that you previously linked to a project in Unica Plan  or 

Affinium Plan.

The campaign opens to its Summary  tab.

3. Click the name of the project in the Parent items and code  field.

Unica Plan  opens, and displays the Summary  tab of the linked project.

4. To return to Unica Campaign, click the name of the project in the Supporting projects 

and requests  field in Unica Plan.

Unica Plan  documentation and help
Different people in your organization use Unica Plan  to accomplish different tasks. 

Information about Unica Plan  is available in a set of guides, each of which is intended for 

use by team members with specific objectives and skill sets.

The following table describes the information available in each guide.
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Table  2. Guides in the Unica Plan  documentation set

The following three-column table describes tasks in one column, guide names in the 

second column, and audience in the third column.

If you See Audience

• Plan and manage 

projects

• Establish workflow 

tasks, milestones, and 

personnel

• Track project expens

es

• Get reviews and ap

provals for content

• Produce reports

• Create to-dos and 

checklists

Unica Plan  User's Guide • Project managers

• Creative designers

• Direct mail marketing 

managers

• Marketers

• Design templates, 

forms, attributes, and 

metrics

• Customize the user in

terface

• Define user access 

levels and security

• Implement optional 

features

• Configure and tune 

Unica Plan

Unica Plan  Administrator's 

Guide

• Project managers

• IT administrators

• Implementation con

sultants
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Table  2. Guides in the Unica Plan  documentation set

The following three-column table describes tasks in one column, guide names in the 

second column, and audience in the third column.

(continued)

If you See Audience

• Create marketing cam

paigns

• Plan offers

• Implement integration 

between Unica Plan 

and Unica Campaign

• Implement integration 

between Unica Plan 

and  IBM Digital Rec

ommendations

Unica Plan  and Integration 

Guide

• Project managers

• Marketing execution 

specialists

• Direct marketing man

agers

• Learn about new sys

tem features

• Research known is

sues and workarounds

Unica Plan  Release Notes® Everyone who uses Unica 

Plan

• Install Unica Plan

• Configure Unica Plan

• Upgrade to a new ver

sion of Unica Plan

Unica Plan  Installation Guide • Software implementa

tion consultants

• IT administrators

• Database administra

tors

Create custom procedures 

to integrate Unica Plan  with 

other applications

Unica Plan  Integration Mod

ule  and the API JavaDocs 

available when you click Help 

> Product Documentation  in 

Unica Plan, and then down

load the UnicaPlan<ver

• IT administrators

• Database administra

tors

• Implementation con

sultants
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Table  2. Guides in the Unica Plan  documentation set

The following three-column table describes tasks in one column, guide names in the 

second column, and audience in the third column.

(continued)

If you See Audience

sion>PublicAPI.zip  file 

for the SOAP API and Uni

caPlan<version>Publi

cAPI-RestClient.zip  for 

the REST API.

Learn about the structure of 

the Unica Plan  database

Unica Plan  System Schema Database administrators

Need more information 

while you work

• Get help and search or 

browse the  User's, Ad

ministrator's, or  Instal

lation  guides: Click Help 

> Help for this page

• Access all of the Unica 

Plan  guides: Click Help 

> Product Documenta

tion

• Access guides for all 

Unica  products: Click 

Help > All Unica  Suite 

Documentation

Everyone who uses Unica 

Plan

Unica Campaign project template design
You can create as many campaign project templates as you want. For example, you might 

want to create a separate campaign project template for each type of campaign that you 

run.
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You create a separate template for each unique combination of forms you need. For 

example, if you need to gather different information to define your target cells for some 

campaigns, you create different Target Cell Spreadsheets (TCS®). Then, associate each 

TCS®  with a different template. Similarly, if some custom campaign attributes are relevant 

only for certain types of campaigns, you can create different campaign project templates. 

You can create separate templates to control custom campaign attributes, the attribute 

display order, and their organization on tabs.

Design your campaign project templates, forms, and attributes
Before you begin creating objects in Unica Plan, you plan and design your campaign project 

templates and the forms and attributes they require.

The result of the design process is a list of attributes and forms to create and details about 

them, such as:

• Whether an attribute is suited for use on multiple forms (shared) or on a single form 

(local)

• Whether users select from data that is supplied by a table, a list of items you define, or 

enter text directly for an attribute

• What constraints are needed on the user interface field, and whether an offer attribute 

must be parameterized (editable) when added to a form, or set to static or hidden 

static

Campaign attributes and cell attributes must be shared attributes. Form and grid attributes 

can be either shared or local.

Target Cell Spreadsheet and other forms
By default, projects have the following tabs: Summary, People, Workflow, Tracking, 

Attachments, and Analysis. If the Financial Management module is installed, projects also 

have a Budget tab.

In a campaign project, the Summary tab includes a set of fields for basic campaign 

information. You cannot remove or reorder these basic campaign attributes.
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If you want to enable users to enter more information about the project, you must create 

forms and add the forms to the project template. Each form displays on the Summary tab or 

on another tab in projects that are created from that template.

All campaign project templates must have a TCS®  form. Other forms are optional.

Campaign Summary section
All campaign projects contain a Campaign Summary  section on the Summary  tab.

The Campaign Summary  section contains the following default campaign attributes:

Table  3. Default campaign attributes on the Campaign Summary section

The following two-columned table contains attributes in one column and field 

description in the second column.

Attribute Field Description

Campaign description Text field

Campaign start date Date field

Campaign end date Date field

Campaign objective Text field

Campaign initiative Text field

Campaign security policy Drop-down list with all the security poli

cies defined for Unica Campaign

The default campaign attributes do not display in the list of campaign attributes on the 

Shared Attributes  page in the Administrative Settings and cannot be edited.

Target cell spreadsheets
A Target Cell Spreadsheet (TCS®) is an editable grid component that has a set of 

predefined attributes. You use Target Cell Spreadsheets when Unica Plan-Unica Campaign 

integration is enabled.
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The TCS®  specifies the data that users must enter in a campaign project to define the 

target and control cells for the campaign. Each column on the TCS®  corresponds to an 

attribute. Values for the predefined, or default, attributes are automatically passed to Unica 

Campaign. In addition to these default attributes, you can add an unlimited number of 

custom attributes to a TCS®.

Cell attributes and grid attributes

A TCS®  can contain attributes that get passed to Unica Campaign  (cell attributes) and 

attributes that display only in Unica Plan  (grid attributes).

Use cell attributes for information you want to pass to Unica Campaign. For example, 

attribute values you want to include in an output list, contact history, or report must be 

created as cell attributes.

Use grid attributes for descriptions, calculations, and data that is not needed in Unica 

Campaign.

Target Cell Spreadsheets and forms

You add a TCS®  to a form by creating a new editable grid and identifying it as a TCS®. (The 

form can contain other attributes in addition to the TCS®.) When you place a TCS®  grid 

component on a form, it contains the default cell attributes. You cannot delete the default 

attributes.

Transfer of cell attribute data

When a user links a flowchart cell to the TCS®  row, the data values supplied for the default 

attributes are passed to Unica Campaign  automatically. Custom cell attributes are available 

automatically in Unica Campaign  as Unica Campaign  Generated fields in contact processes. 

For details on Generated fields, see the Unica Campaign  User's Guide.

Target Cell Spreadsheets and templates

Each campaign project template can contain only one TCS®.
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Default cell attributes for Target Cell Spreadsheets
All TCS®  grids include the predefined cell attributes by default. These attributes are 

available specifically for use in a TCS®  grid, and not displayed on the Shared Attributes 

page.

Descriptions of how these attributes display to users in a campaign project follow.

Table  4. Default cell attributes

The following three-columned table describes cell names in one column, publish 

requirements in the second column, and their description in the third column.

Name

Required 

to publish 

the TCS®?

Description

Cell Name Yes Text field.

Cell Code No Text field.

Description No Text field.

Is Control Cell Yes Drop-down list with Yes and No options.

Control Cell No Drop-down list of control cells.

Assigned Of

fers

No A selection control that you can use to select one or 

more offers or offer lists.

Is Approved No Drop-down list with Yes and No options. This column 

is included only if Approval required  is checked in the 

campaign project template.

Flowchart No Read-only field that displays the name of the flow

chart in which the cell is used.

Last Run No Read-only field that displays the date and time that 

the flowchart that contains this cell was last run.
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Table  4. Default cell attributes

The following three-columned table describes cell names in one column, publish 

requirements in the second column, and their description in the third column.

(continued)

Name

Required 

to publish 

the TCS®?

Description

Actual Count No Read-only field that shows the last run count for this 

cell (count of unique audience IDs in the cell).

Run Type No Read-only field that shows the run type for the last run 

for the flowchart that contains this cell (production or 

test; flowchart, branch, or process box).

After you add a TCS®  grid, you can edit the Attribute Display Name, Description, and some 

of the other properties for the individual cell attributes. You cannot edit the predefined 

values for these properties:

• Attribute Category

• Attribute Type

• Attribute Internal Name

• Attribute Display Name

• Attribute Database Column Name

• Can group by

• Form Element Type

• Special behavior

Designing offer templates
If offer integration is enabled, you can create offer templates in Unica Plan  to guide users in 

creating offers. To work with offer templates, you design the templates first and then create 

the custom offer attributes and forms that are used to build them.
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Note:  For more information about administering and by using offers, see the Unica 

Campaign  guides for administrators and users.

1. When you are ready to create an offer template, select Settings  > Plan Settings  > 

Template Configuration  > Templates.

2. Complete the options in the Offer Templates  section.

3. You can import from Unica Campaign  any pre-existing offer templates, attributes, 

offers, offer lists, and offer folders.

Including  IBM Digital Recommendations  categories
In Unica Plan, administrators can configure offer templates to populate category data that 

uses  IBM Digital Recommendations.

The server that hosts Unica Plan  must have internet connectivity that is enabled. When 

users create offers from these templates, they choose a client ID and category IDs and 

names from lists instead of entering them manually.

To implement this feature in an offer template:

1. Select the Use Offer Integration  check box.

2. Supply the URL  for Digital Recommendations.

Note:  After users create offer instances from this template, do not change the 

supplied URL.

3. Specify Client IDs: you can enter values then Add  them, or you can Import  values from 

a previously defined list. See Defining the client list  (on page 21).

When users create an offer from a template that is configured in this way, they select a 

client ID from the list of values you supplied. The list of category names and IDs for the 

selected client is then populated directly from Digital Recommendations.
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Defining the client list
The Unica Plan  user interface presents several list box controls that administrators can 

configure with customized options.

Note:  For more information about defined lists, see the chapter on "Defining list 

options" in the Unica Plan  Administrator's Guide.

To define a list of the client IDs and names in use by an  IBM Digital Recommendations 

implementation, complete the following step.

Select Settings  > List Definitions  > Coremetrics Clients.

Designing attributes
Each item of information that users can enter for a project has a corresponding attribute on 

a tab in the template.

To include information in campaign, cell, or offer performance reports, make sure that 

information is collected by a corresponding attribute. The information is passed to Unica 

Campaign  by a campaign, cell, or offer attribute.

Campaign project templates can include the following attribute categories:

• For information that is used only in Unica Plan  on a form outside of a grid, use form 

attributes.

• For information is used only in Unica Plan  on a form within a grid (including TCS® 

grids), use grid attributes.

• For information that is shared with Unica Campaign  and that appears on a form 

outside of a grid, use campaign attributes.

• For information that is shared with Unica Campaign  and that appears on a form within 

the TCS®  grid, use cell attributes.

• For systems that also integrate offers, use offer attributes to collect offer information 

to share with Unica Campaign.
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Offer attributes are synchronized with Unica Campaign  when an offer that uses the 

attributes is published to Unica Campaign.

• To view or define shared attributes, choose Settings  > Plan Settings  > Template 

Configuration  > Shared Attributes.

You create all campaign, cell, and offer attributes as shared attributes. You can create 

form and grid attributes as local if they are relevant to a single form only, or shared if 

you plan to use them on multiple forms.

Note:  Standard, default attributes cannot be edited, and are not listed on 

the Shared Attributes  page. For example, default cell attributes appear in all 

Target Cell Spreadsheets, but are not listed on the Shared Attributes  page.

Unica Campaign attributes
When Unica Plan  and Unica Campaign  are integrated, you create custom Unica Campaign 

attributes in Unica Plan. All Unica Campaign attributes are shared, and you use Unica Plan 

to add them to the forms that make up your campaign project templates.

When users create the linked campaign for a campaign project from a template that 

includes custom campaign attributes, the corresponding attributes are created in Unica 

Campaign. If users change the data they enter in a field that is created by a campaign 

attribute after they create the linked campaign, they must update the campaign to send the 

new information to Unica Campaign. You use campaign attribute descriptions and form 

descriptions to inform users which fields require them to update the campaign.

Cell attributes
Cell attributes are Unica Plan  attributes that map to Unica Campaign  for use in Target Cell 

Spreadsheets. Unica Plan  includes a set of default cell attributes that are included in every 

TCS®.

You can also create custom cell attributes in Unica Plan. When users create the linked 

campaign for a campaign project from a template that includes custom cell attributes, the 

corresponding cell attributes are created automatically in Unica Campaign.
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Offer attributes
When offer integration is enabled, a set of standard offer attributes is supplied in Unica Plan 

to correspond to the standard attributes in Unica Campaign. You can also create custom 

offer attributes in Unica Plan.

All offer attributes are shared attributes.

To work with offer attributes, select Settings > Unica Plan  Settings > Template 

Configuration > Shared Attributes.

Standard offer attributes in Unica Campaign
The following table lists the offer attributes that are delivered with Unica Campaign 

available in Unica Plan  systems that enable offer integration.

Table  5. Standard offer attributes

Attribute Display Name Attribute Internal Name*
Form Element Ty

peAttribute Type

Average Avg.  Response 

Revenue

AverageResponseRevenue Text Field - CurrencyMoney

Channel Channel Select Box - StringSin

gle-Select

Channel Type ChannelType Select Box - StringSin

gle-Select

Cost Per Offer CostPerOffer Text Field - CurrencyMoney

Creative URL CreativeURL Text Field - StringCreative 

URL

Effective Date EffectiveDate Text Field - DateDate Select

Expiration Date ExpirationDate Text Field - DateDate Select

Expiration  Duration ExpirationDuration Text Field - NumericFloat
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Table  5. Standard offer attributes  (continued)

Attribute Display Name Attribute Internal Name*
Form Element Ty

peAttribute Type

Fulfillment Cost FulfillmentCost Text Field - CurrencyMoney

Interaction Point ID UACInteractionPointID Text Field - NumericFloat

Interaction Point UACInteractionPointName Text Field - StringText - Sin

gle-Line

Offer Fixed Cost OfferFixedCost Text Field - CurrencyMoney

*In Unica Plan  systems that enable offer integration, attribute internal names are stored as 

all lowercase text.

Offer attribute behavior options
When administrators import an offer attribute into a form, they select its behavior and 

supply a default value.

The behavior options for an offer attribute are:

• Parameterized, which means that the attribute is a required field in the user interface. 

Users can accept the default or supply a different value.

• Static, which means that the attribute is an optional field in the user interface. Users 

can accept the default, supply a different value, or leave the field null.

• Hidden static, which means that the attribute and value do not display to users. 

Hidden static attributes and their values can be included in reports.

These behavior choices correspond to the ways you can use offers in Unica Campaign. For 

more information about these choices, see the Unica Campaign  Administrator's Guide.

To define the behavior for an offer attribute in a form (when you import attributes into the 

form you select Static, Hidden, or Parameterized Attributes), click the name of the attribute 

and click >>.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 25

Creative URL offer attribute
A "Creative URL" is a link to a digital asset, such as a product logo, brand image, marketing 

research document, or document template. When an offer template includes the system-

supplied Creative URL offer attribute, users select a digital asset from the Unica Plan  asset 

libraries to include in each offer.

The Creative URL offer attribute is a system-supplied, shared attribute with the following 

characteristics.

• When administrators work with form definitions in Unica Plan, they can import the 

shared Creative URL attribute as parameterized, static, or hidden. If Creative URL is 

parameterized, an asset value is required in the form definition and corresponding 

offer instances.

• The Creative URL attribute has its own attribute type. In the user interface, the Creative 

URL attribute type presents a field and associated Select  button. Users click Select 

to choose an existing asset or to add an asset. The asset name displays in the 

associated field.

• When administrators export or import a form or an offer template, both the source 

and target systems must be running the same version of Unica Plan. The export and 

import files use an internal field name of digitalasset  for the Creative URL attribute.

• When administrators set up customized alerts, the Creative URL attribute can be 

included as a variable. The message text displays the asset name.

• Users can include columns for the Creative URL attribute on the Operations > Offers 

list page.

• On the Operations > Offers  list page, users can use the Creative URL attribute to 

search for offers. The search uses the asset name.

• When users create a smart offer list, they can include the Creative URL attribute in its 

conditions. The condition uses the asset name to return results.

Campaign, cell, and offer attributes
Only attribute types that exist in both Unica Plan  and Unica Campaign  are available for 

campaign and cell attributes.
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For systems that also integrate offers, the same constraint applies to offer attributes with 

the following exception: when published to Unica Campaign, the attribute type for the 

Creative URL offer attribute changes to Text Field - String.

Table  6. Attribute types for campaign, cell, and offer attributes in Unica Plan

Attribute type

Campaign 

attributes

Cell at

tributes

Offer at

tributes

Text - Single-Line X X X

Text - Multi-Line X X X

Single-Select X X

Single-Select - Database X X

Multiple-Select - Database

Yes or No X X

Date Select X X X

Integer X X

Decimal X X X

Money X X X

User-Select

External Data source

Calculated X X X

URL Field

Single Select Object Reference

Multi-Select Object Reference

Image
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Table  6. Attribute types for campaign, cell, and offer attributes in Unica Plan  

(continued)

Attribute type

Campaign 

attributes

Cell at

tributes

Offer at

tributes

Creative URL X

Rich text type

Note:  For attributes that have the Single-Select - Database attribute type, Unica Plan 

passes the lookup value (not the display value) of the selection to Unica Campaign. 

You determine the lookup value and the display value when you create the lookup 

table.

There is no attribute type in Unica Plan  that corresponds to the "Modifiable drop-down list" 

that is available for custom attributes in stand-alone Unica Campaign.

Creating and enabling a shared attribute
You can create and enable a shared attribute by using Unica Plan  shared attributes function.

1. Select Settings  > Plan Settings.

2. Click Template Configuration.

3. Click Shared Attributes.

The page that displays contains one section for each shared attribute category.

4. Click Create a <category>  Attribute  for the attribute you want to create.

The Create a New Shared Attribute  dialog opens.

5. Supply values to define the attribute.

6. Click Save and Exit  to create the attribute and return to the Shared Attributes  page, or 

click Save and Create Another  to create the attribute and enter values for another new 

attribute.
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You can select a different attribute category.

7. On the Shared Attributes  page, click Enable  in the row for each new attribute to make 

it available for use on a form.

Creating a Flowchart approval
You can create a Flowchart approval by following these steps.

1. In an integrated environment,create campaign project by clicking on Operations -> 

Project -> Add project

2. Select Campaign template

3. Create linked campaign

4. On Implementation tab, create Flow chart

5. Click on Planning tab

6. Select Workflow -> Edit

7. Click on Add Row -> Flowchart Approval

8. Click on Save and Finish

9. Reopen Flowchart approval, Select Approver, Target due date, Flowcharts to approve

10. Click on Send approval

Creating a Target Cell Spreadsheet
You can create a Target Cell Spreadsheet by following these steps.

Before you create a TCS, you must create any custom cell attributes that you want 

to include. Cell attributes map to Unica Campaign  and can be created only as shared 

attributes.

1. Select Settings  > Plan Settings.

2. Under Other Options, click Template Configuration.

3. Under Template Components, click Forms.

4. On the Form Definitions  page, click Create New Form.

The Form Editor  interface displays.
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Note:  Ensure that you do not use the "uap" and "umcm" prefixes while defining 

tables for forms and grids.

5. Complete the Form Properties  tab and click Save Changes.

The Add an Element  tab displays.

6. Click Create New Grid.

The Create New Grid  dialog opens.

7. From the Grid Type  drop-down list, select Editable Grid View.

8. Select the Is TCS  check box.

9. Complete the remaining options and click Save and Exit.

On the Add an Element  tab, click to expand the list of Form Attributes. Your TCS grid 

component displays.

10. To add a TCS grid to a form, you must place it within a group. If the form does not 

already contain a group for the grid, click and drag Attribute Group Header  onto the 

form design area then name it appropriately.

11. From the list of Form Elements, click and drag your TCS®  grid component and drop it 

onto the group.

The default cell attributes display on the grid. See Default cell attributes for Target Cell 

Spreadsheets  (on page 18).

12. Add any attributes that you want to include in the TCS. You can do either of the 

following steps.

• Import custom cell attributes and add them to the TCS to create more columns. 

these columns are passed to Unica Campaign.

• Create or import grid attributes and add them to the TCS to create more 

columns. These columns display only in Unica Plan.

Note:  Ensure that you do not use the "uap" and "umcm" prefixes while 

defining tables for forms and grids.

13. Click Save and Exit  to save the TCS and return to the Form Definitions  list page.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 30

Share Unica Campaign  contact and response data with Unica 
Plan
To enable users to import contact and response counts into Unica Plan, you must map the 

contact count and the response types to Unica Plan  metrics.

Note:  Unica Campaign  passes data to Unica Plan  for one audience level only, the 

audience level that is mapped to the UA_ContactHistory, UA_ResponseHistory, and 

UA_DtlContactHist system tables. The audience level can be any audience level, 

with any number of audience key fields of any data type or name. For details on 

audience levels, see the Unica Campaign  documentation.

The response types are stored in the UA_UsrResponseType system table in the Unica 

Campaign  database. To map a metric to a response type, you must know the name of the 

response type.

The mappings are stored in an XML file.

Mapping Unica Campaign  contact and response counts to Unica 
Plan  metrics
If you want users to be able to import contact and response counts into Unica Plan, you 

must map contact count and the response types to Unica Plan  metrics.

Note:  Unica Campaign  passes data to Unica Plan  for one audience level only, the 

audience level that is mapped to the UA_ContactHistory, UA_ResponseHistory, and 

UA_DtlContactHist system tables. The audience level can be any audience level, 

with any number of audience key fields of any data type or name. For details on 

audience levels, see the Unica Campaign  documentation.

The response types are stored in the UA_UsrResponseType system table in the Unica 

Campaign  database. To map a metric to a response type, you must know the name of the 

response type.

The mappings are stored in an XML file.
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1. In Unica Campaign, modify the list of response types in the UA_UsrResponseType 

table if necessary to include the response types you want to track.

2. Edit the Unica Plan  metrics file being used by your system to include metrics that 

correspond to contact count and the response types.

3. Create a map file that associates the Unica Plan  metrics with contact count and the 

response types.

4. Add the map file to Unica Plan.

5. Create a campaign template and select the map file from the Metric Data Mapping 

drop-down list.

The contact and response data is mapped to metrics for all projects that are created from 

that template.

Metrics data mapping file
You define the metrics to map your data.

The metrics data mapping file must use the container elements <metric-data-mapping> 

and </metric-data-mapping>.

The next line in the mapping file must be as follows:

<datasource type="webservice">

   <service-url>CampaignServices</service-url>

</datasource>

The actual mappings must be contained by the elements <metric-data-map>  and </

metric-data-map>.

metric

Use the <metric>  element to define the metric in a mapping. The <metric>  element has no 

value but must contain the child element <data-map-column>. The <metric>  element has 

the following attributes:



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 32

Attribute Description

id The internal name of the metric

dimension-id The number of the column into which the value from Unica Cam

paign  should be placed. Columns are numbered from left to right. 

The first column is column 0.

data-map-column

Use the <data-map-column>  element to define the data source (either contact count or a 

response type) in a mapping. The <data-map-column>  element must be contained by the 

<metric>  element that defines the metric to which contact count or this response type is 

mapped. The <data-map-column>  element has no value but has the following attributes:

Attribute Description

id The data source to be mapped to the metric. For contact count, use 

contactcount. For a response type, use responsecount_<Respon

seTypeName>.

type This value should always be number.

Adding data mapping files
Use a text or XML editor to create or edit a data mapping file. After you have a data mapping 

file, you add it to Unica Plan.

1. Select Settings  >  Plan Settings.

2. Click Template Configuration  > Data Mapping.

3. Click Add Data Mapping.

The Upload Data Mapping dialog box opens.

4. Enter a name for the data mapping file.

5. Browse to the XML file that defines the data mapping.

6. Click Continue.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 33

Editing data mapping files
If you want to update a data mapping file, you must first edit the XML file, and then reload it 

back into Unica Plan.

1. Open the data mapping XML file in a text editor and make your changes.

2. Select Settings  > Unica Plan  Settings.

3. Click Template Configuration  > Data Mapping.

4. Click the file name that you are updating.

The Update Data Mapping  dialog opens.

5. Select File, and browse to the XML file.

6. Click Continue.

You are prompted to overwrite the existing file.

7. Click Save  to overwrite the existing file with the newer version.

Data Mapping Definitions
The Data Mapping Definitions  page maps data between campaign projects in Unica 

Plan  and campaigns in Unica Campaign. Use the Data Mapping  link on the Template 

Configuration  page to configure data mapping.

The Data Mapping Definitions  page contains the following columns:

Column Description

Name The name of the data mapping file.

Type Campaign Metrics Import: Maps Unica Plan  project metrics to Uni

ca Campaign  contact and response counts.

If you have map files from previous versions, you might see other 

values in the Type column.

Used By A list of templates that use the data map.
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Note:  You cannot create a map file within Unica Plan. Use a text or XML editor to 

create and edit the necessary map files.

Unica Campaign project templates
If Unica Plan  is integrated with Unica Campaign, campaign project templates guide users 

in creating a campaign project. Campaign projects integrate the planning and project 

management features of Unica Plan  with the campaign development features of Unica 

Campaign.

You indicate that a template is a campaign project template when you create the project 

template. In integrated systems, all new project templates include a Campaign tab on which 

you complete the options on the Campaign tab for the template. Then, you must specify 

a Target Cell Spreadsheet. If you want to import Unica Campaign  contact and response 

metrics, you must specify a metric map file.

Creating campaign project templates
In integrated Unica Plan  and Unica Campaign, you use campaign projects to access Unica 

Campaign  information within Unica Plan.

Before you can create a campaign project template, you must create the TCS®  form. If you 

want to include custom campaign attributes or a metric map file in the template, create 

them before you create the template.

1. Select Settings  > Plan Settings.

2. Under Other Options, click Template Configuration  > Templates.

3. In the Project Templates  section, click Add Template.

4. Complete the Properties  tab and click Save Changes.

5. Click the Campaign  tab and select the Campaign Project Template  check box.

6. Complete the remaining fields on the Campaign  tab and click Save Changes.

If you want to require TCS®  approval, select the Approval Required  check box. See 

TCS approval  (on page 65).

7. Complete the remaining tabs, saving each one.
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For more information about these tabs and template creation, read about building or 

editing a template in the  Unica Plan  Administrator's Guide.

The template displays in the list of project templates on the Templates  page.

8. Click Enabled  in the row for the template to make it available to users when they 

create projects.

Project template Campaign tab for communicating with Unica 
Campaign
Use this tab to configure communication from Unica Plan  to Unica Campaign  if integration 

is enabled.

Note:  After a user creates a project from a template, you cannot change a non-

campaign template to a campaign template or vice versa: The Campaign Project 

template  option on this tab is disabled.

After a campaign template is used to create a project, the only option on this tab that can be 

changed is the Metric Data Mapping  setting. To change any of the other options, you must 

first delete all of the projects that were created from this template.

The Campaign tab contains the following settings.

Table  7. Fields on the Campaign tab for project templates

Field Description

Campaign 

Project tem

plate

Select this check box to mark this template as a campaign project 

template and display the other Campaign Integration fields.

TCS®  Form Select the form that contains the Target Cell Spreadsheet to use for 

projects that are created from this template. The drop-down list con

tains all published forms that contain a TCS®.
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Table  7. Fields on the Campaign tab for project templates  (continued)

Field Description

Metric Data 

Mapping

XML file that contains the data map for sending metrics from an 

Unica Campaign  campaign to an Unica Plan  project for reporting 

purposes.

TCS®  Form Dis

play Name

The name to display for the selected form on the TCS®  tab.

Partition ID Identifies the partition of the Unica Campaign  instance in which to 

create the campaigns that correspond to the campaign projects cre

ated from this template.

The default value is partition1, which is correct if Unica Campaign  is 

installed to a single partition. If Unica Campaign  is installed on mul

tiple partitions, you can specify the partition to use for creating cam

paigns.

You can specify any Unica Plan  partition. Make sure that you specify 

a partition to which you have access and for which integration is en

abled.

For more information about setting up Unica Campaign  partitions, 

the Unica Campaign  Installation Guide.

Show TCS®  tab 

in request

Select the check box to display the TCS®  when the template is used 

to request a project. If the check box is clear, the TCS®  displays on

ly in campaign projects and not in requests.

Approval Re

quired

Select the check box to require approval for all the target cells that 

are created in the template. If cleared, the TCS®  grid does not show 

the approval  column or approve all  and deny all.

Note:  As part of the upgrade to version 8.2, Approval Re

quired  is cleared for all upgraded campaign templates.
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Table  7. Fields on the Campaign tab for project templates  (continued)

Field Description

For more information, see TCS approval  (on page 65).

Copy project at

tributes to cam

paign attributes

Select the check box to automatically copy project information to 

campaign when users click Finish  to create campaign projects. If 

this check box is not selected, users can click the Copy project at

tributes to campaign attributes  link to copy the data when they cre

ate a campaign project instance. By default, the check box is not se

lected.

Copying information automatically from Unica Plan  to Unica 
Campaign
You can configure campaign project templates that automatically copy project information 

from projects to campaigns. You can automatically copy the description, Start date, and End 

date so you do not need to enter this information twice.

When you create a campaign project template, select the Copy project attributes to 

campaign attributes  option to automatically copy project attributes to campaign.

If the Copy project attributes to campaign attributes  option is not selected, you can still 

copy the information with one click in the object instance. When you create instances from 

templates without selecting the option, the Copy project attributes to campaign attributes 

link copies project attributes to campaign.

1. Create an instance of the campaign project.

2. Complete the project information: the description, Start and End Dates, and the 

Security policy.

3. If not already selected, clickCopy project attributes to campaign attributes.

4. Click Finish  or Next.

The campaign attributes are automatically filled with the corresponding project attribute 

values.
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Unica Plan  and Unica Campaign  Integration reports package
The Unica Plan  and Unica Campaign  Integration Reports Package contains several IBM® 

Cognos®  reports that query and display information from both the Unica Campaign  system 

tables and the Unica Plan  system tables.

This report package depends on the Unica Campaign  report package because the 

Campaign segments of the integrated reports rely on the reporting schemas from the Unica 

Campaign  Report Package.

Installation prerequisites for the Integration Report Package
Before you can install the Unica Plan  and Unica Campaign  Integration Report Package, the 

following configuration steps must be completed.

• Reporting must be set up for Unica Campaign  and Unica Platform. See the Reports 

Installation and Configuration Guide.

• Reporting must be set up for Unica Plan. See "Installing reports" in the Unica Plan 

Installation Guide.

• The integration of Unica Plan  and Unica Campaign  must be complete.

Additionally, for the sample reports from the Integration Report Package to work correctly, 

the following conditions must be met.

• The Unica Campaign  system must have the standard custom Campaign attributes 

loaded.

• The Unica Plan  system must have the sample templates loaded: most importantly, the 

sample Campaign Project template. Additionally, the Campaign Project template must 

use the corresponding sample Campaign Project metric file.

• The Financial Management module must be enabled on the Unica Plan  system.

When these prerequisites are met, continue with the installation procedure.

Running the installer on the IBM®  Cognos®  system
You can run the installer on your existing IBM®  Cognos®  system.
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1. On the IBM®  Cognos®  system that runs the Cognos®  Content Manager, download 

the Unica Plan  and Unica Campaign  Integration Report Package installer. Download 

them to the same directory to which you previously downloaded the other report 

package installers.

2. Run the installer. (The installer starts the subinstaller for the report package.)

3. In the first Products  window, ensure that the report package option is selected.

4. In the Unica Platform  Database Connection  window, verify that the information about 

how to connect to the Unica Platform  system tables is correct.

5. When the report package installer takes over and displays its installation options, 

select the IBM Cognos package for [product]  option. This installation option copies 

the reports archive and reporting model to the Cognos®  system. You import this 

archive manually later.

Importing the reports folder in Cognos®  Connection
The application reports are in the compressed (.zip) file that the report package installer 

copied to the Cognos®  system. Use the guidelines in this procedure to import the archive 

file for reports into Cognos®  Connection.

1. Go to the IBM\ReportsPackCampaignPlan\Cognos<version-number> 

directory.

2. Copy the reports archive compressed file (Reports for Plan and 

Campaign.zip) to the directory where your Cognos®  deployment archives are 

saved. In a distributed IBM®  Cognos®  environment, this location is on the Content 

Manager system.

The default location is the deployment directory under your IBM®  Cognos® 

installation, and it is specified in the Cognos®  Configuration tool that is installed with 

the Cognos®  Content Manager. For example: cognos\deployment.

3. Locate the HCL\ReportsPackCampaignPlan\Cognos<version-

number>\CampaignPlanModel  subdirectory.

4. Copy the entire subdirectory to any place on the system that is running Cognos® 

Framework Manager that Framework Manager has access to.

5. Open Cognos®  Connection.
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6. From the Welcome  page, click Administer Cognos Content.

If your Welcome  page is turned off, turn it back on in the Cognos®  Connection user 

preferences.

7. Click the Configuration  tab.

8. Select Content Administration.

9. Click the New Import  button on the toolbar .

10. Follow these guidelines as you step through the New Import Wizard:

a. Select the reports archive that you copied in the previous procedure.

b. In the Public folders content list, select all  the options, including the package 

itself (the blue folder).

c. If you do not want users to access the package and its entries yet, select 

Disable after import. Do this step if you want to test the reports before you 

make them available to the application users.

Enabling internal links in the reports
The Unica  application reports have standard links. To enable the links to work properly, 

you must configure the IBM®  Cognos®  Application Firewall. You must also configure the 

redirect URL in the Cognos®  data model for the Unica  application reports.

Note:  This step is not necessary for Unica Deliver  reports.

To configure the redirect URL in the Cognos®  data model for the Unica  application reports, 

complete the following steps.

1. In Cognos®  Framework Manager, browse to the <productName>Model  subdirectory 

that you copied into the Framework Manager directory structure. Select the .cpf file, 

for example CampaignModel.cpf.

2. Select Parameter Maps  > Environment.

3. Right-click Environment  and select Edit Definition.

4. In the Redirect URL  section, select the Value  field. Edit the server name and port 

number so they are correct for the Unica  suite but leave the rest of the URL intact. By 

convention, the host name includes the domain name.
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For example, for Unica Campaign:

http://serverX.ABCompany.com:7001/Campaign/

redirectToSummary.do?external=true&

For example, for Unica Plan:

http://serverX.ABCompany.com:7001/plan/callback.jsp?

5. Save the model and publish the package by completing the following steps:

a. From the navigation tree, expand the Packages  node of the model.

b. Right-click the package instance and select Publish Package.

Verifying data source names and publishing
The name that is specified as the data source for the reports in the model must match the 

name of the data source that you created in Cognos®  Connection. Before you publish the 

model from Framework Manager to the Cognos®  content store, you must verify that the 

data source names match.

If you used the default data source names, the data source names match. If you did not use 

default data source names, you must change the data source names in the model.

To verify and change the data source names in the model, complete the following steps.

1. In Cognos®  Connection, determine the names of the data sources you created.

2. In Framework Manager, select Open a Project.

3. Browse to the <productName>Model  subdirectory you copied into the Framework 

Manager directory structure. Select the .cpf file, for example CampaignModel.cpf.

4. Expand the Data Sources  entry and examine the names of the data sources. Verify 

that they match what you named them in Cognos®  Connection.

5. If the names do not match, select the data source instance and edit the name in the 

Properties  section. Save your changes.

6. Publish the package to the Cognos®  content store.
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Configuring IBM  Cognos®  Application Firewall for Unica
IBM  Cognos®  Application Firewall analyzes and validates requests before the requests are 

processed by IBM  Cognos®  servers.

To configure the IBM  Cognos®  Application Firewall for Unica, you must specify the Unica 

system as a valid domain or host.

To configure IBM  Cognos®  Application Firewall for Unica, complete the following steps.

1. In the Cognos Configuration  window, select Security  > IBM Cognos Application 

Firewall.

2. In the Valid domains or hosts property  window, enter the fully qualified computer host 

name that includes the domain and the port for the computer where Unica Platform  is 

running.

For example:

serverXYZ.mycompany.com:7001

Important:  In a distributed environment, you must complete this step for every 

computer on which an Unica  application that provides Cognos®  reports is 

installed, such as Unica Platform, Unica Campaign, and Unica Plan.

3. Save the configuration.

4. Restart the IBM  Cognos®  service.

Creating Cognos®  data sources for Unica  application databases
The Cognos®  applications need their own data sources that identify the source of the data 

for Unica  application reports.

The Cognos®  data models that are provided in the Unica  reports packages are configured 

to use the data source names that are given in the following table:
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Table  8. Cognos®  data sources

This two-columned table provides information about the Unica  application in one 

column, and the Cognos®  data source names in the second column.

Unica  application Cognos®  data source names

Unica Campaign CampaignDS

Unica Deliver DeliverTrackDS

Unica Interact • For the design time database: InteractDTDS

• For the runtime database: InteractRTDS

• For the learning database: InteractLearning

DS

• For the ETL database: InteractETLDS

Unica Plan PlanDS

Unica Collaborate • For the Unica Collaborate  database: Collabo

rateDS

• For the customer database: CustomerDS

• For the Unica Campaign  database: CampaignDS

Use the following guidelines to create Cognos®  data sources for the HCL application 

databases.

• Use the Administration section of Cognos®  Connection.

• Use the default data source names that are shown in the Cognos®  data sources table 

to avoid having to alter the data model.

• The database type that you select must match that of theHCL application database. 

Use the Cognos®  documentation to determine how to fill database-specific fields.

Note:  For Unica Campaign  and Unica Deliver, the appropriate database is 

Unica Campaign.
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• Be sure that you identify the Unica  application database and not the Cognos®  content 

store.

• When you configure the Signon  section, select the Password  and Create a Signon that 

the Everyone group can use  options.

• In the Signon  section, specify the user credentials for the Unica  application database 

user.

• Consult the Cognos®  data sources table and ensure that you create all the data 

sources that are required by the data model for the reports you are configuring.

For example, the reporting data for Unica Interact  is in three databases, so you must 

create separate Cognos®  data sources for each database.

• If the Unica Campaign  system has more than one partition, create separate data 

sources for each partition.

For example, if Unica Campaign  and Unica Deliver  are configured for multiple 

partitions, create a separate Unica Campaign  and Unica Deliver  data source for each 

partition.

• Verify that you configured each data source correctly by using the Test Connection 

feature.

Creating a campaign in an integrated environment
The workflow for creating a campaign when Unica Plan  and Unica Campaign  are integrated 

consists of the following tasks.

In many organizations, the tasks that are required to create a marketing campaign are 

shared by multiple people.

1. Using the appropriate template, create a campaign project.

Depending on your permissions, you can create the project directly or request a 

project and wait for it to be accepted.

2. Complete any information that is missing on the project tabs.

3. Create the linked campaign for the project.

After this step is completed, the Implementation/Planning  button ( ) appears, so 

you can go back and forth between campaign project and its linked campaign.
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4. Complete the TCS®  to define the control and target cells for the campaign and the 

assigned offers for target cells.

5. Publish the TCS®  to Unica Campaign.

6. Create the flowcharts for the campaign, linking cells that are created in the flowchart 

with the appropriate target and control cells that are defined in the TCS®.

7. Optional:  If TCS®  approval is required, test the flowchart to generate cell counts.

8. Optional:  If TCS®  approval is required, update the cell status from within the TCS® 

for review.

9. Optional:  If TCS®  approval is required and when all information for a cell (for 

example, the count) is appropriate, approve that cell (row) in the TCS®.

10. Optional:  If TCS®  approval is required, repeat the process of publishing the TCS® 

and updating cell status until all cells in use by the flowchart is approved.

11. When all necessary TCS®  rows for the flowchart to run are prepared, publish the 

TCS®  a final time.

12. Optional: If flowchart approval is required, an approval must be created and assigned 

to one or more approvers. A flowchart can only be allowed to run when the approval is 

in completed or canceled state.

13. Start the production flowchart run for the campaign.

Unica Campaign projects in an integrated system
If your Unica Plan  system is integrated with Unica Campaign, you can create campaign 

projects.

A campaign project collects the information that is related to developing a marketing 

campaign and running it through Unica Campaign.

A campaign project can contain any features available to projects, including subprojects. 

Campaign projects also contain a TCS®  tab with a Target Cell Spreadsheet and an 

additional Campaign Summary section of the Summary tab.

In a campaign project, you synchronize the campaign, offer, contact history, and response 

history data for the project with Unica Campaign.
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In a campaign project workflow you can create flowchart approval tasks. When such 

approval are created, the Flowchart will not run until all related approvals are in completed 

or canceled state.

Project codes and campaign codes
When you create a campaign project, you must specify a project name and code. The same 

name and code are used as the campaign name and code when you click the Create Linked 

Campaign  icon to create the campaign in Unica Campaign.

The code must be unique in both Unica Plan  and Unica Campaign. If you change the code, 

the system checks the uniqueness of the code before it creates or saves the project.

Creating projects
You can create a single project from a project template. Your administrator sets up and 

maintains project templates. You can also create projects by copying a project, making up 

to 99 clones of a project, or responding to a project request.

When you create a project, note the following behavior.

• To create a project, you must have the appropriate security permission.

• When you create a project, you are the owner of the project.

• You can add other team members to the project, some of whom can also be project 

owners.

1. Select Operations  > Projects.

2. Click Add Project  ( ).

Note:  Ensure that you do not use the following invalid characters (%?|:,<>&

\/"+$<tab>)*  under the Project name. These special characters are not 

supported for the Project Name field. Although these characters are allowed 

in project name while Campaign is integrated, but you must not use these 

characters.

3. Select a template for your project.
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An Unica Plan  administrator sets up the templates for your organization. To access 

any of the Unica Plan  and Unica Campaign  integration features, you must select a 

template that is configured as a campaign project template. The template selected 

here will reflect in the Operations > Approvals  page in the All approvals > My active 

approvals. The template name is thus indicative of the project template the approval 

belongs to.

4. Click Continue.

5. Use the Add Project wizard to supply values for the project fields.

6. When you save the project, the system verifies that all required fields have a value. It 

also completes optional fields by supplying default values from the template when 

available. To save your project, use one of the following options.

• Click Finish. The Summary tab displays for the new project.

• Click Save and Duplicate. The system saves the initial project and then uses the 

same information to create another project. The Summary tab displays for the 

duplicate project. You can edit the default name for the duplicate project and for 

other fields as needed, then save that project as well.

• Click Save and Return to List  on any page. The All Projects and Requests  page 

displays.

Newly created projects are given a status of Not Started. To use the project to collect and 

share information, you change its status. See Starting projects  (on page 48).

The tabs in a project differ depending on the template you used. A typical project contains 

the following tabs:

• Summary

• People

• Strategy

• Workflow (schedule of tasks, milestones, and approvals)

• Tracking (expenses and resources)

• Health Status (project monitoring)

• Attachments
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When Unica Campaign  is integrated with Unica Plan, a campaign project also contains a 

Target Cell Spreadsheet tab.

Some selections in the Add Project wizard also affect the tab content in the project. If your 

administrator configured workflow template branching, your field options might include 

a specific template for the Workflow  tab. For example, the template might use a different 

workflow for a project that is based on whether you selected direct mail or email as the 

channel.

Starting projects
You start a project by changing the status. Select the transition Start Project.

You can start any project that you own:

• The projects that you create

• The projects that you create when you accept a project request

• The projects that include you as an owner

You can also start several projects at the same time. For more information, see Changing 

the status of multiple projects or requests  (on page 51).

1. Go to the Summary  tab of the project you want to start.

Select Operations  > Projects. Click the Actions  icon and select a view, such as My 

Projects, that includes projects with a "Not Started" status.

2. Click Change Status  and select Start Project  or Start Project with comments  from the 

menu.

3. Optional:  If you chose Start Project with comments, type your comments and click 

Continue.

The project status changes to "In Progress". After you start a project, all project participants 

can work with their assigned tasks.
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Campaign Summary section
The Campaign Summary section of the project Summary tab defines basic information 

about the campaign for this project.

Field Description

Campaign De

scription

Enter a description of the campaign.

Campaign Start 

Date

Date on which the campaign starts

You can manually enter the date or click the drop-down arrow to dis

play a calendar from which you can select a date. If the field con

tains a date, you can click the forward or back arrows to change the 

date.

You cannot create the linked campaign if this field is empty.

Campaign End 

Date

Date on which the campaign ends

You can manually enter the date or click the drop-down arrow to dis

play a calendar from which you can select a date. If the field con

tains a date, you can click the forward or back arrows to change the 

date.

You cannot create the linked campaign if this field is empty.

Campaign Ob

jective

Enter the objectives of the campaign.

Campaign Initia

tive

Enter the initiative under which the campaign falls.

Campaign Se

curity Policy

Select a security policy from the drop-down list of all the security 

policies that are defined for Unica Campaign.

You can select any policy, even policies in which you do not have a 

role. If you put a campaign into the wrong policy, it is not visible to 

the applicable users.
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Field Description

You cannot create the linked campaign if there is no security policy 

specified.

Creating requests
If you do not have permission to create a project, you create a project request.

When you create a project request, note the following behavior:

• You must create the request and then submit it.

• You must have the appropriate security permission.

• After the recipient accepts the request, the recipient owns the project. (You are the 

requester.)

When you create a request, the pages in the wizard that you complete differ depending on 

the type of project you want to create. A typical request contains the following sections:

• Summary information about the request

• Tracking information

• Attachments that are part of the request

1. Select Operations  > Projects.

2. Click Add Request  ( ).

The Add Request  dialog opens.

3. Select a template for your request.

Your administrator sets up project templates that correspond to the types of projects 

that your organization undertakes. To request a project that uses Unica Plan-Unica 

Campaign  integration features, you must select a campaign project template.

4. Click Continue.

5. Use the Add Project wizard to supply values for the project fields.

Each request identifies recipients to review and redraft or approve the request. If the 

template you selected allows these modifications, you can also:
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• Add recipients.

• Change recipient roles.

• Change the duration periods for responses.

• Change the sequence numbers that order request receipt and approval.

• Specify whether a response is required.

6. When you save the request, the system verifies that all required fields have a value. 

It also completes optional fields by supplying default values from the template when 

available. To save your request, use one of the following options:

• Click Finish.

• Click Save and Duplicate. The system saves the initial request and then uses the 

same information to create another request. The Summary tab displays for the 

duplicate request: edit the default name that is supplied for the duplicate and 

other fields as needed, then save that request as well.

• Click Save and Return to List  on any page.

7. Submit the request to the first reviewer.

• If you created a single request, on the Summary  tab, click Change Status  and 

select Submit Request.

• If you created multiple requests, submit them as described in Changing the 

status of multiple projects or requests  (on page 51).

You cannot change the request after the first reviewer approves the project request. 

If you need to change a request after the first reviewer approves the project, you 

should change the project status to draft and resubmit the project after you make your 

changes.

When the last required recipient approves the request, Unica Plan  creates the project.

Changing the status of multiple projects or requests
You can change the status of one or more projects or requests simultaneously to improve 

efficiency.

Your change must meet the following prerequisites; if it does not, a warning message 

describes the possible problems.
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• The new status that you select must be valid for every item that you select.

• To make status changes, you must have appropriate permissions.

• To accept or reject requests, you must be an approver for every item you select.

Your administrator can set up Unica Plan  to send an alert to owners and members of a 

process when its status changes.

1. Select Operations  > Projects.

2. Click Actions  ( ) and select All Projects and Requests.

3. Select one or more items.

Note:  You can select items on more than one page. However, the system 

applies the status change only to the page you are viewing when you select 

the new status.

4. Click Change Status  and select a status from the menu to apply to all of the selected 

items.

You can make most status changes with or without comments.

• If you chose a new status without comments, Unica Plan  changes the status 

immediately when you click the new status.

• If you chose a new status with comments, type your comments and click 

Continue  to apply the new status.

Special characters in Unica Campaign  object names
Some special characters are not supported in any Unica Campaign  object names. In 

addition, some objects have specific naming restrictions.

Note:  If you pass object names to your database (for example, if you use a user 

variable that contains a flowchart name), you must ensure that the object name 

contains only characters supported by your particular database. Otherwise, you will 

receive a database error.
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Creating a linked campaign
You must specify the campaign start date, campaign end date, and campaign security 

policy in a campaign project before you can create the linked campaign for the project.

You must have the Create Campaign permission in Unica Campaign  to create the linked 

campaign.

Note:  All campaigns that are linked to Unica Plan  projects are created in the root 

folder.

The user who clicks the Create Linked Campaign  icon automatically becomes the owner 

of the campaign in Unica Campaign. You cannot change campaign ownership. Ownership 

might grant specific permissions, depending on the security configuration setup in Unica 

Campaign.

To create a linked campaign, complete the following steps.

1. Select Operations  > Projects.

2. Click the project for which you want to create the campaign.

The project Summary tab displays.

3. Click the Create Linked Campaign  icon ( ) in the left toolbar.

The campaign is created in Unica Campaign  and any shared information (except 

information in the TCS®) is automatically published to Unica Campaign.

The Create Linked Campaign  icon changes to the Update Campaign  icon ( ) after the 

campaign is created. The Implementation/Planning  button ( ) appears to the right of the 

project tabs. Click it to navigate to the campaign and click it again to return to the project.

Updating a linked campaign
You must update a linked campaign any time you change the value for a field outside of the 

TCS®.
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You must have the Edit Campaign permission in Unica Campaign  to update the campaign.

When you change the value for a field, outside of the TCS®, whose data gets passed to 

Unica Campaign, you must update the linked campaign. By default, these fields are in the 

Campaign Summary  section of the project Summary  tab. Your template creator might have 

created other fields on other tabs whose data also is passed to Unica Campaign. When in 

doubt, consult your template creator.

Note:  Data in the TCS®  gets sent to Unica Campaign  when you publish the TCS®.

To update a linked campaign, complete the following steps.

1. Open the campaign project for the linked campaign.

2. On the Summary  tab, click the Update Campaign  icon ( ).

The Target Cell Spreadsheet
You define all of the target and control cells for your campaign and assign offers in 

the Target Cell Spreadsheet. Your TCS®  must contain all cell definitions for your entire 

campaign.

Multiple flowcharts in a campaign can link to cells in the TCS®, but each TCS®  row can 

only be linked to only one flowchart cell. For example, you might have cells that are defined 

for wave one of a campaign that is delivered through email and different cells that are 

defined for wave two delivered through the call center. Wave one and wave two might be 

implemented in different flowcharts but the cells can share attribute values (for example, 

cell code) if they represent the same group of audience IDs in both flowcharts.

Each row must have values in the Cell Name  and Is Control Cell  columns or the row are not 

saved. If you do not provide a cell code, one is automatically generated when you publish 

the TCS®. If you provide a code, it must meet the cell code format requirements that are 

configured in Unica Campaign. If the allowDuplicateCellCodes  configuration parameter is 

set to FALSE, cell codes must be unique within a flowchart. If you delete the cell code for a 

row in the TCS®  and republish the TCS®, Unica Campaign  creates a cell code for the row. 

Any existing link between that cell and a flowchart persists.
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The TCS®  is an editable grid, so you enter data in it just as you would in any other editable 

grid. You can copy and paste TCS®  rows.

Additions or changes you make to the TCS®  are not visible in Unica Campaign  until you 

click Publish  on the TCS®.

If you delete a row that is linked to a flowchart cell and republish the TCS®, any flowchart 

cell that is linked to that TCS®  row becomes unlinked, although no data is lost. If that cell is 

input to a contact process (a Call List, Mail List, or Optimize process box), you must link the 

flowchart cell to another TCS®  row before you can run the flowchart in production mode.

Note:  The value of the control cell cannot be copied after the request is accepted,.

Consider the following points when Offer Integration is enabled with Plan.

• You can assign a published offer to the Mail List or Optimize process box by using 

match and link cells.

• After the offer is assigned, you cannot change it manually from the process box. If any 

changes are made to the offer from Plan, the changes are reflected in the process box 

only after the cells are unlinked and then linked again.

Grid edit mode
When you work with grids in edit mode, you can add rows, delete rows, and edit existing 

data. In a single editing session, you can do all of these tasks if you have the appropriate 

permissions.

Permissions

You must have the following permissions to work with grids. Ask your administrator if you 

need help.
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• To add a row, you must have the View Tab, Edit Tab, Edit Grid, and Add Grid Row 

permissions for the tab with the grid.

• To edit a row, you must have the View Tab, Edit Tab, and Edit Grid permissions for the 

tab with the grid.

• To copy and paste a row, you must have the View Tab, Edit Tab, and Edit Grid 

permissions for the tab with the grid.

• To delete a row, you must have the View Tab, Edit Tab, Edit Grid Row, and Delete Grid 

row permissions for the tab with the grid.

Locked data

The system prevents you from editing a row that is being edited by another user. For a 

Target Cell Spreadsheet in a campaign project, the entire grid is locked for editing instead of 

individual grid rows.

Revision history

Unica Plan  maintains an audit log for grids. The audit log contains the user details and the 

time it was saved. This information is available on the Analysis tab.

Adding grid rows
You can add one or more rows of grid data during an editing session.

To add a row, you must have the View Tab, Edit Tab, and Add grid row  permissions for the 

tab with the grid.

Ensure that all required columns are visible in your current grid view. Otherwise, you receive 

an error when you try to save new rows.

Note the following behavior:

• After you add a row, Unica Plan  warns you if you leave the page without saving your 

work.

• All the cells of newly added rows are either blank or filled with default data as 

specified during the form definition.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 57

• If you select multiple rows before you add a row, the new row is added after the 

selected block.

• If you add multiple rows before saving, all new rows must pass validation, or none of 

the new rows are saved.

• If you hide a required column while you are adding data, you receive an error when you 

attempt to save. You must make all required columns visible, and then retry to add 

your data.

• When you save the new data, the position of newly added rows might change; the 

order of rows depends on the sort column for the grid.

To add a row to the grid, complete the following steps.

1. Navigate to the grid you want to update.

2. Click Edit.

3. Select the row above the location for your new row and click Add Row.

Unica Plan  adds a row below the selected row.

Note:  If you do not select a row, the new row is appended to end of the current 

page.

4. Click an empty field in the new row and enter or select values.

5. Click Save.

Editing grid rows
You can edit one or more rows of grid data during an editing session.

To edit a row, you must have the View Tab, Edit Tab, and Edit grid row  permissions for the 

tab with the grid.

Note:  You cannot edit any rows that are in use by another user.

To edit a grid row, complete the following steps.
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1. Navigate to the grid you want to update.

2. Click Edit  to change from view mode to edit mode.

3. Navigate to the page that contains the data to edit, then double-click in any field to 

change its value.

An editor appears for the specific data type of the selected field. For example, if you 

select a date field, the date picker displays.

4. Click Save  to save your work and return to view mode.

Deleting grid rows
You can delete one or more rows of grid data during an editing session.

To delete a row, you must have the View Tab, Edit Tab, and Delete grid row  permissions for 

the tab with the grid.

Before you can delete a row permanently, the system prompts you to confirm your 

selections.

Note:  You cannot delete any rows that are in use by another user.

To delete a grid row, complete the following steps.

1. Navigate to the grid that contains the data that you want to delete.

2. Select one or more rows to delete and click the delete icon.

A message that describes the rows that are marked for deletion appears.

3. Repeat step 2 until all rows you want to delete are marked.

4. Click Save  to remove the rows you marked for deletion.

Any selected rows that are not in use are deleted.

Publishing the TCS®
To make the cell definitions and offer assignments in the TCS®  available to Unica 

Campaign, you must publish the TCS®. Anytime you make updates to data in the TCS®, you 

must publish the TCS®  again to make those changes visible to Unica Campaign.
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To publish the TCS®, you must have the Manage Campaign Target Cells  permission in 

Unica Campaign.

Every row must have a value for the Cell Name  and Is Control Cell?  columns before you 

publish the TCS®. If the TCS®  contains unpublished data, the Publish  button label is red.

A flowchart cannot link any cells to the TCS®  rows until the TCS®  is published. Although 

publishing the TCS®  makes the data available to the flowchart in Unica Campaign, you 

cannot start a production run of a flowchart until all linked rows in the TCS®  are approved. 

You can start a test run of a flowchart at any time.

If the data in the TCS®  changes, you must publish the TCS®  again to update the data 

available to Unica Campaign.

If the TCS®  contains data that has not been published, the Publish  button label is red.

To publish the TCS®, complete the following steps.

1. Open the project that contains the TCS®.

2. Click the Target Cell Spreadsheet  tab.

3. Click Publish.

Accessing a campaign in Unica Campaign
You can access a linked campaign from Unica Plan.

The Implementation  button displays only if the linked campaign for the project exists.

To access a campaign in Unica Campaign, complete the following steps.

1. Open the corresponding campaign project in Unica Plan.

2. Click the Implementation  button ( ) to the right of the Analysis tab.

Updating cell status data in the TCS®
Updating the cell status imports the run results for the cells in the TCS®  from Unica 

Campaign  into Unica Plan. When you update the cell status, Unica Plan  imports the latest 

run results. The results of previous runs are irretrievably lost.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 60

You can update cell status only if one or more cells are linked to a flowchart.

You must have the Manage Campaign target cells  permission in Unica Campaign  to update 

the cell status.

When you update the cell status, Unica Plan  places the imported information in the 

following read-only fields of the TCS®:

Table  9. Updates made on cell status change

Field Description

Flowchart Name of the flowchart in which the cell is used.

Last Run Date and time of the last run for the flowchart that contains this cell.

Actual Count Number of unique audience IDs in the cell during the last run.

Run Type Run type for the last run of the flowchart that contains this cell (pro

duction or test; flowchart, branch, or process box).

To update the cell status data in the TCS®, complete the following steps.

1. Open the project whose cell count data you want to update.

2. Click the Target Cell Spreadsheet  tab.

3. Click Get cell status.

Managing flowcharts
Unica Campaign  flowcharts define the campaign logic. Each flowchart in a campaign 

performs a sequence of actions on data that is stored in your customer databases or flat 

files.

During and after creating flowcharts, you can perform various management activities on 

them. For example, you can test and run flowcharts, edit them, print them, and so on.

Note:  To work with flowcharts, you must have the appropriate permissions assigned 

by an administrator.
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More information

There are restrictions in the use of special characters in flowchart names. For details, see 

Appendix A of the Unica Campaign  User's Guide.

Creating flowcharts
You can add a flowchart to your campaign either by creating a new one, or copying an 

existing one.

Copying an existing flowchart may save time because you can start with a completed 

flowchart and modify it to meet your needs.

To facilitate constructing flowcharts, you can use pre-configured flowchart templates to 

quickly create common campaign logic or process box sequences. You can also save and 

reuse other objects such as queries, table catalogs, triggers, custom macros, user variables, 

and definitions of derived fields.

Create flowcharts
Follow these instructions to add a flowchart to a marketing campaign. A flowchart 

determines the campaign logic.

Each marketing campaign consists of at least one flowchart. A typical campaign has 

a flowchart that selects customers or prospects who will receive offers and a separate 

flowchart that tracks responses.

For example, a contact flowchart might select a set of customers that will be contacted by 

phone or email. Another flowchart in the same campaign tracks responses to those offers. 

After the offers are made, you use the response flowchart to record and analyze responses. 

You can add multiple flowcharts to a campaign as you analyze and refine your results. More 

complex campaigns can include many flowcharts to manage multiple offer streams.

Each flowchart is made up of processes. You configure and then connect processes to 

perform data manipulation, create contact lists, and record contact and response tracking 

for your campaign. By connecting a series of processes in a flowchart, then running that 

flowchart, you define and implement your campaign.
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For example, a flowchart might include a Select process, which is connected to a Segment 

process, which is connected to a Call List process. The Select process can be configured 

to select all customers from your database who live in the northeast. The Segment process 

can segment those customers into value tiers, such as Gold, Silver, Bronze. The Call List 

process assigns offers, generates a contact list for a telemarketing campaign, and records 

the results in the contact history.

The following procedure provides a quick overview of how to create a new flowchart and 

add it to a campaign or a session. (Alternatively, you can copy an existing flowchart. You 

can also use the template library to copy configured processes from one flowchart to 

another.)

Note:  If you are creating an interactive flowchart, see the Unica Interact 

documentation for information.

1. Open a campaign or session.

2. Click Add flowchart   .

The Flowchart properties  page opens.

3. Enter a flowchart name (required) and description (optional). For Flowchart type, 

Standard batch flowchart  is the only option unless you are a licensed user of Unica 

Interact. If you installed a licensed version of Unica Interact, you can select Interactive 

flowchart.

Note:  Flowchart names have specific character restrictions.  See Special 

characters not supported  (on page ).

4. Click Save and edit flowchart.

The flowchart window opens. You see the process palette on the left, a toolbar at the 

top, and a blank flowchart workspace.

5. Add a process to your flowchart by dragging a process box from the palette to the 

workspace.

unique_77
unique_77
unique_77
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A flowchart typically begins with one or more Select or Audience processes to define 

the customers or other marketable entities with which to work.

6. Double-click a process in the workspace or right-click the process and choose 

Process configuration. Then use the configuration dialog to specify how the process 

operates.

7. Connect the configured processes to determine the workflow of your campaign.

8. Use Save and continue   frequently while you work.

9. When you are done, open the Save options  menu and choose Save and exit  .

Test runs for flowcharts
You can conduct a test run on a flowchart or branch if you do not want to output data or 

update any tables or files.

When you conduct a test run on a flowchart or a branch, be aware of the following.

• Triggers run on completion of both test and production runs.

• Global suppression is applied when testing processes, branches, or flowcharts.

• The option Advanced Settings  > Test Run Settings  > Enable Output  determines 

whether output is generated during test runs.

Conduct test runs on processes and branches as you are building flowcharts, so that you 

can troubleshoot errors as they occur. Remember to save each flowchart before you run or 

test it.

Doing a test run of a process, branch, or flowchart
Conduct test runs as you build a flowchart so that you can troubleshoot errors as they 

occur. You can then view a report of any errors in the flowchart.

Always save an edited flowchart before you do a test run. When you do a test run, be aware 

of the following:
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• Test runs do not update any tables or files. However, triggers run on completion of 

test runs and global suppression is applied.

• The option Advanced settings  > Test run settings  > Enable output  determines 

whether output is generated during test runs.

• When you test run a data manipulation process (Select, Merge, Extract, Audience), you 

can limit the number of records. Use the Limit output cell size  option on the Cell Size 

Limit tab in the process configuration dialog.

• Results from a previous test run are lost.

• If a process requires data from an upstream process, you might have to run the 

upstream process first so that its data is available to the downstream process.

1. Open a flowchart in Edit  mode.

2. To test run a process or branch, right-click a process, open the Run  menu  and 

select Test run selected process  or Test run selected branch.

3. To test run blue process boxes only, open the Run menu in the toolbar and select Test 

run blue process boxes only. When we choose Test run blue process boxes, all data 

manipulation processes (Blue Process Boxes) run in test mode, stop when any Red 

Process Boxes are detected, and the Blue Process Boxes that follow the Red Process 

Box will not be run.

4. To test run the entire flowchart, open the Run  menu  in the toolbar and select 

Test run flowchart.

The process, branch, or flowchart runs in test mode. Each process that runs 

successfully displays a green check mark. If there are errors, the process displays a 

red "X".

5. If you want to pause or stop the run, right-click a process box and select Pause  or 

Stop  from the Run  menu.

6. Use one of the Save  options in the toolbar. If you click Save and exit  before the 

flowchart finishes the test run, the flowchart continues to run and is saved when it 

finishes. If anyone reopens the flowchart while it is still running, any changes made to 

the flowchart are lost. For this reason, always save a flowchart before you run it.

7. To determine if there were any errors in the run, click the Analysis  tab and view the 

Campaign flowchart status summary  report.
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TCS®  approval
In integrated Unica Plan  and Unica Campaign  systems, campaign project templates can 

require (target cell spreadsheet) TCS®  approval before flowcharts run in production mode. 

If Approval Required  is selected on the template, then all rows of the TCS®  must to be 

approved before the flowchart can run in production mode. If you run the flowchart in 

production mode and one or more rows on the TCS®  associated with this flowchart are not 

approved, Unica Campaign  generates an error.

If the project was created from a template on which the Approval Required  check box is 

not selected, then approval is not required for top-down cells in the TCS®. In this case, the 

TCS®  grid does not show the approval  column or approve all  and deny all. Leaving the 

approval required check box cleared saves time if campaigns do not require TCS®  approval.

Note:  By default, Approval Required  is cleared. However, after you upgrade to Unica 

Plan  8.5, all upgraded campaign templates have Approval Required  checked.

Import and export

If Approval Required  is selected, the is approved  column is included when you export the 

project.

If Approval Required  is cleared, the is approved  column does not export, and only CSV files 

that match are imported.

Approving an individual TCS®  row
You can approve each row of the TCS®  individually. You can approve rows as soon as they 

are complete and correct, even if other rows on the TCS®  are not yet ready to be approved.

To approve an individual row of the TCS®, complete the following steps.

1. Open the project that contains the TCS®.

2. Click the Target Cell Spreadsheet  tab.

3. Click the Edit  icon.

4. Double-click the Is Approved  column for the row you want to approve.
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The No/Yes  drop-down list displays.

5. Click Yes.

6. When you are through editing the TCS®, click the Save and Exit  icon.

Approving all rows of the TCS®
If the template is set to Approval Required, then you must approve all rows of the TCS® 

before you run the flowchart in production mode.

To approve all rows of the TCS®, complete the following steps.

1. Open the project that contains the TCS®.

2. Click the Target Cell Spreadsheet  tab.

3. Click Approve All.

Denying approval to all TCS®  rows
You can deny approval to all rows of the TCS®.

To deny all rows of the TCS®, complete the following steps.

1. Open the project that contains the TCS®.

2. Click the Target Cell Spreadsheet  tab.

3. Click Deny All.

Testing and running flowcharts
You can do a test or production run on an entire flowchart, a branch, or an individual process 

in the flowchart. You can also validate flowcharts. For best results, conduct test runs and 

perform validation as you build a flowchart, so that you can troubleshoot errors as they 

occur. Be sure to save each flowchart before you do a test or production run and before you 

perform validation.

Important:  For flowcharts that contain contact processes, each production run of 

a flowchart can generate contact history only once. To generate multiple contacts 
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from the same list of IDs, snapshot out the list of IDs and read from the list for each 

flowchart run.

Note:  Users with Administrative privileges can access the Monitoring  page, which 

displays all running flowcharts and their status. The Monitoring  page also provides 

controls to suspend, resume, or stop flowchart runs.

Doing a production run of a flowchart
When you do a production run of a flowchart, the data that it generates is saved in system 

tables. After you run and save the flowchart, you can view the results of the run in reports.

Do a production run after you save, validate, and do a test run. A production run writes to the 

history tables.

The contact processes, such as Mail list and Call list, write entries into Contact History. 

Each production run can generate contact history only once. Contact processes that already 

ran for that production run can be rerun only if the contact history from the current run is 

first deleted. To generate multiple contacts from the same list of IDs, snapshot the list of 

IDs and read from the list for each flowchart run.

Triggers run on completion of a production run.

After initiating a run, users with Administrative privileges can access the Monitoring  page, 

which displays all running flowcharts and their status.

1. Save the flowchart before you run it.

2. If any approval exists for a flowchart , the approval must be in the completed or 

canceled state otherwise the flowchart will not run.

3. If you are viewing a flowchart, open the Run  menu  and select Run.

If you are editing a flowchart, open the Run  menu  and select Save and run 

flowchart.

4. To run a process or branch, right-click a process, open the Run  menu  and select 

Save and run selected process  or Save and run selected branch.
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Note:  Running only a process or a branch of a flowchart does not increment 

the Run ID of a flowchart. When you run only a process or a branch, if contact 

history records exist, you are prompted to choose run history options before 

you can proceed. The Run history options  dialog appears only when you run 

a branch or process that previously generated contact history for the current 

Run ID. You can either append information to contact history or replace 

existing contact history for the Run ID.

5. To run the entire data manipulation processes, open the Run menu and select Save 

and run data manipulation processes.

When we choose Save and run data manipulation processes, all data manipulation 

processes (Blue Process Boxes) run in production mode, stop when any Red Process 

Boxes are detected, and the Blue Process Boxes that follow the Red Process Box will 

not be run.

6. To run the entire flowchart, open the Run  menu  in the toolbar and select Save 

and run flowchart.

If the flowchart has already run, you are asked to confirm the run.

The process, branch, or flowchart runs in production mode. Data from the run is saved 

to the appropriate system tables. Each process that runs successfully displays a 

green check mark. If there are errors, the process displays a red "X".

7. If you want to pause or stop the run, right-click a process box, open the Run  menu and 

select Pause  or Stop.

8. Use one of the Save  options in the toolbar. If you click Save and exit  before the 

flowchart finishes the run, the flowchart continues to run and is saved when it 

finishes. If anyone reopens the flowchart while it is still running, any changes made to 

the flowchart are lost.

You must save the flowchart after it runs to view the results of the run in any reports. 

After you save the flowchart, results of repeated runs are immediately available.

9. To determine if there were any errors in the run, click the Analysis  tab and view the 

Unica Campaign  flowchart status summary  report.
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Importing metrics from a campaign
If your campaign project has a Tracking  tab, the template creator mapped contact and 

response metrics in Unica Campaign  with metrics in Unica Plan. You can import the metric 

data into the campaign project.

You must have the Analyze campaign  permission in Unica Campaign  to import metrics.

To import metrics from a campaign, complete the following steps.

1. Navigate to the Tracking  tab of the campaign project whose metrics you want to 

import.

2. Click Import Values.

The Unica Campaign  metrics are displayed on the Import Values  page. The 

information that is imported depends on the metrics the template creator defined. 

Unica Plan  captures and displays the last date of import, which is shown as External 

Sources Last Refreshed Date Time  at the bottom of the table.

3. Click Save and Finish  to update the metrics on the Tracking  tab and close the Import 

Values  page.

If necessary, manually update the metrics that you imported.

Integration reports
When the Unica Plan  and Unica Campaign  integration report pack is installed, the following 

reports are available.

Table  10. Integration report pack reports

Report Description

Campaign Cell 

Financial Com

parison

A Cognos®  report that displays budget, revenue, and ROI informa

tion for each campaign and each cell within the campaign. This re

port requires the Unica Plan  Financial Management module.

Campaign Of

fer by Channel 

A Cognos®  report that displays budget, revenue, and ROI informa

tion for each campaign, each channel within the campaign, and 
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Table  10. Integration report pack reports  (continued)

Report Description

Financial Com

parison

each offer within the channel. This report requires the Unica Plan  Fi

nancial Management module.

Campaign Offer 

Financial Com

parison

A Cognos®  report that displays budget, revenue, and ROI informa

tion for each campaign and each offer within the campaign. This re

port requires the Unica Plan  Financial Management module.

Offers and offer templates in an integrated system
If offer integration is enabled, you create offers in Unica Plan, then publish them for use in 

Unica Campaign. You can set up offers before they are assigned to cells in Unica Campaign. 

Offers are based on templates, which are also created in Unica Plan.

When offer integration is enabled:

• You can import any offers previously established in Unica Campaign  into Unica Plan.

• Users create and manage offers, offer lists, and offer folders by selecting Operations 

> Offers  instead of Unica Campaign  > Offers.

• You create and manage offer attributes and offer templates by selecting Settings  > 

Unica Plan  Settings  > Template Configuration  instead of Settings  > Unica Campaign 

Settings  > Templates and Customization  options.

• You use Unica Plan  to assign offers and offer lists to output cells in the Target Cell 

Spreadsheet (TCS®) form of a campaign project.

Offer workflow features
For systems that enable offer integration, several features are available when you work with 

offers in Unica Plan.

Offer approvals

When you create or edit an offer, Unica Plan  provides a check box to indicate offer approval. 

Only approved offers can be published to Unica Campaign.
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Offer states

Offers and offer folders can have the following states.

Offer state Definition

Draft When you create an offer, the state of the new offer is Draft.

Published The state "Published" pushes the offer instance to Unica Cam

paign. The first time an offer is published in Unica Plan, the sys

tem creates the offer in Unica Campaign; subsequent publish

ing updates the offer instance in Unica Campaign.

Redraft After an offer is Published, it cannot be edited. To edit a pub

lished offer, the user can redraft the offer, which changes it 

to the Draft state. User can then edit the offer and publish 

changes.

Retire Only Published offers can be Retired. After the offer is Retired, it 

is not available for future use and cannot be edited or changed 

to any other state.

Offer codes automatically generated

In Unica Plan, the offer code that is assigned to each offer can be generated by the Default 

code generator. Users cannot modify the offer code generator. In the wizard mode of offer 

creation, the Auto-generate on save  check box creates the offer code automatically. If the 

check box is selected, the offer code is generated from Unica Campaign. If the check box is 

not selected, validation is made for the valid offer code.

Offer templates and integration with  IBM Digital 
Recommendations  (optional)
If your installation also uses Digital Recommendations, you can configure offer templates in 

Unica Plan  to dynamically receive category ID and name values for specified clients.

With this configuration, to include a category in an offer, users select from a list that 

is populated directly from Digital Recommendations  rather than entering ID numbers 
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manually. For more information, see Including IBM Digital Recommendations categories  (on 

page 20).

Enabling offer integration in Unica Plan
When offer integration is enabled, you manage offers and offer templates in Unica Plan 

rather than Unica Campaign. You can enable offer integration either when you integrate 

Unica Plan  with Unica Campaign  or after you use Unica Campaign  to manage offers.

Offer integration is a separate option from campaign integration. When campaign 

integration is enabled, you can also enable offer integration.

To enable offer integration in Unica Plan, complete the following steps.

1. Confirm that integration is enabled in Unica Plan  and in each of the appropriate Unica 

Campaign  partitions, as explained in Configuring property settings for integrated 

deployment  (on page 9).

2. On the Settings  > Configuration  page, under Unica, click Unica Platform.

3. Click Edit Settings  and set Plan - Offer integration  to True. This setting enables the 

offer lifecycle management features in Unica Plan.

The system checks for compatibility issues. For example, if an attribute with the 

"creativeurl" internal name exists in Unica Plan, offer integration fails so that values 

for that existing attribute are not overwritten. Before you can proceed with offer 

integration, you must resolve all reported issues.

4. If your Unica Campaign  installation has multiple partitions, set the following property 

for each partition where you want to enable offer integration.

a. Expand HCL Unica  > Campaign  > partitions  > partition[n]  > server  and click 

internal.

b. Set Plan - Offer integration  to Yes.

5. Repeat step 4 for other partitions as needed.

6. If you managed offers in Unica Campaign  before you enabled offer integration, import 

the metadata and data for those offers into Unica Plan  for each partition.
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After you enable offer integration, you use Unica Plan  to create, edit, and manage offers, 

including any offers that you created in Unica Campaign  before you enabled offer 

integration.

Note:  Avoid disabling offer integration after you enable it.

Importing offers from Unica Campaign
When you enable offer integration, you can import offer metadata and data from Unica 

Campaign  to Unica Plan.

Before you import offers, verify that every user who is referenced as an owner, modifier, or 

user in a Unica Campaign  offer or offer list has Unica Plan  privileges.

To import offer data and metadata from Unica Campaign  successfully, you must have 

administrative privileges to both Unica Plan  and Unica Campaign.

Note:  Complete this procedure immediately after you enable offer integration, and 

before you create any offer-related items with Unica Plan.

Typically, you import offers from Unica Campaign  only one time. If the import procedure 

fails, review and resolve the errors and then start the import process again. Successfully 

imported offers and offer lists are flagged in Unica Campaign  to prevent duplicate imports. 

After integration, users enter all offer metadata and data with Unica Plan, so you do not 

need to repeat this procedure.

Note:  Verify that the offer import procedure completes successfully.

1. Select Settings  > Plan Settings.

2. In the Other Options  section, click Import Unica Campaign  Offers.

The Import Campaign Offers  page enumerates the offer templates, offer folders, 

offers, and offer lists available for import.
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3. Click Continue. The import process starts and the status displays. You can navigate 

to other pages and return to the Import Campaign Offers  page to check the status 

and see results.

Note:  Verify that the offer import procedure completes successfully before 

Unica Plan  users start to work with offers.

4. In a multi-partitioned Unica Campaign  environment, you repeat these steps for 

each partition. Log in to Unica Plan  with a user ID associated with each of the other 

partitions and repeat this procedure.

The import process brings the offer data and metadata that exists in Unica Campaign  into 

Unica Plan. The import process sets the status of each imported item to "Published".

Note:  Retired offers and offer lists are not imported. Retired offer templates are 

imported with a status of "Disabled".

To review any error or warning conditions, navigate to the Import Campaign Offers  page and 

click Error(s) from current / last completed import job.

Table  11. Offer-related items imported from Unica Campaign

Items import

ed (in sequence) Possible errors and resolutions

1. Offer templates • A referenced standard attribute does not exist: 

Add the attribute to Unica Plan  and re-import.

• Unexpected error: Review details for possible 

causes, such as a network or database problem, 

and re-import.
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Table  11. Offer-related items imported from Unica Campaign  (continued)

Items import

ed (in sequence) Possible errors and resolutions

2. Offer folders • An offer folder with the same name exists: Re

name the existing offer folder in either Unica 

Campaign  or Unica Plan  and re-import.

• The parent offer folder does not exist: Resolve 

the error for the parent offer folder and re-import.

• Unexpected error: Review details for possible 

causes, such as a network or database problem 

and re-import.

3. Offers • A referenced offer template does not exist: Re

solve the error for the offer template and re-im

port.

• A referenced offer folder does not exist: Resolve 

the error for the offer folder and re-import.

• A referenced user does not exist: Provision the 

user with privileges for Unica Plan  and re-import.

• An offer with the same offer code exists (warn

ing): The offer is imported. Follow up by chang

ing the code to a unique value in Unica Plan.

• Unexpected error: Review details for possible 

causes, such as a network or database problem, 

and re-import.

Note:  When offer data and metadata are im

ported from Unica Campaign, the user who ini

tiates the import becomes the owner of the of

fers in Unica Plan.
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Table  11. Offer-related items imported from Unica Campaign  (continued)

Items import

ed (in sequence) Possible errors and resolutions

4. Offer lists • One or more of the offers was not imported: Re

solve the error for each offer and re-import.

• A referenced offer folder does not exist: Resolve 

the error for the offer folder and re-import.

• A referenced user does not exist: Provision the 

user with privileges for Unica Plan  and re-import.

• Unexpected error: Review details for possible 

causes, such as a network or database problem, 

and re-import.

Note:  When offer list data and metadata are 

imported from Unica Campaign, the user who 

initiates the import becomes the owner of the 

offer lists in Unica Plan.

Creating offers in an integrated system
When offer integration is enabled, you create offer templates and offers in Unica Plan  and 

publish the offers for use in Unica Campaign.

The following steps provide a high-level overview of the workflow for offer creation when 

offer integration is enabled. Complete these steps in Unica Plan.

1. Review the offer attributes and templates that are imported from Unica Campaign  (if 

any), and design new offer templates as needed.

2. To add new offer attributes, select Settings  > Plan Settings  > Template Configuration 

> Shared Attributes.

3. To create a form for the attributes you need, select Settings  > Plan Settings  > 

Template Configuration  > Forms.
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4. To create or edit an offer template, select Settings  > Plan Settings  > Template 

Configuration  > Templates.

Note:  For more information about designing a template to create offers 

available for real-time personalization, see Defining suppression rules for real-

time personalization  (on page 82).

5. Click the Tabs  tab and select the form.

6. Publish the offer template to Unica Campaign.

7. To create an offer based on the offer template, select Operations  > Offers, click the 

Add Offer  icon, select an offer template, and use the wizard to create the offer. You 

can also create offer lists or folders.

8. Approve the offer and publish it to Unica Campaign. You also publish offer lists and 

offer folders to Unica Campaign.

9. Add the offer to output cells in the Target Cell Spreadsheet form in a campaign 

project.

When Unica Campaign  is integrated with Unica Plan, a campaign project includes a 

Target Cell Spreadsheet tab. Double-click the Assigned Offers  column in the TCS®  to 

search or browse for offers.

10. Publish the TCS®.

The offer is now available in Unica Campaign. The attribute information is automatically 

passed to Unica Campaign  when a user links a flowchart cell to the TCS®  row.

Managing offer templates and attributes when offer integration is 
enabled
In an integrated system, you access offer templates from Unica Plan  Settings  instead of 

Campaign Settings.

For more information about designing offer templates and attributes, see the Unica 

Campaign  Administrator's Guide.

Follow these guidelines to manage offer templates and attributes in an integrated 

environment.
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• To work with offer templates, select Settings  > Plan Settings  > Template 

Configuration  > Templates. Use the options in the Offer Templates section to add, 

enable, edit, and perform other template operations.

See Designing offer templates  (on page 19).

• To work with offer attributes, select Settings  > Plan Settings  > Template 

Configuration  > Shared Attributes. Use the options in the Offer Attribute  section to 

create or edit your custom offer attributes.

See Offer attributes  (on page 23).

You can then add offer attributes to forms for use on offer templates. When you add an 

offer attribute to a form, you specify its behavior as parameterized, hidden, or hidden static. 

Forms for your offer templates can also include local or shared form and grid attributes, but 

those attributes and the data they collect are used only within Unica Plan. Only the data that 

is collected by offer attributes is published to Unica Campaign.

Managing offers when offer integration is enabled
In an integrated system, you access offers from the Operations  menu instead of the Unica 

Campaign  menu. You can then complete tasks as you would in an unintegrated Unica 

Campaign  system.

You also use Unica Plan  to organize offers into offer folders and lists.

Note:  When you delete an offer folder, all of the subfolders, offers, and offer lists 

that it contains are also deleted.

Note:  In clustered environments, changes to offer folders are made on a single 

node. For information about configuring caching so that changes to offer folders 

are replicated to other nodes automatically rather than requiring a system restart, 

see the Unica Plan  Installation Guide.

For more information about offers, see the Unica Campaign  User's Guide.
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Follow these guidelines to manage offers, offer folders, and lists in an integrated 

environment.

• To create an offer, complete the following steps:

1. Select Operations  > Offers.

2. Click the Add Offer  icon and select an offer template.

3. Use the wizard to create the offer.

You can select the Is Approved  option to approve the offer when you create 

it, or you can approve it later. An offer is always in one of four states: Draft, 

Published, Redraft, or Retire. When an offer is created, its state is Draft.

4. To make the offer available in Unica Campaign, you must approve and then 

publish the offer.

• To approve an offer, complete the following steps:

1. Select Operations  > Offers.

2. Click the linked offer name and select the Is Approved  option.

3. You can publish the offer to Unica Campaign.

• To publish an offer, complete the following steps:

Note:  Only approved offers can be published.

1. Select Operations  > Offers.

2. Select the box next to the offer.

3. Click the Status  icon and select Publish Selected.

This action pushes the offer instance to Unica Campaign. Published offers can 

be selected for use in a Target Cell Spreadsheet.

• To edit an offer, complete the following steps:
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Note:  A published offer cannot be edited until you change it to the "Draft" 

state.

1. Select Operations  > Offers.

2. Select the check box next to the published offer.

3. Click the Status  icon and select Re-draft Selected.

4. You can then edit the offer and publish your changes.

• To retire an offer, complete the following steps:

Note:  Only published offers can be retired. A retired offer is not available for 

future use and cannot be edited or changed to any other state.

1. Select Operations  > Offers.

2. Select the check box next to the published offer.

3. Click the Status  icon and select Retire Selected.

• To create an offer folder, complete the following steps:

1. Select Operations  > Offers.

2. Click the Add Folder  icon.

3. To add a subfolder, click the linked folder name, and click the Add Folder  icon.

4. After you add a folder, you can add offers and offer lists to it. You must publish 

the folder to make it available in Unica Campaign.

• To move items into a folder, complete the following steps:

1. Select Operations  > Offers.

2. Locate the offer, offer list, or folder that you want to move.

3. Select the check box next to the item, and click the Move Selected Items  icon.

• To publish an offer folder, complete the following steps:

1. Select Operations  > Offers.

2. Check the box next to the folder and click the Status  icon.
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3. Select Publish Selected.

This action pushes the offer folder to Unica Campaign. However, this procedure 

does not publish any of the offers or subfolders that are in the "Draft" state. 

These items must be published individually.

• To create an offer list, complete the following steps:

Note:  In Unica Plan, the query builder for smart offer lists displays in edit 

mode only. In Unica Campaign, the query builder displays in both edit mode 

and view mode.

1. Select Operations  > Offers.

2. Click the Add Offer List  icon.

Note:  You must publish an offer list to make it available in Unica 

Campaign.

Assigning offers and offer lists to cells when offer integration is 
enabled
In an integrated environment, use Unica Plan  to assign offers and offer lists to output cells 

in a Target Cell Spreadsheet (TCS®). The TCS®  is a part of each campaign project in Unica 

Plan.

Note:  To search or browse for offers, double-click the Assigned offers  column for a 

row when the TCS®  is in edit mode.

When you publish the TCS®, the offers are automatically assigned to cells when you select 

them in a contact process box in the flowchart. In this way, the TCS®  cells are linked to 

flowchart cells. This method is known as "top-down" management.

To allow bottom-up target cells, complete the following steps.
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1. Navigate to Settings  > Configuration  > HCL Unica  > Campaign  > partitions  > 

partition[n]  > server  > internal.

2. Set MO_UC_BottomUpTargetCells  to Yes.

Note:  Additions and changes to the TCS®  are not visible in Unica Campaign  until 

you click Publish  on the TCS®.

Defining suppression rules for real-time personalization
Use the Unica Campaign  and Unica Plan  integration to make offers available for real-time 

personalization, and define rules to supress offers that are no longer relevant for real-time 

personalization.

1. Click Settings  > Plan settings  > Template Configurations  > Temlates. Then click Add 

Template  from the Offer Templates section.

2. When you create a new template or edit a template associate a form where offer 

shared attributes InteractPointName  and InteractPointID  are exposed.

3. Click Operations  > Offers.

4. Complete the options in the Offer suppression for real-time interactions  section.

You can choose when to suppress offers on offer acceptance, offer rejection, and 

offer presentation for various response types. You can also choose to suppress offers 

depending on the offer attributes and for how long to suppress the offer in days.

Creating a Target Cell Spreadsheet
You can create a Target Cell Spreadsheet by following these steps.

Before you create a TCS, you must create any custom cell attributes that you want 

to include. Cell attributes map to Unica Campaign  and can be created only as shared 

attributes.

1. Select Settings  > Plan Settings.

2. Under Other Options, click Template Configuration.

3. Under Template Components, click Forms.
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4. On the Form Definitions  page, click Create New Form.

The Form Editor  interface displays.

Note:  Ensure that you do not use the "uap" and "umcm" prefixes while defining 

tables for forms and grids.

5. Complete the Form Properties  tab and click Save Changes.

The Add an Element  tab displays.

6. Click Create New Grid.

The Create New Grid  dialog opens.

7. From the Grid Type  drop-down list, select Editable Grid View.

8. Select the Is TCS  check box.

9. Complete the remaining options and click Save and Exit.

On the Add an Element  tab, click to expand the list of Form Attributes. Your TCS grid 

component displays.

10. To add a TCS grid to a form, you must place it within a group. If the form does not 

already contain a group for the grid, click and drag Attribute Group Header  onto the 

form design area then name it appropriately.

11. From the list of Form Elements, click and drag your TCS®  grid component and drop it 

onto the group.

The default cell attributes display on the grid. See Default cell attributes for Target Cell 

Spreadsheets  (on page 18).

12. Add any attributes that you want to include in the TCS. You can do either of the 

following steps.

• Import custom cell attributes and add them to the TCS to create more columns. 

these columns are passed to Unica Campaign.

• Create or import grid attributes and add them to the TCS to create more 

columns. These columns display only in Unica Plan.

Note:  Ensure that you do not use the "uap" and "umcm" prefixes while 

defining tables for forms and grids.

13. Click Save and Exit  to save the TCS and return to the Form Definitions  list page.
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Assigning offers and offer lists to cells when offer 
integration is enabled
In an integrated environment, use Unica Plan  to assign offers and offer lists to output cells 

in a Target Cell Spreadsheet (TCS®). The TCS®  is a part of each campaign project in Unica 

Plan.

Note:  To search or browse for offers, double-click the Assigned offers  column for a 

row when the TCS®  is in edit mode.

When you publish the TCS®, the offers are automatically assigned to cells when you select 

them in a contact process box in the flowchart. In this way, the TCS®  cells are linked to 

flowchart cells. This method is known as "top-down" management.

To allow bottom-up target cells, complete the following steps.

1. Navigate to Settings  > Configuration  > HCL Unica  > Campaign  > partitions  > 

partition[n]  > server  > internal.

2. Set MO_UC_BottomUpTargetCells  to Yes.

Note:  Additions and changes to the TCS®  are not visible in Unica Campaign  until 

you click Publish  on the TCS®.

Disable and re-enable integration
Although it is possible to disable integration after you enable it, it is best to avoid this action 

if possible.

Disabling Unica Plan-Unica Campaign  integration

If you disable Unica Plan  and Unica Campaign  integration, Unica Campaign  reverts to its 

stand-alone behavior and appearance. However, there are several important issues to keep 

in mind:
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• To access flowcharts that are associated with integrated campaigns after you disable 

the integration, you must publish all campaigns in Unica Plan  before you turn off 

the integration. The campaigns are then available in the top-level folder in Unica 

Campaign.

• If you disable the integration, there is no navigation link between campaign projects 

and campaigns. Users can still access their campaign projects, but the icons for 

creating and updating campaigns are disabled. The options for publishing TCS®  data 

and getting cell status are not available. Campaign project templates are not included 

in the list of templates that users see.

• If you want to re-enable integration, contact technical support to discuss the 

implications. Any changes that are made to campaigns while integration is disabled 

are overwritten the first time you update the campaign or publish the TCS®  from 

within Unica Plan  after you re-enable the integration.

Disabling offer integration

Try to avoid disabling offer integration, as this action can lead to inconsistent data. For 

example, an offer is created in Unica Plan  and published to Unica Campaign. After offer 

integration is turned off, that offer is modified in Unica Campaign. If offer integration is 

turned on again, the change that is made in Unica Campaign  is not synchronized with 

Unica Plan. Unica Plan  does not have the updated offer information, even if offer data is 

reimported from Unica Campaign. The transfer of data between the products is primarily 

one way, from Unica Plan  to Unica Campaign.

Configuring property settings for integrated 
deployment
When Unica Plan  and Unica Campaign  are integrated, you use Unica Plan  to plan, create, 

and approve campaigns.

For systems that enable offer integration, features for offer lifecycle management are added 

to Unica Plan. See Enabling offer integration in Unica Plan  (on page 72).

To integrate Unica Plan  and Unica Campaign, set the following properties.
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1. On the Settings  > Configuration  page, under HCL Unica, click Unica Platform.

2. Click Edit Settings  and set Plan - Campaign  integration to True. This setting enables 

integration so that you can use Unica Plan  to create, plan, and approve campaigns.

3. If your Unica Campaign  installation has multiple partitions, set the properties for 

each partition where you want to enable integration. Expand HCL Unica  > Campaign  > 

partitions  > partition[n]  > server  and click internal.

4. Click Edit Settings  and set MO_UC_integration  to Yes. This setting enables Unica 

Plan-Unica Campaign  integration for this partition.

Note:  To set either of the next two options to Yes, you must first set 

MO_UC_integration  to Yes. The following options apply only when 

MO_UC_integration  is enabled.

5. Optional:  Set MO_UC_BottomUpTargetCells  to Yes.

When MO_UC_integration  is enabled, TCS®  cells that are created from Unica Plan 

are always top-down. To allow for bottom-up Target Cell Spreadsheet cells for this 

partition, set this property to Yes. When set to Yes, both top-down and bottom-up 

target cells are visible, and a Get Bottom Up Cells  control is available in the Unica 

Plan  Target Cell Spreadsheet. This control gets bottom-up cells that are created in 

Unica Campaign  into Unica Plan. The bottom-up cells are read-only in Unica Plan, and 

cannot be published back to Unica Campaign  from Unica Plan.

6. Optional:  Set Legacy_campaigns  to Yes.

This setting enables access to campaigns created before integration, including 

campaigns that were created in Affinium Campaign 7.x and linked to Affinium Plan 7.x 

projects.

7. Repeat steps 4-6 for other partitions as needed.

8. Expand HCL Unica  > Plan  > umoConfiguration  and click campaignIntegration.

9. Click Edit Settings  and set the defaultCampaignPartition.

When Unica Plan  and Unica Campaign  are integrated, this parameter specifies the 

default Unica Campaign  partition to use when the campaign-partition-id is not defined 

by the project template. The default is partition1.
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10. Set the webServiceTimeoutInMilliseconds  for Web Services integration API calls.

This parameter is used as a timeout for web services API calls.

Continue with the steps for Enabling offer integration in Unica Plan  (on page 72).

The Target Cell Spreadsheet
You define all of the target and control cells for your campaign and assign offers in 

the Target Cell Spreadsheet. Your TCS®  must contain all cell definitions for your entire 

campaign.

Multiple flowcharts in a campaign can link to cells in the TCS®, but each TCS®  row can 

only be linked to only one flowchart cell. For example, you might have cells that are defined 

for wave one of a campaign that is delivered through email and different cells that are 

defined for wave two delivered through the call center. Wave one and wave two might be 

implemented in different flowcharts but the cells can share attribute values (for example, 

cell code) if they represent the same group of audience IDs in both flowcharts.

Each row must have values in the Cell Name  and Is Control Cell  columns or the row are not 

saved. If you do not provide a cell code, one is automatically generated when you publish 

the TCS®. If you provide a code, it must meet the cell code format requirements that are 

configured in Unica Campaign. If the allowDuplicateCellCodes  configuration parameter is 

set to FALSE, cell codes must be unique within a flowchart. If you delete the cell code for a 

row in the TCS®  and republish the TCS®, Unica Campaign  creates a cell code for the row. 

Any existing link between that cell and a flowchart persists.

The TCS®  is an editable grid, so you enter data in it just as you would in any other editable 

grid. You can copy and paste TCS®  rows.

Additions or changes you make to the TCS®  are not visible in Unica Campaign  until you 

click Publish  on the TCS®.

If you delete a row that is linked to a flowchart cell and republish the TCS®, any flowchart 

cell that is linked to that TCS®  row becomes unlinked, although no data is lost. If that cell is 

input to a contact process (a Call List, Mail List, or Optimize process box), you must link the 

flowchart cell to another TCS®  row before you can run the flowchart in production mode.
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Note:  The value of the control cell cannot be copied after the request is accepted,.

Consider the following points when Offer Integration is enabled with Plan.

• You can assign a published offer to the Mail List or Optimize process box by using 

match and link cells.

• After the offer is assigned, you cannot change it manually from the process box. If any 

changes are made to the offer from Plan, the changes are reflected in the process box 

only after the cells are unlinked and then linked again.

Creating offers in an integrated system
When offer integration is enabled, you create offer templates and offers in Unica Plan  and 

publish the offers for use in Unica Campaign.

The following steps provide a high-level overview of the workflow for offer creation when 

offer integration is enabled. Complete these steps in Unica Plan.

1. Review the offer attributes and templates that are imported from Unica Campaign  (if 

any), and design new offer templates as needed.

2. To add new offer attributes, select Settings  > Plan Settings  > Template Configuration 

> Shared Attributes.

3. To create a form for the attributes you need, select Settings  > Plan Settings  > 

Template Configuration  > Forms.

4. To create or edit an offer template, select Settings  > Plan Settings  > Template 

Configuration  > Templates.

Note:  For more information about designing a template to create offers 

available for real-time personalization, see Defining suppression rules for real-

time personalization  (on page 82).

5. Click the Tabs  tab and select the form.

6. Publish the offer template to Unica Campaign.



Unica Plan and Unica Campaign V12.1.4 Integration Guide  | 1 - Unica Plan and Unica Campaign Integration Guide  | 89

7. To create an offer based on the offer template, select Operations  > Offers, click the 

Add Offer  icon, select an offer template, and use the wizard to create the offer. You 

can also create offer lists or folders.

8. Approve the offer and publish it to Unica Campaign. You also publish offer lists and 

offer folders to Unica Campaign.

9. Add the offer to output cells in the Target Cell Spreadsheet form in a campaign 

project.

When Unica Campaign  is integrated with Unica Plan, a campaign project includes a 

Target Cell Spreadsheet tab. Double-click the Assigned Offers  column in the TCS®  to 

search or browse for offers.

10. Publish the TCS®.

The offer is now available in Unica Campaign. The attribute information is automatically 

passed to Unica Campaign  when a user links a flowchart cell to the TCS®  row.

Managing offers when offer integration is enabled
In an integrated system, you access offers from the Operations  menu instead of the Unica 

Campaign  menu. You can then complete tasks as you would in an unintegrated Unica 

Campaign  system.

You also use Unica Plan  to organize offers into offer folders and lists.

Note:  When you delete an offer folder, all of the subfolders, offers, and offer lists 

that it contains are also deleted.

Note:  In clustered environments, changes to offer folders are made on a single 

node. For information about configuring caching so that changes to offer folders 

are replicated to other nodes automatically rather than requiring a system restart, 

see the Unica Plan  Installation Guide.

For more information about offers, see the Unica Campaign  User's Guide.
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Follow these guidelines to manage offers, offer folders, and lists in an integrated 

environment.

• To create an offer, complete the following steps:

1. Select Operations  > Offers.

2. Click the Add Offer  icon and select an offer template.

3. Use the wizard to create the offer.

You can select the Is Approved  option to approve the offer when you create 

it, or you can approve it later. An offer is always in one of four states: Draft, 

Published, Redraft, or Retire. When an offer is created, its state is Draft.

4. To make the offer available in Unica Campaign, you must approve and then 

publish the offer.

• To approve an offer, complete the following steps:

1. Select Operations  > Offers.

2. Click the linked offer name and select the Is Approved  option.

3. You can publish the offer to Unica Campaign.

• To publish an offer, complete the following steps:

Note:  Only approved offers can be published.

1. Select Operations  > Offers.

2. Select the box next to the offer.

3. Click the Status  icon and select Publish Selected.

This action pushes the offer instance to Unica Campaign. Published offers can 

be selected for use in a Target Cell Spreadsheet.

• To edit an offer, complete the following steps:
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Note:  A published offer cannot be edited until you change it to the "Draft" 

state.

1. Select Operations  > Offers.

2. Select the check box next to the published offer.

3. Click the Status  icon and select Re-draft Selected.

4. You can then edit the offer and publish your changes.

• To retire an offer, complete the following steps:

Note:  Only published offers can be retired. A retired offer is not available for 

future use and cannot be edited or changed to any other state.

1. Select Operations  > Offers.

2. Select the check box next to the published offer.

3. Click the Status  icon and select Retire Selected.

• To create an offer folder, complete the following steps:

1. Select Operations  > Offers.

2. Click the Add Folder  icon.

3. To add a subfolder, click the linked folder name, and click the Add Folder  icon.

4. After you add a folder, you can add offers and offer lists to it. You must publish 

the folder to make it available in Unica Campaign.

• To move items into a folder, complete the following steps:

1. Select Operations  > Offers.

2. Locate the offer, offer list, or folder that you want to move.

3. Select the check box next to the item, and click the Move Selected Items  icon.

• To publish an offer folder, complete the following steps:

1. Select Operations  > Offers.

2. Check the box next to the folder and click the Status  icon.
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3. Select Publish Selected.

This action pushes the offer folder to Unica Campaign. However, this procedure 

does not publish any of the offers or subfolders that are in the "Draft" state. 

These items must be published individually.

• To create an offer list, complete the following steps:

Note:  In Unica Plan, the query builder for smart offer lists displays in edit 

mode only. In Unica Campaign, the query builder displays in both edit mode 

and view mode.

1. Select Operations  > Offers.

2. Click the Add Offer List  icon.

Note:  You must publish an offer list to make it available in Unica 

Campaign.

Managing offer templates and attributes when offer 
integration is enabled
In an integrated system, you access offer templates from Unica Plan  Settings  instead of 

Campaign Settings.

For more information about designing offer templates and attributes, see the Unica 

Campaign  Administrator's Guide.

Follow these guidelines to manage offer templates and attributes in an integrated 

environment.

• To work with offer templates, select Settings  > Plan Settings  > Template 

Configuration  > Templates. Use the options in the Offer Templates section to add, 

enable, edit, and perform other template operations.

See Designing offer templates  (on page 19).
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• To work with offer attributes, select Settings  > Plan Settings  > Template 

Configuration  > Shared Attributes. Use the options in the Offer Attribute  section to 

create or edit your custom offer attributes.

See Offer attributes  (on page 23).

You can then add offer attributes to forms for use on offer templates. When you add an 

offer attribute to a form, you specify its behavior as parameterized, hidden, or hidden static. 

Forms for your offer templates can also include local or shared form and grid attributes, but 

those attributes and the data they collect are used only within Unica Plan. Only the data that 

is collected by offer attributes is published to Unica Campaign.

Assigning offers and offer lists to cells when offer 
integration is enabled
In an integrated environment, use Unica Plan  to assign offers and offer lists to output cells 

in a Target Cell Spreadsheet (TCS®). The TCS®  is a part of each campaign project in Unica 

Plan.

Note:  To search or browse for offers, double-click the Assigned offers  column for a 

row when the TCS®  is in edit mode.

When you publish the TCS®, the offers are automatically assigned to cells when you select 

them in a contact process box in the flowchart. In this way, the TCS®  cells are linked to 

flowchart cells. This method is known as "top-down" management.

To allow bottom-up target cells, complete the following steps.

1. Navigate to Settings  > Configuration  > HCL Unica  > Campaign  > partitions  > 

partition[n]  > server  > internal.

2. Set MO_UC_BottomUpTargetCells  to Yes.

Note:  Additions and changes to the TCS®  are not visible in Unica Campaign  until 

you click Publish  on the TCS®.
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Publishing the TCS®
To make the cell definitions and offer assignments in the TCS®  available to Unica 

Campaign, you must publish the TCS®. Anytime you make updates to data in the TCS®, you 

must publish the TCS®  again to make those changes visible to Unica Campaign.

To publish the TCS®, you must have the Manage Campaign Target Cells  permission in 

Unica Campaign.

Every row must have a value for the Cell Name  and Is Control Cell?  columns before you 

publish the TCS®. If the TCS®  contains unpublished data, the Publish  button label is red.

A flowchart cannot link any cells to the TCS®  rows until the TCS®  is published. Although 

publishing the TCS®  makes the data available to the flowchart in Unica Campaign, you 

cannot start a production run of a flowchart until all linked rows in the TCS®  are approved. 

You can start a test run of a flowchart at any time.

If the data in the TCS®  changes, you must publish the TCS®  again to update the data 

available to Unica Campaign.

If the TCS®  contains data that has not been published, the Publish  button label is red.

To publish the TCS®, complete the following steps.

1. Open the project that contains the TCS®.

2. Click the Target Cell Spreadsheet  tab.

3. Click Publish.


	Unica Plan and Unica Campaign V12.1.4 Integration Guide
	Contents
	Chapter 1. Unica Plan and Unica Campaign Integration Guide
	Introduction to the integration
	Integration with Unica Plan
	Overview of the data transfer between Unica Plan and Unica Campaign
	Campaign data transfer
	Cell data transfer
	Offer data transfer

	Differences between integrated and stand-alone Unica Campaign
	Differences between integrated and stand-alone Unica Plan
	Campaign project management
	Offer lifecycle management

	License and permission issues for Unica Plan and Unica Campaign integration
	Disable and re-enable integration
	Disabling Unica Plan-Unica Campaign integration
	Disabling offer integration

	Integrating Unica Plan and Unica Campaign
	Configuring property settings for integrated deployment
	Navigating from a linked legacy campaign to a Unica Plan project
	Unica Plan documentation and help

	Unica Campaign project template design
	Design your campaign project templates, forms, and attributes
	Target Cell Spreadsheet and other forms
	Campaign Summary section
	Target cell spreadsheets
	Cell attributes and grid attributes
	Target Cell Spreadsheets and forms
	Transfer of cell attribute data
	Target Cell Spreadsheets and templates

	Default cell attributes for Target Cell Spreadsheets

	Designing offer templates
	Including IBM Digital Recommendations categories
	Defining the client list

	Designing attributes
	Unica Campaign attributes
	Cell attributes
	Offer attributes
	Standard offer attributes in Unica Campaign
	Offer attribute behavior options
	Creative URL offer attribute

	Campaign, cell, and offer attributes


	Creating and enabling a shared attribute
	Creating a Flowchart approval
	Creating a Target Cell Spreadsheet
	Share Unica Campaign contact and response data with Unica Plan
	Mapping Unica Campaign contact and response counts to Unica Plan metrics
	Metrics data mapping file
	metric
	data-map-column

	Adding data mapping files
	Editing data mapping files
	Data Mapping Definitions

	Unica Campaign project templates
	Creating campaign project templates
	Project template Campaign tab for communicating with Unica Campaign
	Copying information automatically from Unica Plan to Unica Campaign

	Unica Plan and Unica Campaign Integration reports package
	Installation prerequisites for the Integration Report Package
	Running the installer on the IBM® Cognos® system
	Importing the reports folder in Cognos® Connection
	Enabling internal links in the reports
	Verifying data source names and publishing
	Configuring IBM Cognos® Application Firewall for Unica
	Creating Cognos® data sources for Unica application databases


	Creating a campaign in an integrated environment
	Unica Campaign projects in an integrated system
	Project codes and campaign codes
	Creating projects
	Starting projects
	Campaign Summary section
	Creating requests
	Changing the status of multiple projects or requests
	Special characters in Unica Campaign object names

	Creating a linked campaign
	Updating a linked campaign
	The Target Cell Spreadsheet
	Grid edit mode
	Permissions
	Locked data
	Revision history

	Adding grid rows
	Editing grid rows
	Deleting grid rows

	Publishing the TCS®
	Accessing a campaign in Unica Campaign
	Updating cell status data in the TCS®
	Managing flowcharts
	More information
	Creating flowcharts
	Create flowcharts

	Test runs for flowcharts
	Doing a test run of a process, branch, or flowchart


	TCS® approval
	Import and export
	Approving an individual TCS® row
	Approving all rows of the TCS®
	Denying approval to all TCS® rows

	Testing and running flowcharts
	Doing a production run of a flowchart

	Importing metrics from a campaign
	Integration reports

	Offers and offer templates in an integrated system
	Offer workflow features
	Offer approvals
	Offer states
	Offer codes automatically generated
	Offer templates and integration with IBM Digital Recommendations (optional)

	Enabling offer integration in Unica Plan
	Importing offers from Unica Campaign

	Creating offers in an integrated system
	Managing offer templates and attributes when offer integration is enabled
	Managing offers when offer integration is enabled
	Assigning offers and offer lists to cells when offer integration is enabled
	Defining suppression rules for real-time personalization

	Creating a Target Cell Spreadsheet
	Assigning offers and offer lists to cells when offer integration is enabled
	Disable and re-enable integration
	Disabling Unica Plan-Unica Campaign integration
	Disabling offer integration

	Configuring property settings for integrated deployment
	The Target Cell Spreadsheet
	Creating offers in an integrated system
	Managing offers when offer integration is enabled
	Managing offer templates and attributes when offer integration is enabled
	Assigning offers and offer lists to cells when offer integration is enabled
	Publishing the TCS®


