<L

Unica Journey V12.1.4 Release Notes




Contents

Chapter 1. System requirements and compatibility..........cccccceerriirmeiiiriiiiriinrrereeeeeeeeee. 1
Chapter 2. Prerequisites for Unica Journey Installation or Upgrade...........cccccceevvueenennnnnnee. 6
Chapter 3. New features and changes in version 12.1.4.........cccccoiiiiiiiirereeennrcerreeeeeeeeneeeees 8
Chapter 4. Fixed DefeCts.........cciiiiiuuiiiiiiiiiirieeitretneeeeceeeneeeeeeeennneeeeeesesnnsssssesssnnsssssessenns 10

Chapter 5. Known issues

Chapter 6. Before you contact HCL technical support............ccccccoeeiriiiiiiiiiieenneeneecnccnennn. 14



Chapter 1. System requirements and
compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.4 requires
Unica Platform 12.1.4.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party
requirements for this product, see the Recommended Software Environments and Minimum

System Requirements document.

You can also access this document by selecting Help > Product documentation when you

are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following

requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower
resolutions can result in some information not being properly displayed. If you use a
lower resolution, maximize the browser window to see more content.

« Amouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and
Forward buttons. Instead, use the controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica
Journey might not function properly. For best results, disable pop-up blocker software
while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and
the supported platforms. For more information, see the Recommended Software

Environments and Minimum System Requirements document.
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» The correct browser and versions must be used. For more information, see the

Recommended Software Environments and Minimum System Requirements

document.

- Clear the browser cache after installation. This only needs to be done once, after the

application is updated.

Important: Do not use any other method to open multiple sessions. For example,

do not open a new tab; do not open another browser session from the Start menu

or desktop icon; and do not use File > New Window in Microsoft Internet Explorer.

These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and

developers to get their hands on the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the
product

For the first release, all new features are

available in the Unica Journey User Guide

Find out about the known issues and limi-

tations

Unica Journey Release Notes

Learn about the structure of the Unica

Journey system tables

Unica Journey System Schema

Installation and configuration of Unica

Journey

Unica Journey Installation Guide

Upgradation and configuration of Unica

Journey

Unica Journey Upgrade Guide
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Table 2. Installing and Configuring Unica Link

Task

Documentation

Installation and configuration of Unica
Link

Unica Link Installation Guide

Installing Unica Link connector app for

Journey

Unica Link Installation Guide

Installing Unica Link connector -
MailChimp

Unica Link Mailchimp Connector User
Guide

Installing Unica Link connector — Mandrill

Unica Link Mandrill Connector User
Guide

Installing Unica Link connector — Twilio

Unica Link Twilio Connector User Guide

Installing Unica Link connector — Sales-

force

Unica Link Salesforce Connector User
Guide

Table 3. Integrate Unica Campaign with other HCL products

Task

Documentation

Integration of Unica Campaign and Unica

Journey

Unica Campaign Administration Guide

and Unica Campaign User Guide

Integration of Unica Campaign and Unica
Interact

Unica Interact Administration Guide

Integration of Unica Deliver with Unica

Journey

Unica Journey User Guide

Integration of Unica Centralized Offer

Management and Unica Journey

Unica Journey User Guide
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Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product doc-
umentation while you logged in Help >

Product documentation.

Unica Journey when installed with other Unica suite products
Before you start installation of Unica Journey you can refer to below sections to plan

Journey installation.

Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of
these integration as per your requirements. Please refer to documentation map section for

appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system,
application server etc., is not exactly same support with Unica Journey. Please refer to

Recommended Software Environments and Minimum System Requirements guide.

For example, If your existing Unica products are installed on stack as below:

* Operating System - AIX 7.1
« Application Server - WebSphere
« Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended
Software Environments and Minimum System Requirements guide and it would be

compatible with existing Unica products.
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Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.4, you can complete your

upgrade and then install Unica Journey 12.1.4.

Where to find documentation
You can find the documentation here.

* PDFs:
* Online Help:



Chapter 2. Prerequisites for Unica Journey
Installation or Upgrade

Before installing Unica Journey version 12.1.4, you have to ensure that a few prerequisites

are met.

If a you are a new user, and if you have HCL OneDB, MariaDB, or Microsoft SQL Server as the

database, you can directly install Unica Journey 12.1.4. Ensure that Unica Platform version

12.1.4 is operating correctly.

The supported upgrade path for Unica Journey 12.1.4 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey

Upgrade Guide and the list of sub-topics in the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base

Unica Journey can be:

*12.1.x
«12.1.0.x

In case of Microsoft SQL
Server, MariaDB and
OneDB, the base version is
12.1.0.3 and later.

In case of Oracle, the up-
grade path can be:

*121x—~121.4
*121.0x—-121.4

In case of Microsoft SQL
Server, MariaDB and
OneDB, the upgrade path

is:

*12.1.0x—~12.1.4

1. Upgrade Unica Mar-
keting Platform to
12.1.4

2. Run upgrade Unica
Journey to 12.1.4 in-
staller

3. Configure Journey
application

4. Deploy Journey appli-
cation

5. Run Journey applica-

tion

Clean Installing Journey on
existing Unica environment
when you have system ta-
bles as OneDB, MariaDB

and SQL Server databases

In place upgrade to Unica

Journey 12.1.4

1. Upgrade Unica Mar-
keting Platform and
required Unica prod-
ucts to 12.1.4 except

Journey.
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Table 5. This table describes the topics that are included in the Unica Journey

Upgrade Guide and the list of sub-topics in the second column. (continued)

2. Run clean installer of
Unica Journey 12.1.4

3. Configure Journey
application

4. Deploy Journey appli-
cation

5. Run Journey applica-

tion

Note:

1. If Journey is not already installed on an existing Unica environment with
Oracle database, install Unica Journey version 12.1.0 and upgrade to Unica
Journey version 12.1.4. If Journey is already installed and the Journey version
is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment
with either MS SQL Server, OneDB or MariaDB database then you can install

Journey version 12.1.4 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it.
Also, stop all other components, for example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application
server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to

any temporary directory.



Chapter 3. New features and changes in
version 12.1.4

In Unica Journey 12.1.4, we have introduced some new features, and we have made

changes to some existing features or functionality.

The following list mentions the support for new platforms, in Unica Journey 12.1.4:

* Supports IBM WebSphere Application Server and Red Hat JBoss Enterprise
Application Platform.

« Supports Kafka on windows operating system. To configure Kafka on
Windows operating system, see https://support.hcltechsw.com/csm?
id=kb_article&sysparm_article=KB0085551.

The following list mentions the new features, and the changes to existing features, in Unica

Journey 12.1.4:

- Journey supports DB2 as system tables

Journey system tables can now be deployed on DB2.
« Offer Integration for Publish Touchpoint

Offers can now be integrated in the Publish Touchpoint. The offers are included as
delimited list in the CSV output.
- Offer Integration for REST Touchpoint

Offers can now be integrated in the REST Touchpoint.
- Offer Integration for JDBC Touchpoint

Offers can now be integrated in the JDBC Touchpoint.
« Integrate Landing page data from Deliver

If Landing pages are associated with Email template in Deliver, these can now be
associated with Journey and the fields and data can be used in Decision Splits.

« Journey Publish View


https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551
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Journey design can now be viewed in Read Only mode while the Journey is published.
This allows checking the various touchpoint configurations without having to Pause
the Journey.

« Isolating the use of proxy server to specific products rather than the entire Unica

Suite

Journey now allows you to configure proxy server to communicate with specific Unica
products. For example, if you want to configure proxy server for communication only
with Deliver and Link, you can do so and avoid configuring the proxy server for other

integrations like Platform.



Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.4:

Defect ID Description

HMA-343008 Instead of Mapping the LP attributes to Field values those
should be mapped to Label in Deliver

HMA-338565 IF 01-Error message column did not populated for
Mailchimp although we get Error message in incoming re-
sponse topic and data Error table in ONEDB

HMA-338531 IFO1-SQL Server Issue 12.1.0.3 to 12.1.1 - Performance Re-
ports dont work correctly due to trigger issue

HMA-338514 IFO1 v12.1.3 - REGBB- Journey is not getting copied if hav-
ing link connector

HMA-338387 v12.1.3: Copyright year is incorrect in Fed tar Response
files(ResponseFiles.tar.gz)

HMA-336307 Disable_Validations_On_Journey_Records: No -> With this
settings Data greater than set length should get rejected but
getting accepted

HMA-334560 offsets.topic.replication.factor=1 property from the kafka
server.properties get commented in clean as well as over-
write installation.

HMA-330727 ORA-02264: name already used by an existing constraint
displayed while executing the JourneyReportOracleCreate-
Tables.sql on oracle 12c on single schema for Journey

HMA-334480 Facebook version for 12.1.1 and 12.1.2is V11.0

HMA-334130 Journey system schema procedure need to compiled manu-
ally on Oracle Database.
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Defect ID Description

HMA-334459 Please document in the release notes, install and upgade
guide

HMA-334549 Edit issue when single external source is mapped to same
journey entry source

HMA-334614 Journey with preferences configured on timezone and chan-
nels - When template is created with this journey, new jour-
ney does not have the preferences at journey level nor at the
touchpoints

HMA-333490 REGBB- (Docker Tomcat) For linkedin not showing states
count

HMA-335161 User is logged out when tried to access Kafka type of Entry
Source

HMA-338024 IFO1-Maria DB- Not getting deliver responses in journey as
unique constraints are not working for null xid

HMA-338440 IFO1-12.1.3 - Getting error on running gdpr utility since
three log4j jars (log4j-api-2.17.1,log4j-core-2.17.1,log4j-1-
.2-api-2.17.1) are missing from GDPR lib folder

HMA-337336 Journey uninstallation did not remove all the files which is
lay down by the installer

HMA-337222 Error message column did not populated for Mailchimp al-

though we get Error message in incoming response topic



Chapter 5. Known issues

Deliver SMS - After adding PF fields in SMS template in Deliver - in journey user not getting

mapping fields and even not getting sms

The following table lists the known issues in Unica Journey 12.1.4:

Defect ID Known Issue

HMA-344209 Deliver -LP - If user modify the LP, these changes are not
getting in effected in Journey

HMA-342112 LandingPage - Attributes getting is response is different for
Check box and radio button type fields

HMA-342759 Enhance checkbox group handling so responses appear

against group attribute name

HMA-344196 Deliver LP - Some times deliver is not sending LP data to

Journey, its sending blank

HMA-342065 Landing Page- Only one URL is getting available on Engage-
ment split page for Landing page associated URLs

HMA-342064 Landing Page- Only one URL is getting available on Goal
page for Landing page and user is not able to identify which
url is of which LP

HMA-343927 In Deliver if user adds LP in Email communication after as-
signing it in Journey - Then in actual email User is not get-
ting LP

HMA-344622 Deliver email - If user modify the link URL or adds any new
Link in already configured email communication modified

links not working

HMA-344635 Deliver SMS - After adding PF fields in SMS template in De-
liver - in journey user not getting mapping fields and even

not getting sms




Unica Journey V12.1.4 Release Notes | 5 - Known issues | 13

Defect ID Known Issue

HMA-343292 Landing_Page- If two landing pages attributes mapped in
Email communications, one of Landing page attributes are

not getting in Journey

HMA-344005 Publish Offer - Offers codes display in CSV file in one row

with semi colon separator

HMA-333396 Journey - Mobile app change from deliver end

HMA-334727 Control Center-know limitation - If Global preferance is
deleted/Edited from Control center - journey showing blank

Timezone in journey

HMA-337225 Web and engine application properties - properties are get-
ting merged after updating or upgrading the build

HMA-337881 Journey audiences archival speed needs improvement

HMA-334502 Unable to Publish paused Journey when milestones added
and Duplicate records are allowed in Journey settings

HMA-334254 Global Preference: For non set communication days on jour-
ney stats its showing waiting reason as "Invalid communi-

cation time"

HMA-344637 Docker-DB2- In decision split always sending data to No
path where db2 version 11.1.0.0




Chapter 6. Before you contact HCL technical
support

If you encounter a problem that you cannot resolve by referring the documentation, your
company's designated support contact can log a call with HCL technical support. Use these

guidelines to ensure that your problem is resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your HCL

administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as

described in "System information."

System information

When you call HCL technical support, you might be asked to provide information about your

environment.

If your problem does not prevent you from logging in, much of this information is available

on the About page, which provides information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, check foraver si on. t xt file that is located under the installation directory for

your application.

Contact information for HCL technical support
For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support


https://www.hcltech.com/products-and-platforms/contact-support
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