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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.11 requires Unica Platform 12.1.11.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this product, see

the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some

information not being properly displayed. If you use a lower resolution, maximize the browser window to see more

content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the

controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function properly.

For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms. For

more information, see the Recommended Software Environments and Minimum System Requirements document.

» The correct browser and versions must be used. For more information, see the Recommended Software

Environments and Minimum System Requirements document.

« Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do not

open another browser session from the Start menu or desktop icon; and do not use File > New Window in Microsoft

Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their hands on

the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the

Unica Journey User Guide
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Table 1. Get up and running (continued)

Task Documentation

Find out about the known issues and limitations Unica Journey Release Notes
Learn about the structure of the Unica Journey system Unica Journey System Schema
tables

Installation and configuration of Unica Journey Unica Journey Installation Guide
Upgradation and configuration of Unica Journey Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide

Installing Unica Link connector app for Journey Unica Link Installation Guide

Installing Unica Link connector — MailChimp Unica Link Mailchimp Connector User Guide
Installing Unica Link connector — Mandrill Unica Link Mandrill Connector User Guide
Installing Unica Link connector — Twilio Unica Link Twilio Connector User Guide
Installing Unica Link connector — Salesforce Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task Documentation

Integration of Unica Campaign and Unica Journey Unica Campaign Administration Guide and Unica Campaign
User Guide

Integration of Unica Campaign and Unica Interact Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey Unica Journey User Guide

Integration of Unica Centralized Offer Management and Unica Journey User Guide

Unica Journey

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product documentation while you

logged in Help > Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.
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Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per your

requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.11, you can complete your upgrade and then install Unica

Journey 12.1.11.
Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:



Chapter 2. Prerequisites for Unica Journey Installation or

Upgrade

Before installing Unica Journey version 12.1.11, you have to ensure that a few prerequisites are met.

About this task

If a you are a new user, and if you have HCL MariaDB, Postgres, DB2 or Microsoft SQL Server as the database, you can

directly install Unica Journey 12.1.11. Ensure that Unica Platform version 12.1.11 is operating correctly.

The supported upgrade path for Unica Journey 12.1.11 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in

the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

*+12.1.x
*12.1.0.x

In case of Microsoft SQL Server and
MariaDB the base version is 12.1.0.3

and later.

In case on Db2 Base version should be
12.1.4

In case of Oracle, the upgrade path can
be:

*+12.1.x>12.1.11
*+12.1.0x>12.1.11

In case of Microsoft SQL Server and
MariaDB the upgrade path should be:

*+12.1.0.3>12.1.11

In case of DB2, the upgrade path should
be:

+ 121412111

1. Upgrade Unica Marketing
Platform to 12.1.11

2. Run upgrade Unica Journey to
12.1.11 installer

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on existing
Unica environment when you have
system tables as SqlServer, MariaDB,
DB2 databases and Postgres
databases.

In place upgrade to Unica Journey
12.1.11

1. Upgrade Unica Marketing
Platform and required Unica
products to 12.1.11 except
Journey.

2. Run clean installer of Unica
Journey 12.1.11

3. Configure Journey application.

4. Deploy Journey application.

5. Run Journey application.
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Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in
the second column. (continued)

In case of Postgres, the base Unica In case of Postgres upgrade path

Journey can be: 12.1.8 should be 12.1.8 » 12.1.11. 1. Installed Unica Marketing
Platform and required Unica

products to 12.1.8.
2. Run clean installer of Unica
Journey 12.1.8
. Configure Journey application.
. Deploy Journey application.

. Run Journey application.

o bW

. Upgrade Unica Marketing
platform and Journey to 12.1.11

Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.11. If Journey is already installed and the
Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server, DB2,
MariaDB or PostgreSQL database then you can install Journey version 12.1.11 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other components, for
example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.11

Features

This release includes platform-level updates focused on stability and security. These changes are internal and do not

introduce functional or user-facing behavior changes.

Platform and Security Updates

Framework Upgrades: This release includes upgrades to Java 17 and the Spring 6.x framework.
Security Remediation: Updates include remediation of identified security vulnerabilities.

Application Server Stack: As a result of these upgrades, the supported application server stack has changed from previous
releases. For more information, refer Unica Recommended Software Environments and Minimum System Requirements

document.

Prerequisites: Customers are advised to review the detailed release notes for complete information on supported application
servers and related prerequisites.



Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.11:

Defect ID Fixed Issue

HMA-399240 Not able to add Goals to Journey if the Journey is in Published state.

HMA-388726 Journey re-entry is happening even if dedupe settings is enabled and
Dedup_End_Audience" set as No.

HMA-387584 Pen Test vulnerability - Outdated and Vulnerable Components LOW (3.0).
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Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.11:

Defect ID Known Issue

HMA-403291 Audiences available in waiting state as of CC capacity and regional preference time
on journey base setup are not getting ahead after journey upgrade.

HMA-402962 REGBB - This specific Journey is not getting exported

HMA-363512 Db2_docker-(inconsistent) Some times audiences available in loop is getting stuck
and not moving ahead.

HMA-403232 Upgrade 12.1.9 to 12.1.11 - Journey audiences available in delay TP in paused journey
are not getting processed by Publish TP available next to Delay TP.

HMA-402783 While upgrading Journey from version 12.1.7 to 12.1.11, one non-fatal error received.

HMA-402860 Journey having Rest TP with responses not getting deleted.

HMA-402809 Mobile Push some times while saving mobile push TP along with Eng split its not
saving journey and showing message "some thing went wrong on server"

HMA-402821 Some time data gets rejected saying required field is not available - where that
required field is not a part of that Journey DD.

HMA-402201 Journey with CIF external ES exported journey if gets import then external source
configuration in ES is getting lost

HMA-363277 DB2 Link Salesforce & twilio goals count is not updating on goals page.

HMA-402608 After upgrading from Oracle 12.1.8 to 12.1.11, the Journey Engine fails to process

Deliver channel responses, resulting in the error

ORA-01400: cannot insert NULL into
("XJ11"."JOURNEYDELIVERRESPONSEMASTER"."EMAIL")

Work Around:

Upon investigation, it was identified that there was null constraint on the email column
of JourneyDeliverResponseMaster table which was removed in 12.1.0.3 script.

However, the sql statement in 12.1.0.3 might not have taken effect.

In that case, please run below query on journey database/schema to address this

issue.
ALTER TABLE JOURNEYDELIVERRESPONSEMASTER MODIFY EMAIL NULL;

This issue is not applicable for clean install of 12.1.11 or upgrades from 12.1.0.3 to
12.1.11
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Defect ID Known Issue

HMA-400964 Import Journey is not working if have REST TP configured.
Description:
When importing a journey canvas containing REST touchpoints from a JRE 1.8
environment to a JRE 17 environment, the import fails if any REST touchpoint is
configured with custom headers or request parameters. This issue is expected
to be rare, as export/import operations are typically performed between identical
environments (for example, from a 12.1.11 staging environmentto a 12.1.11
production environment).

HMA-401083 Docker MSSQL - Audience Archival is not working (non-jdk17).

Workaround:

Drop the A_<source_table> table if its column order does not match the column order
of the corresponding <source_table>. Recreate the table using a CREATE TABLE SQL
command that follows the column order defined in the source table.

Example: If column order of A_JourneyAudienceFlow does not match with that of

JourneyAudienceFlow, then run below commands:
Drop table A_JourneyAudienceFlow
CREATE TABLE A_JourneyAudienceFlow(
id BIGINT NOT NULL,

audienceld BIGINT NOT NULL,

nodeld BIGINT NOT NULL,

edge BIGINT NOT NULL,

audienceStage BIGINT,

direction BIT DEFAULT 0 NOT NULL,
logTimeStamp DATETIME2,

createdDate DATETIME?2,

version BIGINT,

isProcessed BIT DEFAULT 0 NOT NULL,

logTimeStampEpoch BIGINT,

11
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Defect ID Known Issue
createdDateEpochBIGINT,
iteration BIGINT DEFAULT 1 NOT NULL
)
Provided that JourneyAudienceFlow has exactly same order of columns in its
definitionYou can use any database viewing software to view the column order of any
particular table.

HMA-381896 REGBB_ Ms sql server - Rest TP - if Completed journey having rest TP with responses -
journey is not getting delete.

HMA-382025 CC - REGBB - If CC is down and Pratition wise CC flag is enabled then though journey
is not configured with CC all the audiences goes in waiting state.

HMA-381473 Salesgoals - Goals data is not getting available gols page instantly and if user adds
non frequency based goals then not showing old responses on goals page.

HMA-379675 Extra validation 'Data not found' is received on deleting Journey.

HMA-376121 When we removed the license parameter from the jvm its gives Error for adding Link
connection.

HMA-375720
Oracle upgraded setup - Not able to configure SMS whatsapp and push deliver
touchpoints. Need to drop constraint SYS_C0037600 on DeliverMetaData table

HMA-375744 ISAM- On ISAM setup opt in opt out not working in Journey

HMA-375523 Opt out - Whatsapp TP- Postgres - Audience which is not in opted out state - also
getting added in opted out state of TP

HMA-369764 Multiple engine nodes - Performance issues observed during longevity runs

HMA-368281 Milestone processing service needs enhancement when large audience set matches
with the applied condition of milestone

HMA-375637 Two ES - If journey is having two ES with data refresh enabled, then when refresh data
comes stats counts mismatches

HMA-376226 Clicking on view of journey in journey approval gives 404 error on setup configured
with ISAM login method.

HMA-375085 Retry - On retry page - with larger data - Retry job gets completed within time but data
is not getting available quickly on Retry page and not having auto refresh to show
case data on retry page
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Defect ID Known Issue

HMA-374895 Retry - 12.1.7 t0 12.1.9 DB2 - for SMS for some audiences retry not working and
showing message data not found.

HMA-374380
SSL_Kafka - If Journey hosted on Machine A and SSL_kafka on other machine then its
showing NullPointerException: null value in entry: ssl.

HMA-373789 In Journey Overview report, appearance is not as expected.

HMA-373648 Optin-out - In CC if audience id value is empty and in Journey payload also having
empty value for same audience field opt out is not working.

HMA-373306 After deleting Decision split its Ul gets distorted

HMA-372432 org.springframework.dao.DeadlockLoserDataAccessException error observed for
delete & move operations

HMA-372430 archival.AudienceMove processing needs performance improvement

HMA-372301 Observing DatalntegrityViolationException for
AudienceOptInOutCheckUtility.saveAudienceResponse while processing large data

HMA-372299 Opt out processing needs improvement.

HMA-372006 Time taken for consent data insertion to journey tables needs improvement

HMA-371436
Status of all audiences is not getting updated to JOURNEY_COMPLETED for journey
with re-enter contacts selected

HMA-371356 Journey processing gets degraded if re-enter contacts is chosen for a journey

HMA-369487 Irrespective of Dedupe settings applied on a field duplicate data is observed in
Journey when data is sent through Campaign.
Since there are duplicate data in same batch and the data is processing in multiple
threads, at the time of process checks if the record already exist into the system it
gets false. Further, till the time it inserts into the system (db tables) the same entry
would be done by another process. Hence, results are duplicate data insertion.

HMA-375046 Status of all audiences is not getting updated to JOURNEY_COMPLETED for journey
with re-enter contacts selected.

HMA-373961 SSL_SASL - Kafka topic is not getting created on SSL_SASL kafka where internal kafka
is standalone kafka.

HMA-370171 If you configure a Journey with Deliver Push or copy an existing Journey with Push

configuration, publish and pause the Journey, you cannot edit the application selected

for Push Touchpoint.

13
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Defect ID

Known Issue

HMA-362126

Postgres - Error observed when trying to create Duplicate copy for Imported Journey.




Chapter 6. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated support
contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is resolved efficiently
and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which provides

information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for aver si on. t xt file

that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support
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