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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.10 requires Unica Platform 12.1.10.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this product, see

the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some

information not being properly displayed. If you use a lower resolution, maximize the browser window to see more

content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the

controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function properly.

For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms. For

more information, see the Recommended Software Environments and Minimum System Requirements document.

» The correct browser and versions must be used. For more information, see the Recommended Software

Environments and Minimum System Requirements document.

« Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do not

open another browser session from the Start menu or desktop icon; and do not use File > New Window in Microsoft

Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their hands on

the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the

Unica Journey User Guide
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Table 1. Get up and running (continued)

Task Documentation

Find out about the known issues and limitations Unica Journey Release Notes
Learn about the structure of the Unica Journey system Unica Journey System Schema
tables

Installation and configuration of Unica Journey Unica Journey Installation Guide
Upgradation and configuration of Unica Journey Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide

Installing Unica Link connector app for Journey Unica Link Installation Guide

Installing Unica Link connector — MailChimp Unica Link Mailchimp Connector User Guide
Installing Unica Link connector — Mandrill Unica Link Mandrill Connector User Guide
Installing Unica Link connector — Twilio Unica Link Twilio Connector User Guide
Installing Unica Link connector — Salesforce Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task Documentation

Integration of Unica Campaign and Unica Journey Unica Campaign Administration Guide and Unica Campaign
User Guide

Integration of Unica Campaign and Unica Interact Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey Unica Journey User Guide

Integration of Unica Centralized Offer Management and Unica Journey User Guide

Unica Journey

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product documentation while you

logged in Help > Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.
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Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per your

requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.10, you can complete your upgrade and then install Unica
Journey 12.1.10.

Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:

Google Chrome and Microsoft Edge configuration

Recently, the browsers Google Chrome and Microsoft Edge updated a security fix and this security fix affects the access of
Unica applications. We have received some issues from our customers like:

« issues with Ul

- getting logged out from Unica

These issues are observed due to the change of behavior in browsers after applying the security fix. Applying the security
fix automatically enables Origin-keyed Agent Clusters by default. If the setting Origin-keyed Agent Clusters by default

is enabled automatically, it prevents changes in document referrer and domain values so that malicious websites cannot
execute any type of impersonation. The setting Origin-keyed Agent Clusters by default existed earlier as well, but was not
enabled by default.

If you update Google Chrome or Microsoft Edge to the latest version, you will observe the earlier mentioned issues. Because
of how Unica is designed and because the Unica suite is deployed over multiple JVMs, it is essential that you disable the

Origin-keyed Agent Clusters by default setting for Unica to function correctly and to provide a good user experience.

As a solution, we recommend that you perform the steps mentioned in the following Knowledge Base article: https://

support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185.

Note: The update to Microsoft Edge browser is very recent and the Knowledge Base article is not yet updated for the

Microsoft Edge browser.

The CliffsNotes solution is as follows:


https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
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1. Open your browser and navigate to one of the following URLs based on your browser:

- Google Chrome: chrome://flags/#origin-agent-cluster-default

> Microsoft Edge: edge://flags/#origin-agent-cluster-default
2. From the dropdown of the highlighted parameter Origin-keyed Agent Clusters by default, select bi sabl ed.
3. At the bottom of the page, click the Apply Changes button.

4. Log out of Unica applications, log back in, and verify if everything is working as expected.


chrome://flags/#origin-agent-cluster-default
edge://flags/#origin-agent-cluster-default

Chapter 2. Prerequisites for Unica Journey Installation or

Upgrade

Before installing Unica Journey version 12.1.10, you have to ensure that a few prerequisites are met.

About this task

If a you are a new user, and if you have HCL OneDB, MariaDB, DB2 or Microsoft SQL Server as the database, you can directly

install Unica Journey 12.1.10. Ensure that Unica Platform version 12.1.10 is operating correctly.

The supported upgrade path for Unica Journey 12.1.10 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in

the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

*+12.1.x
*12.1.0.x

In case of Microsoft SQL Server,
MariaDB and OneDB, the base version
is 12.1.0.3 and later.

In case on Db2 Base version should be
12.1.4

In case of Oracle, the upgrade path can
be:

*+12.1.x>12.1.10
*+12.1.0x->12.1.10

In case of Microsoft SQL Server,
MariaDB and OneDB, the upgrade path
should be:

+12.1.0.3>12.1.10

In case of DB2, the upgrade path should
be:

+12.1.4512.1.10

1. Upgrade Unica Marketing
Platform to 12.1.10

2. Run upgrade Unica Journey to
12.1.10 installer

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on existing
Unica environment when you have
system tables as SqlServer,MariaDB,
OneDb, DB2 databases and Postgres

databases.

In place upgrade to Unica Journey
12.1.10

1. Upgrade Unica Marketing
Platform and required Unica
products to 12.1.10 except
Journey.

2. Run clean installer of Unica
Journey 12.1.10

3. Configure Journey application.

4. Deploy Journey application.

5. Run Journey application.
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Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in
the second column. (continued)

In case of Postgres, the base Unica In case of Postgres upgrade path

Journey can be: 12.1.8 should be 12.1.8 » 12.1.10. 1. Installed Unica Marketing
Platform and required Unica

products to 12.1.8.
2. Run clean installer of Unica
Journey 12.1.8
. Configure Journey application.
. Deploy Journey application.

. Run Journey application.

o bW

. Upgrade Unica Marketing
platform and Journey to 12.1.10

Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.10. If Journey is already installed and the
Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server, OneDB,
DB2, MariaDB or PostgreSQL database then you can install Journey version 12.1.10 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other components, for
example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.10

In Unica Journey 12.1.10, we have not introduced any new feature.
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Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.10:

Defect ID

Fixed Issue

HMA-381239

Journey cloud native issue.
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The following table lists the known issues in Unica Journey 12.1.10:

Defect ID Known Issue

HMA-382030 logout URL is appearing incorrect on Docker Setup.

HMA-381896 REGBB_ Ms sql server - Rest TP - if Completed journey having rest TP with responses -
journey is not getting delete.

HMA-380952 Error 500 received on exporting Journey on LDAP setup 12.1.10
WAS-27+Windows+MSSQL Server.

HMA-382025 CC - REGBB - If CC is down and Pratition wise CC flag is enabled then though journey
is not configured with CC all the audiences goes in waiting state.

HMA-381294 Kafka version appears as 3.4 during Journey Web deployment.

HMA-376207 When we removed the license parameter from the jvm its gives Error for adding Link
connection.

HMA-381473 Salesgoals - Goals data is not getting available gols page instantly and if user adds
non frequency based goals then not showing old responses on goals page.

HMA-379675 Extra validation 'Data not found' is received on deleting Journey.

HMA-376121 When we removed the license parameter from the jvm its gives Error for adding Link
connection.

HMA-376139 Whatsapp Interactive - when journey is imported the , engagement split path names
are not retained on canvas.

HMA-375908 Optin-out - Inconsistent - Found one opted record available on CC got added twice in
Journey table.

HMA-375720
Oracle upgraded setup - Not able to configure SMS whatsapp and push deliver
touchpoints. Need to drop constraint SYS_C0037600 on DeliverMetaData table

HMA-375744 ISAM- On ISAM setup opt in opt out not working in Journey

HMA-375523 Opt out - Whatsapp TP- Postgres - Audience which is not in opted out state - also
getting added in opted out state of TP

HMA-369764 Multiple engine nodes - Performance issues observed during longevity runs

HMA-368281 Milestone processing service needs enhancement when large audience set matches
with the applied condition of milestone

HMA-375637 Two ES - If journey is having two ES with data refresh enabled, then when refresh data
comes stats counts mismatches

11
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Defect ID Known Issue

HMA-375585 Clicking on view of journey in journey approval gives 404 error on was85526

HMA-376226 Clicking on view of journey in journey approval gives 404 error on setup configured
with ISAM login method.

HMA-375085 Retry - On retry page - with larger data - Retry job gets completed within time but data
is not getting available quickly on Retry page and not having auto refresh to show
case data on retry page

HMA-374895 Retry - 12.1.7 to 12.1.9 DB2 - for SMS for some audiences retry not working and
showing message data not found.

HMA-374685 Concurrent user Journey - User is able to logged in journey even if user set max
session in platform

HMA-374380
SSL_Kafka - If Journey hosted on Machine A and SSL_kafka on other machine then its
showing NullPointerException: null value in entry: ssl.

HMA-373789 In Journey Overview report, appearance is not as expected.

HMA-373648 Optin-out - In CC if audience id value is empty and in Journey payload alos having
empty value for same audience field opt out is not working.

HMA-373306 After deleting Decision split its Ul gets distorted

HMA-372432 org.springframework.dao.DeadlockLoserDataAccessException error observed for
delete & move operations

HMA-372430 archival.AudienceMove processing needs performance improvement

HMA-372301 Observing DatalntegrityViolationException for
AudienceOptIinOutCheckUtility.saveAudienceResponse while processing large data

HMA-372299 Opt out processing needs improvement.

HMA-372006 Time taken for consent data insertion to journey tables needs improvement

HMA-371961 User is not getting logged out from Journey if s/he logged off from Platform

HMA-371436
Status of all audiences is not getting updated to JOURNEY_COMPLETED for journey
with re-enter contacts selected

HMA-371356 Journey processing gets degraded if re-enter contacts is chosen for a journey

HMA-369487 Irrespective of Dedupe settings applied on a field duplicate data is observed in
Journey when data is sent through Campaign.

Since there are duplicate data in same batch and the data is processing in multiple
threads, at the time of process checks if the record already exist into the system it




Chapter 5. Known issues

Defect ID

Known Issue

gets false. Further, till the time it inserts into the system (db tables) the same entry

would be done by another process. Hence, results are duplicate data insertion.

HMA-375721

On below setup upgraded from 12.1 to 12.1.9, users were not able to configure sms,

whatsapp and push touchpoints.
Workaround
ALTER TABLE DeliverMetaData DROP constraint SYS_C0037600.

Run above query and then deliver touchpoint configuration works fine.

HMA-375046

Status of all audiences is not getting updated to JOURNEY_COMPLETED for journey
with re-enter contacts selected.

HMA-374899

Completed journey where rest TP having responses is not getting deleted.
Workaround

Once upgrade to 12.1.8 and or 12.1.9 is performed, ensure to run below sqgl on db2
journey database. Replace the text in bold by actual journey schema to drop the

constraints on these tables.

DECLARE

CURSOR c_syscate_ref IS

SELECT ref.* from syscat.references ref

WHERE ref.tabname IN (AUDIENCERESPONSE', 'AUDIENCEBULKRESPONSE')

AND ref. REFTABSCHEMA-="<enter user or schema name>' AND ref. REFTABNAME IN
('POINTY);

r_syscate_ref c_syscate_ref%rowtype;

BEGIN

IF NOT c_syscate_ref%isopen THEN OPEN c_syscate_ref;
END IF;

LOOP

FETCH c_syscate_ref INTO r_syscate_ref;

EXIT WHEN c_syscate_ref%notfound;

13
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Defect ID Known Issue
EXECUTE IMMEDIATE 'ALTER TABLE ' || r_syscate_ref.tabname || ' DROP
CONSTRAINT ' || r_syscate_ref.constname;

END LOOP;
CLOSE c_syscate_ref;
END

HMA-373961 SSL_SASL - Kafka topic is not getting created on SSL_SASL kafka where internal kafka
is standalone kafka.

HMA-370171 If you configure a Journey with Deliver Push or copy an existing Journey with Push
configuration, publish and pause the Journey, you cannot edit the application selected
for Push Touchpoint.

HMA-362126 Postgres - Error observed when trying to create Duplicate copy for Imported Journey.




Chapter 6. Known Limitation

The following table lists the known issues in Unica Journey 12.1.9:

Defect ID

Known Issue

HMA-374748

If the parameter HCL Plan - Journey integration is enabled in Af fi ni unj sui te,
and if you publish a Journey that is not mapped to any Plan Approval, or if the Unica
Plan application is down, you will see the following Journey Publish error: pian is

unr eachabl e. Contact administrator.

15
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Chapter 7. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated support
contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is resolved efficiently
and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which provides

information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for aver si on. t xt file

that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support


https://www.hcltech.com/products-and-platforms/contact-support
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