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Chapter 1. System requirements and
compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.0.3 requires

Unica Platform 12.1.0.3.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party

requirements for this product, see the Recommended Software Environments and Minimum

System Requirements document.

You can also access this document by selecting Help > Product documentation when you

are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following

requirements:

• For an improved user experience, use at least a 21-inch screen.

• For an improved user experience, set your screen resolution to 1600x900. Lower

resolutions can result in some information not being properly displayed. If you use a

lower resolution, maximize the browser window to see more content.

• A mouse is best for navigating in the user interface.

• Do not use the browser controls to navigate. For example, avoid using the Back and

Forward buttons. Instead, use the controls that are in the user interface.

• If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey

might not function properly. For best results, disable pop-up blocker software while

running Unica Journey.

• Ensure that the technical environment meets the minimum system requirements and

the supported platforms. For more information, see the Recommended Software

Environments and Minimum System Requirements document.
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• The correct browser and versions must be used. For more information, see the

Recommended Software Environments and Minimum System Requirements

document.

• Clear the browser cache after installation. This only needs to be done once, after the

application is updated.

Important:  Do not use any other method to open multiple sessions. For example, do

not open a new tab; do not open another browser session from the Start menu or desktop

icon; and do not use File > New Window in Microsoft Internet Explorer. These methods can

corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and

developers to get their hands on the product functionality.

Table 1. Get up and running

Task Documentation

Find out about the new features in the

product

For the first release, all new features are

available in the Unica Journey User Guide

Find out about the known issues and

limitations

Unica Journey Release Notes

Learn about the structure of the Unica

Journey system tables

Unica Journey System Schema

Installation and configuration of Unica

Journey

Unica Journey Installation Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide
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Task Documentation

Installing Unica Link connector app for

Journey

Unica Link Installation Guide

Installing Unica Link connector – MailChimp Unica Link Mailchimp Connector User

Guide

Installing Unica Link connector – Mandrill Unica Link Mandrill Connector User Guide

Installing Unica Link connector – Twilio Unica Link Twilio Connector User Guide

Installing Unica Link connector – Salesforce Unica Link Salesforce Connector User

Guide

Table 3. Integrate Unica Campaign with other HCL products

Task Documentation

Integration of Unica Campaign and Unica

Journey

Unica Campaign Administration Guide and

Unica Campaign User Guide

Integration of Unica Campaign and Unica

Interact

Unica Interact Administration Guide

Integration of Unica Deliver with Unica

Journey

Unica Journey User Guide

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product

documentation while you logged in Help >

Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan

Journey installation.
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Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of

these integration as per your requirements. Please refer to documentation map section for

appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system,

application server etc., is not exactly same support with Unica Journey. Please refer to

Recommended Software Environments and Minimum System Requirements guide.

For example, If your existing Unica products are installed on stack as below:

• Operating System - AIX 7.1

• Application Server - WebSphere

• Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended

Software Environments and Minimum System Requirements guide and it would be

compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.03, you can complete your

upgrade and then install Unica Journey 12.1.0.3.



Chapter 2. Prerequisites for Unica Journey
Installation or Upgrade

Before installing Unica Journey version 12.1.0.3, you have to ensure that a few prerequisites

are met.

If a you are a new user, and if you have HCL OneDB, MariaDB, or Microsoft SQL Server as the

database, you can directly install Unica Journey 12.1.0.3. Ensure that Unica Platform version

12.1.0.3 is operating correctly.

The supported upgrade path for Unica Journey 12.1.x.x are as follows:

Source

Version
Upgrade path to 12.1.0.3 Prerequisites for Oracle Database

12.1.0 Directly upgrade to 12.1.0.3 If you are upgrading Unica Journey from

version 12.1.0 to 12.1.0.3, ensure that Unica

Platform and Unica Journey version 12.1.0

are operating correctly.

12.1.0.1 Directly upgrade to 12.1.0.3 If you are upgrading Unica Journey from

version 12.1.0.1 to 12.1.0.3, ensure that Unica

Platform, and Unica Journey version 12.1.0

and 12.1.0.1 are operating correctly.

12.1.0.2 Directly upgrade to 12.1.0.3 If you are upgrading Unica Journey from

version 12.1.0.2 to 12.1.0.3, ensure that Unica

Platform, and Unica Journey version 12.1.0

and 12.1.0.2 are operating correctly.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also,

stop all other components, for example Journey Engine, Kafka server, etc.
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3. Undeploy Unica Platform and Unica Journey web application from the application

server.

4. Stop the application server and clean the application server cache. For more

information, see Cleaning the Apache Tomcat application server cache (on page

6).

5. Back up the Unica Platform and Unica Journey database and file system directory to

any temporary directory.

Cleaning the Apache Tomcat application server cache

1. Access the Instance location used for Unica Journey. For example, /opt/Tomcat/

instance1.

2. Delete the contents of the folders webapps and work.



Chapter 3. New features and changes in
version 12.1.0.3

In Unica Journey 12.1.0.3, we have introduced some new features, and we have made

changes to some existing features or functionality.

We have updated the documents and you can access the latest documentation using the

following links:

• PDFs: http://doc.unica.com/products/index.php?

showFolder=RW50ZXJwcmlzZQ==&folder=am91cm5leS8xMl8xXzA=

• Online Help: https://help.hcltechsw.com/unica/Journey/en/12.1.0/index.html 

The following list mentions the support for new platforms, in Unica Journey 12.1.0.3:

• Supports HCL OneDB as system database. For more information about installing Unica

Journey 12.1.0.3 with system tables on HCL OneDB, see Unica Journey Installation

Guide for OneDB Guide.

• Supports SQL Server, MariaDB as system database. For more information about

installing Unica Journey 12.1.0.3 with system tables on SQL Server, MariaDB, see Unica

Journey Installation Guide.

• Supports Kafka on windows operating system. To configure Kafka on

Microsoft Windows operating system, refer the following technote: https://

support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551

The following list mentions the new features, and the changes to existing features, in Unica

Journey 12.1.0.3:

• Journey supports three new databases: MariaDB, OneDB, and SQL server.

• Introduced Report Screen

◦ Summary screen displays Journey canvas along with touchpoint details.

◦ Email and SMS performance can be tracked.

◦ Display Goals progress report in graphical format.

http://doc.unica.com/products/index.php?showFolder=RW50ZXJwcmlzZQ==&folder=am91cm5leS8xMl8xXzA=
http://doc.unica.com/products/index.php?showFolder=RW50ZXJwcmlzZQ==&folder=am91cm5leS8xMl8xXzA=
https://help.hcltechsw.com/unica/Journey/en/12.1.0/index.html
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551
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◦ Display Audience counts from different entry sources.

• Enhancement to Creating Journey

◦ Milestones can be added while creating a Journey. A maximum of seven

milestones can be added to one Journey.

• Enhancement to Entry Source

◦ Unica Interact and Unica Discover entry sources are created for integrating

respective Interact and Discover data with Journey.

• Enhancement to Journey Goals

◦ Multiple goals can be viewed and added to a journey. A maximum of 15 goals can

be added to one Journey.

◦ Sales-based goals can be created.

◦ Goals' historical performance can be tracked.

◦ Added Goals can be edited.

◦ Goals can be switched.

• Journey now supports Adtech touchpoint

• Introduced Centralized logging to trace audience movement

• Integration of Journey SMS channel with Deliver



Chapter 4. Fixed Defects

The following defects were fixed in Unica Journey version 12.1.0.3.

Issue ID Defect

HMA-315526 Connection was not visible on the SMS configuration screen.

HMA-315322 Wrong time displayed on the warning message for date goal

validations.

HMA-300821 Closing the browser did not clear the session or log out the

user.

HMA-302508 If you access Journey using a Safari browser, and created an

Entry source, an excess of blank space existed between the

upload file and the Create entry source button.

HMA-302554 If you access Journey using a Chrome browser, the hover

action was hiding other columns.

HMA-302528 If you access Journey using a Safari browser, an excess of

blank space existed on the side navigation bar.

HMA-319141 Journey Web Application properties file did not have

uncommented lines for spring.jpa.properties.hibernate.dialect

property and journey.datasource.driver-class-name property.

HMA-311946 Journey application was showing Unica Platform URL On

Journey Preinstallation summary page.

HMA-316262 For Paused Journeys, users could not add Significant Field for

an In use Data Definition.

HMA-316264 If a Journey was in Paused state or Published state, it was not

changing to Completed state even after achieving a contact

based goal.



Unica Journey V12.1.0.3 Release Notes | 4 - Fixed Defects | 10

Issue ID Defect

HMA-310708 The Goal add/edit page did not have the provision to track

goals based on individual links.

HMA-310904 The login screen of Unica and Unica Journey was not the same.

HMA-311940 On the Journey UI, the date formats were incorrect, and the

casing was inconsistent.

HMA-311066 If user deletes Kafka topic created by Publish control, It

requires to delete Kafka logs and other Publish Kafka topics

gets deleted.

HMA-310351 UL-171 - Journey "Upload Contact" action, Group contacts by

tag: Default run time tag was not assigned to a Mailchimp

contact in addition to the user defined tag.

HMA-310348 HIP Mailchimp JIRA 01 - Journey: On Mailchimp, the fields

associated with a particular email were used to send the email

communication and not the fields provided while passing the

data through an Entry Source.

HMA-302713 The error {"403":["Access Denied."]} was seen for Journey

Application when accessed from the Marketing Platform with

the saml login method.

HMA-313604 When upgrading Journey from 12.1 to 12.1.0.1 the Journey

backup folder was not backing up the folder named Files.

HMA-313259 Two non-fatal errors were seen when running the Journey

Installer.

HMA-312413 Journey Installer: During installation if the user selected only

the Journey Engine component, the installer prompted for

Platform and Journey Web details.
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Issue ID Defect

HMA-321284 (Deliver) Not getting Email Link click events on journey from

Deliver Contact Hcl product support team for the fix.



Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.0.3:

Issue ID Known Issue

HMA-320980 Sort by date does not show latest date in journey.

HMA-320932 LICENSE: If Unica Link License is not available, Journey does

not process the data or provide validations as to why it is not

processed.

HMA-320721 If you send large number of audiences for processing, ignite

error is observed.

HMA-320720 On Goal analysis page its showing one extra record for a period

specific date, last 3 months option, last 12 months option, or

last 30 days option.

HMA-320719 On the goal analysis page the current day/week is not showing

up as per historical page.

HMA-320706 Since Journey is mono partition if a user tries to access

Journey from different partitions, "Access Denied" error is

displayed.

HMA-320703 On the Goal analysis page, Last generated on information is not

as per the time zone configured on Journey.

HMA-320622 When editing the non-frequency based goal, you can select the

checkbox 'Mark journey as completed' even when the target

goal and actual goal is the same.

HMA-320585 Incorrect counts displayed in Stats view for Journey.

HMA-320300 Target object allows NULL value causing errors in performance

runs with MariaDB.
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Issue ID Known Issue

HMA-320207 Documentation defect: In Journey "Recommended Software

Environments and Minimum System Requirements" document,

either the first section should be of Journey or for each product

should be specified.

HMA-319576 Milestone reorder is not working for Pause and Republish.

HMA-315896 Localization issues exist.

HMA-312551 Engine - \ is not getting replaced by /.

HMA-320872 Journey encryption utility cannot encrypt special characters

like - $ &.

HMA-320456 Db specific database information should be available in Engine

application.properties file.

HMA-321141 When there are leading and trailing spaces in milestone name,

it is getting added as new milestone.

HMA-320870 License - Entitlement consumption shown on license details

page is not as per Usage report for journey.

HMA-311595 Some times kafka stops and does not restart.



Chapter 6. Before you contact HCL technical
support

If you encounter a problem that you cannot resolve by referring the documentation, your

company's designated support contact can log a call with HCL technical support. Use these

guidelines to ensure that your problem is resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your HCL

administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

• A brief description of the nature of your issue.

• Detailed error messages that you see when the issue occurs.

• Detailed steps to reproduce the issue.

• Related log files, session files, configuration files, and data files.

• Information about your product and system environment, which you can obtain as

described in "System information."

System information

When you call HCL technical support, you might be asked to provide information about your

environment.

If your problem does not prevent you from logging in, much of this information is available

on the About page, which provides information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not

accessible, check for a version.txt file that is located under the installation directory for

your application.
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Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support

https://www.hcltech.com/products-and-platforms/contact-support
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