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Chapter 1. Release Notes for version 12.1.2
Contains information about new features, defect fixes, and known issues in Unica Campaign 

and Optimize that HCL releases as part of a scheduled software release.

System requirements and compatibility
Unica Campaign  is part of the Unica  suite of products. Unica Campaign  version 12.1.2 

requires Unica Platform  12.1.2

Where to find complete system requirement and compatibility information

For a list of Unica  product versions compatible with this product and a list of third-party 

requirements for this product, see the Recommended Software Environments and Minimum 

System Requirements  document. ).

You can also access this document by selecting Help > Product documentation  when you 

are logged in to Unica.

Prerequisites for using Unica Campaign
Before you begin using Unica Campaign, confirm that your environment meets the following 

requirements.

• For an improved user experience, use at least a 21" screen.

• For an improved user experience, set your screen resolution to 1600 x 900. Lower 

resolutions can result in some information not being properly displayed. If you use a 

lower resolution, maximize the browser window to see more content.

• A mouse is best for navigating in the user interface.

• Do not use the browser controls to navigate. For example, avoid using the Back and 

Forward buttons. Instead, use the controls that are in the user interface.

• If pop-up blocker (ad blocker) software is installed on the client machine,  Unica 

Campaign  might not function properly. For best results, disable pop-up blocker 

software while running Unica Campaign.
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• Ensure that the technical environment meets the minimum system requirements and 

the supported platforms.*

• The correct browser and versions must be used.*

• Clear the browser cache after upgrading or applying any fix pack. This only needs to 

be done once, after the application is updated.

• If you use Internet Explorer (IE) with Unica Campaign  or any module that uses 

Unica Campaign  flowcharts (Unica Deliver, Unica Optimize, Unica Interact, Unica 

Collaborate): To log in multiple times to view side-by-side information, open IE and log 

in to Unica. Then select File  > New Session  in the IE menu bar. In the new IE browser 

window, log in to Unica  as the same or a different user.

Important:  Do not use any other method to open multiple sessions. For 

example, do not open a new tab; do not open another browser session from 

the Start  menu or desktop icon; and do not use File > New Window  in IE. 

These methods can corrupt information that is shown in the application.

*For details on the items indicated by an asterisk, see the Unica  Recommended Software 

Environments and Minimum System Requirements.

Unica Campaign  documentation roadmap
Unica Campaign  provides documentation and help for users, administrators, and 

developers.

Table  1. Get up and running

Task Documentation

Find out about new features, known 

issues, and limitations

Unica Campaign Release Notes

Learn about the structure of the Unica 

Campaign  system tables

Unica Campaign System Tables and Data Dictio­

nary

Install or upgrade Unica Campaign One of the following guides:
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Table  1. Get up and running  (continued)

Task Documentation

• Unica Campaign Installation Guide

• Unica Campaign Upgrade Guide

Unica Insights Reports for Unica 

Campaign

Unica Insights Installation and Configuration Guide

Implement the IBM Cognos®  reports 

provided with Unica Campaign

Unica Reports Installation and Configuration Guide

Table  2. Configure and use Unica Campaign

Task Documentation

• Adjust configuration and securi­

ty settings

• Prepare Unica Campaign  for 

users

• Run utilities and perform main­

tenance

• Learn about integrations

Unica Campaign Administrator's Guide

• Create and deploy marketing 

campaigns

• Analyze campaign results

Unica Campaign User's Guide

Improve flowchart performance Unica Campaign Tuning Guide

Use Unica Campaign  functions Macros for HCL Unica

Table  3. Integrate Unica Campaign  with other HCL products

Task Documentation

Integrate with Acoustic Campaign and Acoustic Integration Guide for IBM 

Marketing Cloud
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Table  3. Integrate Unica Campaign  with other HCL products  (continued)

Task Documentation

Integrate with Coremetrics Unica Campaign  Administrator's Guide: How to 

configure the integration

Unica Campaign  User's Guide: Targeting IBM Digi­

tal Analytics segments in Campaigns

Integrate with Unica Plan Unica Plan and Unica Campaign Integration Guide

Integrate with  Opportunity Detect Unica Campaign  Administrator's Guide: How to 

configure the integration

Opportunity Detect  Administrator's Guide  and Op­

portunity Detect  User's Guide: How to administer 

and use the product

Integrate with Unica Deliver Unica Campaign  Installation and Upgrade guides: 

How to install and prepare Deliver components in 

the local environment.

Unica Deliver  Startup and Administrator's Guide: 

How to connect to the hosted messaging re­

sources.

Unica Campaign  Administrator's Guide: How to 

configure offer integration.

Integrate with IBM SPSS Modeler Ad­

vantage Enterprise Marketing Man­

agement Edition

Unica Campaign  and IBM SPSS Modeler Advan­

tage Enterprise Marketing Management Edition In­

tegration Guide

Integrate with IBM WeatherFX. You can integrate IBM WeatherFX with Campaign 

so that you can pull weather events into your mar­

keting campaigns. Unica Campaign version 9 and 

version 10 users can integrate with WeatherFX by 

using the UBX toolkit.
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Table  3. Integrate Unica Campaign  with other HCL products  (continued)

Task Documentation

Integrate with  Unica Director. Unica Director Installation Guide: You can inte­

grate  Unica Director with  Campaign so that you 

can get status of all the running/completed/failed 

flowcharts, migrate Camapigns from one Unica 

Campaign  environment to other, download/delete 

flowchart logs etc.

Integrate with Journey Unica Campaign can integrate with Journey so that 

a continuous communication with users can be es­

tablished based on the inputs from Campaign.

Refer Campaign Administrators guide > Unica 

Campaign and Unica Journeys integration

Integrate with Link Unica Campaign uses Link capabilities of connec­

tors which include the configuration and provision­

ing to connect to any delivery channel.

Refer Campaign Administrators guide > Unica 

Campaign and Unica Link integration

Note:  Additional integrations may be available that are not listed in this table. See 

Product tools and utilities for Unica Campaign.

Table  4. Develop for Unica Campaign

Task Documentation

Use the REST API See the Unica Campaign REST API

Use the SOAP API • See the Unica Campaign SOAP API Specifi­

cation

• JavaDocs in devkits\CampaignSer­

vicesAPI

https://www-947.ibm.com/support/entry/myportal/clientsidetools/enterprise_marketing_management/ibm_campaign?productContext=-198760082
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Table  4. Develop for Unica Campaign  (continued)

Task Documentation

Develop Java™ plug-ins or com­

mand-line executables to add valida­

tion to Unica Campaign

• See the Unica Campaign Validation PDK 

Guide

• Java-docs in devkits\validation

Table  5. Get help

Task Instructions

Open online help When using the Unica Campaign  application:

1. Choose Help > Help for this page  to open a 

context-sensitive help topic.

2. Click the Show navigation  icon in the help 

window to display the full help.

You must have web access to view context-sensi­

tive online help. Contact  Support for more infor­

mation about accessing and installing  Knowledge 

Center locally for offline documentation.

Get PDFs When using the Unica Campaign  application:

• Choose Help > Product documentation  to 

access Unica Campaign  PDFs.

• Choose Help > All Unica  documentation  to 

access all product PDFs.

• Click the links for PDFs during the installa­

tion process.
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New features and changes in version 12.1.2
Unica Campaign  12.1.2 includes a number of new features and changes. These are listed 

underneath.

For a list of newly supported and discontinued platforms, see the Recommended Software 

Environments and Minimum System Requirements guide.

Upgrade Paths

Unica Campaign supports the following upgrade paths:

• 12.1.x →  12.1.2

• 12.1.0.x →  12.1.2

Customers on versions earlier than 8.6.x must:

• perform a Fast Upgrade from existing version to version 8.6.0 (for more information, 

see HCL Unica 8.6.0 Fast Upgrade Guide).

• perform a Fast Upgrade from version 8.6.0 to version 12.1.0 (for more information, 

see HCL Unica 12.1.0 Fast Upgrade Guide).

• perform an in-place upgrade from version 12.1.0 to version 12.1.2.

Customers on versions earlier than 11.1.x.x can:

• perform a Fast Upgrade from existing version to version 12.1.0 (for more information, 

see HCL Unica 12.1.0 Fast Upgrade Guide).

• perform an in-place upgrade from version 12.1.0 to version 12.1.2.

Customers on versions 11.1.x.x/12.0.x.x can use one of the following options for upgrade:

• Option 1

◦ perform an in-place upgrade from existing version to version 12.1.0.

◦ perform an in-place upgrade from version 12.1.0 to version 12.1.2.

• Option 2
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◦ perform a Fast Upgrade from existing version to version 12.1.0 (for more 

information, see HCL Unica 12.1.0 Fast Upgrade Guide).

◦ perform an in-place upgrade from version 12.1.0 to verison 12.1.2.

Fast Upgrade

Unica Campaign  12.1.2 supports the fast upgrade approach. This helps customers 

bypassing the multi-step upgrade. The Fast Upgrade approach is also useful in reducing 

upgrade downtime. The approach is provided for  Unica Platform,  Campaign,  Optimize, 

Plan,  Interact.

Optimized Mailist PB performance

In V12.1.2 Unica Campaign suite, Maillist performance improvement has been done. Maillist 

PB opening has been optimized. Also, opening of flowcharts containing maillist has been 

optimized making it faster compared to previous releases.

Campaign License Metering

Unica Campaign V12.1.2 supports enhanced License metering.

Campaign Catalog usage/reporting

The Campaign table catalog usage is reported at two levels flowchart level and Global level.

Table Catalog In Use column : Does not mark table as used if it is not selected as input in 

any PB's but used only in extract fields

Quadbase charts replacement

In V12.1.2 Unica Campaign suite, Quadbase charts with open source is replaced with 

stacked column charts by syncfusion

Concurrent flowchart access enhancement

Update name of user editing the flowchart in near real time.

Fixed defects in Unica Campaign  V12.1.2
The following defects were fixed in Unica Campaign  12.1.2.
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Issue ID Description

HMA-333022 404 Error While Saving Updated Rule Data 

For "Never A followed by B"

HMA-331662 User variable picking value from the pre­

vious run when flowchart executed using 

Platform Scheduler with future date

HMA-330420 Campaign Listener randomly exits

HMA-333007 Campaign folder description cross-site is­

sue.

HMA-332037 Listener gets crashed after some duration 

when concurrent users are creating offers 

in Plan

HMA-331403 Optimize "Agent customer relationship 

template table" not appearing in drop­

down when Optimize session

HMA-329133 Select PB exporting more data in output 

to snapshot PB, even user sets limit size 

to any number for base with dimension 

tables as input

HMA-331646 Scheduled flowchart for future time and 

the user variable picks up OLD value 

which is previous run's value (not curren­

t_date-1).

HMA-331720 Security Vulnerability â€“ Improper Error 

Handling

HMA-333808 Tokens passed to triggers wrapped in 

two sets of double quotes when space is 

present



Unica Campaign V12.1.2 Release Notes  | 1 - Release Notes for version 12.1.2  | 10

HMA-333332 Double data type data is sent from Cam­

paign to Journey if input is taken from ta­

ble

HMA-333721 Oracle ODBC connection with DMY as a 

date format for data source

HMA-331516 Non Translated Text on Select Proccess 

box for a French User

Known issues in Unica Campaign  V12.1.2
Unica Campaign  12.1.2 includes the following known issues.

Issue ID Description

HMA-326854 Incorrect date format written to UA_OF­

FERHISTATTRIB from mail list process 

box

HMA-331085 Documentation - Docker : Use -async op­

tion while running ACOOptAdmin utility

HMA-330431 Campaign Offer reports show incorrect 

data when SAME offer is used in Cam­

paign as well as Journey

HMA330613 DOC Help URL is not working for Eng­

lish,French and German locales.

HMA-330562 Docker : Campaign kafka template is 

missing for Docker

For resolution on this, please contact HCL 

Unica support team.
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HMA-330433 User is not able to login to platform after 

upgrade to 12.1.1 in case Deliver is con­

figured.

Resolution

Execute below query on Platform data­

base :

select * from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica­

tion=101 and partition_id=<>)

Specify actual partition id in above query , 

default for partition1 , partition id =1 , it 

varies for multiple partitions.

If above result in more than one row , con­

tact HCL support to help in executing be­

low delete query - delete one of the du­

plicate record of *D*eliver_admin role by 

running below query :

delete from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica­

tion=101 and partition_id=<>) and paren­

t_role_id=<partition_id>

For example , for partition id =1 ,

delete from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica­

tion=101 and partition_id=1) and parent_­

role_id=1
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HMA-306326 JNDI creation for Campaign installer with 

Informix database and Websphere appli­

cation server is not creating JNDI with 

correct details. Create JNDI connection 

manually in websphere with Informix re­

ferring to the Campaign Installation guide.

HMA-306329 JNDI creation for Campaign installer with 

Informix database and Tomcat applica­

tion server is not creating JNDI with cor­

rect details.Create JNDI connection man­

ually in Tomcat with Informix referring to 

the Campaign Installation guide

HMA-332306 Jboss7.3 : Getting "UT005023: Excep­

tion handling request to /unica/servlet/

ScheduleProcessor: java.lang.NoClass­

DefFoundError: oracle/sql/BLOB" error 

when user tries to schedule Campaign 

flowchart.

Resolution:

Run the below command to make the 

module global using jboss-cli.sh/bat

_/subsystem=ee:write-attribut­

e(name=global-modules,value=[

{name=com.oracle.jdbc}

]_

OR

1. In <JBOSS_HOME>/standalone/config­

uration/standalone.xml searched module 

name for driver.
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<driver name="oracledriver" module="ora­

cle.jdbc">

<xa-datasource-class>oracle.jdbc.Oracle­

Driver</xa-datasource-class>

</driver>

2. Then add the below statement under­

neath <subsystem xmlns="urn:jboss:do­

main:ee:4.0"> to make the module name 

global.

<global-modules>

<module name="oracle.jdbc"/>

</global-modules>

3. Restart JBOSS server.

HMA-333252 Troubleshooting tip for Campaign Flow­

chart not opening from Schedule manage­

ment page.

Resolution:

Navigate to Affinium|Campaign|naviga­

tion

Change the below parameter

flowchartDetailPageURI=='flowchartDe­

tails.do?campaignID=&id=' to 'flowchart­

Details.go?campaignID=&id='

HMA-334488 PRE: Java Illegal Argument Exception 

While Saving Smart Offer List

HMA-334489 UI Dropdown Alignment Gets Disturbed If 

we use "Spacebar" to open a dropdown
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HMA-310343 Campaign flowcharts with old eMessage 

process box will not work in v12.1.2.

HMA-312109 Campaign upgrade installation from 12.0 

to 12.1.2 completed with 3 nonfatal error.

HMA-300159 HTTP Communication error occurs, while 

saving flowchart if Unica Platform and 

Campaign applications are using the 

same JNDI. It is suggested to use sepa­

rate JNDIs for Platform and Campaign ap­

plications.

HMA-295574 Deployment of Campaign application in 

wWebSphere application server failed 

due to java.lang.NoClassDefFound­

Error: javax.el.ELManager. Users 

are required to copy javax.el-3.0­

.1b11.jar  in the Websphere application 

servers lib directory. They can download 

javax.el-3.0.1-b11.jar  from https://

mvnrepository.com/artifact/org.glass­

fish/javax.el/3.0.1-b11.

HMA-311916 Journey Process box: Searching in Jour­

ney PB retains its last search string. User 

need to manually clear the search criteria.

HMA-306110, HMA-306108 While deploying or starting Campaign ap­

plication, it throws errors related to mod­

ule-info.class, and warning related to ob­

solete hibernate namespace. These can 

be ignored.

HMA-304803 Getting "jcc][t4][10217][10310][4.14.111] 

Connection read-only mode is not en­

https://mvnrepository.com/artifact/org.glassfish/javax.el/3.0.1-b11
https://mvnrepository.com/artifact/org.glassfish/javax.el/3.0.1-b11
https://mvnrepository.com/artifact/org.glassfish/javax.el/3.0.1-b11


Unica Campaign V12.1.2 Release Notes  | 1 - Release Notes for version 12.1.2  | 15

forceable after the connection has been 

established." warnings in WebSphere con­

sole log. No impact on application side. 

These can be ignored.

HMA-306095 Production documentation links on Cam­

paign installer are broken. See the docu­

mentation available along with product in­

stallers.

HMA-312150 Journey Process box: Search in Associ­

ated Journyes with multiple words is not 

working.

HMA-310126 eMessage instances in Campaign unin­

stall folder – these can be ignored. Unica 

no longer support eMessage.

HMA-312299 Campaign or Platform navigation url 

when contains default http or https port 

then recent menu’s does not work. If you 

are using default http (80) or https (443) 

ports in navigation url please remove 

them.

HMA-312231 Campaign swagger APIs will not work on­

ly on swagger page when marketing plat­

form login method is set to Web Access 

control.

HMA-303532 With MariaDB as system database Opti­

mize, Maillist or Calllist process box exe­

cution fail with error 10646. You must en­

able In DB Optimization in flowchart ad­

vance settings to resolve this error.
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HMA-13460 When the Export to File option is 

unchecked on the Fulfillment tab of the 

Mail List process, the Summary File op­

tion is enabled but should not be.

HMA-175825 When defaultBehaviorWhenOutputTo­

File  is set to Create New File, it works 

only when you select a new output (ex­

port) file for the first time. If you try to 

change the existing output file and select 

a new output file, then the option Append 

to Existing Data  gets selected by de­

fault. It can be changed manually to Cre­

ate New File.

APAR 198495, PO05293, 198494 For a custom macro, if a user account 

has assigned as Not Granted permission 

for a stored object (Custom Macros, Flow­

chart Templates, Stored Derived Fields, 

etc.), the custom macro can be used to 

edit, delete, add, move all stored objects 

regardless of permissions.

HMA-204347 LARGE_DATA: Browser Crash - Mail List 

process box with 700 segments - Save 

with 512 offers to each segment.

HMA-211253 File-based input with multiple columns 

containing date in different format does 

not read the date correctly.

HMA-212890 Boolean type column on Amazon Redshift 

is recognized as 'Test' field type in table 

mapping.
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HMA-220474 When the column name of the source 

table contains Non-ASCII characters 

and is long (probably longer than 10 x 

3bytes characters in UTF8), the Snapshot 

process does not run because the temp 

table is not created.

HMA-220705 Profiling count for Dimension table fields 

is incorrect and profiling percentage is 

displayed as 100% even if profiling is in 

progress.

APAR 222047, PO06172, 222049 Unica Campaign extract process does not 

write to DB2 database when flowchart is 

configured with two extract processes 

and the second extract process contains 

a derived field that uses French accent­

ed characters in the name of the derived 

field.

APAR 225568, PO06304, 225572 temptablepostexecutionsql  is not run 

when selecting coremetrics segment.

HMA-230340 Inconsistent behavior for the Mail list 

process is observed when the data filter 

is assigned to Effective date  on the Pa­

rameters tab in a new Mail list process 

when compared to an edited existing Mail 

list process. The Mail list process does 

not output a datetime derived field in the 

output log file. Changing the effective 

date parameter values might cause exe­

cution failure of the Mail list.
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HMA-230606 In a flowchart where fields are extracted 

and used in a Mail list process, the fields 

under Extract Node on the Personaliza­

tion tab of the Mail list process are differ­

ent before and after running the process.

HMA-231859 While using the Chrome browser, it takes 

around 20 seconds to respond while load­

ing the Personalization tab of the Mail 

list process if it contains large number of 

treatments and offers assigned. For ex­

ample, a Mail list process with 250 cells, 

each cells with multiple offers, each offer 

having multiple attributes.

HMA-232502 A Mail list performance issue occurs 

when the user changes the input in any 

way and there is a delay when initially 

switching tabs. After the user changes 

the input and switches to the Treatment 

or Process tab for the first time, there is 

a delay of around 10-15 seconds depend­

ing on the number of inputs selected. Af­

ter this initial delay, there is no delay until 

the input is changed.

HMA-232835 The Campaign application performance 

is affected and sometimes an exception 

error message is displayed on the Cam­

paign pages when the application is used 

for a longer time (some days) with contin­

uous usage. You must restart your Cam­

paign web application and Campaign Lis­

teners.
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HMA-238789 While using the Chrome browser, when a 

user opens a Mail list with 600 cells hav­

ing multiple offers assigned to each cell, 

the application stops responding. While 

using the Internet Explorer 11 brows­

er, nothing is displayed in the Mail list 

process box.

HMA-239142 When the Audience process fails because 

of an incorrect Count filter expression, 

and the user removes the filter expres­

sion, adds a Condition, and runs the Au­

dience process again, the process fails. 

The Condition is not considered and in­

stead the previous Count filter expression 

is used resulting in the failure. To run the 

Audience process successfully, you must 

re-open the Audience process configura­

tion window, click the Condition, Save and 

Close. The Audience process now consid­

ers the Condition and runs successfully.

HMA-271642 A "Please wait....."  message is dis­

played multiple times in console mode in­

stallation while upgrading from version 

10.1 and also for new Installation

HMA-271676 The Extract table on the DB2 and Oracle 

databases is not deleted when In-DB opti­

mization is unchecked.

HMA-272253 The Campaign application performance 

is affected when a user opens the Table 
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mapping window and more than 500 ta­

bles are mapped.

HMA-2968 Hot keys are not implemented on most of 

the windows. In the Dojo implementation 

it is not possible to use keyboard short­

cuts to activate certain functions. Instead 

the user must click buttons.

HMA-PMR 266519, 75262 Clicking Return to previous page distorts 

the user interface in some cases. Use 

the links within the products to navigate, 

rather than the browser controls.

N/A When Unica Campaign is deployed in 

an application server cluster environ­

ment with 80 port, the Campaign nav­

igation URL should not contain this 

port number. For example: http://

<host>.<domain>:80/ Campaign should 

be changed to http://<host>.<do­

main>/Campaign. Change the value of the 

serverURL property under Campaign|nav­

igation on the Settings > Configuration 

page.

N/A Mail List process box gets unconfig­

ured with error "31606: History table are 

changed" on Flowchart run.

1. There is no issue if the history ta­

bles are mapped prior to building 

a flowchart and adding a Mail List 

process.
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2. If you do not follow step 1, you can 

still map the history tables after the 

error appears. If you edit the flow­

chart and configure the process 

box, the process will run.

N/A After migrating non-ASCII data to Cam­

paign, in some cases you cannot open 

Campaign flowcharts on the target sys­

tem. Session flowcharts open successful­

ly. To work around this issue, remigrate 

the campaigns in overwrite mode. You 

can then open the flowcharts.

TT 062333 Information related to associated prod­

ucts does not appear in offer on Market­

ing Operations. When an offer created in 

Campaign with products associated with 

it is imported in Marketing Operations, in­

formation about the associated products 

is not available in Marketing Operations.

HMA-270655 Table Mapping : Table name containing @ 

is supported while mapping a table, spe­

cial characters like @ are should not be 

supported in Table names. Since Table 

name containing @ is supported since 

some time, this functioning is not updat­

ed now.

HMA-283637 When user has one maillist PB config­

ured in the flowchart and he adds anoth­

er maillist PB in the same flowchart, it 

is observed that All the values from al­

ready configured in treatment tab, Para­
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meters tab, Personalisation tab of new 

Maillist PB appear automatically in any 

new dragged maillist PB.

HMA-281389 While running Campaign in the Upgrade 

mode, the installer should read the instal­

lation properties files from the previous 

version response files as we had that re­

sponse available at the install location 

from the previous installation. However, 

it does not read the installation proper­

ties files from the earlier version response 

files.

HMA-280623 In Sample PB if we specify '3' in "# of 

Samples/Output Cells" field and Config­

ure [sample1] with 3 samples having sam­

ple sizes as 50%, 50% and "All remain­

ing records" respectively based on "Ran­

dom Sample method" then after running 

Flowchart if we reopen the Sample PB 

"Process run results will be lost. Contin­

ue?" message is displayed in sample PB 

when remaining All check boxed is check.

HMA-283101 CHROME: "Unable to notify roles/per­

mission changes to Campaign, Deliver 

OD may be out of sync". On clicking save 

changes for the Security Policy displays 

the following pop-up, this happens just 

first time after user logs in and changes 

anything in the policy and clicks save 

changes. Also, this is reproducible just 
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on CHROME. Tested on Chrome V64 and 

V65.

HMA-282844 Campaign Offer doesn’t sort on 'Chan­

nel' & 'Eff./Exp.Dates'. After clicking on 

every column the offers below it should 

be sorted in ascending order. If you click 

on the same column the second time, the 

offers beneath it should be sorted in the 

descending order.

HMA-283695 Segment process box execution failed 

with extract enabled to User database for 

the IMPALA user DB. This error does not 

reproduce when extracting to Unica Cam­

paign server.

HMA-284436 Platform.war and campaign.war in ear 

file deployment will not work in Weblog­

ic 12.2.1, work around is to deploy cam­

paign.war and unica.war separately.

HMA-288228 If the date field uploaded to IMC side 

is not in mm/dd/yyyy format, the email 

process box fails to execute. This da­

ta format is required by IMC Importlist 

API. It works accurately if DELIM_M_D_­

YYYY(mm/dd/yyyy) format is used for 

date while uploading to IMC using im­

portlist API.

HMA-289135 TOMCAT : Occasionally Unica Platform 

or Campaign does not gets started after 

deploying in tomcat application server. 

Workaround : delete Campaign and Plat­
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form directory available inside Tomcat 

webapps directory and delete the content 

of work directory from the path where 

Tomcat is installed.

HMA-304945 Refresh command does not refresh 

the master listener priority or weight, if 

you need to make changes in priority or 

weight you require to take a downtime 

and restart the application.

HMA-312445 Link Process box - sending data only for 

the first input cell selected to link.

UL-285 Connection Salesforce - Subsequent 

Salesforce actions are failing for Update 

(Lead/Contact) intermittently.

UL-250 Connection Mandrill - Intermittenly stop 

sending emails to targeted audiences.

UL-281 Connection Mandrill - Subject line with 

non english characters - mandrill not 

sending email to user.

UL-259/UL-242 Connection Mailchimp/Mandril - results 

would be available for 1000 users only.

UL-214 MailChimp/Mandril - Audience value is 

getting changed to id field after selection 

or reopening process box.

UL-194 MailChimp/Mandril - In Mandrill template 

if merging field added as localized char­

acter - personalization is not working.

UL-257 Link Connections page takes time to load 

in the Campaign process box.
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UL-231 Twilio Connection - Only 5 fields are sup­

ported for personalization in SMS body/

text area.q

UL-279 Connection MailChimp - Branch run or 

single link process box run is not support­

ed with Link process box with Mailchimp 

connection. You will need to execute 

complete flowchart.

UL-287 Link process box fails when no output da­

ta.

NA Unica Campaign and Unica Link applica­

tions urls should be having same domain 

names. Unica Campaign and Link applica­

tions deployed on different domains will 

not work.

UL-189 Connection Mandrill/MailChimp- Emo­

jis are not working in Mandrill and 

MailChimp connector Mail Subject line.

HMA-313650 Platform Scheduled flowcharts are not 

getting executed afterupgrade.Use the 

quartzjobtool to update scheduler jobs. 

This is a requiredstep. If this upgrade tool 

is not run, any existing scheduled job will­

fail to start. The quartzjobtool is in the 

tools\bin directory underUnica Platform 

installation. Run this utility from the tools 

\bindirectory.Example command (Win­

dows): quartzjobtool.batExample com­

mand (Unix): ./quartzjobtool.sh
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HMA-306383 UBX registration utility is failing with er­

ror Caused by: java.lang.ClassNotFound­

Exception: org.jboss.logging.BasicLogger 

error

HMA-316802 MariaDB]:CODE 704: File write error. while 

extracting extracted fields and table fields 

to database server through Segment PB

Known issues in Optimize V12.1.2
No known issues for Optimize V12.1.2

Known limitations in Unica Campaign  V12.1.2
Unica Campaign  12.1.2 includes the following known limitations.

Issue ID Description

HMA-330347 Users can use Sankey flowchart to view 

waterfall information. This solution is of­

fered with certain limitations:

For huge flowcharts, with approximately 

50+ process boxes, clearly displaying all 

process boxes and related flow is difficult. 

The information or labels may get over­

lapped and thus look cluttered. Users are 

advised to use zoom in and zoom out fea­

ture along with scrollbars to navigate to 

area of interest for better picture.

HMA-291963 Browse table in table mapping feature not 

to be used



Unica Campaign V12.1.2 Release Notes  | 1 - Release Notes for version 12.1.2  | 27

Known limitations in Unica Optimize V12.1.2
No known limitations for Optimize V12.1.2
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