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Chapter 1. Release Notes for version 12.1.1
Contains information about new features, defect fixes, and known issues in Unica Campaign 

and Optimize that HCL releases as part of a scheduled software release.

System requirements and compatibility
Unica Campaign  is part of the Unica  suite of products. Unica Campaign  version 12.1.1 

requires Unica Platform  12.1.1

Where to find complete system requirement and compatibility information

For a list of Unica  product versions compatible with this product and a list of third-party 

requirements for this product, see the Recommended Software Environments and Minimum 

System Requirements  document. ).

You can also access this document by selecting Help > Product documentation  when you 

are logged in to Unica.

Prerequisites for using Unica Campaign
Before you begin using Unica Campaign, confirm that your environment meets the following 

requirements.

• For an improved user experience, use at least a 21" screen.

• For an improved user experience, set your screen resolution to 1600 x 900. Lower 

resolutions can result in some information not being properly displayed. If you use a 

lower resolution, maximize the browser window to see more content.

• A mouse is best for navigating in the user interface.

• Do not use the browser controls to navigate. For example, avoid using the Back and 

Forward buttons. Instead, use the controls that are in the user interface.

• If pop-up blocker (ad blocker) software is installed on the client machine,  Unica 

Campaign  might not function properly. For best results, disable pop-up blocker 

software while running Unica Campaign.
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• Ensure that the technical environment meets the minimum system requirements and 

the supported platforms.*

• The correct browser and versions must be used.*

• Clear the browser cache after upgrading or applying any fix pack. This only needs to 

be done once, after the application is updated.

• If you use Internet Explorer (IE) with Unica Campaign  or any module that uses 

Unica Campaign  flowcharts (Unica Deliver, Unica Optimize, Unica Interact, Unica 

Collaborate): To log in multiple times to view side-by-side information, open IE and log 

in to Unica. Then select File  > New Session  in the IE menu bar. In the new IE browser 

window, log in to Unica  as the same or a different user.

Important:  Do not use any other method to open multiple sessions. For 

example, do not open a new tab; do not open another browser session from 

the Start  menu or desktop icon; and do not use File > New Window  in IE. 

These methods can corrupt information that is shown in the application.

*For details on the items indicated by an asterisk, see the Unica  Recommended Software 

Environments and Minimum System Requirements.

Unica Campaign  documentation roadmap
Unica Campaign  provides documentation and help for users, administrators, and 

developers.

Table  1. Get up and running

Task Documentation

Find out about new features, known 

issues, and limitations

Unica Campaign Release Notes

Learn about the structure of the Unica 

Campaign  system tables

Unica Campaign System Tables and Data Dictio

nary

Install or upgrade Unica Campaign One of the following guides:
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Table  1. Get up and running  (continued)

Task Documentation

• Unica Campaign Installation Guide

• Unica Campaign Upgrade Guide

Unica Insights Reports for Unica 

Campaign

Unica Insights Installation and Configuration Guide

Implement the IBM Cognos®  reports 

provided with Unica Campaign

Unica Reports Installation and Configuration Guide

Table  2. Configure and use Unica Campaign

Task Documentation

• Adjust configuration and securi

ty settings

• Prepare Unica Campaign  for 

users

• Run utilities and perform main

tenance

• Learn about integrations

Unica Campaign Administrator's Guide

• Create and deploy marketing 

campaigns

• Analyze campaign results

Unica Campaign User's Guide

Improve flowchart performance Unica Campaign Tuning Guide

Use Unica Campaign  functions Macros for HCL Unica

Table  3. Integrate Unica Campaign  with other HCL products

Task Documentation

Integrate with Acoustic Campaign and Acoustic Integration Guide for IBM 

Marketing Cloud
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Table  3. Integrate Unica Campaign  with other HCL products  (continued)

Task Documentation

Integrate with Coremetrics Unica Campaign  Administrator's Guide: How to 

configure the integration

Unica Campaign  User's Guide: Targeting IBM Digi

tal Analytics segments in Campaigns

Integrate with Unica Plan Unica Plan and Unica Campaign Integration Guide

Integrate with  Opportunity Detect Unica Campaign  Administrator's Guide: How to 

configure the integration

Opportunity Detect  Administrator's Guide  and Op

portunity Detect  User's Guide: How to administer 

and use the product

Integrate with Unica Deliver Unica Campaign  Installation and Upgrade guides: 

How to install and prepare Deliver components in 

the local environment.

Unica Deliver  Startup and Administrator's Guide: 

How to connect to the hosted messaging re

sources.

Unica Campaign  Administrator's Guide: How to 

configure offer integration.

Integrate with IBM SPSS Modeler Ad

vantage Enterprise Marketing Man

agement Edition

Unica Campaign  and IBM SPSS Modeler Advan

tage Enterprise Marketing Management Edition In

tegration Guide

Integrate with IBM WeatherFX. You can integrate IBM WeatherFX with Campaign 

so that you can pull weather events into your mar

keting campaigns. Unica Campaign version 9 and 

version 10 users can integrate with WeatherFX by 

using the UBX toolkit.
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Table  3. Integrate Unica Campaign  with other HCL products  (continued)

Task Documentation

Integrate with  Unica Director. Unica Director Installation Guide: You can inte

grate  Unica Director with  Campaign so that you 

can get status of all the running/completed/failed 

flowcharts, migrate Camapigns from one Unica 

Campaign  environment to other, download/delete 

flowchart logs etc.

Integrate with Journey Unica Campaign can integrate with Journey so that 

a continuous communication with users can be es

tablished based on the inputs from Campaign.

Refer Campaign Administrators guide > Unica 

Campaign and Unica Journeys integration

Integrate with Link Unica Campaign uses Link capabilities of connec

tors which include the configuration and provision

ing to connect to any delivery channel.

Refer Campaign Administrators guide > Unica 

Campaign and Unica Link integration

Note:  Additional integrations may be available that are not listed in this table. See 

Product tools and utilities for Unica Campaign.

Table  4. Develop for Unica Campaign

Task Documentation

Use the REST API See the Unica Campaign REST API

Use the SOAP API • See the Unica Campaign SOAP API Specifi

cation

• JavaDocs in devkits\CampaignSer

vicesAPI

https://www-947.ibm.com/support/entry/myportal/clientsidetools/enterprise_marketing_management/ibm_campaign?productContext=-198760082
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Table  4. Develop for Unica Campaign  (continued)

Task Documentation

Develop Java™ plug-ins or com

mand-line executables to add valida

tion to Unica Campaign

• See the Unica Campaign Validation PDK 

Guide

• Java-docs in devkits\validation

Table  5. Get help

Task Instructions

Open online help When using the Unica Campaign  application:

1. Choose Help > Help for this page  to open a 

context-sensitive help topic.

2. Click the Show navigation  icon in the help 

window to display the full help.

You must have web access to view context-sensi

tive online help. Contact  Support for more infor

mation about accessing and installing  Knowledge 

Center locally for offline documentation.

Get PDFs When using the Unica Campaign  application:

• Choose Help > Product documentation  to 

access Unica Campaign  PDFs.

• Choose Help > All Unica  documentation  to 

access all product PDFs.

• Click the links for PDFs during the installa

tion process.
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New features and changes in version 12.1.1
Unica Campaign  12.1.1 includes a number of new features and changes. These are listed 

underneath.

For a list of newly supported and discontinued platforms, see the Recommended Software 

Environments and Minimum System Requirements  guide.

Upgrade Paths
Unica Campaign supports the following upgrade paths:

• 12.1.x →  12.1.1

• 12.1.0.x →  12.1.1

Customers on versions earlier than 8.6.x must:

• perform a Fast Upgrade from existing version to version 8.6.0 (for more information, 

see HCL Unica 8.6.0 Fast Upgrade Guide).

• perform a Fast Upgrade from version 8.6.0 to version 12.1.0 (for more information, 

see HCL Unica 12.1.0 Fast Upgrade Guide).

• perform an in-place upgrade from version 12.1.0 to version 12.1.1.

Customers on versions earlier than 11.1.x.x can:

• perform a Fast Upgrade from existing version to version 12.1.0 (for more information, 

see HCL Unica 12.1.0 Fast Upgrade Guide).

• perform an in-place upgrade from version 12.1.0 to version 12.1.1.

Customers on versions 11.1.x.x/12.0.x.x can use one of the following options for upgrade:

• Option 1

◦ perform an in-place upgrade from existing version to version 12.1.0.

◦ perform an in-place upgrade from version 12.1.0 to version 12.1.1.

• Option 2
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◦ perform a Fast Upgrade from existing version to version 12.1.0 (for more 

information, see HCL Unica 12.1.0 Fast Upgrade Guide).

◦ perform an in-place upgrade from version 12.1.0 to verison 12.1.1.

Fast Upgrade

Unica Campaign  12.1 supports the fast upgrade approach. This helps customers bypassing 

the multi-step upgrade. The Fast Upgrade approach is also useful in reducing upgrade 

downtime. The approach is provided for  Unica Platform,  Campaign,  Optimize,  Plan, 

Interact.

Optimize Campaign Decoupling

In V12.1.1 Unica Campaign suite, user can decouple campaigns from the Optimize session 

without having to modify flowchart.

Custom DB Function

Unica Campaign V12.1.1 supports custom DB functions for ORACLE, DB2, Oracle ODBC and 

MSSQL

Concurrent flowchart access depiction

When users access a flowchart already in edit mode they will get status on flowchart 

toolbar <user name> is working. On clicking the edit button in the flowchart toolbar, user will 

get a message Flowchart is in use by user <user name>. Do you still want to continue? If 

you click OK, changes made by user <user name> will be lost.

Campaign support for Journey CH/RH

Unica Campaign V12.1.1 supports Contact History and Response history from Unica 

Journey.

Campaign REST APIs to share segments with other tools

New REST API provided to query strategic segments related data from third party tools.
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Return cell counts from flowchart and process box APIs

New REST API provided to query status of process boxes in a flowchart and related cell 

counts

Kafka as output data source

Snapshot process box can be configured to export selected fields in JSON format to a 

Kafka. This provides a way for third party tools to consume data from a flowchart

Insights- Enhance reports from Campaign product

Enhanced UI of Insights reports under Campaign Analytics. With this change, reports are 

consistent visually and properly spaced to improve readability.

Send time optimization

Unica Open Insights provides the best hour of day for the email recipients based on their 

past interactions. This information can be used in the upcoming Deliver campaigns. For 

more details on implementing send time optimization, see the Unica Campaign User Guide.

Fixed defects in Unica Campaign  V12.1.1
The following defects were fixed in Unica Campaign  12.1.1.

Issue ID Description

HMA-323311 Phishing via Content Spoofing

HMA-326516 Process box configuration and Flowchart 

options are Blank-12.1.1

HMA-270339 Screen jumps in certain cell selections in 

IE11

HMA-135346 Campaign Waterfall report shows un

known for segment counts

HMA-322073 Not able to use table field as integer value 

in ADD_MONTHS macro
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HMA-222618 Error Control cell not linked to any target

HMA-327746 No warning/error message on UI while 

deleting optimize session linked to flow

chart

HMA-218314 Defect to fix 10404 error

HMA-318518 Parameter, ‘SegmentTablePostExecution

SQL’, is missing in MariaDB datasource.

HMA-291963 Browse table in table mapping feature not 

to be used

HMA-325862 Flowchart log process count doesn't 

match UI result

HMA-326477 Installer - Campaign configuration change 

for campaign_log4j.xml

HMA-90239 SCROLLING ISSUES WHILE MAPPING 

TABLES

HMA-319040 Inconsistent Date Format

HMA-310769 Current_date() macro is not compatible 

with impala datasource

HMA-319036 Error in exporting data to Cloudera data

source via snapshot

HMA-325765 Blank process box page when followed 

specific path for Non en_US locale

HMA-329369 Stored Cross-Site Scripting in Cell Code in 

TCS

HMA-326014 Some of the Process boxes cross out af

ter indicating sucessful flowchart run
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HMA-325486 UBX download ETL: Could not obtain We

bSphere Liberty transaction manager

HMA-326748 Tables are highlighted in blue to appear 

as they are selected even when they are 

not within Select process box

HMA-327010 Problems with Segment process after up

grade to 12.1.0.FP4

HMA-328565 Problem with SSL and kafka

HMA-328513 unica_acsesutil processes are running 

out of control; spawning indefinitely over 

time eventually crashing the server

HMA-322608 advSrchAgent.sh" fails with error, "Error: 

Partition specified is not correct!"

HMA-325071 UCGF.rundate value when used in string 

concat function gives null output

HMA-324058 Missing *spring_update.xml files for Cam

paign 12.1.0.0 fast upgrade guide.

HMA-323759 "OPEN JDK 1.8.0.275" incompatibility is

sues during UNICA 12.x upgrade

HMA-246488 DOCUMENT DEFECT REGARDING CLASS 

LOADER SETTINGS

HMA-325067 CODE 10634: Incompatible sort order de

tected.

Known issues in Unica Campaign  V12.1.1
Unica Campaign  12.1.1 includes the following known issues.

Issue ID Description
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HMA-326854 Incorrect date format written to UA_OF

FERHISTATTRIB from mail list process 

box

HMA-331085 Documentation - Docker : Use -async op

tion while running ACOOptAdmin utility

HMA-330431 Campaign Offer reports show incorrect 

data when SAME offer is used in Cam

paign as well as Journey

HMA330613 DOC Help URL is not working for Eng

lish,French and German locales.

HMA-330562 Docker : Campaign kafka template is 

missing for Docker

For resolution on this, please contact HCL 

Unica support team.

HMA-326516 Process box configuration and Flowchart 

options are Blank.

HMA-330433 User is not able to login to platform after 

upgrade to 12.1.1 in case Deliver is con

figured.

Resolution

Execute below query on Platform data

base :

select * from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica

tion=101 and partition_id=<>)
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Specify actual partition id in above query , 

default for partition1 , partition id =1 , it 

varies for multiple partitions.

If above result in more than one row , con

tact HCL support to help in executing be

low delete query - delete one of the du

plicate record of *D*eliver_admin role by 

running below query :

delete from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica

tion=101 and partition_id=<>) and paren

t_role_id=<partition_id>

For example , for partition id =1 ,

delete from usm_role_role_map where 

role_id = (select ID from usm_role where 

name='Deliver_admin' and applica

tion=101 and partition_id=1) and parent_

role_id=1

HMA-306326 JNDI creation for Campaign installer with 

Informix database and Websphere appli

cation server is not creating JNDI with 

correct details. Create JNDI connection 

manually in websphere with Informix re

ferring to the Campaign Installation guide.

HMA-306329 JNDI creation for Campaign installer with 

Informix database and Tomcat applica

tion server is not creating JNDI with cor

rect details.Create JNDI connection man
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ually in Tomcat with Informix referring to 

the Campaign Installation guide

Known issues in Optimize V12.1
No known issues for Optimize V12.1.1

Known limitations in Unica Campaign  V12.1.1
Unica Campaign  12.1.1 includes the following known limitations.

Issue ID Description

HMA-330347 Users can use Sankey flowchart to view 

waterfall information. This solution is of

fered with certain limitations:

For huge flowcharts, with approximately 

50+ process boxes, clearly displaying all 

process boxes and related flow is difficult. 

The information or labels may get over

lapped and thus look cluttered. Users are 

advised to use zoom in and zoom out fea

ture along with scrollbars to navigate to 

area of interest for better picture.

HMA-291963 Browse table in table mapping feature not 

to be used

Known limitations in Unica Optimize V12.1.1
No known limitations for Optimize V12.1.1
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