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Chapter 1. Installing reports

This chapter describes how to install and set up reporting for your IBM® EMM
applications. Information on upgrading and configuring customized reports is
provided elsewhere in this guide.

For its reporting feature, IBM EMM integrates with IBM Cognos® BI, a business
intelligence application. Reporting relies on the following components:
v An installation of IBM Cognos BI
v A set of IBM EMM components that integrates with the IBM Cognos installation
v For Campaign, eMessage, and Interact, reporting schemas that enable you to

build reporting views or tables in the application’s system tables
v The example reports for IBM EMM applications, built with IBM Cognos Report

Studio

To install reporting, you do the following:
v Install the IBM EMM integration components and report models on the IBM

Cognos system.
v Install the reporting schemas from the application report package on the

machine where the Marketing Platform is installed.
v Set up the reporting views or tables.

Reporting installation roadmap
The following table provides a high level overview of the IBM EMM reports
installation process, with brief descriptions of the steps involved and information
on where to find detailed instructions. For upgrades, see the chapter on upgrading
in this guide.

Step Description Where to find details

Install reporting components

Install IBM EMM products. Install the products that provide the data used in reports. See the individual product
installation guides.

Install IBM Cognos. Install the supported version of IBM Cognos, which is
required for many, but not all, IBM EMM reports.

See the IBM Cognos
documentation.

Set up a system user. Configure a user with access to the Settings >
Configuration and Settings > Report SQL Generator
pages so you can log in as this user when you need to
configure the reporting properties and generate the SQL
used to create reporting schema.

See “Step: Set up a user
with the ReportsSystem
role, if necessary” on page
3.

Install the reporting
schemas on the machine
where the Marketing
Platform is installed.

Place the IBM master installer and the report pack
installers in the same directory and launch the master
installer.

See “Step: Install the
reporting schemas on the
IBM EMM system” on page
4

Create JDBC data sources. In the application server where the Marketing Platform is
deployed, create JDBC data source connections to the
system table databases for the products you want to use
for reporting.

See “Step: Create JDBC
data sources” on page 5.

Set up the reporting views or tables

© IBM Corporation 1999, 2012 1



Step Description Where to find details

Load the templates for the
Reports SQL Generator.

To implement reporting for Campaign, eMessage, and
Interact, you create reporting views or tables from which
the reports extract reportable data. The reports packs
contain templates that the Reports SQL Generator uses
when generating SQL scripts for creating these views or
tables. In this step, you load these templates into the
Marketing Platform system table database.

See “Step: Load the
templates for the Reports
SQL Generator” on page 5.

Generate the view or table
creation scripts.

Set some required configuration properties, and then use
the Report SQL Generator to produce the SQL for
creating the reporting views or tables.

See “Step: Generate the
view or table creation
scripts” on page 5.

Create the reporting views
or tables.

Create the views or tables in the IBM EMM product
system table databases.

See “Step: Create the
reporting views or tables”
on page 6.

Set up data
synchronization.

If you created materialized views or tables for reports,
use your database administration tools to schedule
regular data synchronization.

See “Step for tables and
materialized views only:
Set up data
synchronization” on page
10.

Install and test IBM Cognos BI

Install IBM Cognos BI Use the IBM Cognos documentation to guide your
installation, and then test the system.

See “Test the IBM Cognos
BI installation” on page 12.

Install IBM EMM integration components and report models on the Cognos system

Obtain the JDBC driver
used for the Marketing
Platform system tables.

Copy the JDBC driver used for Marketing Platform to the
machine where the Cognos Content Manager is installed.
When IBM authentication is implemented, Cognos uses
this when it obtains user information.

See “Step: Obtain the JDBC
driver for the Marketing
Platform system tables” on
page 13.

Install the reporting models
and integration component
on the Cognos system.

Place the IBM EMM master installer, Marketing Platform
installer, and product report pack installers in the same
directory on the machine where the Cognos Content
Manager is installed, and launch the master installer.

See “Step: Install the
reporting models and
integration component on
the IBM Cognos system”
on page 14.

Create the Cognos data
sources for the IBM EMM
application databases.

The Cognos applications need to connect to the IBM
EMM application data sources for the reports. Use the
Administration section of Cognos Connection to create
these data sources.

See “Step: Create the IBM
Cognos data sources for the
IBM EMM application
databases” on page 14.

Set up email notification
(optional).

If you want to enable an option for sending a report as
an email attachment, configure notification in Cognos
Configuration.

See “Optional step: Set up
email notification” on page
15.

Configure the Cognos
firewall.

In Cognos Configuration, specify the IBM EMM system
as a valid domain or host.

See “Step: Configure the
IBM Cognos application's
firewall” on page 16.

Import the reports folder. In Cognos Connection, import the compressed file for
reports.

See “Step: Import the
reports folder in Cognos
Connection” on page 16.

Configure and publish the
data model, if necessary.

If the data source login you used when you created the
Cognos data sources is not the owner of the IBM EMM
system tables, perform this step.

See “Step: Configure and
publish the data model, if
necessary” on page 17.

Enable internal links in the
reports.

The IBM EMM reports have standard links. To enable
them, you must configure the redirect URL in the Cognos
data model.

See “Step: Enable internal
links in the reports” on
page 17.
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Step Description Where to find details

Verify the data source
names and publish.

This step varies, depending on whether you used the
default data source names in Cognos Connection, as
described in that step.

See “Step: Verify the data
source names and publish”
on page 18.

Configure the Cognos
reporting properties in IBM
EMM.

Log in to IBM EMM and set Cognos reporting properties. See “Step: Configure
Cognos reporting
properties in the Marketing
Platform” on page 18.

Configure report folder
permissions.

To give users permission to run reports from within IBM
EMM applications, assign the default ReportsUser role to
the appropriate user groups or users.

See “Step: Set report folder
permissions” on page 19.

Test your configuration
without authentication
enabled.

After the reports are installed and configured, but before
you enable authentication, test the setup by running
some reports.

See “Step: Test your
configuration without
authentication enabled” on
page 20.

Configure Cognos to use
IBM EMM authentication.

The IBM EMM Authentication Provider enables the
Cognos applications to use IBM EMM authentication to
communicate with the Marketing Platform as if it were
another application in the suite. This step has several
sub-steps.

See “Configure IBM
Cognos to use IBM EMM
authentication” on page 20.

Test your configuration
with authentication
configured.

After you configure Cognos to use IBM EMM
authentication, test the system again.

See “Step: Test your
configuration with
authentication configured”
on page 24.

Perform customization
steps.

At this point, reporting is working properly and the
example reports are in their default state. You may need
to customize the reports or reporting schemas for
Campaign, Interact, or Marketing Operations.

See “Next steps for
reporting” on page 25.

Install reporting components
Installing and configuring IBM EMM product report packages is a multi-step
process. Perform the tasks in this section to perform the installation.

Step: Set up a user with the ReportsSystem role, if necessary
Configure a user with access to the IBM EMM Settings > Configuration and
Settings > Report SQL Generator pages so you can log in as this user when you
need to configure the reporting properties and generate the SQL used to create
reporting schema.

The easiest way to do this is to assign the ReportSystem role to the
platform_admin user. This role is under Report > PartitionN on the User Roles
and Permissions page.

See “Assigning a role to or removing a role from a user” for general information
on performing this task.

Assigning a role to or removing a role from a user
Use this procedure to assign or remove roles.
1. Click Settings > Users.
2. Click the name of the user account that you want to work with.
3. Click Edit Roles.
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Roles that are not assigned to the user are shown in the Available Roles box
on the left. Roles that are currently assigned to the user are shown in the Roles
box on the right.

4. Click a role name in the Available Roles box to select it.
5. Click Add or Remove to move the role name from one box to the other.
6. Click Save Changes to save your changes.
7. Click OK.

Step: Install the reporting schemas on the IBM EMM system
Use the IBM EMM suite master installer and the reports package installers to
install the desired reporting schemas on the machine where the Marketing
Platform is installed.

Follow these guidelines when the reports package installer launches.
1. In the ReportsPackProduct Components window, select Reporting Schema.
2. If more than one option appears in the Schema Type Selection window, it

means that the IBM application has prepackaged custom attributes. Do one of
the following.
a. To install reporting schemas that include the custom attributes, select

Custom. The sample reports for Campaign are configured to use custom
attributes. Therefore, if you are installing the Campaign report package and
you want the sample reports to function correctly, you must select this
option.

b. To install reporting schemas that do not include the custom attributes, select
Base.

The installer places the reporting schema in the file system and registers the
schema with the Marketing Platform.

3. Verify that the reporting schema are registered in the Marketing Platform, as
follows.
a. Log in to the IBM EMM system as the platform_admin user.
b. Select Settings > Configuration.
c. Expand Reports > Schemas > ProductName.
If you see the schema configuration properties for your application, you
installation is complete.
If the schema configuration properties for your application are not present, the
report package has not been registered, and you must register them manually
as described in the next step.

4. Only if the schema configuration properties are not present, register them
manually as follows.
a. Open the import_all script and edit it as follows.

The script is located in the tools directory under your reports package
installation.
Set the value of the MANAGER_TOOLS_BIN_DIR variable to the path of the
tools/bin directory under your Marketing Platform installation.

b. Run the script.
The script invokes the Marketing Platform configTool utility and registers
the schemas.

c. Verify that the schema configuration properties are present.
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Step: Create JDBC data sources
The IBM EMM Reports SQL Generator tool must be able to connect to the IBM
EMM application databases to generate SQL scripts that create reporting tables.
The SQL Generator can generate SQL scripts that create views or materialized
views without access to the these application databases, but it cannot validate the
SQL without a data source connection.

In the application server hosting the Marketing Platform, configure a JDBC data
source for each IBM EMM application for which you want to enable reporting. Use
the default JNDI name listed below. If you do not use the default JNDI names
described in the following tables, make a note of what they are so you can specify
the correct name of the data source when you run the SQL Generator tool.

IBM application Default JNDI name

Campaign campaignPartition1DS

If there are multiple partitions, create a data source for
each partition.

eMessage campaignPartition1DS for the system tables

eMessagePartition1TrackingDS for the tracking tables

Interact campaignPartition1DS for the design-time database

InteractRTDS for the runtime database

InteractLearningDS for the learning tables

If you need additional help with this task, see the application server
documentation.

Set up the reporting views or tables
To implement reporting for Campaign, eMessage, and Interact, you create
reporting views or tables from which the reports extract reportable data. This
section describes how to run the Reports SQL Generator, which uses the reporting
schemas to generate view or table creation scripts. You then run those scripts on
the IBM application database to create the views or tables.

Step: Load the templates for the Reports SQL Generator
The reports packages for IBM EMM applications that have reporting schemas
contain a SQL script that loads template SQL select statements into the
uar_common_sql table. The Reports SQL Generator uses these templates when
generating the SQL scripts for creating the reporting views or tables. In this task,
you run the script that loads the templates.
1. Navigate to the schema directory under your report pack installation and locate

the templates_sql_load.sql script.
2. Run the templates_sql_load.sql script in the Marketing Platform database.

Step: Generate the view or table creation scripts
Complete the following steps.
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1. Log in to IBM EMM as the platform_admin user (or another user with access
to the Report SQL Generator menu item).

2. Only if you did not use the default JNDI names for the JDBC data sources
you created in an earlier step, do the following.
a. Select Settings | Configuration | Reports | Schemas | ProductName .
b. Change the default values of the JNDI property to match the JNDI names

you gave the JDBC connections in an earlier step.
3. Select Settings | Reports SQL Generator.
4. In the Product field, select the appropriate IBM application.
5. In the Schema field, select one or more reporting schemas.
6. Select the Database Type.
7. In the Generate Type field, select the appropriate option (views, materialized

views, or tables).
Materialized views are not an option when Database Type is set to MS SQL
Server.
If the JNDI data source names are incorrect or have not been configured, the
SQL Generator cannot validate the SQL.scripts that create tables.

8. Ensure that Generate Drop Statement is set to No.
The first time you run the view or table creation scripts there are no existing
views or tables to drop so there is no need to create drop scripts.

9. (Optional.) To examine the SQL that will be generated, click Generate. The
SQL Generator creates the script and displays it in the browser window.

10. Click Download.
The SQL Generator creates the script and prompts you to specify where you
want to save the file. If you selected a single reporting schema from the
Schema field, the script name matches the name of schema
(eMessage_Mailing_Performance.sql, for example). If you selected more than
one reporting schema, the script name uses the product name only
(Campaign.sql, for example). For a complete list of names, see “SQL scripts by
data source” on page 7.

11. Specify the location where you want to save the script. If you change the
name of the file, be sure to use something that clearly indicates which
schemas you selected. Then click Save.

12. Repeat steps 5 through 12 for each script you need to generate.

Note: The Interact reporting schemas reference more than one data source.
Generate a separate SQL script for each data source.

Step: Create the reporting views or tables
Use the SQL you created in a previous step to create the reporting views or tables.
Complete one or more of the following, as appropriate for your installation.

Refer to “SQL scripts by data source” on page 7 as necessary.
v “Create views or materialized views for Campaign or eMessage” on page 7
v “Create views or materialized views for Interact” on page 8
v “Create and populate reporting tables for Campaign or eMessage” on page 9
v “Create and populate reporting tables for Interact” on page 10
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SQL scripts by data source
The following table shows which scripts you need to generate for each data source,
the resulting script names and, for creating views or materialized views, which
script should be run against which IBM EMM application database. Note the
following.
v The table lists the default names for the data sources and the generated scripts,

which you might have changed.
v The Interact reporting schemas reference more than one data source. Generate a

separate SQL script for each data source.

Reporting schema Data source (default names) Script name (default names)

All Campaign reporting schemas Campaign system tables

(campaignPartition1DS)

Campaign.sql, unless you generated
separate scripts for each reporting
schema. If you did, each script is
named after the individual schema.

eMessage Mailing Performance eMessage tracking tables, which are
with the Campaign system tables

(campaignPartition1DS)

eMessage_Mailing_ Performance.sql

Interact Deployment History, Interact
Performance, and Interact Views

Interact design time database

(campaignPartition1DS)

Interact.sql

Interact Learning Interact Learning tables

(InteractLearningDS)

Interact_Learning.sql

Interact Run Time Interact run time database

(InteractRTDS)

Interact_Runtime.sql

Create views or materialized views for Campaign or eMessage
1. Locate the SQL scripts that you generated and saved previously. Refer to “SQL

scripts by data source” if necessary.
2. Use your database administration tools to run the appropriate script against the

appropriate application database(s) for the report package you are configuring.

Note: When you run a script that creates materialized views on a DB2®

database, your database may return the error "SQL20059W The materialized
query table-name may not be used to optimize the processing of queries."
However, the materialized view is successfully created.

3. For Campaign with a DB2 database only, increase the DB2 heap size to 10240
or higher. (The default heap size is 2048.) Use the following command:
db2 update db cfg for databasename using stmtheap 10240

where databasename is the name of the Campaign database.
Increasing the heap size ensures that IBM Cognos does not display SQL error
messages if a user selects all the campaigns when running a report like the
Financial Summary report.

4. For eMessage only, do the following.
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v In the ReportsPackCampaign\tools directory under your reports pack
installation, locate the uare_lookup_create_DB_type.sql script, where
DB_type is the database type appropriate for your installation of Campaign.

v Edit the appropriate version of the script to remove the drop table statements
and save the script.

v Run the appropriate version of the script against your Campaign system
tables database.

Create views or materialized views for Interact
1. Verify that the language setting of the client from which you will run the

lookup_create SQL script is UTF-8.
For examples of how to do this for Oracle and DB2, see “Setting the language
in Oracle and DB2.”

2. Locate the SQL scripts that you generated and saved previously. Refer to “SQL
scripts by data source” on page 7 if necessary.

3. Use your database administration tools to run the appropriate script against the
appropriate application database(s) for the report package you are configuring.

Note: When you run a script that creates materialized views on a DB2
database, your database may return the error "SQL20059W The materialized
query table-name may not be used to optimize the processing of queries."
However, the materialized view is successfully created.

4. Locate the tools subdirectory in the reports package installation directory and
find the lookup_create script for your database type. For example, the script
for SQL is named uari_lookup_create_MSSQL.sql, and so on.
Run this script on the the Interact design time database. Ensure that the
database tool you are using commits the changes. For example, you may need
to set the database's auto-commit option to true.

5. Locate the db/calendar subdirectory in the Marketing Platform installation
directory and find the ReportsCalendarPopulate script appropriate for the
database type. This script creates two more tables: UA_Calendar and UA_Time.

6. Run this script on the Interact run time database (InteractRTDS).
For DB2 only, do one of the following:
v Either run the script from the command line using the command db2 -td@

-vf ReportsCalendarPopulate_DB2.sql

v Or, if you use the DB2 client interface, change the termination character to
the @ character in the Statement termination character field.

Setting the language in Oracle and DB2:
Oracle example

For example, for Windows and Oracle:
1. Close any open Oracle sessions.
2. Open the Registry Editor.
3. Navigate to HKEY_LOCAL_MACHINE > SOFTWARE > ORACLE and open

the folder for your Oracle Home (ex. KEY_OraDb10g_home1).
4. Search for the NLS_LANG setting.
5. Make sure the last part of the value specified is UTF8. For example:

AMERICAN_AMERICA.UTF8.
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DB2 example

For example, for DB2, from the machine that is running the script and has the DB2
client installed, run a DB2 command window. Then run the following command:

db2set

In the output, look for the following variable/value pair: DB2CODEPAGE=1208

If this variable is not set, run the following command

db2 db2set db2codepage=1208

Then close the session window so the change can take effect.

Create and populate reporting tables for Campaign or eMessage
1. Create the new reporting database.
2. Locate the SQL scripts that you generated and saved previously. Refer to “SQL

scripts by data source” on page 7 if necessary.
3. Use your database administration tools to run the generated script(s) in the

new database.
4. For Campaign and a DB2 reporting database only, increase the DB2 heap size

to 10240 or higher. (The default heap size is 2048.) Use the following command:
db2 update db cfg for databasename using stmtheap 10240

where databasename is the name of the reporting database.
Increasing the heap size ensures that Cognos does not display SQL error
messages if a user selects all the campaigns when running a report like the
Financial Summary report.

5. Locate the db/calendar subdirectory of the Marketing Platform installation and
find the version of the ReportsCalendarPopulate script appropriate for the
database type. This script creates two more tables: UA_Calendar and UA_Time.

6. Run the ReportsCalendarPopulate script on the new database that you created
with the table creation script.
For DB2 only, do one of the following:
v Either run the script from the command line using the command db2 -td@

-vf ReportsCalendarPopulate_DB2.sql

v Or, if you use the DB2 client interface, change the termination character to
the @ character in the Statement termination character field.

7. Use your database administration tools to populate the new tables with the
appropriate data from the production system database.

Note: Note that you must use your own tools for this step. The SQL Generator
does not generate this SQL for you.

8. For eMessage only, do the following.
v In the ReportsPackCampaign\tools directory under your reports pack

installation, locate the uare_lookup_create_DB_type.sql script, where
DB_type is the database type appropriate for your installation of Campaign.

v Edit the appropriate version of the script to remove the drop table statements
and save the script.

v Run the appropriate version of the script against your Campaign system
tables database.
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Create and populate reporting tables for Interact
1. Create the new reporting databases.
2. Locate the SQL scripts that you generated and saved previously. Refer to “SQL

scripts by data source” on page 7 if necessary.
3. Use your database administration tools to run the generated script(s) in the

new database.
4. Locate the tools subdirectory in the reports package installation directory and

find the lookup_create script for your database type. For example, the script
for SQL is named uari_lookup_create_MSSQL.sql, and so on.
Run this script on the the Interact design time database. Ensure that the
database tool you are using commits the changes. For example, you may need
to set the database's auto-commit option to true.

5. Locate the db/calendar subdirectory in the Marketing Platform installation
directory and find the ReportsCalendarPopulate script appropriate for the
database type. This script creates two more tables: UA_Calendar and UA_Time.

6. Run this script on both the set of tables that represents the Interact design time
database and the tables that represent the Interact run time database.
For DB2 only, do one of the following:
v Either run the script from the command line using the command db2 -td@

-vf ReportsCalendarPopulate_DB2.sql

v Or, if you use the DB2 client interface, change the termination character to
the @ character in the Statement termination character field.

7. Use your database administration tools to populate the new tables with the
appropriate data from the production system database.

Note: Note that you must use your own tools for this step. The SQL Generator
does not generate this SQL for you.

Step for tables and materialized views only: Set up data
synchronization

If you created materialized views, be sure to use your database administration
tools to schedule regular data synchronization between the production databases of
the IBM EMM application and the materialized views.

If you created reporting tables, be sure to use scheduled ETL (Extraction,
Transformation and Load) or any custom method to schedule regular data
synchronization, between the the production databases of the IBM EMM
application and the new reporting tables.

Install and test IBM Cognos BI
If your license agreement with IBM grants you an IBM Cognos BI license, you can
download the IBM Cognos BI installation media from the IBM Customer Central
website.

IBM Cognos BI, IBM reporting, and domains
Before you begin, determine whether you are installing IBM Cognos BI in the same
domain as the IBM EMM suite. As a best practice, you are encouraged to install
IBM Cognos and the IBM EMM system in the same domain. If you do not, you
must configure both IBM Cognos and IBM EMM to use SSL.
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Note: After you install IBM Cognos BI, be sure to use Cognos Configuration to
configure the Cognos URLs appropriately. On a Windows system, the default
values for these URLs use the machine name "localhost." You must replace the
"localhost" placeholder with the fully qualified host name, including domain.

IBM Cognos BI applications
IBM Cognos BI is a collection of several applications, servers, and services,
organized in a multi-tiered architecture. When you use IBM Cognos BI with your
IBM EMM suite, you use the following subset of Cognos BI applications:
v IBM Cognos BI Server, which provides storage for reports and folders (plus the

queries and metadata models), the Content Manager, and so on.
v IBM Cognos Connection, a web application that you use to import, configure,

and schedule the reports. This application also provides access to the following
additional components:
– Cognos Viewer: used for displaying reports. Cognos Viewer is the module

that displays the reports in your IBM EMM applications.
– Report Studio: used for customizing reports and creating new ones.
– Cognos Administration: used for configuring data sources, and so on.

v IBM Cognos Framework Manager, the metadata modeling tool that you use to
configure and customize the Cognos data model that supports the IBM Cognos
BI reports for your IBM EMM application.

v IBM Cognos Configuration, the configuration tool that you use to configure
individual Cognos BI components.

IBM Cognos BI installation options
Before you install IBM Cognos BI, use the IBM Cognos BI Architecture and
Deployment Guide to learn about the various components, the installation options,
and the configuration approaches recommended by IBM Cognos.

The IBM Cognos documentation uses two general categories to describe
installations: installing in a distributed environment versus installing all the
components on one computer. For best results, do not install all components on
one computer unless it is for a proof of concept or is a demonstration environment.

Installing the subset of IBM Cognos BI applications that IBM reporting uses
requires that you use two IBM Cognos installers. One provides the IBM Cognos BI
server, the Content Manager, Cognos Configuration, and the Web-based user
interfaces. You use a separate installer to install Framework Manager, the metadata
modeling tool, because it must be installed on a Windows machine.

See the Cognos documentation for complete installation details.

IBM Cognos BI web applications and the web server
IBM does not provide the web server that hosts Cognos Connection and the other
IBM Cognos BI web applications. For Windows, the IBM Cognos documentation
assumes that you are using Microsoft IIS (Internet Information Services) but you
can also use Apache HTTP.

If you use the Apache HTTP server, take care to set up the web aliases for the
Cognos web applications in the VirtualHost configuration directive of the Apache
httpd.conf file correctly: be sure to order the most specific alias first (the script
alias) and set directory permissions for each alias.
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Example httpd.conf code snippet

The following example is from an Apache installation on a Windows system. The
Apache server is running on the default port 80.

<VirtualHost *:80>
ScriptAlias /ibmcognos/cgi-bin "C:/cognos/cgi-bin"

<Directory "C:/cognos/cgi-bin">
Order allow,deny
Allow from all

</Directory>
Alias /ibmcognos "C:/cognos/webcontent"

<Directory "C:/cognos/webcontent">
Order allow,deny
Allow from all

</Directory>
</VirtualHost>

Note: This httpd.conf file snippet is an example only. Be sure to configure your
web aliases appropriately for your systems.

IBM Cognos BI and locale
If you plan to install a localized version of your IBM EMMapplication report
package (other than English), be sure to set the product locale to match the
language of the application report package.

On the system running the Cognos Content Manager, open IBM Cognos
Configuration, select Actions > Edit Global Configuration, and configure the
locale for the IBM Cognos BI system. For more information, see the IBM Cognos
Configuration User Guide, available from the Help menu in Configuration Manager.

Test the IBM Cognos BI installation
Test your IBM Cognos installation using the following guidelines.
v Stop and restart the Cognos BI server and check the cogserver.log file for

errors. The file is located in the logs directory of your Cognos installation.
v Verify that database tables exist in the Cognos content store. There should be

approximately 134 tables.

If you have a distributed Cognos environment with components installed on
different machines, for example Cognos BI server on a UNIX system and
Framework Manager installed on a Windows machine, do the following.
v Verify that you can communicate with the internal and external dispatcher and

the Content Manager from the machine where the Gateway is installed. To test
components that do not have a user interface, enter the URI of the component in
a browser’s address field. A Cognos page should appear in the browser.

v Open Framework Manager and start to create a project. This test ensures that
you can log in. Check the log file again for errors.

Install IBM EMM integration components and report models on the
Cognos system

To integrate the IBM EMM suite with Cognos, you need the following installers.
v The IBM EMM master installer—You always run this installer to launch the

other installers
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v The Marketing Platform installer—You install the Cognos integration component
from this installer

v The reports pack installer or installers for the products for which you want to
implement reporting—You install the reports archive containing the models and
sample reports from this installer

After you perform the installation, you perform the following configuration steps,
as described in the remainder of this section.
v Configure IBM EMM and Cognos reporting properties in the Marketing Platform

interface
v Import the report into Cognos Connection
v Configure Cognos to use IBM EMM authentication

Installation checklist: IBM Cognos integration
The following list provides a high level overview of how to install and configure
the IBM components and reports on the IBM Cognos system. Each step is
described in detail later in this section.
1. “Step: Obtain the JDBC driver for the Marketing Platform system tables.”
2. “Step: Install the reporting models and integration component on the IBM

Cognos system” on page 14.
3. “Step: Create the IBM Cognos data sources for the IBM EMM application

databases” on page 14.
4. “Optional step: Set up email notification” on page 15.
5. “Step: Configure the IBM Cognos application's firewall” on page 16.
6. “Step: Import the reports folder in Cognos Connection” on page 16.
7. “Step: Configure and publish the data model, if necessary” on page 17.
8. “Step: Enable internal links in the reports” on page 17.
9. “Step: Verify the data source names and publish” on page 18.

10. “Step: Configure Cognos reporting properties in the Marketing Platform” on
page 18.

11. “Step: Set report folder permissions” on page 19.
12. “Step: Test your configuration without authentication enabled” on page 20.
13. “Configure IBM Cognos to use IBM EMM authentication” on page 20.
14. “Step: Test your configuration with authentication configured” on page 24.

Step: Obtain the JDBC driver for the Marketing Platform
system tables

Obtain the JDBC drivers and any required associated files that you used to
configure the JDBC data source for the Marketing Platform's system tables when
you set up the IBM EMM system. In a task later in this chapter, you configure
Cognos to use IBM EMM authentication. Cognos needs the JDBC driver so it can
obtain user information from the Marketing Platform system tables when it uses
IBM EMM authentication.

Copy the JDBC driver to the machine where the Cognos Content Manager is
installed, to the webapps\p2pd\WEB-INF\AAA\lib directory under your Cognos
installation.
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Step: Install the reporting models and integration component
on the IBM Cognos system

If yours is a distributed Cognos installation, determine which machine is running
the Cognos Content Manager so you can run the IBM EMM installers on this
machine.
1. On the machine where the Cognos Content Manager is installed, place the

following IBM EMM installers in a single directory.
v IBM EMM master installer
v Marketing Platform
v The reports pack installer or installers for the products for which you want

to implement reporting
2. Run the IBM EMM master installer, and select the Marketing Platform and

Reports packages you want to install.
3. Following the prompts, enter the connection information for the Marketing

Platform system table database.
4. When the Marketing Platform installer launches and the Platform Installation

Components window appears, select the Reports for IBM Cognos 10 BI option
and clear the other options

5. When the Marketing Platform installer prompts for the path to the JDBC driver,
enter the fully qualified path for the JDBC driver you copied to the Cognos
system during the task “Step: Obtain the JDBC driver for the Marketing
Platform system tables” on page 13.

6. When the Marketing Platform installer prompts for the location of the IBM
Cognos installation, enter or browse to the top level of the IBM Cognos
installation directory.
The default value provided in this field is a static value that is not based on the
actual file structure of your IBM Cognos system.

7. When the report pack installer or installers displays installation options, select
Product Reports Package, and clear the option for the reporting schemas.
This option copies the reports archive to the Cognos machine. You import this
archive later.

Step: Create the IBM Cognos data sources for the IBM EMM
application databases

The IBM Cognos applications need their own data sources that identify the IBM
EMM application databases; that is, the source of the data for the reports. The IBM
Cognos data models provided in the IBM EMM reports packages are configured to
use the following data source names:

Table 1. Cognos data sources

IBM EMM application Cognos data source name(s)

Campaign CampaignDS

eMessage eMessageTrackDS

Interact InteractDTDS for the design time database

InteractRTDS for the runtime database

InteractLearningDS for the learning database

Marketing Operations MarketingOperationsDS

Leads LeadsDS for the data mart tables
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Use the following guidelines to create Cognos data sources for the IBM application
databases:
v Use the Administration section of Cognos Connection.
v Use the default data source names that are shown in the Cognos data sources

table. That way you can avoid having to alter the data model.
v The database type you select must match that of the IBM application database.

Use the Cognos documentation and help topics to determine how to fill out
database-specific fields.

v Be sure that you identify the IBM EMM application database and not the
Cognos content store.

v When you configure the Signon section, select the Password and Create a
Signon that the Everyone group can use options.

v In the Signon section, specify the user credentials for the IBM EMM application
database user.

v Consult the Cognos data sources table and ensure that you create all the data
sources required by the data model for the reports you are configuring. For
example, the reporting data for Interact is located in three databases so you must
create separate Cognos data sources for each one.

v If the Campaign system has more than one partition, create separate data
sources for each partition. For example, if Campaign is configured for multiple
partitions, create a separate Campaign data source for each partition.

v Verify that you have configured each data source correctly by using the Test
Connection feature.

If you have any questions about configuring Cognos data sources, see the IBM
Cognos Administration and Security Guide, "Chapter 6: Data Sources and
Connections" and the Cognos online help.

Optional step: Set up email notification
When an IBM Cognos report is displayed in the IBM EMM interface, the Cognos
Viewer toolbar in the window includes an option for sending the report as an
attachment in an email. If you want to enable IBM Cognos to send IBM EMM
reports as email attachments, configure notification in Cognos Configuration.

Use the following guidelines to set up email notification for the IBM EMM
application reports:

Obtain the following information.
v Host name or IP address of your SMTP server
v User name and password for the account on that server
v Email address for the default sender email

In Cognos Configuration, select Data Access > Notification and do the following.
v Specify the SMTP mail server using the host name or the IP address plus the

port using the format host:port or IPAddress:port. For example, serverX:25 or
192.168.1.101:25. (The default SMTP port is usually 25.)

v To set the user name and password of the account, click in the Value column
and click the pencil icon to open the Value dialog box.

v Specify the default sender using the pattern user@company.com.

Chapter 1. Installing reports 15



If you have any questions about configuring email notification, see the Cognos
Connection online help.

Step: Configure the IBM Cognos application's firewall
To configure the IBM Cognos firewall, you specify the IBM EMM system as a valid
domain or host.
1. In Cognos Configuration, select Security > IBM Cognos Application Firewall.
2. In the valid domains or hosts property, enter the fully qualified machine host

name, including the domain and the port, for the system where the Marketing
Platform is running.

Important: If you have a distributed IBM EMM environment, you must do this
for every machine on which an IBM EMM product that renders Cognos reports
is installed (for example, the Marketing Platform, which has dashboards;
Campaign; and Marketing Operations).
For example:
serverXYZ.mycompany.com:7001

3. Save the configuration.
4. Restart the IBM Cognos service.

Step: Import the reports folder in Cognos Connection
The IBM EMM application reports are in the compressed (.zip) file the report
package installer copied to the IBM Cognos machine. Use the guidelines in this
procedure to import the compressed file for reports into Cognos Connection.
1. Navigate to the Cognosnn directory under your report package installation on

the IBM Cognos machine, where nn indicates the version number.
2. Copy the compressed reports archive file (for example IBM EMM Reports for

Campaign.zip) to the directory where your Cognos deployment archives are
saved. In a distributed IBM Cognos environment, this is a location on the
system running the Content Manager.
The default location is the deployment directory under your IBM Cognos
installation and it is specified in the Cognos Configuration tool installed with
the Cognos Content Manager. For example: cognos\deployment.

3. Locate the Cognosnn\ProductNameModel subdirectory under your report
package installation on the Cognos machine.

4. Copy the entire subdirectory to any place on the system running Cognos
Framework Manager that Framework Manager has access to.

5. Open Cognos Connection.
6. From the Welcome page, click Administer Cognos Content.

If your Welcome page is turned off, turn it back on in the Cognos Connection
user preferences.

7. Click the Configuration tab.
8. Select Content Administration.

9. Click (New Import) on the toolbar.
10. Follow these guidelines as you step through the New Import Wizard:

a. Select the reports archive that you copied in the previous procedure.
b. In the Public folders content list, select all the options, including the

package itself (the blue folder).
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c. If you do not want users to access the package and its entries yet, select
Disable after import. Make this selection if you want to test the reports
before you make them available to the IBM EMM application users.

Step: Configure and publish the data model, if necessary
In “Step: Create the IBM Cognos data sources for the IBM EMM application
databases” on page 14, you set up the IBM EMM system tables as a Cognos data
source. If the data source login you used is not the owner of the IBM EMM
application system tables, perform the step described here. If the data source login
you used does own the IBM EMM application system tables, then you can skip
this step.
1. Locate the Model directory under the reports package installation. Copy all of

the files in this Model directory to anywhere under your Cognos Framework
Manager installation directory. These files constitute the application-specific
data model.

2. In Framework Manager, open the project file. The project file has a .cpf
extension and the file name includes the IBM EMM application name (for
example, ProductNameModel.cpf).

3. Open the data model for the application and do the following.
a. In the Project Viewer, expand Data Sources.
b. Click the data source for the application.
c. Update the data source as described in the following table.

Database Fields

SQL Server v Catalog: Enter the name of the IBM EMM application database.

v Schema: Enter the name of the IBM EMM application database
schema. For example, dbo

Oracle v Schema: Enter the name of the IBM EMM application database
schema.

DB2 v Schema: Enter the name of the IBM EMM application database
schema.

4. Save and republish the package.
If you need basic instructions on publishing a package in IBM Cognos, see the
Cognos Framework Manager User Guide.

Step: Enable internal links in the reports
The IBM EMM application reports have standard links. To enable these links to
work properly, you must configure the Cognos firewall as described in “Step:
Configure the IBM Cognos application's firewall” on page 16, and you must
configure the redirect URL in the Cognos data model (the .cpf file) for the IBM
EMM application reports, as follows.

Note: This step is not necessary for eMessage reports.
1. From Cognos Framework Manager, browse to the <productName>Model

subdirectory you copied into the Framework Manager directory structure and
select the .cpf file. For example, CampaignModel.cpf.

2. Select Parameter Maps > Environment.
3. Right click Environment and select Edit Definition.
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4. In the Redirect URL section, select the Value field. Edit the server name and
port number so they are correct for the IBM EMM system, leaving the rest of
the URL intact. By convention, the host name includes the domain name.
For example, for Campaign:
http://serverX.ABCompany.com:7001/Campaign/
redirectToSummary.do?external=true&

For example, for Marketing Operations:
http://serverX.ABCompany.com:7001/plan/callback.jsp?

5. Save the model and publish the package:
a. From the navigation tree, expand the Packages node of the model.
b. Right click the package instance and select Publish Package.

Step: Verify the data source names and publish
When you publish the model from Framework Manager to the Cognos content
store, the name specified as the data source for the reports in the model must
match the name of the data source you created in Cognos Connection. If you used
the default data source names as described in “Step: Create the IBM Cognos data
sources for the IBM EMM application databases” on page 14, the data source
names match. If they do not, you must change the name of the data source in the
model.
1. In Cognos Connection, determine the names of the data sources you created.
2. In Framework Manager, select the Open a Project option.
3. Browse to the <productName>Model subdirectory you copied into the Framework

Manager directory structure and select the .cpf file. For example,
CampaignModel.cpf.

4. Expand the Data Sources entry and examine the names of the data sources.
Verify that they match what you named them in Cognos Connection.
a. If they match, you are finished with this procedure.
b. If they do not match, select the data source instance and edit the name in

the Properties section. Save your changes.
5. Publish the package to the Cognos content store

Step: Configure Cognos reporting properties in the Marketing
Platform

There are several sets of properties for configuring reporting in IBM EMM. Some
specify parameter values for the reporting components in the Marketing Platform.
You have already set these properties, as described in “Step: Generate the view or
table creation scripts” on page 5.

Other properties specify URLs and other parameters for the IBM Cognos system.
This procedure describes how to set these Cognos properties.
1. Log in to IBM EMM as the platform_admin user or another user with the

ReportsSystem role.
2. Select Settings > Configuration > Reports > Integration > Cognos version

3. Set the value of the Enabled property to True.
4. Set the value of the Domain property to the name of the company domain on

which the IBM Cognos system is running.
For example, xyzCompany.com.
If your company uses subdomains, the value in this field should include the
company domain and the subdomain.
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5. Set the value of the Portal URL property, to the URL of the Cognos Connection
portal. Use a fully qualified host name, including the domain and any
subdomains (specified in the Domain property).
For example: http://MyCognosServer.xyzCompany.com/cognos10/cgi-bin/
cognos.cgi

You can find this URL in the Cognos Configuration utility under Local
Configuration > Environment.

6. In the Dispatch URL field, specify the URL of the primary Cognos Content
Manager dispatcher. Use a fully qualified host name, including the domain and
any subdomains (specified in the Domain property).
For example: http://MyCognosServer.xyzCompany.com:9300/p2pd/servlet/
dispatch

You can find this URL in the Cognos Configuration utility under Local
Configuration > Environment.

7. Leave Authentication mode set to anonymous for now.
8. Save the settings.

Step: Set report folder permissions
If you configured the system to use the "authenticated per user" mode, ensure that
the appropriate IBM users can run the reports from the IBM EMM applications.
The easiest way to do this is to assign the default ReportsUser role to the
appropriate user groups or users, as described in “Configuring report folder
permissions.”

Configuring report folder permissions
In addition to controlling access to the Analytics menu item and the Analysis tabs
for object types (campaigns and offers, for example), you can configure
permissions for groups of reports based on the folder structure in which they are
physically stored on the IBM Cognos system.

Before you run Sync Report Folder Permissions, you must ensure that the
following conditions exist:
v Reporting is be enabled after configuration.
v The Cognos server where reports are configured is up and running.
1. Log in as a Campaign administrator who has the ReportSystem role.
2. Select Settings > Sync Report Folder Permissions.

The system retrieves the names the folders located on the IBM Cognos system,
for all partitions. (This means that if you decide to configure folder
permissions for any partition, you must configure it for all of them.)

3. Select Settings > User Roles & Permissions > Campaign.
4. Under the Campaign node, select the first partition.
5. Select Add Roles and Assign Permissions.
6. Select Save and Edit Permissions.
7. On the Permissions form, expand Reports.

The Reports entry does not exist until after you run the Sync Report Folder
Permissions option for the first time.

8. Grant permission for Performance Reports to the appropriate role.
9. Configure the access settings for the report folders appropriately and then

save your changes.
10. Repeat steps 4 through 8 for each partition.
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Step: Test your configuration without authentication enabled
After the reports are installed and configured but before you enable authentication,
test the setup by running some reports.
1. Verify that IBM EMM is running and that the IBM Cognos BI service is

running.
2. Log in to IBM EMM as a user with application access and create some data.

(Otherwise the reports have nothing to show.)
3. Open Cognos Connection.
4. Navigate to the report folders you imported and click the link to a basic report.

For example, for Campaign, select Public Folders > Campaign > Campaign >
Campaign Summary.
If the report fails, verify that you configured the Cognos data source for the
IBM EMM application database correctly. See “Step: Create the IBM Cognos
data sources for the IBM EMM application databases” on page 14.

5. Click a link in the report.
If the internal links from the reports do not work, the redirect URL is not
configured correctly. See “Step: Enable internal links in the reports” on page 17.

6. Log in to the IBM EMM application as a user with application access and
navigate to the Analysis page.
When you specify the URL for the IBM EMM application, be sure to use a fully
qualified host name with your company domain (and subdomain, if
appropriate). For example:
http://serverX.ABCompany.com:7001/unica

7. Click the link to the same report that you tested in Cognos.
If you cannot view the report, it is likely that the IBM Cognos firewall isn't
configured correctly. See “Step: Configure the IBM Cognos application's
firewall” on page 16.

8. Click a link in the report.
If the internal links from the reports do not work, the redirect URL is not
configured correctly. See “Step: Enable internal links in the reports” on page 17.

9. Open an individual item, click the Analysis tab, and verify that the report is
correct.

Configure IBM Cognos to use IBM EMM authentication
The IBM EMM Authentication Provider enables the Cognos applications to use
IBM EMM authentication to communicate with the IBM EMM system as though it
were another IBM EMM application in the suite.

Before you begin the procedures in this section, be sure that you know which
authentication mode you plan to configure ("authenticated" or "authenticated per
user). If you need more information, see “Step: Determine which authentication
mode to configure.”

Step: Determine which authentication mode to configure
The IBM EMMAuthentication Provider is one of the components that integrates the
IBM Cognos Business Intelligence system with IBM EMM. This component enables
the IBM Cognos BI applications to use IBM authentication to communicate with
the IBM EMM system as though it were another IBM EMMapplication in the suite.

There are three authentication options: anonymous, authenticated, and
authenticated per user.
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v Anonymous means authentication is disabled. You use this mode to test your
configuration without the added complication of authentication settings.

v Authenticated means that the communications between the IBM EMM system
and the IBM Cognos system are secured at the machine level. You configure a
single system user and configure it with the appropriate access rights. By
convention, this user is named "cognos_admin."

v Authenticated per user means that the system evaluates individual user
credentials.

Determine which authentication mode you need to configure. For a complete
description of these options, see “About reporting and security” on page 46.

Step: Create the reporting system user, if necessary

Note: If you are setting the authentication mode to "authenticated per user" skip
this procedure and continue to “Step: Configure the Cognos authentication
properties in IBM EMM.”

When you create the reports system user, you create the user and add data source
credentials to the user that holds login information for IBM Cognos BI. In this way,
you configure two sets of logins for the same user:
v One for the IBM system: the user name and password specified for the reports

system user (cognos_admin)
v One for IBM Cognos BI: the user name and password specified as data source

credentials for the reports system user
1. Log in to IBM EMM as the platform_admin user.
2. Select Settings > Users.
3. Create an IBM user with the following attributes:

a. User name: cognos_admin
b. Password: admin

4. Create a new data source for the user with the following attributes:
a. Data Source: Cognos
b. Data Source Logon: cognos_admin

Ensure that the user name in the data source exactly matches the user name
of the IBM user you created in step 3.

c. Data Source Password: admin
5. Add the Reports System role to the user.
6. If IBM EMM is configured to expire user passwords, log out and then log back

in as the reporting system user (cognos_admin). This step ensures that you
interact with the IBM security "change password" challenge and reset the
password before you log in to IBM Cognos as this user in a later task.

Step: Configure the Cognos authentication properties in IBM
EMM
1. Log in to IBM EMM as the platform_admin user.
2. Select Settings > Configuration.
3. Expand Reports > Integrations > Cognos version .
4. Set the value of the Authentication Mode property by selecting either

authenticated or authenticatedPerUser, as appropriate for your system.
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5. For "authenticated" only. Verify that the values in the Authentication user
name and Authentication datasource name fields match those of the user and
data source you created in the previous task, “Step: Create the reporting system
user, if necessary” on page 21.

6. Set the value of the Enable form authentication property.
This setting indicates that IBM EMM security uses form-based authentication in
place of cookies. You set this property to True when either of the following is
true.
v When the IBM EMM is not installed in the same network domain as the

Cognos applications.
v When Cognos is accessed using an IP address (within the same network

domain) instead of the Fully Qualified Hostname (which is being used to
access the IBM EMM applications), even if both the IBM EMM applications
and the Cognos installation are on the same machine.

However, when the value is True, the login process to Cognos Connection
passes the login name and password in clear text and therefore is not secure
unless Cognos and the IBM EMM are configured to use SSL communication.
Even with SSL configured, the user name and password appear as clear text in
the HTML source code when you "view source" in a displayed report. For this
reason, you should install Cognos and IBM EMM in the same network domain.
Note that when the Enable form authentication property is set to True, the
Authentication mode property automatically behaves as though it were set to
authenticated, and you must perform the step required for this mode,
described in “Step: Create the reporting system user, if necessary” on page 21.

7. Save the new settings.
8. For "authenticatedPeruser" only. Assign the ReportUser role to the default

asm_admin user. You perform this step so that you can test reports: you need a
user with access to both the IBM EMM application and report data. The
platform_admin user does not have access to the IBM EMM application
features.

Step: Configure IBM Cognos to use the IBM EMM Authentication
Provider
In this task, you use the Cognos Configuration and Cognos Connection
applications to configure the IBM Cognos BI applications to use the IBM EMM
Authentication Provider.
1. On the machine running the Cognos Content Manager, open Cognos

Configuration
2. Select Local Configuration > Security > Authentication.
3. Right-click Authentication and select New resource > Namespace.
4. Complete the fields as follows, and then click OK:

a. Name: Unica
b. Type: Custom Java Provider.

5. On the Resource Properties page, complete the fields as follows and then save
your changes:
a. NamespaceID: Unica
b. Java class name:

com.unica.report.adapter.UnicaAuthenticationProvider

6. Stop and restart the IBM Cognos BI service.
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On a Windows system, sometimes the Cognos interface indicates that the
service is stopped when it is not. To ensure that the service has really stopped,
use the Windows Administrative tools to stop the service.

7. Under Local Configuration > Security > Authentication, right-click Unica
and select Test.
If Cognos Connection displays an error, examine the cogserver.log file,
located in the logs directory of your Cognos installation to determine the
problem.

8. Log in to Cognos Connection as follows to verify that the IBM EMM
Authentication provider is configured correctly:
v If you set the Cognos authentication mode in the IBM EMM configuration

properties to authenticated, log in as the cognos_admin (report system)
user.

v If you set the authentication mode in the IBM EMM configuration
properties to authenticatedPerUser, log in as the asm_admin user.

If IBM Cognos displays the error "The 3rd party provider returned an
unrecoverable exception," expand the error message. If it states "invalid
credentials," you made an error entering your user credentials. Try again.
However, if it states "password expired," IBM EMM expired the password.
Log in to IBM EMM application as the reporting system user and reset the
password. Then try logging in to Cognos Connection again.
If you still cannot log in to Cognos Connection, examine the cogserver.log
file, located in the logs directory of your Cognos installation, to determine the
problem.

9. When you can successfully log in to Cognos Connection, open Cognos
Configuration again.

10. Select Local Configuration > Security > Authentication > Cognos.
11. Disable anonymous access to IBM Cognos BI by setting Allow anonymous

access? to false.
12. Save your changes.
13. Stop and restart the IBM Cognos service.

If the IBM Cognos service cannot communicate successfully with the
authentication provider, it cannot start. If the IBM Cognos service fails to start,
verify your configuration by retracing the steps in this procedure.

14. Distributed systems only. If your IBM Cognos system has backup Content
Managers configured for failover support, repeat this procedure on all the
servers with Content Manager installed.

At this point, anyone logging in to an application on the Cognos system must be
authenticated by IBM EMM. Additionally, the authentication namespace Unica
now appears in the IBM Cognos user interface for logon and security
administration tasks.

Configuration required when the IBM Marketing Platform is
integrated with an LDAP server or a web access control system
When the IBM Marketing Platform is integrated with an LDAP server, Windows
Active Directory (Windows Integrated Login), or a web access control system such
as Tivoli® or SiteMinder, you must perform the following additional configurations.
1. In Cognos Configuration, set the flag Selectable for authentication to false for

the Unica® authentication namespace.
When you set this flag to false, Cognos Connection and Cognos Administration
cannot access the Unica namespace for the purpose of authentication. However,
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IBM EMM applications can still access the Unica namespace via the Cognos
SDK API (for example, when users view Cognos reports from within IBM
EMM applications).

2. If you need authenticated access to the Cognos URL, do the following.
a. In Cognos Configuration, configure a namespace using the appropriate

bundled authentication provider.
b. Set Selectable for authentication to true.
c. Use this new namespace for the Cognos URL.

Step: Test your configuration with authentication configured
After configuring IBM Cognos to use IBM authentication, test the system again.
1. Verify that IBM EMM is running and that the IBM Cognos service is running.
2. Open Cognos Connection.
3. Navigate to the report folders you imported and click the link to a basic report.

For example, for Campaign, select Public Folders > Campaign > Campaign >
Campaign Summary.
If the report fails, verify that you configured the IBM Cognos data source for
the IBM application database correctly. See “Step: Create the IBM Cognos data
sources for the IBM EMM application databases” on page 14.

4. Click a link in the report.
If the internal links from the reports do not work, the redirect URL is not
configured correctly. See “Step: Enable internal links in the reports” on page 17.

5. Log in to IBM EMM and navigate to the Analysis page.
When you specify the URL for the IBM application, be sure to use a fully
qualified host name with your company domain (and subdomain, if
appropriate). For example:
http://serverX.ABCompany.com:7001/unica

6. Click the link to the same report that you tested in IBM Cognos.
If you see error messages about security, it is likely that the IBM Authentication
Provider is not configured correctly. See “Configure IBM Cognos to use IBM
EMM authentication” on page 20.
If you are prompted to enter credentials for authentication, it is likely that the
domain name is missing from one of your URLs. Log in to IBM EMM as a user
with admin privileges. Then select Settings > Configuration and ensure that
the URLs in the following properties include the domain name and any
appropriate subdomain name.
v Reports > Integration > Cognos > Portal URL and Dispatch URL

v Any URL properties for the IBM applications, for example: Campaign >
navigation > serverURL

7. Click a link in the report.
If you are prompted to enter credentials for authentication, it is likely that the
domain name is missing from one of the URLs.

8. Open an individual item, click the Analysis tab, and verify that the report is
correct.
If you see error messages about security, it is likely that the IBM Application
Provider is not configured correctly.
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Next steps for reporting
At this point, reporting is working properly and the example reports are in their
default state. When you finish configuring the actual data design of your IBM
EMM applications - things like campaign codes, custom campaign attributes,
response metrics, and so on - you will return to reporting because you may need
to customize the reports or reporting schemas.
v If you are using Campaign or Interact, see the "Configuring reporting" chapter in

the this guide.
v If you are using Marketing Operations, see the "Using Reports" chapter in the

IBM Marketing Operations Administrator's Guide.
v If you are setting up reporting for eMessage, you are done configuring

reporting.
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Chapter 2. Upgrading reports

In IBM EMM, reporting is one of the components provided by the Marketing
Platform.

When you upgrade, the installer and database scripts also upgrade the reporting
feature, retaining the configuration settings for the Campaign and Interact
reporting schemas. This chapter describes how to upgrade and configure the other
reporting components.

Upgrade scenarios

Source version Upgrade path

Pre-7.5.1 If you are upgrading an IBM EMM application from a pre-7.5.1
version, there is no upgrade path for reporting. Instead, see Chapter 1,
“Installing reports,” on page 1.

7.5.1 If you are upgrading an IBM EMM application from the 7.5.1 version,
perform the following steps.

v “Initial steps for upgrading reports, all supported versions, all
products”

v “Upgrading reports from version 7.5.1” on page 31

Note: Because there is no upgrade path for eMessage from version
7.5.x to versions 8.x and later, there is also no upgrade path for the
eMessage reports.

8.x If you are upgrading an IBM EMM application from an 8.x version,
perform the steps described in:

v “Initial steps for upgrading reports, all supported versions, all
products”

v “Upgrading reports from version 8.x” on page 41

Initial steps for upgrading reports, all supported versions, all products
To begin upgrading reports, complete the preparatory tasks in this section. Perform
these steps regardless of the product or the version from which you are upgrading.

Step: Verify that a user with the ReportsSystem role exists
If you are upgrading from version 7.x you must configure an IBM EMM user with
appropriate permissions to work with reporting. If you are upgrading from 8.x,
this user probably exists already.

If you do need to configure this reporting user, see “Step: Set up a user with the
ReportsSystem role, if necessary” on page 3 for instructions.

Step: Upgrade IBM Cognos BI, if necessary
If necessary, upgrade your version of IBM Cognos BI to the version supported for
the report packs you are installing.

For help with this task, see the IBM Cognos BI documentation.
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After you upgrade Cognos, perform the Cognos configuration tasks described in
the installation chapter of this guide.

Step: Back up the Cognos model and report archive
On the IBM Cognos BI system, complete the following tasks:
v Make a back up copy of the model subdirectory. That is, locate the application

model installed by the IBM EMM reports package installers, and copy the entire
model subdirectory to create a backup.

v Use the export deployment specification feature in Cognos Connection to create
a backup of the application's reports archive. Export the entire content store.

v Delete the old models and folders from the Cognos user interface. Do not delete
them from the file directory structure or from Cognos Framework Manager..

Step: Generate the SQL to drop tables and run the SQL in
product databases

In this step, you use the Report SQL Generator to generate drop table SQL
commands and run them against the appropriate product system table database.
You do this before you upgrade the reporting schemas because you want to
generate and run the old SQL drop statements.
1. Log in to IBM EMM as the platform_admin user (or another user with access

to the Report SQL Generator menu item).
2. Only if you did not use the default JNDI names for the JDBC data sources

you created in an earlier step, do the following.
a. Select Settings | Configuration | Reports | Schemas | ProductName .
b. Change the default values of the JNDI property to match the JNDI names

you gave the JDBC connections in an earlier step.
3. Select Settings | Reports SQL Generator.
4. In the Product field, select the appropriate IBM application.
5. In the Schema field, select one or more reporting schemas.
6. Select the Database Type.
7. In the Generate Type field, select the appropriate option (views, materialized

views, or tables).
Materialized views are not an option when Database Type is set to MS SQL
Server.
If the JNDI data source names are incorrect or have not been configured, the
SQL Generator cannot validate the SQL.scripts that create tables.

8. Ensure that Generate Drop Statement is set to Yes.
9. (Optional.) To examine the SQL that will be generated, click Generate. The

SQL Generator creates the script and displays it in the browser window.
10. Click Download.

The SQL Generator creates the script and prompts you to specify where you
want to save the file. If you selected a single reporting schema from the
Schema field, the script name matches the name of schema
(eMessage_Mailing_Performance.sql, for example). If you selected more than
one reporting schema, the script name uses the product name only
(Campaign.sql, for example). For a complete list of names, see “SQL scripts by
data source” on page 7.

11. Specify the location where you want to save the script. If you change the
name of the file, be sure to use something that clearly indicates which
schemas you selected. Then click Save.
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12. Repeat steps 5 through 12 for each drop table script you need to generate.

Note: The Interact reporting schemas reference more than one data source.
Generate a separate SQL script for each data source.
There may be times when you want to disable script validation. For example,
perhaps the Marketing Platform cannot connect to the IBM application
database but you want to generate the scripts anyway. To disable validation,
clear the data source names from the data source fields (see step 3, above).
When you generate the scripts, the SQL Generator displays a warning that it
cannot connect to the data source, but it still generates the SQL script.

13. Run the drop table SQL in your product system table database. Repeat for
each product for which you are upgrading reports.

Step: Upgrade the reporting schemas on the Marketing
Platform

You must run the IBM EMM master installer with the reports packs installers to
upgrade the reporting schemas and reports integration configuration properties.

To perform this portion of the upgrade, run the IBM EMM master installer with
the appropriate report package installer on the machine where the Marketing
Platform is installed, and select the IBM EMM Product Reporting Schemas
installation option.

How to verify that the upgrade has been performed

To verify whether the upgrade has been performed, take the following steps.
1. Log in to the IBM EMM system as the platform_admin user.
2. Select Settings > Configuration.
3. Expand Reports > Schemas > ProductName .

If the schema configuration categories for your application were not upgraded,
you have not yet upgraded reports on the Marketing Platform.

Note: If you are upgrading Marketing Operations, skip this step (Marketing
Operations does not have reporting schemas).

4. Expand Reports > Integrations.
If the schema configuration categories were upgraded, and if your current
reports installation is pre 8.6.0, you will see a new category for Cognos 10
configuration. Your Cognos 8 category is disabled, but it is retained for
reference purposes, to assist you in setting the configuration properties for
Cognos 10. After you have fully configured and tested your reporting upgrade,
you should use the Delete Category link to remove the Cognos 8 configuration
category.

Step: Upgrade the reporting templates in the Marketing
Platform

Note: If you are upgrading Marketing Operations, skip this step: Marketing
Operations does not have reporting schemas.

After you have run the report pack installer, complete the following steps.
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1. Navigate to the Unica\productReportsPack\schema directory, locate the
templates_sql_load.sql script and run the script in the Marketing Platform
system tables database.

2. Ensure that the Marketing Platform is running.
3. Log in to IBM EMM as a user with administrator privileges.
4. Under Settings > Users, give yourself the ReportsSystem role. Then log out

and log back in.
5. Campaign only.

The database schema for adding new campaign attributes changed in
Campaign 8.0.0. Therefore, if the reporting schema customizations included
additional campaign attributes, do the following.
a. Use your database management tools to determine the value from each

attribute's AttributeID column in the UA_CampAttribute table.
b. In IBM EMM, select Settings > Configuration and expand Reports >

Schemas > Campaign > Campaign Custom Attributes > Columns >
Campaign.

c. Delete the existing custom campaign attributes that were added for this
installation, but do not delete the standard custom campaign attributes. (The
standard custom campaign attributes were upgraded by the installer.)

d. Re-create the attributes you deleted. Enter the ID of the attribute in the
Attribute ID field.

Step: Update lookup tables (eMessage and Interact only)
In this step, you use your database client to run some upgrade scripts against the
system table database.
1. eMessage only.

v In the ReportsPackCampaign\tools directory under your reports pack
installation, locate the uare_lookup_create_DB_type.sql script, where
DB_type is the database type appropriate for your installation of Campaign.

v If you are upgrading from an 8.x version of eMessage, edit this script to
remove the drop table statements. This is required because the tables do not
exist in the 8.x version.

v Run the appropriate version of the script against your Campaign system
tables database.

2. Interact only.

v In the ReportsPackInteract\tools directory under your reports pack
installation, locate the uari_lookup_create_DB_type.sql script, where
DB_type is the database type appropriate for your installation of Campaign.

v Run the appropriate version of the script against your Interact design time
database.

Step: Generate new SQL and upgrade and the views or tables
in the product databases

1. Generate updated SQL, as described in “Step: Generate the view or table
creation scripts” on page 5.

2. Run the SQL scripts you generated earlier against the product system table
databases..

3. For Campaign, eMessage, and Interact, create reporting views or tables using
the new SQL and the SQL scripts provided with your reports packs, as
described in “Step: Create the reporting views or tables” on page 6.
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Step: Run the installers on the Cognos Content Manager
machine and upgrade the IBM EMM integration components

If yours is a distributed Cognos installation, determine which machine is running
the Cognos Content manager.
1. On the IBM Cognos BI system that runs the Cognos Content Manager,

download or copy the following IBM EMM installers to a single directory:
v IBM EMM master installer
v Marketing Platform installer
v IBM EMM application report package installers

2. Run the IBM EMM master installer. (It will launch the sub-installers for the
Marketing Platform and the report packages in order.)

3. In the first Products window, ensure that both the Marketing Platform and the
report package options are selected.

4. In the Platform Database Connection window, provide the necessary
information for connecting to the Marketing Platform system tables.

5. When the Platform Installation Components window appears, select the
Reports for IBM Cognos option and clear the other options

6. When the Marketing Platform installer prompts for the path to the JDBC driver,
enter the fully qualified path for the JDBC driver you copied to the Cognos
system during the initial install of reporting.
See “Step: Obtain the JDBC driver for the Marketing Platform system tables” on
page 13 for more information.

7. When the Marketing Platform installer prompts for the location of the IBM
Cognos installation, enter or browse to the top level of the IBM Cognos
installation directory.
The default value provided in this field is a static value that is not based on the
actual file structure of your IBM Cognos system.

8. When the report package installer takes over and displays its installation
options, select the IBM Cognos package for IBM EMM [product] option and
clear the option for the reporting schemas. This installation option copies the
reports archive to the Cognos machine. You import this archive manually later.

9. When the installers are finished, copy the JDBC driver for the Marketing
Platform database to the IBM Cognos webapps\p2pd\WEB-INF\AAA\lib directory.
Be sure to copy the driver. Do not cut and paste the driver.

Upgrading reports from version 7.5.1
After you have performed the steps described in “Initial steps for upgrading
reports, all supported versions, all products” on page 27, follow the steps in this
section if you are upgrading an IBM EMM application from version 7.5.1.

About upgrading from version 7.5.1

IBM EMM reporting is no longer provided in a separate web application as it was
in Affinium Reports 7.5.x.

When you install the IBM Cognos reports archive from the reports package, you
run an upgrade script that preserves your customizations to the Cognos data
model, but you must replace the 7.5.1 reports with the new reports. Although the
majority of the older reports are compatible with the upgraded Cognos models, the
new reports packages include new and enhanced reports, and most of the
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packages also contain Dashboard reports. The only way to obtain the new or
enhanced reports is to install the new reports archive, which overwrites the
existing reports.

Therefore, you have two options for upgrading your reports.
v Back up the old reports, install the new reports, and then recreate your

customizations using the old reports for reference.
v Back up the old reports and install the new reports. Compare the new reports to

your old reports and examine your customizations. If you are certain that a
customized report will function properly with the new data model, copy the old
customized report back into the reports folder.

Note that the 7.5.1 version of the Campaign Performance by Cell reports and the
Offer Performance Summary by Campaign reports do not function at all without
manual intervention. Additionally, the new versions of many of the old reports
include enhancements and minor bug fixes. This chapter includes procedures that
describe how to manually fix the old Campaign Performance by Cell reports and
the Offer Performance Summary by Campaign reports so they function with the
new model. This chapter does not describe how to manually apply the
enhancements or minor fixes to the other 7.5.1 reports. To obtain those changes,
you must use the new versions of the reports.

Step: Upgrade the 7.5.1 model and install the new reports
The new report packages include new and changed reports as well as dashboard
reports for most of the IBM EMM applications. Although the model can be
upgraded, your 7.5.1 reports cannot. Instead you must install the new reports and
then either recreate the reporting customizations you made to the 7.5.1 versions or
copy the old reports back into the folder.
1. Verify that you backed up the model and the old reports.
2. Navigate to the ProductNameReportsPack\CognosN directory under your IBM

EMM product installation.
The N in the path refers to the Cognos version number.

3. Copy the reports archive .zip file (for example Unica Reports for
Campaign.zip) to the directory where your Cognos deployment archives are
saved.
The default location is the deployment directory under your IBM EMM
Cognos installation and it is specified in the Cognos Configuration tool
installed with the Cognos Content Manager.
For example: cognosN\deployment.
The N in the path refers to the Cognos version number.
In a distributed IBM Cognos environment, this is a location on the system
running the Content Manager.

4. If the Reports Pack installation directory and Framework Manager are on
different machines, locate the cognosN\model directory under the Reports Pack
installation directory, and copy it to the directory on the machine where your
Framework Manager is installed.
The N in the path refers to the Cognos version number.

5. Only if you did not install your IBM EMM product to the default directory
(C:\Unica on Windows) you must update some upgrade scripts as described
in this step.
You must update the scripts listed here. The scripts you must update differ,
depending on the reports package, as shown below.
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The scripts are all located in the ProductNameReportsPack\cognosN\
ProductNameModel directory under your IBM EMM product installation.
The N in the path refers to the Cognos version number.
Campaign

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

eMessage

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade86to90.xml

Interact

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

Leads

v upgrade81to85.xml

v upgrade86to90.xml

Campaign with Marketing Operations

v upgrade80to81.xml

v upgrade82to85.xml

v upgrade86to90.xml

Marketing Operations

v upgrade80to81.xml

v upgrade82to85.xml

v upgrade85to86.xml

v upgrade86to90_DB2.xml (for DB2 database only)
v upgrade86to90_Oracle.xml (for Oracle database only)
v upgrade86to90_Sqlserver.xml (for SQLServer database only)
In each script, edit file paths that point to directories where localized language
versions of the models are stored to reflect your product install location. Make
this change for every language your users need. For example:
install_directory \ReportsPackCampaign\cognosN\CampaignModel\
translations\L\translations.txt

The N in the path refers to the Cognos version number.
The L in the path refers to one of the following language indicators.
v fr
v de
v es
v it
v ja
v ko
v pt
v ru
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v zh
6. Open Cognos Connection.
7. Select Administer Cognos Content > Configuration > Content

Administration.

8. Click the New Import button on the toolbar and import the reports
folder.

9. Open Cognos Framework Manager and select the project that corresponds to
your old reports.

10. Select Project > Run Script.
11. Run the following scripts from your new version against your old reports.

You must run the scripts listed here. The scripts you must run differ,
depending on the reports package, as shown below.
The scripts are all located in the ProductNameReportsPack\cognosN\
ProductNameModel directory under your IBM EMM product installation.
The N in the path refers to the Cognos version number.
Campaign

v preUpgrade_86_fromanyversion.xml

v upgrade75to751.xml

v upgrade751to80.xml

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

eMessage

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade86to90.xml

Interact

v preUpgrade_86_fromanyversion.xml

v upgrade75to751.xml

v upgrade751to80.xml

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

Leads

v upgrade75to80.xml

v upgrade81to85.xml

v upgrade86to90.xml

Campaign with Marketing Operations

v upgrade80to81.xml

v upgrade81to82.xml

v upgrade82to85.xml

v upgrade86to90.xml

Marketing Operations
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v upgrade75to80.xml

v upgrade80to81.xml

v upgrade81to82.xml

v upgrade82to85.xml

v upgrade85to86.xml

v upgrade86to90_DB2.xml (for DB2 database only)
v upgrade86to90_Oracle.xml (for Oracle database only)
v upgrade86to90_Sqlserver.xml (for SQLServer database only)

12. Publish the package to the Cognos content store.
13. Run a report to ensure that it works properly.
14. If the 7.5.1 reports were customized, recreate those customizations.

Alternately, if you can ensure that an old report will work properly with the
upgraded model, copy the old report back.
For information about fixing the old Campaign Performance by Cell reports
and the old Offer Performance Summary by Campaign reports so they work
with the new data model, continue with the remaining procedures in this
section.

15. If you have reports installed for multiple partitions, configure reports
packages for the additional partitions using the instructions in the chapter that
describes how to configure multiple partitions.

16. Optional. See “Configure IBM Cognos to use IBM EMM authentication” on
page 20 for information about the new authentication mode, "authenticate per
user."

Step: Updating the old Campaign Performance by Cell reports
After you upgrade the Campaign model from 7.5.1 to 8.x, the old Campaign
Performance by Cell reports do not function properly. If you want to use your old
Campaign Performance by Cell reports rather than the new ones, you must
manually update them yourself.

How to fix the cross-object Performance by Cell reports
Use this procedure to fix the old versions of the following cross-object reports so
they function with the new data model.
v Campaign Performance Summary by Cell
v Campaign Performance Summary by Cell (with Revenue)
v Campaign Performance Summary by Cell by Initiative

Complete the following steps.
1. Open the report in IBM Cognos Report Studio.
2. Click the lock icon on the toolbar to unlock the report.
3. Browse to the Query Explorer and open the Report Query for a list of all the

query items in the report.
4. For all three reports, remap the following query items as follows:

Query item Mapping

Number of Offers Given [Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Number of Offers Given]

Response Transactions [Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Response Transactions]
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Query item Mapping

Unique Recipients [Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Unique Recipients]

Unique Responders [Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Unique Responders]

Unique Recipients Control
Group

[Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Unique Recipients Control Group]

Unique Responders
Control Group

[Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Unique Responders Control Group]

5. For the report with revenue, remap for the Gross Revenue item as follows:
[Campaign Performance Summary].[Campaign Cell RH with Controls
Summary].[Gross Revenue]

6. Update the formula for the Responder Rate Control Group to be the
following:
IF(([Unique Responders Control Group]/([Unique Recipients Control Group]

* 1.00)) is missing)
THEN (0)
ELSE(([Unique Responders Control Group]/([Unique Recipients Control Group]

* 1.00)))

7. From the Detail Filter list, select the first detail filter and edit it so it looks
like this:
[Campaign Performance Summary] . [Campaign] . [Campaign ID] in
(?CampaignIds?)

8. From the Detail Filter list, delete the second detail filter – the one that looks
like this:
[Campaign Performance Summary].[Responder Rate Control Group at Cell
Level].[Campaign ID] in (?CampaignIds?)

9. Lock the report.
10. Do the following in Report Studio for each report.

a. Go to File > Report Package.
b. Select Unica Campaign Package and click OK.
c. Fill in prompts on the report as necessary.
d. After the report is validated, click Close in the Validation Response

window.
11. Save and run the report.

How to fix the object-specific Performance by Cell reports
Use this procedure to fix the old versions of the following object specific reports to
function with the new data model.
v Campaign Performance Summary by Cell
v Campaign Performance Summary by Cell (with Revenue)

Complete the following steps.
1. Open the report in IBM Cognos Report Studio.
2. Click the lock icon on the toolbar to unlock the report.
3. Browse to the Query Explorer and open the Report Query for a list of all the

query items in the report.
4. For both reports, remap the following query items as follows:
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Query item Mapping

Number of Offers Given [Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Number of Offers Given]

Response Transactions [Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Response Transactions

Unique Recipients [Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Unique Recipients]

Unique Responders [Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Unique Responders]

Unique Recipients Control
Group

[Campaign Performance Summary].[Campaign Cell CH with
Controls Summary].[Unique Recipients Control Group]

Unique Responders
Control Group

[Campaign Performance Summary].[Campaign Cell RH with
Controls Summary].[Unique Responders Control Group]

5. For the report with revenue, remap the Gross Revenue query item as follows:
[Campaign Performance Summary].[Campaign Cell RH with Controls
Summary].[Gross Revenue]

6. Update the formula for the Responder Rate Control Group to be the
following:
IF(([Unique Responders Control Group]/([Unique Recipients Control Group]
* 1.00)) is missing)
THEN (0)
ELSE(([Unique Responders Control Group]/([Unique Recipients Control Group]
* 1.00)))

7. From the Detail Filter list, select the first detail filter and edit it so it looks
like this:
[Campaign Performance Summary].[Campaign].[Campaign ID] in
(?CampaignIds?)

8. Delete the second detail filter – the one that looks like this:
[Campaign Performance Summary].[Responder Rate Control Group at Cell
Level].[Campaign ID] in (?CampaignIds?)

9. Lock the report.
10. Do the following in Report Studio for each report.

a. Go to File > Report Package.
b. Select Unica Campaign Package and click OK.
c. Fill in prompts on the report as necessary.
d. After the report is validated, click Close in the Validation Response

window.
11. Save and run the report.

Step: Updating the old Offer Performance Summary by
Campaign reports

After upgrading the Campaign model from 7.5.1 to 8.x, the old Offer Performance
Summary by Campaign reports do not function properly. If you want to use your
old Offer Performance Summary by Campaign reports rather than the new ones,
you must update them manually.

How to fix the Offer Performance Summary by Campaign
cross-object report
Use this procedure to fix the old version of the cross-object Offer Performance
Summary by Campaign report so it functions with the new data model.

Chapter 2. Upgrading reports 37



1. Open the report in IBM Cognos Report Studio.
2. Browse to the Query Explorer and open the Report Query for a list of all the

query items in the report.
3. Configure the aggregation as follows for the following Campaign Level

Counts query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Number of Offers Given None Automatic

Response Transactions None Automatic

Unique Recipients None Automatic

Unique Responders None Automatic

Not Contacted Responders None Automatic

Responses after Expiration None Automatic

Unique Recipients Control Group None Automatic

Unique Responders Control Group None Automatic

4. Configure the aggregation as follows for the following Campaign Level
Counts query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Response Rate Automatic Automatic

Responder Rate Automatic Automatic

Responder Rate Control Group Automatic Automatic

Best Offer Lift Over This Automatic Automatic

Lift Over Worst Offer Automatic Automatic

Lift Over Control Group Automatic Automatic

5. Configure the aggregation as follows for the following Offer Level Counts
query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Number of Offers Given-Offer None Automatic

Unique Responders-Offer None Automatic

Not Contacted Responders-Offer None Automatic

Responses after Expiration-Offer None Automatic

Unique Responders Control Group-Offer None Automatic

6. Change the expression for the Response Transactions-Offer query item to be
the following.
[Offer Performance Summary].[Offer Response History Summary].
[Response Transactions] / count([Campaign Name] for [Offer ID])

7. Configure the aggregation as follows for the following Offer Level Counts
query items.
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Query item
Aggregate
Function

Rollup Aggregate
Function

Response Transactions - Offer Total Automatic

Unique Recipients - Offer Total Automatic

Unique Recipients Control Group - Offer Total Automatic

8. Configure the aggregation as follows for the following Offer Level Counts
query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Response Rate - Offer Automatic Automatic

Responder Rate - Offer Automatic Automatic

Responder Rate Control Group - Offer Automatic Automatic

Lift Over Control Group - Offer Automatic Automatic

9. For the Report Total level counts, change the expression for Total Response
Transactions to be the following.
total ([Response Transactions-Offer])

10. Also for Total Response Transactions, confirm that Aggregate Function is set
to Automatic and that Rollup Aggregate Function is set to Automatic.

11. Lock the report.
12. Do the following in Report Studio for each report.

a. Go to File > Report Package.
b. Select Unica Campaign Package and click OK.
c. Fill in prompts on the report as necessary.
d. After the report is validated, click Close in the Validation Response

window.
13. Save and run the report.

How to fix the single object Offer Performance Summary by
Campaign report
Use this procedure to fix the old version of the single object Offer Performance
Summary by Campaign report so it functions with the new data model.
1. Open the report in IBM Cognos Report Studio.
2. Browse to the Query Explorer and open the Report Query for a list of all the

query items in the report.
3. Configure the aggregation as follows for the following Campaign Level

Counts query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Number of Offers Given None Automatic

Response Transactions None Automatic

Unique Recipients None Automatic

Unique Responders None Automatic

Not Contacted Responders None Automatic

Responses after Expiration None Automatic
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Query item
Aggregate
Function

Rollup Aggregate
Function

Unique Recipients Control Group None Automatic

Unique Responders Control Group None Automatic

4. Configure the aggregation as follows for the following Campaign Level
Counts query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Response Rate Automatic Automatic

Responder Rate Automatic Automatic

Responder Rate Control Group Automatic Automatic

Best Offer Lift Over This Automatic Automatic

Lift Over Worst Offer Automatic Automatic

Lift Over Control Group Automatic Automatic

5. Configure the aggregation as follows for the following Offer Level Counts
query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Number of Offers Given-Offer None Automatic

Unique Responders-Offer None Automatic

Not Contacted Responders-Offer None Automatic

Responses after Expiration-Offer None Automatic

Unique Responders Control Group-Offer None Automatic

6. Change the expression for the Response Transactions-Offer query item to be
the following.
[Offer Performance Summary].[Offer Response History Summary].
[Response Transactions] / count([Campaign Name] for [Offer ID])

7. Configure the aggregation as follows for the following Offer Level Counts
query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Response Transactions - Offer Total Automatic

Unique Recipients - Offer Total Automatic

Unique Recipients Control Group - Offer Total Automatic

8. Configure the aggregation as follows for the following Offer Level Counts
query items.

Query item
Aggregate
Function

Rollup Aggregate
Function

Response Rate - Offer Automatic Automatic

Responder Rate - Offer Automatic Automatic

Responder Rate Control Group - Offer Automatic Automatic
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Query item
Aggregate
Function

Rollup Aggregate
Function

Lift Over Control Group - Offer Automatic Automatic

9. Lock the report.
10. Do the following in Report Studio for each report.

a. Go to File > Report Package.
b. Select Unica Campaign Package and click OK.
c. Fill in prompts on the report as necessary.
d. After the report is validated, click Close in the Validation Response

window.
11. Save and run the report.

Upgrading reports from version 8.x
After you have performed the steps described in “Initial steps for upgrading
reports, all supported versions, all products” on page 27, follow the steps in this
section if you are upgrading an IBM EMM application from version 8.x.

For eMessage reports, the only supported upgrade is from version 8.6.

Step: Upgrade the 8.x model and install the new reports
1. Navigate to the Unica\ProductNameReportsPack\CognosN directory, where N is

the version of your Cognos installation..
2. Copy the reports archive .zip file (for example Unica Reports for

Campaign.zip) to the directory where your Cognos deployment archives are
saved.
The default location is the deployment directory under your IBM Cognos
installation and it is specified in the Cognos Configuration tool installed with
the Cognos Content Manager. For example: cognos\deployment
In a distributed IBM Cognos environment, this is a location on the system
running the Content Manager.

3. If the Reports Pack installation directory and Framework Manager are on
different machines, locate the cognos10\model directory under the Reports
Pack installation directory, and copy it to the directory on the machine where
your Framework Manager is installed.

4. Only if you did not install your IBM EMM product to the default directory
(C:\Unica on Windows), you must update some upgrade scripts as described
in this step.
You must update the scripts listed here. The scripts you must update differ,
depending on the reports package, as shown below.
Also, you should take into consideration the 8.x version from which you are
upgrading. You do not have to update the scripts that refer to earlier versions.
For example, if you are upgrading Campaign reports from version 8.5.0, you
would not have to update the upgrade80to81.xml and upgrade81to85.xml
scripts.
The scripts are all located in the ProductNameReportsPack\cognosN\
ProductNameModel directory under your IBM EMM product installation.
The N in the path refers to the Cognos version number.
Campaign
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v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

eMessage

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade86to90.xml

Interact

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

Leads

v upgrade81to85.xml

v upgrade86to90.xml

Campaign with Marketing Operations

v upgrade80to81.xml

v upgrade82to85.xml

v upgrade86to90.xml

Marketing Operations

v upgrade80to81.xml

v upgrade82to85.xml

v upgrade85to86.xml

v upgrade86to90_DB2.xml (for DB2 database only)
v upgrade86to90_Oracle.xml (for Oracle database only)
v upgrade86to90_Sqlserver.xml (for SQLServer database only)
Distributed Marketing

v upgrade86to90.xml

Upgrade is supported from version 8.6 only
Interaction History

v Upgrade to version 9.0 is not supported.
Attribution Modeler

v Upgrade to version 9.0 is not supported.
In each script, edit file paths that point to directories where localized language
versions of the models are stored to reflect your product install location. Make
this change for every language your users need. For example:
install_directory \ReportsPackCampaign\cognosN\CampaignModel\
translations\L\translations.txt

The N in the path refers to the Cognos version number.
The L in the path refers to one of the following language indicators.
v fr
v de
v es
v it
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v ja
v ko
v pt
v ru
v zh

5. Open Cognos Connection.
6. Select Administer Cognos Content > Configuration > Content

Administration.

7. Click the New Import button on the toolbar and import the reports
folder.

8. Open Cognos Framework Manager and open the project for the version from
which you are upgrading.

9. Select Project > Run Script.
10. Run the following scripts from the new version.

You must run the scripts listed here. The scripts you must run differ,
depending on the reports package, as shown below.
Also, you should take into consideration the 8.x version from which you are
upgrading, as follows.
v You do not have to run the scripts that refer to earlier versions. For

example, if you are upgrading Campaign reports from version 8.5.0, you
would not have to run the upgrade80to81.xml and upgrade81to85.xml
scripts.

v You must run the preUpgrade_86_fromanyversion.xml script for upgrades
from all versions except 8.6.

The scripts are all located in the ProductNameReportsPack\cognosN\
ProductNameModel directory under your IBM EMM product installation.
The N in the path refers to the Cognos version number.
Campaign

v preUpgrade_86_fromanyversion.xml

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

eMessage

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade86to90.xml

Interact

v preUpgrade_86_fromanyversion.xml

v upgrade80to81.xml

v upgrade81to85.xml

v upgrade85to86.xml

v upgrade86to90.xml

Leads

v upgrade81to85.xml

v upgrade86to90.xml
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Campaign with Marketing Operations

v upgrade80to81.xml

v upgrade81to82.xml

v upgrade82to85.xml

v upgrade86to90.xml

Marketing Operations

v upgrade80to81.xml

v upgrade81to82.xml

v upgrade82to85.xml

v upgrade85to86.xml

v upgrade86to90_DB2.xml (for DB2 database only)
v upgrade86to90_Oracle.xml (for Oracle database only)
v upgrade86to90_Sqlserver.xml (for SQLServer database only)
Distributed Marketing

v upgrade86to90.xml

Upgrade is supported from version 8.6 only
Interaction History

v Upgrade to version 9.0 is not supported.
Attribution Modeler

v Upgrade to version 9.0 is not supported.
11. Publish the package to the Cognos content store.
12. Do the following in Cognos Report Studio for each cross-object Performance

by Cell and object-specific Performance by Cell report.
a. Go to File > Report Package.
b. Select Unica Campaign Package and click OK.
c. Fill in prompts on the report as necessary.
d. After the report is validated, click Close in the Validation Response

window.
This is not required for Attribution Modeler or eMessage.

13. Run a report to test your upgrade.
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Chapter 3. Configuring reporting

This chapter describes each of the reporting components and provides information
about post-installation configuration. Information about installing and upgrading
reporting is provided elsewhere in this guide.

For its reporting feature, IBM EMM integrates with IBM Cognos, a third-party
business intelligence application. Reporting relies on the following components:
v An installation of IBM Cognos
v A set of IBM EMM components that integrate IBM Enterprise applications with

the IBM Cognos installation
v For several IBM EMM applications, reporting schemas that enable you to build

reporting views or tables in the IBM system tables of the application
v The example reports for the IBM EMM application, built with IBM Cognos

Report Studio

About reporting in the IBM EMM suite
When you install IBM EMM applications, each application registers itself with the
Marketing Platform. During that registration process, it adds an entry for itself to
the Analytics menu item.

After the report package for the application is configured:
v The Analytics menu item for the application provides access to its cross-object

reports.
v The single object reports then appear on the Analysis tabs of the appropriate

objects.
v The dashboard reports for the application can be enabled and used in

dashboards.

Typically, the reports packages for the IBM EMM products are installed when the
IBM EMM applications are installed. Not all of the reports packages contain
reporting schemas, but they all contain the following IBM Cognos BI components:
v A customizable IBM Cognos reporting metadata model for the IBM EMM

application reports
v Customizable IBM EMM application reports built with IBM Cognos BI Report

Studio
v Reference documentation that describes the reporting data model and the

reports

The IBM Cognos model references the reporting views (or tables) in the IBM EMM
application database, making that data available to the IBM Cognos reports that
are also delivered in IBM EMM Reports Packages.

Immediately after installation, the reports are in their default state and are to be
considered example reports. Why? Because many IBM EMM applications have a
set of objects, attributes, or metrics that can be added or customized. For example,
Campaign allows you to add response types, custom campaign attributes,
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additional audience levels, and so on. After the data design of your system is
implemented, you can revisit reporting to customize the example reports and
create new reports.

How you configure the reports after the data design phase of your implementation
depends on which IBM EMM applications are included in your IBM EMM system.
v For Campaign and Interact, you customize the reporting schemas and then

update the views or reporting tables that were created during installation. At
that point, you synchronize the Cognos data model with the newly updated
reporting views and publish the revised model to the Cognos content store. Now
the new custom attributes are available in Report Studio and you can add them
to the sample reports, or create new reports that display the attributes.

v For the IBM EMM applications that do not provide reporting schemas and for
eMessage (which provides schemas that cannot be customized), you configure
the Cognos IBM reports only.

This section describes the security model, the schemas, the data models, and the
reports.

About reporting and security
The reporting feature is controlled by the following access control mechanisms:
v Whether users can run reports from the IBM EMM interface depends on

permissions granted by the IBM EMM application access settings. Additionally,
for Campaign, eMessage, and Interact, you can grant or deny access to groups of
reports based on their folder structure on the IBM Cognos system. (This feature
is not available for the other products.)

v Whether an administrator can customize the schemas or run the Report SQL
Generator depends on permissions configured for the Marketing Platform.

v You can also configure the IBM Cognos BI system to use IBM EMM
authentication, thereby controlling access to the IBM application data from the
IBM Cognos system.

About report folder permissions
The IBM Cognos report packages that you install on the IBM Cognos system
contains the report specifications for the IBM applications, organized into folders.
For example, the folder for Interact is named "Interact Reports" and the reports
specifiations are physically located in that folder on the IBM Cognos system.

For Campaign, eMessage, and Interact, you can configure permissions for groups
of reports based on the folder structure in which they are physically stored on the
IBM Cognos system.

Synchronize with the IBM Cognos file directory

After reporting is installed, to make the IBM system aware of the report folders on
the IBM Cognos system, you run the Sync Report Folder Permissions option
located on the Settings menu in the IBM interface. This option connects to the IBM
Cognos system to determine which folders are present. It then creates an entry in
the user permissions lists for the Campaign partitions. The entry, named Reports,
appears in the permissions lists between the Logging and the System Tables
entries. When you expand it, the report folder names are listed and now represent
permissions.
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The default setting for the new permissions is "not granted." Therefore, after you
run the Sync Report Folder Permissions option, you must configure permissions
for the report folders. Otherwise, no one has access to the IBM Cognos reports
anymore.

Partitions and folder partitions

The folder synchronizing process retrieves the names of all the folders located on
the Cognos system, for all partitions. If you decide to configure report folder
permissions for any partition, you must configure permissions for all partitions.

About securing the IBM Cognos BI system
When your IBM EMM system integrates with the IBM Cognos BI system, the IBM
Cognos system provides access to the IBM EMMapplication data in two ways.
v From the IBM EMM applications: when someone requests a report from the

IBM EMM interface, the IBM EMM system contacts the IBM Cognos system
which queries the reporting views or tables and then sends the report back to
the IBM EMM interface.

v From the IBM Cognos applications: when you work with the IBM EMM
application data model in Framework Manager or the reports in Report Studio,
you connect to the database for the IBM EMM application.

In its default state, the Cognos system is unsecured, which means that anyone who
has access to the IBM Cognos applications has access to the data from the IBM
EMM application database.

IBM EMM Authentication Provider

When IBM Cognos is configured to use IBM EMM authentication, the IBM EMM
Authentication Provider installed on the IBM Cognos BI system communicates
with the security layer of the Marketing Platform to authenticate users. For access,
the user must be a valid IBM EMM user and must have a role that grants one of
the following permissions:
v report_system, which also grants access to the reporting configuration options

in the IBM EMM interface. The default role ReportsSystem grants this
permission.

v report_user, which grants access to the reports but not to the reporting
configuration options in the IBM EMM interface. The default role ReportsUser
grants this permission.

There are two authentication options: authenticated and authenticated per user.

Mode = authenticated

When the authentication mode is set to “authenticated,” the communications
between the IBM EMM system and the IBM Cognos system are secured at the
machine level.

You configure a single report system user and identify it in the reporting
configuration settings. To configure the report system user you do the following:
v Create the user and assign to it the ReportsSystem role, which grants it access

to all reporting functions.
v Store login credentials for the IBM Cognos system in a user data source.
v Name it, by convention (which is not required), cognos_admin.
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The IBM EMM Authentication Provider then authenticates users as follows.
v Each time an IBM EMM user attempts to display a report, the Marketing

Platform uses the credentials stored in the report system user record in its
communication with the Cognos system. The authentication provider verifies the
user credentials.

v When report authors log in to the IBM Cognos applications, they log in as the
report system user, cognos_admin and the authentication provider verifies the
user credentials.

Mode = authenticated per user

When the authentication mode is set to “authenticated per user,” the system does
not use a report system user. Instead, it evaluates the user credentials of each
individual user.
v Each time an IBM EMM user attempts to display a report, the Marketing

Platform includes the user credentials in its communication with the Cognos
system. The authentication provider verifies the user credentials.

v When report authors log in to the IBM Cognos applications, they log in as
themselves and the authentication provider verifies their credentials.

With this mode, all users must have either the ReportsUser or the ReportsSystem
role in order to see the reports. Typically, you assign the ReportsSystem role to one
or two administrators and assign the ReportsUser role to the user groups of the
IBM EMM users who need to see reports in the IBM EMM interface.

Authentication vs. authorization

Other than checking for a reporting permission, the authentication provider does
no authorization checking. Report authors who log in to the Cognos applications
have access to all the reports on the Cognos system, no matter how their report
folder permissions might be set on the IBM EMM system.

Reporting permissions reference
Access to the reporting configuration functions and to the reports themselves are
controlled by the following settings.

User interface item Access control

Configuration option on the Settings menu (you
configure reporting schemas on the Configuration page)

The Platform permission Access to Configuration
located under Settings > User Roles & Permissions >
Platform

Report SQL Generator and Sync Report Folder
Permissions options on the Settings menu

The Report permission report_system, located under
Settings > User Roles & Permissions > Report

The standard ReportsSystem role has this permission.

Analytics menu Application access settings that vary by product, as
follows:

v For Campaign, eMessage, and Interact, the
Administration > Access Analysis Section permission
at the campaign partition level of Settings > User
Roles & Permissions .

v For Marketing Operations and Distributed Marketing,
the Analysis permissions in the security policies.
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User interface item Access control

Analysis tabs The Analysis (or Analyze) permissions in the security
policies for the individual objects.

Data displayed by the reports When the authentication mode of the Cognos system is
"authenticated per user," users must have either the
ReportsSystem or ReportsUser role in order to see the
data in a report.

About reporting schemas
To implement reporting for Campaign, Interact, and eMessage, you start by
creating reporting views or tables so the reports can extract reportable data. The
report packages for these applications include reporting schemas that the
Reporting SQL Generator uses to produce SQL scripts that create reporting views
or tables.

For Campaign and Interact, you customize the schema templates so that all the
data you want to include in your reports is represented. Then you run the
Reporting SQL Generator, take the resulting scripts, and run them on your
application databases.

Although you cannot customize the eMessage reporting schemas, you or the
installation team must still generate the SQL that builds the reporting views or
tables and then run the scripts on the eMessage databases.

The reporting schemas make it easier for you to use any third-party reporting tool
to examine your IBM application data. However, if you want to display reports in
the IBM EMM user interface, your installation must be integrated with IBM
Cognos BI.

About the Reporting SQL Generator
The Reporting SQL Generator uses the reporting schemas to determine the analytic
logic necessary to extract data from the database for the IBM EMM application. It
then generates SQL that creates views or reporting tables that implement that logic
and that enables business intelligence tools to extract reportable data.

During installation and configuration, the system implementers configured data
source properties that identify the IBM EMM application databases. The Reporting
SQL Generator connects to the application databases as follows.
v To validate scripts that create views or materialized views.
v To determine the correct data types to use in scripts that create reporting tables.

If the JNDI data source names are incorrect or missing, the Reporting SQL
Generator cannot validate scripts that create reporting tables.

About the reporting deployment options
When you run the Report SQL Generator tool, you specify whether you want the
script to create views, materialized views, or tables. Which deployment option you
use depends on the amount of data contained in your system.
v For smaller implementations, reporting views that directly query the production

data might perform sufficiently for your needs. If they do not, try materialized
views.
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v For medium sized implementations, use either materialized views on the
production system database or set up reporting tables in a separate database.

v For large implementations, configure a separate reporting database.

For all implementations, you can use Cognos Connection Administration to
schedule reports that retrieve large amounts of data to run during off hours.

Materialized views and MS SQL Server

The reporting feature does not support materialized views for MS SQL Server.

In SQL Server, materialized views are called "indexed views." However, the
definition that creates an index in a view on SQL Server cannot use certain
aggregations, functions, and options that the reporting views include. Therefore, if
you are using a SQL server database, use views or reporting tables.

eMessage and Oracle

If your installation includes eMessage and your database is Oracle, it is a best
practice to use materialized views or reporting tables.

Data synchronization

When you deploy with materialized views or reporting tables, determine how
frequently you want to synchronize the data with the production system data.
Then, use your database administration tools to schedule data synchronization
processes to refresh the reporting data regularly.

About control groups and target groups in the reports
The example IBM Cognos BI reports from the report packages include data from
both target groups and control groups. To support these reports, the reporting
schemas contain two columns for each of the default contact and response history
metrics and default response types. One column represents the response from the
control group and the other column represents the response from the target group.

If you plan to extend the example reports or create your own new reports,
determine whether you want to include response information from both the target
and control groups. If the answer is yes and you add metrics or response types,
create two columns for that item in the reporting schema, one for the target and
one for the control. If the answer is no, you create only the target group column in
the reporting schema for that item.

About audience levels and the reports
In their default state, the reporting schemas reference the system tables for the
single pre-defined audience level delivered with Campaign, Customer. This means
that performance reports and response history reference the Customer audience
level by default.

You can change the audience level in your reports by editing the performance and
response schemas to reference the system tables for the correct audience level.

Additionally, for Campaign and Interact, you can add reporting schemas for
additional audience levels. You create the reporting schemas from the templates in
the Marketing Platform's configuration pages. Add the additional reporting views
to the Cognos data model; and then modify the Cognos reports to accommodate
the additional audience level or levels.
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These tasks are described in more detail elsewhere in this chapter.

About audience keys in reporting schemas
When you configure the audience level for performance reports and response
history, or when you create new reporting schemas for additional audience levels,
you specify the audience key for the audience level. If the key includes more than
one database column (sometimes referred to as a multikey audience key), you use
commas between the column names. For example, ColumnX,ColumnY.

The maximum length of the string you can enter in the Audience Key field of a
reporting schema is 255 characters. If the audience key is longer than 255
characters, you can work around this restriction in the generated SQL. Enter the
first 255 characters of the key in the Audience Key field and generate the SQL script
as usual. Then, open the generated script in an editor and use find and replace to
replace each of the truncated audience key references with the complete string.

About partitions and reporting schemas
If Campaign has more than one partition, the system implementer configured a
reports package on the Cognos system for each partition. However, after the data
design of your system is implemented, you must revisit the reporting views or
tables for each partition.

You can add reporting schemas for each partition. You create the reporting
schemas from the templates in the Schemas configuration pages.

About the Framework Manager data models
A Cognos model is reporting metadata that describes physical database objects and
their relationships to query subjects and query items. When you build reports in
IBM Cognos 8 BI Report Studio, you build them from query subjects and items
described in the model.

The data model for an IBM EMM application references the reporting views in the
IBM EMM application database, making that data available to the Cognos 8 reports
that are also delivered in the IBM EMM Reports Package.

When you configure the reporting views to include additional attributes, metrics,
response types, and so on, you synchronize the Cognos reporting model with the
reporting views and publish the revised model to the Cognos content store. At that
point, those new attributes become available in Report Studio and you can add
them to the IBM EMM reports.

The IBM Cognos 8 model from a IBM EMM Reports Package presents the IBM
EMM application metadata in the following three categories (folders).
v Import View. This level represents the data from the reporting schemas in the

IBM EMM application database. You use this view to synchronize the data
model with the IBM EMM database views, materialized views, or reporting
tables through the data source connection.

v Model View. This is the working area where you perform basic metadata
transformations. You set up relationships between object entities represented by
query subjects, creating building blocks that can be used in the Business View.

v Business View. This level organizes query subjects in terms of business objects
to simplify report building. This is the information you see when you open an
IBM EMM application report in Report Studio.

Chapter 3. Configuring reporting 51



The Campaign and eMessage models include shortcuts from the Model View to the
Business View. The Interact model does not use shortcuts in the same way because
some of its query subjects span two data sources.

About the Report Studio reports
Each IBM EMM reports package contains several reports for that application built
with IBM Cognos Report Studio. When they are installed, you can select and run
an example report from the following locations in the IBM EMM suite common
user interface.
v The multiple object reports are accessible from the Analytics menu.
v The single object reports appear on the Analysis tab of items like campaigns or

offers.
v Additionally, for Campaign, Marketing Operations, eMessage, and Interact, the

reports packages include pre-configured portlets (reports) for use with IBM
EMM dashboards.See the IBM Marketing Platform Administrator's Guide for
information on how to work with dashboards.

About the folders, subfolders, and access settings
During installation, the system implementers imported the IBM EMM application's
reports archive in Cognos Connection to the Public Folders area. Each IBM EMM
application's reports are organized into folders and subfolders with names that
represent both the application and the purpose of the report in that Public Folders
area.

The folders and subfolders are also used by the security access control model for
Campaign , Interact, and eMessage, which includes security settings for the reports
by folder. That is, the security policies for those applications grant users access to
all the reports in a folder. The access control model for Marketing Operations does
not provide this level of access. In Marketing Operations, you either have access to
all the reports or none of the reports.

As a best practice, you should not rename the folders or subfolders in the IBM
Cognos Connection interface. If you do, ensure that you configure your IBM
application so that it recognizes the changed folder names.
v For Campaign, eMessage, and Interact, select Settings > Configuration and

then edit the values of the reporting folder properties under Campaign >
partitions > [partition name] > reports so they match the actual names of the
folders.

v For Marketing Operations, open the plan_config.xml file and edit the values for
the reportsAnalysisSectionHome and reportsAnalysisTabHome configuration
settings.

About the report styles and appearance
The reporting integration components include a global stylesheet,
GlobalReportStyles.css. This stylesheet establishes common reporting styles
across the reports for all the IBM EMM applications. For information about styles,
see the appendix Appendix B, “Formatting the Cognos reports,” on page 95. This
appendix provides the following information for the various kinds of reports.
v The styles implemented by the GlobalReportStyles.css file.
v Style formatting that you must do manually when you author a report because

there are certain styles that cannot be implemented by the stylesheet.
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The dash character ("-") has special meaning in the IBM EMM reports: it denotes
calculations that do not apply. For example, if the unique count in a row that
shows totals cannot be calculated, a "-" is displayed to indicate that fact.

Some of the reports do not appear at their best on systems with little or no data.
For example, a line graph with one data point cannot display a line, which makes
the graph look empty. Additionally, graphical representations of summary data do
not list the dates or times for data points that do not have data. For example, if
you specify a date range that has only one day with data, the graph shows that
date only.

You can customize the reports to use the chart or graph type that works best for
the data from your systems.

About setting up schedules for generating reports
In IBM Cognos Connection, you can schedule the automatic running of your
reports. For each report, you can select the run frequency, format options, delivery
methods, locations for saving, and so on.

For example, you can schedule a report to run every Monday at 9:00 AM, and
distribute the report using an auto-generated email to a specified group of
recipients.

For details about scheduling and distributing reports, see the schedule chapter in
the IBM Cognos Connection User Guide.

Customizing reporting schemas
This section describes how to customize your reporting schemas to include custom
data so you can display it in your reports. The first step in this task is to determine
which schema you want to modify. Then complete the steps in the procedures in
this section as appropriate for the reporting goals of your system.
v “Which reporting schema?”
v “To add contact or response metrics” on page 54
v “To add custom attributes” on page 54
v “To add response types” on page 55
v “To add contact status codes” on page 55
v “To specify the calendar time periods for performance reports” on page 56
v “To configure audience level for performance reports and response history” on

page 56

Which reporting schema?
The reporting schema you must modify depends on the reports you plan to
customize. The appendix named "Reports and Reporting Schemas by Product"
provides tables that show which reporting schemas support the sample reports
provided in the report packs. Determine which reports you plan to customize and
then consult the appropriate report to reporting schema map
v Appendix C, “Reports and reporting schemas by product,” on page 103
v “Interact Reports and Reporting Schemas” on page 105
v “eMessage Reports and Reporting Schemas” on page 105

Note: You cannot customize the eMessage reporting schemas, but you can modify
and create new eMessage reports.
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To add contact or response metrics
You can add contact or response metrics to the Campaign Performance and Offer
Performance reporting schemas. Before you begin, determine the following
information.
v Which reporting schema supports the report you want to add the metric to. See

the appendix Appendix C, “Reports and reporting schemas by product,” on page
103 for information.

v Whether you need to add a column to the reporting schema for the control
group in addition to the target group. See “About control groups and target
groups in the reports” on page 50.

v How the metric is calculated. For example, it could be summed, averaged, or
counted.

Then complete the following steps.
1. Select Settings > Configuration and expand Reports > Schemas > Campaign >

name of the appropriate reporting schema .
2. Expand the Columns node and select either Contact Metric or Response

Metric.
3. In the form on the right, click New category name and enter the name of the

contact or response metric.
4. For Column Name, enter the name to use in the reporting schema for the

attribute. Use all UPPERCASE letters with no spaces.
5. For Function, specify how the metric is calculated or determined.
6. For Input Column Name, enter the name of the column for this attribute from

the appropriate table in the IBM application database. Input column names are
case-sensitive.

7. For Control Treatment Flag, enter the number 0 (zero) to indicate that this
column in the reporting schema represents the target group.

8. Click Save Changes.
9. Repeat this procedure to add the control group column to the reporting

schema, if necessary. This time, enter the number 1 (one) to indicate that this
column represents the control group.

To add custom attributes
You can add custom campaign, offer, and cell attributes to the Custom Campaign
Attributes reporting schema. Before you begin, determine the following
information.
v The value from the attribute's AttributeID column in the UA_CampAttribute,

UA_CellAttribute, or UA_OfferAttribute table, as appropriate
v The data type of the attribute: string value, number value, or date/time value

Then complete the following steps.
1. Select Settings > Configuration and expand Reports > Schemas > Campaign >

Campaign Custom Attributes > Columns.
2. Select the type of column that matches the type of attribute you want to add.
3. In the form on the right, click New category name and enter the name of the

custom attribute.
4. For Column Name, enter the name to use in the reporting schema for the

attribute. Use all UPPERCASE letters with no spaces.
5. For Attribute ID, enter the ID of this attribute.
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6. For Value Type, specify the data type of the attribute.

Note: If you are adding an attribute that holds a currency value, specify
NumberValue in the Value Type field. If you are adding an attribute whose Form
Element Type was set to Select Box - String in Campaign, specify
StringValue in the Value Type field.

7. Click Save Changes.

To add response types
You can add response types to the Campaign Offer Response Breakout schema.
Before you begin, determine the following information.
v Whether you need to add a column to the reporting schema for the control

group in addition to the target group. See “About control groups and target
groups in the reports” on page 50.

v The response type code from the UA_UsrResponseType table.

Then complete the following steps.
1. Select Settings > Configuration and expand Reports > Schemas > Campaign >

Campaign Offer Response Breakout > Columns > Response Type.
2. In the form on the right, click New category name and enter the name of the

response type.
3. For Column Name, enter the name to use in the reporting schema for the

response type.
4. For Response Type Code, enter the three letter code for this response type.

Response type codes are case-sensitive.
5. For Control Treatment Flag, enter the number 0 (zero) to indicate that this

column in the reporting schema represents the target group
6. Click Save Changes.
7. Repeat this procedure to add the control group column to the reporting

schema, if necessary. This time, enter the number 1 (one) to indicate that this
column represents the control group.

To add contact status codes
You can add contact status codes to the Campaign Offer Contact Status Breakout
schema. Before you begin, determine the contact status code from the
UA_ContactStatus table.

Then complete the following steps.
1. Select Settings > Configuration and expand Reports > Schemas > Campaign >

Campaign Offer Contact Status Breakout > Columns > Contact Status.
2. In the form on the right, click New category name and enter the name of the

contact status type.
3. For Column Name, enter the name to use in the reporting schema for the

contact status type
4. For Contact Status Code, enter the three letter code for this contact status.

Contact status codes are case-sensitive.
5. Click Save Changes.
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To specify the calendar time periods for performance reports
The standard reports for both Campaign and Interact include performance reports
that summarize data over calendar periods. To specify time periods used in these
reports to be something other than the default over time variations, complete the
following steps.
1. Select Settings > Configuration and expand Reports > Schemas and then

select either Campaign or Interact.
2. Select the performance schema of interest.
3. Click Edit Settings.
4. In the Schema Settings section, select the appropriate values for the Over Time

Variations option list.
5. Click Save Changes.

To configure audience level for performance reports and
response history

Before you begin, determine the following:
v The names of the contact history, detailed contact history, and response history

tables for the audience level of interest.
v The audience key to the contact history and detailed contact history tables. See

“About audience keys in reporting schemas” on page 51.

Then, complete the procedure in this section for each of the appropriate reporting
schemas.
v For Campaign: Offer Performance, Campaign Performance, Campaign Offer

Response Breakout, Campaign Offer Contact Status Breakout
v For Interact: Interact Performance
1. Select Settings > Configuration and expand Reports > Schemas > ProductName

> SchemaName .
2. In the form on the right, click Edit Settings.
3. In the Input Tables section, identify the system tables for the audience level

and the audience key.

Note: Remember to use commas to separate column names for a multikey
audience key. See “About audience keys in reporting schemas” on page 51 for
more information.

4. Click Save Changes.

Creating reporting schemas for additional audience levels or partitions
You are likely to create additional reporting schemas for the following reasons:
v You want to report on more than one audience level. Perhaps you plan to create

reports that present data for more than one audience level, or add filters that
prompt users to specify one of several audience levels. Therefore, you need
schemas that point to an additional set of contact and response history table.

v You are configuring reporting for multiple partitions and you need to implement
different schema customizations for each set of partition system tables

Before you begin, determine the following information.
v Which reporting schemas to create.

56 IBM EMM Reports: Installation and Configuration Guide



– For Campaign: Campaign Offer Response Breakout, Offer Performance,
Campaign Performance, Offer Contact Status Breakout, and Campaign
Custom Attributes

– For Interact: Interact Performance
v The names of the following tables for this audience level.

– For Campaign: contact history, detailed contact history, and response history
tables

– For Interact: detailed contact history and response history tables
v The name of the audience key column (or columns) for this audience level
v Pick a short 2 or 3 letter code to represent the name of the audience level. You

use this code when you specify the table or view names for the new reporting
schema.

Complete the steps in the following procedures as appropriate for your reporting
goals.

To create a Campaign Offer Response Breakout schema
1. Select Settings > Configuration and expand Reports > Schemas > Campaign

> Campaign Offer Response Breakout Star Schema.
2. Click New category name and enter a descriptive name for the reporting

schema that indicates the audience level. For example, Campaign Offer
Response Household.

3. In the Input Tables section, enter the name of the response history table for
this audience level, and then click Save Changes.
A new node appears in the Configuration tree for the schema. You cannot
change the name of the node.

4. Under the new node, select Columns > Response Type and then configure
the response types for this audience level.
For help with this step, see the procedure “To add response types” on page
55.

5. Under the new node, select SQL Configuration > Campaign Response
Breakout and click Edit Settings.

6. In the form that appears, edit the name in the Table/View Name field to
include the code for the audience level. The name can be no longer than 18
characters and must be in all UPPERCASE letters.
For example, if the name of the audience level is household, you might
specify: UARC_CRBO_HH_. For more information about table and view naming
conventions, see the “Reports | Schemas | [product] | [schema name] | SQL
Configuration” on page 78.

7. Click Save Changes.
8. Under the new node, select SQL Configuration > Campaign Offer Response

Breakout and click Edit Settings.
9. Edit the name in the Table/View Name field to include the code for the

audience level. The name can be no longer than 18 characters and must be in
all UPPERCASE letters.
For example, UARC_CORBO_HH_.

10. Click Save Changes.
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To create a Campaign Offer Contact Status Breakout schema
1. Select Settings > Configuration and expand Reports > Schemas > Campaign

> Campaign Offer Response Breakout Star Schema.
2. Click New category name and enter a descriptive name for the reporting

schema that indicates the audience level. For example, Campaign Offer
Contact Status Household.

3. In the Input Tables section, enter the name of the response history table for
this audience level, and then click Save Changes.
A new node appears in the Configuration tree for the schema. You cannot
change the name of the node.

4. Under the new node, select Columns > Contact Status Code and then
configure the contact status codes for this audience level.
For help with this step, see the procedure “To add contact status codes” on
page 55.

5. Under the new node, select SQL Configuration > Campaign Contact Status
Contact History and click Edit Settings.

6. In the form that appears, edit the name in the Table/View Name field to
include the code for the audience level. The name can be no longer than 18
characters and must be in all UPPERCASE letters.
For example, if the name of the audience level is household, you might
specify: UARC_CCSBO_HH_. For more information about table and view naming
conventions, see the “Reports | Schemas | [product] | [schema name] | SQL
Configuration” on page 78.

7. Click Save Changes.
8. Under the new node, select SQL Configuration > Campaign Offer Contact

Status Contact and click Edit Settings.
9. Edit the name in the Table/View Name field to include the code for the

audience level. The name can be no longer than 18 characters and must be in
all UPPERCASE letters.
For example, UARC_COCSBO_HH_.

10. Click Save Changes.

To create an Offer Performance schema
1. Select Settings > Configuration and expand Reports > Schemas > Campaign

> Offer Performance Star Schema.
2. In the New category name, enter a descriptive name for the reporting schema

that indicates the audience level. For example, Offer Performance Household.
3. In the Input Tables section, identify the tables that support the audience level

and the audience key.
4. In the Schema Settings section, select the Over Time Variations options that

apply and then click Save Changes.
A new node appears in the Configuration tree for the schema. You cannot
change the name of the node.

5. Under the new node in the Configuration tree, select Columns > Contact
Metric and then configure the contact metrics for this audience level.
For help with this step, see the procedure “To add contact or response
metrics” on page 54.

6. Under the new node, select Columns > Response Metric and then configure
the response metrics for this audience level.
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For help with this step, see the procedure “To add contact or response
metrics” on page 54.

7. Under the new node, expand SQL Configuration, select the first item (Offer
Contact History) and click Edit Settings.

8. In the form that appears, edit the value in the Table/View name field to
include the code for the audience level. The name can be no longer than 18
characters and must be in all UPPERCASE letters.
For example, if the name of the audience level is household, you might
specify: UARC_OCH_HH_. For more information about table and view naming
conventions, see “Reports | Schemas | [product] | [schema name] | SQL
Configuration” on page 78.

9. Click Save Changes.
10. Repeat steps 7 through 9 for each item listed under the SQL Configuration

section of the new reporting schema.

To create a Campaign Performance schema
1. Select Settings > Configuration and expand Reports > Schemas > Campaign

> Campaign Performance Star Schema.
2. Click New category name and enter a descriptive name for the reporting

schema that indicates the audience level. For example, Campaign Performance
Household.

3. In the Input Tables section, identify the tables that support the audience level
and the audience key.

4. In the Schema Settings section, select all the Over Time Variations options
that apply and then click Save Changes.
A new node appears in the Configuration tree for the schema. You cannot
change the name of the node.

5. Under the new node, select Columns > Contact Metric and then configure the
contact metrics for this audience level.
For help with this step, see the procedure “To add contact or response
metrics” on page 54.

6. Under the new node, select Columns > Response Metric and then configure
the response metrics for this audience level.
For help with this step, see the procedure “To add contact or response
metrics” on page 54.

7. Under the new node, select SQL Configuration and select the first item,
Campaign Contact History.

8. In the form that appears, edit the value in the Table/View name field to
include the code for the audience level. The name can be no longer than 18
characters and must be in all UPPERCASE letters.
For example, if the name of the audience level is household, you might
specify: UARC_CCH_HH_. For more information about table and view naming
conventions, see the “Reports | Schemas | [product] | [schema name] | SQL
Configuration” on page 78.

9. Click Save Changes.
10. Repeat steps 8 and 9 for each item listed under the SQL Configuration

section of the new reporting schema.
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To create a Campaign Custom Attributes schema
You need just one Campaign Custom Attributes schema for each partition. The
same schema is used for all audience levels.
1. Select Settings > Configuration and expand Reports > Schemas > Campaign >

Campaign Custom Attributes.
2. In the New category name, enter a descriptive name for the reporting schema

that indicates the partition. For example, Campaign Custom Attributes
Partition 2.

3. Under the new node in the Configuration tree, expand Columns and then add
the custom cell, offer, and campaign attributes required by the partition for
which you are creating this reporting schema.
For help with this step, see the procedure “To add custom attributes” on page
54.

4. (Optional) You can optionally edit the view or table names. Under the new
node, expand SQL Configuration and select each item and examine the view
or table names. If you decide to change the names, note that names can be no
longer than 18 characters, must be in all UPPERCASE letters, and can include
no spaces. For more information about table and view naming conventions, see
“Reports | Schemas | [product] | [schema name] | SQL Configuration” on
page 78

5. Click Save Changes.

To create an Interact Performance schema
1. Select Settings > Configuration and expand Reports > Schemas > Interact >

Interact Performance Star Schema.
2. In the New category name field, enter a descriptive name for the reporting

schema that indicates the audience level. For example, Interact Performance
Household.

3. In the Input Tables section, identify the tables that support the audience level
and the audience key.

4. In the Schema Settings section, select all the Over Time Variations options that
apply and then click Save Changes.
A new node appears in the Configuration tree for the schema. You cannot
change the name of the node.

5. Under the new node, select SQL Configuration and select the first item,
Interactive Channel Offer Contact History Summary.

6. In the form that appears, edit the value in the Table/View name field to
include the code for the audience level. The name can be no longer than 18
characters and must be in all UPPERCASE letters.
For example, if the name of the audience level is household, you might specify:
UARI_ICP_OCH_HH_. For more information about table and view naming
conventions, see the “Reports | Schemas | [product] | [schema name] | SQL
Configuration” on page 78.

7. Click Save Changes.
8. Repeat steps 6 and 7 for each item listed under the SQL Configuration section

of the new reporting schema.
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Generating updated view or table creation scripts
This section describes the process you follow to update the default reporting views
or schemas that were set up during installation and configuration of Campaign,
eMessage, and Interact. If reporting has not yet been set up for your IBM EMM
system, do not use the procedures in this section. Instead, see the installation
information elsewhere in this guide.

Before you begin updating views or reporting tables
Before you begin, verify that the data source properties are configured correctly:
1. Consult the table in “SQL scripts by data source” on page 7 to verify the

database where you will run the updated scripts.
2. Select Settings > Configuration and expand Reports > Schemas >

ProductName.
3. Verify that the values set in the data source fields match the actual JNDI names

of the appropriate data sources.

Generate updated SQL scripts for the reporting views or
tables

This procedure describes how to generate updated SQL scripts for existing
reporting views or tables. If you are configuring views or tables for the first time,
do not use this procedure. Instead, see the installation chapter in this guide.

To generate updated SQL scripts, complete the following steps:
1. Select Settings > Reports SQL Generator. The SQL Generator page appears.
2. In the Product field, select the appropriate IBM application.
3. In the Schema field, select one or more reporting schemas. Use the table in

“SQL scripts by data source” on page 7 to determine the appropriate schemas
to select.

4. Select the Database Type. This option must match the database type of the
database for which you are generating the script.

5. In the Generate Type field, select the appropriate option (views, materialized
views, or tables).
Materialized views are not an option when Database Type is set to MS SQL
Server.
If the JNDI data source names are incorrect or have not been configured, the
SQL Generator cannot validate scripts that create tables.

6. Set the value in the Generate Drop Statement field to Yes.
7. (Optional.) To examine the SQL, click Generate. The SQL Generator creates

the script and displays it in the browser window.
8. Click Download.

The SQL Generator creates the script and prompts you to specify where you
want to save the file. If you selected a single reporting schema from the
Schema field, the script name matches the name of schema
(eMessage_Mailing_Execution.sql, for example). If you selected more than one
reporting schema, the script name uses the product name only (Campaign.sql,
for example). For a complete list of names, see “SQL scripts by data source”
on page 7.

9. Specify the location where you want to save the script. If you change the
name of the file, be sure to use something that clearly indicates which
schemas you selected. Then click Save.
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10. Repeat steps 7 through 10 but select No in the Drop Statement field this time.
11. Repeat steps 3 through 11 for each script you want to generate.

Note: There might be times when you want to disable script validation. For
example, perhaps the Marketing Platform cannot connect to the IBM
application database but you want to generate the scripts anyway. To disable
validation, clear the values in the data source configuration properties for
reporting. When you generate the scripts, the Reports SQL Generator displays
a warning that it cannot connect to the data source, but it still generates the
SQL script.

Update the views or reporting tables
Note that this procedure describes updating existing views or reporting tables. If
you are creating views or reporting tables for the first time, do not use this
procedure. Instead, use the reports chapter in the installation guide for your IBM
application.

After you generate and download the SQL scripts that update your views or
tables, run them on the application databases.
1. Locate the SQL scripts that you generated and saved. Use the table in “SQL

scripts by data source” on page 7 to determine which scripts to run against
which database.

2. Use your database administration tools to run the drop scripts.
3. Use your database administration tools to run the creation scripts.
4. For reporting tables, use your database administration tools to populate the

new tables with the appropriate data from the production system database.
5. For reporting tables and materialized views, use your database administration

tools to schedule data synchronization processes between the IBM application's
production databases and the new reporting tables or materialized views to run
regularly.

Note: You must use your own tools for this step. The Reports SQL Generator
does not generate this SQL for you.

SQL scripts by data source
The following table shows which scripts you need to generate for each data source,
the resulting script names and, for creating views or materialized views, which
script should be run against which IBM EMM application database. Note the
following.
v The table lists the default names for the data sources and the generated scripts,

which you might have changed.
v The Interact reporting schemas reference more than one data source. Generate a

separate SQL script for each data source.

Reporting schema Data source (default names) Script name (default names)

All Campaign reporting schemas Campaign system tables

(campaignPartition1DS)

Campaign.sql, unless you generated
separate scripts for each reporting
schema. If you did, each script is
named after the individual schema.
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Reporting schema Data source (default names) Script name (default names)

eMessage Mailing Performance eMessage tracking tables, which are
with the Campaign system tables

(campaignPartition1DS)

eMessage_Mailing_ Performance.sql

Interact Deployment History, Interact
Performance, and Interact Views

Interact design time database

(campaignPartition1DS)

Interact.sql

Interact Learning Interact Learning tables

(InteractLearningDS)

Interact_Learning.sql

Interact Run Time Interact run time database

(InteractRTDS)

Interact_Runtime.sql

Reports SQL Generator page reference
The Reports SQL Generator uses the reporting schemas you configure to generate
SQL that creates views and reporting tables.

Item Description

Product Lists the products whose reporting schema templates are installed.

Schema Lists the reporting schemas for the product you selected. For more information see the
following descriptions.

v Appendix C, “Reports and reporting schemas by product,” on page 103

v “eMessage Reports and Reporting Schemas” on page 105

v “Interact Reports and Reporting Schemas” on page 105

Database Type
Indicates the database type of the application database where you plan to run the
scripts you are generating.

Generate Type Indicates whether the scripts you are generating should create views, materialized
views, or reporting tables.

v Materialized views are not an option when Database Type is set to MS SQL Server.

v If the JNDI data source names are incorrect or have not been configured, the SQL
Generator cannot validate scripts that create tables.

v The fourth option, XML, doesn't result in a SQL script. Instead, it creates a
description of the schema in XML. You can then use the XML file as needed with
your third-party ETL or import tools.

See also, “About the reporting deployment options” on page 49.

Generate Drop Statement? Indicates whether the scripts you are generating are drop scripts or not. When
updating existing views or tables, it is best practice to generate a drop script and a
creation script and to then run the drop script before you run the new creation script.

When you select Yes in the field, the SQL Generator appends the word DROP to the end
of the script.

Generate Click this option to have the SQL Generator create the script and then display it in
this window. You can then copy and paste it as appropriate.
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Item Description

Download Click this option to have the SQL Generator create the script and then prompt you to
save it to your system. For information about the names it uses for the generated
scripts, see:

“SQL scripts by data source” on page 7.

Customizing the IBM Cognos Model
When you customize an IBM EMM reporting schema to include additional metrics,
attributes, or audience levels and then modify the reporting view or tables that are
based on that schema, you must also edit the IBM Cognos BI model. Use IBM
Cognos Framework Manager features to query the views or tables and then import
the additional items in the data model.

The way you update the Cognos model depends on the changes you made in the
IBM EMM reporting views or tables.
v If you modified existing views by adding columns for attributes, metrics, or

response types, import the new columns by updating the query object that
represents the associated view.

v If you modified the over time variations for performance or runtime reports or
created new reporting schemas for additional audience levels, you have added
new views. In this case, use the Framework Manager MetaData Wizard to
import the views into the data model.

This section provides examples that you can use as guidelines for adding your
customizations to the Cognos model. For more information, see the IBM Cognos BI
Framework Manager User Guide and the Framework Manager online help.

Example: Add attributes to an existing view or table in a data
model

The following example procedure shows how to add an item to an existing view in
the IBM Cognos model. For this example, assume that you need to add a custom
offer attribute to the Campaign database and then include it in a report. You have
already completed the following tasks:
v Created the offer attribute in the UA_OfferAttribute table.
v Added the offer attribute to the Campaign Custom Attributes reporting schema.
v Used the Reports SQL Generator to generate the view creation script.
v Ran the generated script in the Campaign database to update the Offer Custom

Attribute reporting view, UARC_OFFEREXTATTR.

Now, to add the new offer attribute to the Cognos Campaign model, you would
complete the following steps.
1. Make a backup of the Campaign model. That is, navigate to the Cognos/models

directory and copy the CampaignModel subdirectory. In a distributed Cognos
environment, the models directory is in a location on the system running the
Content Manager.

2. In Framework Manager, open the Campaign.cpf file (the project) and expand
the Import View node.
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3. Under Import View, select the query object that represents the reporting view
for custom offer attributes: Import View > Campaign Custom Attributes >
UARC_OFFEREXTATTR.

4. Select Tools > Update Object. Cognos refreshes the columns listed under the
node for the view so they reflect all the columns currently present in the
UARC_OFFEREXTATTR reporting view in the Campaign database.

5. Expand the Model View and select the node that represents custom offer
attributes in this view: Model View > Campaign Custom Attributes > Offer
Custom Attributes.

6. Double-click the Offer Custom Attributes node to open the Query Subject
Definition dialog box.

7. Locate the new column and add it to the Model View. Then edit the name of
the query item so it can be read easily. For example, the column named
LASTRUNDATE in the Import View of the Campaign data model appears as Last
Run Date in the Model View.

Note: Because the Business View contains a shortcut to the Offer Custom
Attributes node in the Model View, the new query item now available in the
Business View without your having to add it manually.

8. Save the model.
9. Publish the package to the Cognos content store.

Now you can add the attribute to the appropriate report using IBM Cognos
Report Studio.

Example: Add new views to IBM Cognos data model
The following example procedure shows how to add new views or tables to the
IBM Cognos data model. For this example, assume that you changed the Over
Time Variations for the Campaign Peformance reporting schema and now need to
import the change in the Cognos model. You have already completed the following
tasks:
v Modified the Campaign Performance schema by adding Quarterly to the Over

Time Variations options.
v Used the Reporting SQL Generator to generate the view creation script. This

script now contains instructions to create the following additional reporting
views: UARC_CCCH_QU, UARC_CCH_QU, UARC_CCRH_QU,
UARC_COCH_QU, UARC_CORH_QU, and UARC_CRH_QU

v Ran the generated script in the Campaign database to create the additional
reporting views.

Now, to add the new reporting views to the Cognos Campaign data model, you
would complete the following steps.
1. Make a backup of the Campaign model.

That is, navigate to the Cognos/models directory and copy the CampaignModel
subdirectory. In a distributed Cognos environment, the models directory is in a
location on the system running the Content Manager.

2. In Framework Manager, open the Campaign project and expand the Import
View node

3. Select the Campaign Performance folder and run the Metadata Wizard
(accessed through the right-mouse menu).

4. Use the Metadata Wizard to import the new views.
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5. Expand the Model View > Campaign Performance node and model a new
entry named Campaign Performance by Quarter.
For help with this step, examine the other entries for reference. Be sure to
maintain the same structure and relationships that are included in the other
over time variation nodes. Additionally, consult the Cognos BI Framework
Manager User Guide for information about the following:
v Creating a new namespace.
v Creating star schema groupings.
v Adding joins.

6. Expand the Business View and create a shortcut to the Campaign Performance
by Quarter node in the Model View .

7. Save the model.
8. Publish the package to the Cognos content store.
9. Open Report Studio and create a new report with the objects from the Campaign

Performance by Quarter schema that you just created.

Customizing or creating Cognos reports for IBM EMM applications
You can customize the example reports so they include your custom data and you
can create new reports. From Cognos Connection, you can configure options for
the reports, schedule them to run at regular times, and use Report Studio to
customize them.

Consult the following sources when you are planning and implementing your
reports.
v The user's guides for your IBM EMM applications include short descriptions of

all the reports in the IBM EMM reports package for that product.
v The IBM EMM reports packages provide reference documentation that describes

the specifications of each of the reports in the pack and the Framework Manager
metadata model that supports the reports. You can find the reference
documentation in the reports package installation directory, in a location similar
to <ReportsPackInstallationDirectory>/cognos10/<Product>Docs.
For example, the IBM EMM Campaign reports package documentation might be
found in the Reports Pack installation directory under /IBM/EMM/
ReportsPackCampaign/cognos10/CampaignDocs.
Examine these documents before you customize a model or a report. Be sure
that you understand how a report is constructed before you modify it.

v For detailed documentation about creating and editing IBM Cognos BI reports,
see the IBM Cognos BI documentation, especially the IBM Cognos BI Report
Studio Professional Authoring User Guide.

v For information about the report styles to use, see the appendix Appendix B,
“Formatting the Cognos reports,” on page 95.

v For information about customizing Marketing Operations reports, see the
Marketing Operations Administration Guide.

Guidelines for creating new Campaign reports
Use the following guidelines to create new reports for Campaign in IBM Cognos
Report Studio:
v Examine the reference documentation that describes the metadata model and

the specifications of the example reports from the Campaign report package. It is

66 IBM EMM Reports: Installation and Configuration Guide



located in the CampaignReportPack\cognosN\docs subdirectory in the report
package installation directory, where N is the version number of your Cognos
installation.

v Using Report Studio, create a new report, or copy and modify an existing
report. For details, see the Cognos Report Studio documentation.

v If you are modifying a copy of an existing report (or the report itself), ensure
that you understand how the report is constructed. Then you can add your
custom attributes and metrics, and modify the objects and query items in an
appropriate way, using the toolbar and Properties pane in Report Studio. For
information about using Report Studio, see the Cognos Report Studio
documentation. For information about the objects and query items in an example
report, consult the reference documentation from the report package.

v For object-specific reports that appear on the Analysis tab, create a parameter
ID that accepts the passed value from the object. For a system-wide report that
appears on the Analysis page, create a prompt that contains all object values for
campaigns or offers. For details, see the Cognos Report Studio documentation.

v Save the new report into the appropriate folder under Public Folders to make it
visible in Campaign.
– If it should appear on the Analysis tab, save it in the Campaign - Object

Specific Reports folder.
– If it should appear on the Analysis page, save it in the Campaign folder.
– If you plan to add it to a dashboard portlet, save it in the Unica

Dashboards\Campaign forlder.

Configuring the Interaction Point Performance dashboard
portlet

Interact has one IBM Cognos dashboard report: Interaction Point Summary.
Because Dashboard reports do not prompt users for query parameters, the channel
ID of the interactive channel in the Interaction Point Performance report is a static
value. By default, the channel ID for this report is set to 1. If the channel ID is not
correct for your implementation, you can customize the report and change the
channel ID in the report's filter expression.

To customize any of the IBM Cognos reports, you need IBM Cognos report
authoring skills. For detailed documentation about creating and editing IBM
Cognos BI reports, see the IBM Cognos BI documentation, especially IBM Cognos
BI Report Studio Professional Authoring User Guide for the version of Cognos you are
using.

For information about the queries and data items in the Interaction Point
Performance report, see the reference documentation provided in the Interact
report package.

If you need to display a chart for more than one interactive channel in the
Dashboard, make a copy of the Interaction Point Performance Dashboard and
modify the channel ID. Then create a new dashboard portlet for the new report
and add it to your dashboards.

Guidelines for creating new, custom dashboard reports
The IBM EMM reporting packages for Campaign, Interact, eMessage, and
Marketing Operations include pre-configured reports (portlets) that are specially
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formatted to for use with IBM EMM dashboards. See the IBM Marketing Platform
Administrator's Guide for details on working with dashboards and using these
pre-configured portlets.

If you want to create new, custom dashboard reports in Cognos Report Studio, use
the following guidelines.
v Examine the reference documentation that describes the metadata model and the

specifications of the example reports from the report package. It is located in the
ProductNameReportPack\cognosN\docs subdirectory in the report package
installation directory, where N is the version number of your Cognos installation.

v Save all dashboard reports in the appropriate product subdirectory under the
main Unica Dashboards folder.

v The report must be formatted and sized so it fits properly in a dashboard
portlet. See “Dashboard report styles” on page 101 in the "Style Guide for the
IBM Cognos BI reports" appendix for a description of the formatting you should
use.

v Do not include a title in a dashboard report. The portlet it appears in will give
the report its title.

v Do not include hyperlinks in a dashboard report.
v Do not include page numbers in a dashboard report.

To create a new dashboard portlet and add the report to it, see the IBM EMM
Marketing Platform Administrator's Guide.
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Chapter 4. Configuring reporting for multiple partitions

Follow the instructions in this chapter to set up reporting when you have
configured multiple partitions in Campaign and eMessage.

For instructions on configuring partitions in Campaign and eMessage, see the IBM
Campaign Administrator's Guide.

Configuring the IBM Cognos Reports for multiple partitions
If you are using Campaign, eMessage, and/or Interact with more than one
partition, you must configure IBM Cognos reports packages for each partition. A
utility, partition_tool.sh, is provided to help with this process.

When you run the partition_tool.sh utility, it does the following:
v Copies the xml files from the original reports zip archive.
v Replaces the package references in the xml files to reference a new package

under a new folder that you specify.
v Zips up the new files into a new archive, adding the new partition name to the

end of the file name.

After running the partition_tool.sh utility, you create a folder in Cognos
Connection using the name you specified, and import the new archive into that
folder. Finally, you copy the original project file (which contains the model) so you
can change the datasource to point to the new partition, and then publish the
model to the new folder.

This section describes how to configure the IBM Cognos reports for multiple
partitions.

Before you begin
The reporting partition utility, partition_tool.sh, is a UNIX shell script. Before
you run the utility, do the following.

Determine values for input parameters

The reporting partition tool has two input parameters: the name of the partition
folder you want to create in Cognos, and the location of the reports archive to
copy.
v Decide the name of the top-level partition folder you plan to create in Cognos.

This name is used in Cognos for the package references. For example,
"Partition2."

v Note the path to the original reports archive. For example: IBM\Unica\
ReportsPacksCampaign\cognos<version>\IBM EMM Reports for Campaign.zip

Windows only: obtain a shell script simulator

If Cognos is running on Windows, you must run the script from a shell script
simulator (for example, Cygwin).
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If you do not have a shell script simulator installed on the machine that is running
the Cognos Content Manager, download and install one now.

Ensure that a zip utility is installed

The reporting partition tool creates a zip archive for the new partition reports. To
enable this function, a zip utility must be installed on the Cognos system.

If you do not have a zip utility installed on the machine that is running the
Cognos Content Manager, download and install one now.

Run the reporting partition tool to create a copy of the reports archive
.zip file

Perform this procedure for each partition in your system.
1. From the shell or the shell simulator, navigate to the IBM\Unica\Platform\

tools\cognos<version>\bin directory.
2. Run the partition_tool.sh utility, providing values for the partition name and

archive path parameters.
Examples

For a Campaign reports archive

partition_tool.sh Partition2 "IBM\Unica\ReportsPacksCampaign\
cognos<version>\Unica Reports for Campaign.zip"

For an eMessage reports archive

partition_tool.sh Partition2 "IBM\Unica\ReportsPackseMessage\cognos10\
Unica Reports for eMessage.zip"

Note: You must use quote characters around the parameter values if they
contain spaces, as shown above for the archive paths.

3. Copy each new zip file to the Cognos deployment directory.
If you used the partition name provided in the example above, the new zip file
would be named as follows.
v Campaign - Unica Reports for Campaign_Partition2.zip

v eMessage - Unica Reports for eMessage_Partition2.zip

4. Open Cognos Connection.
5. Under Public Folders, create a folder for the reports partition.

For example, Campaign Partition 2.
6. Import each new zip archive, selecting the folder you created in step 5 as the

target location in the import wizard.
If you followed the example, you would target the "Campaign Partition 2"
folder.

Create a copy of the Cognos model for Campaign
Perform this step if you plan to use Campaign reports in multiple partitions.

In this task, you create a copy of the IBM Cognos data model for the new
Campaign reports and ensure that the model references the correct data source
name.
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1. Verify that you created a IBM Cognos data source for this partition. If you have
not yet created the data source for this partition, see “Step: Create JDBC data
sources” on page 5.

2. Use Framework Manager to open the Campaign project (cpf file), the
CampaignModel.cpf file.

3. Use Save As to copy the CampaignModel project and give it a new name that
indicates the partition where it is used.
For example, CampaignModelPartition2.

4. In the Project Viewer, expand the Data Sources node and select CampaignDS.
If the Properties pane does not appear by default, select View > Properties.

5. Click in the Name field and change the value from the default data source
(CampaignDS) to the correct data source name for this Campaign partition.
For example, CampaignDS_partition2.

6. Click in the Content Manager Datasource field and change the value of the
default data source (CampaignDS) to the same value that you specified in the
previous step.
In this example, the value is CampaignDS_partition2.

7. Save your changes.
8. Publish the package to the content store and when the publish wizard displays

the Select Location Type window, navigate to and specify the folder where you
imported the reports archive in Cognos Connection in the previous task.
In the example, the folder is Campaign Partition 2.

Create a copy of the Cognos model for eMessage
Perform this step if you plan to use eMessage reports in multiple partitions.

In this task, you create a copy of the IBM Cognos data model for the new
eMessage reports and ensure that the model references the correct data source
name.
1. Verify that you created a IBM Cognos data source for this partition. If you have

not yet created the data source for this partition, see “Step: Create JDBC data
sources” on page 5.

2. Use Framework Manager to open the eMessage project file, eMessageModel.cpf.
3. Use Save As to copy the eMessageModel project and give it a new name that

indicates the partition where it is used.
For example, eMessageModelPartition2.

4. In the Project Viewer, expand the Data Sources node and select
eMessageTrackDS.
If the Properties pane does not appear by default, select View > Properties.

5. Click in the Name field and change the value of the default data source
(eMessageTrackDS) to the new data source name for this eMessage partition.
For example, eMessageTrackDS_partition2.

6. Click in the Content Manager Datasource field and change the value of the
default data source (eMessageTrackDS) to the same value that you specified in
the previous step.
In this example, the value is eMessageTrackDS_partition2.

7. Save your changes.

Chapter 4. Configuring reporting for multiple partitions 71



8. Publish the package to the content store and when the publish wizard displays
the Select Location Type window, navigate to and specify the folder where you
imported the reports archive in Cognos Connection in the previous task.
In the example, the folder is Campaign Partition 2.

Update the partition's report properties on the IBM EMM Configuration
page

Each partition has a set of reports properties that specifies the location of the
report folders. You must edit the values of each of the reports properties to reflect
the actual path of the folders by inserting the string that identifies the new
top-level partition folder.

Campaign example

If the new partition folder in Cognos Connection is named "Campaign Partition 2",
you would edit the report property settings as shown in the following example.

folder[@name='Campaign Partition 2']/

For example, to update the offerAnalysisTabCachedFolder property, you would
change the value from

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='offer']/folder[@name='cached']

to

/content/folder[@name='Campaign Partition 2']/folder[@name='Affinium
Campaign - Object Specific Reports']/folder[@name='offer']/
folder[@name='cached']

eMessage example

If the new partition folder in Cognos Connection is named "Campaign Partition 2",
you would edit the report property settings as shown in the following example.

folder[@name='Campaign Partition 2']/

For example, to update the campaignAnalysisTabEmessageOnDemandFolder property,
you would change the value from

/content/folder[@name='Affinium Campaign']/folder[@name='eMessageReports']

to

/content/folder[@name='Campaign Partition 2']/folder[@name='Affinium
Campaign']/folder[@name='eMessage Reports']

To update the partition's report properties
1. Log in to IBM EMM as the platform_admin user.
2. Select Settings > Configuration .
3. Expand Campaign > partitions > partitionName > reports
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4. Edit the value of each of the properties in this section so they reflect the actual
path to the reporting folders as described above.

5. Save your changes.
6. Repeat steps 3 through 5 for each partition.
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Appendix A. Reporting configuration properties

For reporting, the IBM EMM suite integrates with IBM Cognos, a third-party
business intelligence application. You use the Cognos properties to identify the
IBM Cognos system used by your IBM installation. Then, for Campaign, eMessage,
and Interact, there are additional configuration properties that you use to set up
and customize reporting schemas.

Reports | Integrations | Cognos [version]
This page displays properties that specify URLs and other parameters for the IBM
Cognos system used by this IBM system.

Integration Name

Description

Read-only. Specifies that IBM Cognos is the third-party reporting or
analytical tool used by the IBM EMM to display the reports.

Default value

Cognos

Vendor

Description

Read-only. Specifies that IBM Cognos is the name of the company that
provides the application specified by the Integration Name property.

Default value

Cognos

Version

Description

Read-only. Specifies the product version of the application specified by the
Integration Name property.

Default value

<version>

Enabled

Description

Specifies whether IBM Cognos is enabled for the suite.

Default value

False

Valid Values

True | False
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Integration Class Name

Description

Read-only. Specifies the fully-qualified name of the Java™ class that creates
the integration interface used to connect to the application specified by the
Integration Name property.

Default value

com.unica.report.integration.cognos.CognosIntegration

Domain

Description

Specifies the fully-qualified company domain name in which your Cognos
server is running. For example, myCompanyDomain.com.

If your company uses subdomains, the value in this field must include the
appropriate subdomain as well.

Default value

[CHANGE ME]

Valid Values

A string no longer than 1024 characters.

Portal URL

Description

Specifies the URL of the IBM Cognos Connection portal. Use a fully
qualified host name, including the domain name (and subdomain, if
appropriate) that is specified in the Domain property. For example:
http://MyReportServer.MyCompanyDomain.com/cognos<version>/cgi-bin/
cognos.cgi

You can find the URL in IBM Cognos Configuration at: Local
Configuration > Environment .

Default value

http://[CHANGE ME]/cognos<version>/cgi-bin/cognos.cgi

Valid Values

A well-formed URL.

Dispatch URL

Description

Specifies the URL of the IBM Cognos Content Manager. Use a fully
qualified host name, including the domain name (and subdomain, if
appropriate) specified in the Domain property. For example:
http://MyReportServer.MyCompanyDomain.com:9300/p2pd/servlet/dispatch

You can find the URL in Cognos Configuration at: Local Configuration >
Environment .

Default value

http://[CHANGE ME]:9300/p2pd/servlet/dispatch
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Note that 9300 is the default port number for the Cognos Content
Manager. Be sure that the port number specified matches that used in the
Cognos installation.

Valid Values

A well-formed URL.

Authentication mode

Description

Specifies whether the IBM Cognos application is using the IBM
Authentication Provider, which means it relies on the Marketing Platform
for authentication.

Default value

anonymous

Valid Values

v anonymous: means authentication is disabled.
v authenticated: means that the communications between the IBM system

and the Cognos system are secured at the machine level. You configure a
single system user and configure it with the appropriate access rights.
By convention, this user is named "cognos_admin."

v authenticatedPerUser: means that the system evaluates individual user
credentials.

Authentication namespace

Description

Read only. The namespace of the IBM Authentication Provider.

Default value

Unica

Authentication user name

Description

Specifies the login name for the reporting system user. The IBM
applications log in to Cognos as this user when Cognos is configured to
use the Unica Authentication provider Note that this user also has access
to IBM EMM.

This setting applies only when the Authentication mode property is set to
authenticated .

Default value

cognos_admin

Authentication datasource name

Description

Specifies the name of the data source for the reporting system user that
holds the Cognos login credentials.

Default value

Cognos
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Enable form authentication

Description

Specifies whether form-based authentication is enabled. You set this
property to True when either of the following is true:
v When the IBM EMM is not installed in the same domain as the

IBMCognos applications.
v When IBMCognos is accessed using an IP address (within the same

network domain) instead of the Fully Qualified Hostname (which is
being used to access the IBM EMM applications), even if both the IBM
EMM applications and the IBMCognos installation are on the same
machine.

However, when the value is True, the login process to Cognos Connection
passes the login name and password in clear text and therefore is not
secure unless IBMCognos and the IBM EMM are configured to use SSL
communication.

Even with SSL configured, the user name and password appear as clear
text in the HTML source code when you "view source" in a displayed
report. For this reason, you should install IBM Cognos and IBM EMM in
the same domain.

Default value

False

Valid Values

True | False

Reports | Schemas | [product] | [schema name] | SQL Configuration
Table/View Name

Description

Specifies the name of the view or table that the SQL script you generate for
this reporting schema will create. As a best practice, you should not change
the name for any of the standard or default Table/View names. If you do,
you must also change the name of the view in the Cognos model in IBM
Cognos Framework Manager.

When you create a new reporting schema for a new audience level, you
must specify the names of all the new reporting tables/views.

Default value

Varies by schema

Valid Values

A string with the following restrictions.
v It can be no longer than 18 characters
v It must use all UPPER-CASE letters

Following is the naming convention you should use:
v Start the name with the letter "UAR"
v Add a one-letter code to represent the IBM EMM application. See the list

of codes, below.
v Add an underscore character
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v Add the table name, including a one or two letter code to indicate the
audience level

v Finish with an underscore character.

The SQL generator appends a time dimension code, if appropriate. See the
list of codes, below.

For example: UARC_COPERF_DY is the name of the reporting view or table for
Campaign Offer Performance by Day.

Following is the list of IBM EMM application codes.
v Campaign: C
v eMessage: E
v Interact: I
v Distributed Marketing: X
v Marketing Operations: P
v Leads: L

Following is the list of the Time Dimension Codes added by the generator.
v Hour: HR
v Day: DY
v Week: WK
v Month: MO
v Quarter: QU
v Year: YR

Reports | Schemas | Campaign
Input Datasource (JNDI)

Description

Specifies the name of the JNDI data source that identifies the Campaign
database, specifically, the system tables. This data source must exist if you
want to use the SQL generation tool to generate scripts that create
reporting tables. The SQL generation tool can generate scripts that create
reporting views without this data source, but it cannot validate them.

The database type of this data source must match the database type you
select when you generate the SQL scripts for the Campaign views or
reporting tables.

Default value

campaignPartition1DS

Reports | Schemas | Campaign | Offer Performance
The Offer Performance Schema yields contact and response history metrics for all
offers and for offers by campaign. By default, the schema is configured to generate
a “summary” view (or table) across all time.

Audience Key

Description

Specifies the name of the column that is the Audience Key for the audience
level supported by this reporting schema.
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Default value

CustomerID

Valid Values

A string value no longer than 255 characters

If the key includes more than one column, use commas between the
column names. For example, ColumnX,ColumnY.

Contact History Table

Description

Specifies the name of the Contact History table for the audience level
supported by this reporting schema.

Default value

UA_ContactHistory

Detailed Contact History Table

Description

Specifies the name of the Detailed Contact History table for the audience
level supported by this reporting schema.

Default value

UA_DtlContactHist

Response History Table

Description

Specifies the name of the Response History table for the audience level
supported by this reporting schema.

Default value

UA_ResponseHistory

Over Time Variations

Description

Specifies the calendar time periods used by the "over time" reports
supported by this schema.

Default value

Day, Month

Valid Values

Day, Week, Month, Quarter, Year

Reports | Schemas | Campaign | [schema name] | Columns | [Contact
Metric]

Use this form to add contact metrics to the Campaign Performance or Offer
Performance reporting schemas.
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Column Name

Description

Specifies the name to use in the reporting view or table for the column
specified in the Input Column Name field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Function

Description

Specifies how the contact metric is determined or calculated.

Default value

count

Valid Values

count, count distinct, sum, min, max, average

Input Column Name

Description

The name of the column that provides the contact metric you are adding to
this reporting schema.

Default value

[CHANGE ME]

Valid Values

The name of the column in the Contact History and Detailed Contact
History tables.

Control Treatment Flag

Description

If you use the sample IBM Cognos reports or create your own custom
reports that include control groups, then each contact metric must have
two columns in the reporting schema. One column represents the metric
for the control group and the other column represents the metric for the
target group. The value in Control Treatment Flag specifies whether the
column in the view represents the control group or the target group.

If your reports do not include control groups, you do not need the second
column for the control group.

Default value

0

Valid Values

v 0: the column represents the target group
v 1: the column represents the control group

Appendix A. Reporting configuration properties 81



Reports | Schemas | Campaign | [schema name] | Columns |
[Response Metric]

Use this form to add the response metrics you want to include in your reports to
the Campaign Performance or Offer Performance reporting schemas.

Column Name

Description

Specifies the name to use in the reporting view or table for the column
specified in the Input Column Name field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Function

Description

Specifies how the response metric is determined or calculated.

Default value

count

Valid Values

count, count distinct, sum, min, max, average

Input Column Name

Description

The name of the column that provides the response metric you are adding
to this reporting schema.

Default value

[CHANGE ME]

Valid Values

The name of the column in the Response History table.

Control Treatment Flag

Description

If you use the standard IBM Cognos reports or create your own custom
reports that include control groups, then each response metric must have
two columns in the reporting schema. One column represents the response
from the control group and the other column represents the response from
the target group. The value in Control Treatment Flag specifies whether
the column in the view represents the control group or the target group.

If your reports do not include control groups, you do not need the second
column for the control group.

Default value
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0

Valid Values

v 0: the column represents the target group
v 1: the column represents the control group

Reports | Schemas | Campaign | Campaign Performance
The Campaign Performance schema yields contact and response history metrics at
the campaign, campaign-offer, and campaign-cell level.

Audience Key

Description

Specifies the name of the column that is the Audience Key for the audience
level supported by this reporting schema.

Default value

CustomerID

Valid Values

A string value no longer than 255 characters

If the key includes more than one column, use commas between the
column names. For example, ColumnX,ColumnY.

Contact History Table

Description

Specifies the name of the Contact History table for the audience level
supported by this reporting schema.

Default value

UA_ContactHistory

Detailed Contact History Table

Description

Specifies the name of the Detailed Contact History table for the audience
level supported by this reporting schema.

Default value

UA_DtlContactHist

Response History Table

Description

Specifies the name of the Response History table for the audience level
supported by this reporting schema.

Default value

UA_ResponseHistory

Over Time Variations

Description
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Specifies the calendar time periods used by the "over time" reports
supported by this schema.

Default value

Day, Month

Valid Values

Day, Week, Month, Quarter, Year

Reports | Schemas | Campaign | Campaign Offer Response Breakout
This schema supports reporting on campaign-detailed responses, broken out by
response type and by offer data. This schema template gives different response
counts for each custom Response Type for campaigns and offers grouped by
campaign.

Response History Table

Description

Specifies the name of the Response History table for the audience level
supported by this reporting schema.

Default value

UA_ResponseHistory

Reports | Schemas | Campaign | Campaign Offer Response Breakout |
Columns | [Response Type]

Use this form to add to the reporting schema any custom response types you want
to include in your reports.

Column Name

Description

Specifies the name to use in the reporting view or table for the column
specified in the Response Type Code field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Response Type Code

Description

The response type code for the specified response type. This is the value
held in the ResponseTypeCode column in the UA_UsrResponseType table.

Default value

[CHANGE ME]

Valid Values

The example response type codes are as follows:
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v EXP (explore)
v CON (consider)
v CMT (commit)
v FFL (fulfill)
v USE (use)
v USB (unsubscribe)
v UKN (unknown)

Your Campaign installation may have additional custom response type
codes.

Control Treatment Flag

Description

If you use the standard IBM Cognos reports provided in the IBM EMM
Reports Pack or custom reports that include control groups, then each
response type must have two columns in the reporting schema. One
column represents the response type from the control group and the other
column represents the response type from the target group. The value in
Control Treatment Flag specifies whether the column in the view
represents the control group or the target group.

If your reports do not include control groups, you do not need the second
column for the control group.

Default value

0

Valid Values

v 0: the column represents the target group
v 1: the column represents the control group

Reports | Schemas | Campaign | Campaign Offer Contact Status
Breakout

This schema supports reporting on campaign-detailed contacts, broken out by
contact status type and by offer data. This schema template gives different contact
counts for each custom Contact Status Type for campaigns and offers grouped by
campaign.

By default, none of the example Campaign reports use this schema.

Audience Key

Description

Specifies the name of the column that is the Audience Key for the audience
level supported by this reporting schema.

Default value

CustomerID

Valid Values

A string value no longer than 255 characters
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If the key includes more than one column, use commas between the
column names. For example, ColumnX,ColumnY.

Contact History Table

Description

Specifies the name of the Contact History table for the audience level
supported by this reporting schema.

Default value

UA_ContactHistory

Detailed Contact History Table

Description

Specifies the name of the Detailed Contact History table for the audience
level supported by this reporting schema.

Default value

UA_DtlContactHist

Reports | Schemas | Campaign | Campaign Offer Contact Status
Breakout | Columns | [Contact Status]

Column Name

Description

Specifies the name to use in the reporting view or table for the column
specified in the Contact Status field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Contact Status Code

Description

The name of the contact status code. This is the value held in the
ContactStatusCode column in the UA_ContactStatus table.

Default value

[CHANGE ME]

Valid Values

The example contact status types are as follows.
v CSD (campaign send)
v DLV (delivered)
v UNDLV (undelivered)
v CTR (control)

Your Campaign installation may have additional custom contact status
types.
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Reports | Schemas | Campaign | Campaign Custom Attributes |
Columns | [Campaign Custom Column]

Use this form to add to the reporting schema any custom campaign attributes that
you want to include in your reports.

Column Name

Description

Specifies the name to use in the reporting view or table for the attribute
identified in the Attribute ID field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Attribute ID

Description

The value from the attribute's AttributeID column in the
UA_CampAttribute table.

Default value

0

Value Type

Description

The data type of the campaign attribute.

Default value

StringValue

Valid Values

StringValue, NumberValue, DatetimeValue

If this campaign attribute holds a currency value, select NumberValue.

If this campaign attribute's Form Element Type was set to Select Box -
String in Campaign, select StringValue.

Reports | Schemas | Campaign | Campaign Custom Attributes |
Columns | [Offer Custom Column]

Use this form to add to the reporting schema any custom offer attributes that you
want to include in your reports.

Column Name

Description

Specifies the name to use in the reporting view or table for the attribute
identified in the Attribute ID field.
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Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Attribute ID

Description

The value from the attribute's AttributeID column in the
UA_OfferAttribute table.

Default value

0

Value Type

Description

The data type of the offer attribute.

Default value

StringValue

Valid Values

StringValue, NumberValue, DatetimeValue

If this offer attribute holds a currency value, select NumberValue.

If this offer attribute's Form Element Type was set to Select Box - String
in Campaign, select StringValue.

Reports | Schemas | Campaign | Campaign Custom Attributes |
Columns | [Cell Custom Column]

Use this form to add to the reporting schema any custom cell attributes that you
want to include in your reports.

Column Name

Description

Specifies the name to use in the reporting view or table for the attribute
identified in the Attribute ID field.

Default value

[CHANGE ME]

Valid Values

The name can be no longer than 18 characters, it must be in all
UPPER-CASE letters, and it cannot have spaces.

Attribute ID

Description

The value from the attribute's AttributeID column in the
UA_CellAttribute table.
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Default value

0

Value Type

Description

The data type of the cell attribute.

Default value

StringValue

Valid Values

StringValue, NumberValue, DatetimeValue

Reports | Schemas | Interact
The Interact reporting schemas reference three separate databases: the design time,
run time, and learning databases. Use the properties from this page to specify the
JNDI names of the data sources for those databases.

The data sources specified on this page must exist if you want to use the Reporting
SQL generation tool to generate scripts that create reporting tables. The SQL
generation tool can generate scripts that create reporting views without these data
sources, but it cannot validate the scripts.

Note that the database type of the data sources must match the database type you
select when you generate the SQL scripts for the views or reporting tables.

Interact Design Datasource (JNDI)

Description

Specifies the name of the JNDI data source that identifies the Interact
design time database, which is also the Campaign system tables.

Default value

campaignPartition1DS

Interact Runtime Datasource (JNDI)

Description

Specifies the name of the JNDI data source that identifies the Interact
runtime database.

Default value

InteractRTDS

Interact Learning Datasource (JNDI)

Description

Specifies the name of the JNDI data source that identifies the Interact
learning database.

Default value

InteractLearningDS
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Reports | Schemas | Interact | Interact Performance
The Interact Performance schema yields contact and response history metrics at the
channel, channel-offer, channel-segment, channel-interaction point, interactive cell,
interactive cell-offer, interactive cell-interaction point, interactive offer, interactive
offer-cell and interactive offer-interaction point levels.

Audience Key

Description

Specifies the name of the column that is the Audience Key for the audience
level supported by this reporting schema.

Default value

CustomerID

Valid Values

A string value no longer than 255 characters.

If the key includes more than one column, use commas between the
column names. For example, ColumnX,ColumnY.

Detailed Contact History Table

Description

Specifies the name of the Detailed Contact History table for the audience
level supported by this reporting schema.

Default value

UA_DtlContactHist

Response History Table

Description

Specifies the name of the Response History table for the audience level
supported by this reporting schema.

Default value

UA_ResponseHistory

Over Time Variations

Description

Specifies the calendar time periods used by the "over time" reports
supported by this schema.

Default value

Hour, Day

Valid Values

Hour, Day, Week, Month, Quarter, Year

Reports | Schemas | eMessage
eMessage Tracking Datasource (JNDI)

Description
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Specifies the name of the JNDI data source that identifies the eMessage
tracking tables, which are located in the Campaign system tables. This data
source must exist if you want to use the Reports SQL generation tool to
validate scripts that create reporting tables. The SQL generation tool can
generate scripts that create reporting views without this data source, but it
cannot validate them.

The database type of this data source must match the database type you
select when you generate the SQL scripts for the views or reporting tables.

Default value

campaignPartition1DS

Campaign | partitions | partition[n] | reports
These configuration properties define folders for reports.

offerAnalysisTabCachedFolder

Description

The offerAnalysisTabCachedFolder property specifies the location of the
folder that contains the specification for bursted (expanded) offer reports
listed on the Analysis tab when you reach it by clicking the Analysis link
on the navigation pane. The path is specified using XPath notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='offer']/folder[@name='cached']

segmentAnalysisTabOnDemandFolder

Description

The segmentAnalysisTabOnDemandFolder property specifies the location of
the folder that contains the segment reports listed on the Analysis tab of a
segment. The path is specified using XPath notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='segment']/folder[@name='cached']

offerAnalysisTabOnDemandFolder

Description

The offerAnalysisTabOnDemandFolder property specifies the location of the
folder that contains the offer reports listed on the Analysis tab of an offer.
The path is specified using XPath notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='offer']

segmentAnalysisTabCachedFolder

Description

The segmentAnalysisTabCachedFolder property specifies the location of the
folder that contains the specification for bursted (expanded) segment
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reports listed on the Analysis tab when you reach it by clicking the
Analysis link on the navigation pane. The path is specified using XPath
notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='segment']

analysisSectionFolder

Description

The analysisSectionFolder property specifies the location of the root
folder where report specifications are stored. The path is specified using
XPath notation.

Default value

/content/folder[@name='Affinium Campaign']

campaignAnalysisTabOnDemandFolder

Description

The campaignAnalysisTabOnDemandFolder property specifies the location of
the folder that contains the campaign reports listed on the Analysis tab of a
campaign. The path is specified using XPath notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='campaign']

campaignAnalysisTabCachedFolder

Description

The campaignAnalysisTabCachedFolder property specifies the location of
the folder that contains the specification for bursted (expanded) campaign
reports listed on the Analysis tab when you reach it by clicking the
Analysis link on the navigation pane. The path is specified using XPath
notation.

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='campaign']/folder[@name='cached']

campaignAnalysisTabEmessageOnDemandFolder

Description

The campaignAnalysisTabEmessageOnDemandFolder property specifies the
location of the folder that contains the eMessage reports listed on the
Analysis tab of a campaign. The path is specified using XPath notation.

Default value

/content/folder[@name='Affinium Campaign']/folder[@name='eMessage
Reports']
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campaignAnalysisTabInteractOnDemandFolder

Description

Report server folder string for Interact reports.

Default value

/content/folder[@name='Affinium Campaign']/folder[@name='Interact
Reports']

Availability

This property is applicable only if you have installed Interact.

interactiveChannelAnalysisTabOnDemandFolder

Description

Report server folder string for Interactive Channel analysis tab reports

Default value

/content/folder[@name='Affinium Campaign - Object Specific
Reports']/folder[@name='interactive channel']

Availability

This property is applicable only if you have installed Interact.
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Appendix B. Formatting the Cognos reports

The IBM Cognos reporting integration components include a global report
stylesheet, GlobalReportStyles.css. When you create new IBM Cognos reports for
your IBM EMM applications, your reports should use the styles from this css file
with some additional manual formatting. That way the styles in the new reports
match those used by the reports provided in the IBM EMM reports packages.

This appendix provides the following information for the various kinds of reports
(lists, charts, and so on).
v The styles implemented with the GlobalReportStyles.css file.
v Style formatting is something that you must do manually when you author a

report, because there are certain cases in which the style cannot be provided by
the stylesheet.

Global report styles

Item CSS class name Style

General font family pg, pp font-family: Arial, ...

Report title ta font-size: 10pt;

Page – Header ph padding-bottom:10px;

font-size:8pt;

font-weight:bold;

Page – Footer pf padding-top:10px;

font-size:8pt;

font-weight:bold;

Field Set Labels fs font-size:8pt;

Table tb border-collapse:collapse

Table - List Column
Title Cell

lt text-align:left;

background-color:#F2F2F2; /*light grey*/

font-weight:bold;

border-top:1px solid silver;

border-left:1px solid silver;

border-bottom:1.5pt solid black;

border-right:1px solid silver;

padding-top: 13px;

Table - List Column
Body Cell

lc, lm border:1px solid silver;

Table – Outer header oh background-color:#FFFFCC; /*light yellow*/

Table – List Footer of, os border-top:1.5pt solid black;

Crosstab xt border-collapse:collapse;
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Item CSS class name Style

Crosstab – Default
Measure Cell

xm border-top:1px solid silver;

border-left:1px solid silver;

border-bottom:1.5pt solid black;

border-right:1.5pt solid black;

Crosstab – Member
Label Cell

ml
background-color: transparent;

border:1px solid silver;

Crosstab – Outer Level
Total

ol background-color:#F7F7F7; /*offwhite*/

Crosstab – Spacer xs
background-color: transparent;

font-weight: bold;

Chart ch border:1pt solid #E4E4E4;

Chart – Title ct
font-size:10pt;

font-weight:bold;

Chart – Axis Labels al font-size:10pt;

Chart – Axis Line at color:#939393;

Chart - Gradient In XML Report
Specification

Before the closing chart tag (</combinationChart>) in the XML
Report Specification, paste the following:

<fillEffects>

<chartGradient direction="up" fromColor="#F2F2F2"
toColor="#FFFFFF"/>

</fillEffects>
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Item CSS class name Style

Chart – Chart Palette In XML Report
Specification

Before the closing chart tag (</combinationChart>) in the XML
Report Specification, paste the following:

<chartPalette>

<chartColor value="#00508A"/>

<chartColor value="#376C37"/>

<chartColor value="#FB9A4D"/>

<chartColor value="#B8351F"/>

<chartColor value="#69817B"/>

<chartColor value="#473E9A"/>

<chartColor value="#5384AE"/>

<chartColor value="#61C2A3"/>

<chartColor value="#FF5656"/>

<chartColor value="#A583BB"/>

<chartColor value="#506079"/>

<chartColor value="#A0A080"/>

<chartColor value="#F1EDC1"/>

<chartColor value="#A6A6A6"/>

<chartColor value="#818181"/>

</chartPalette>

Report page styles

Item Style

Text Arial font

Report title text Arial 10 point

Page footer text Arial 8 point

Field Set labels Arial 8 point

List report styles
List reports obtain the following formatting from the GlobalStyleSheet.css:

Item Style

Cells 1 px silver line borders (unless otherwise
noted)

Column header Light gray background; 1.5 pt black line
separates column header from rest of table

Summary header rows (list headers) Light yellow background
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Item Style

Total row at bottom Dark gray background; 1.5 pt black line
separates row from rest of table

Additionally, when you create a new list report, do the following to make it match
the existing reports:
v Use List Headers (and not List Footers) to display summarizations at the object

level.
v Manually right-justify any numbers displayed in List Headers. Unlike List

Footers, List Headers are not separated into the outer component and summary
component, which use a right-justified style by default. So when summarizing
information into a List Header, you must perform this extra step and
right-justify the values.

v Optionally add 1.5 pt solid black borders to group columns

Following is a list report that does not use the global styles.

Following is a list report that uses the global styles.
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Crosstab report styles
Crosstab reports obtain the following formatting from the GlobalStyleSheet.css.

Item Style

Cells Transparent background; 1 px silver line
borders

Measure cell (upper left) 1.5 pt black line separates the cell from the
rest of the crosstable

Outer level totals Gray/offwhite background

Additionally, when you create a new list report, do the following to make it match
the existing reports.
v Use 1.5 pt black borders to separate summarizations from measures.
v Use 1.5 black borders to group logical column groupings.
v General guideline: avoid summarizing both columns and rows in the same

report.

Following is a crosstab report that does not use the global styles.
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Following is a crosstab report that uses the global styles and has 1.5 px borders
applied to show column groupings.

Chart styles
Charts obtain the following formatting from the GlobalStyleSheet.css.

Item Style

Charts 1 pt light gray border

Titles and labels 10 point bold font

Additionally, when you create a new chart, do the following to make it match the
existing chart reports.
v Use the default width, unless there is more than one chart on the report. When

you include multiple charts in a single report, set the chart width to 750px.
v To use gradients and color palettes, copy and paste the strings from the table in

“Global report styles” on page 95 into the XML report specification.
v General guideline: select the chart type based on the data you expect to be

returned.
– Use line graphs as the chart type only when you can guarantee the report

will retrieve continuous data.
– If there are multiple series, a stacked bar works better than a non-stacked

bar.
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– As a best practice, use percentages only when the total percentage equals
100%. Pie charts tend to confuse people when the values do not add up to
100%.

v

If there are only two series on a chart and you display both the Y1 and Y2 axes,
as a best practice you should match the colors to the first two palette colors for
the axis labels.

Following is a chart that does not use the global styles.

Following is a chart that uses the global styles and has additional formatting
applied.

Dashboard report styles
Dashboard reports use the global styles with some manual formatting. Be sure to
format reports that will be displayed in the Dashboard according to the following
guidelines so they fit properly in Dashboard portlets.

Item Style

Background color Keep background color set to gray (hex
value F2F2F2).
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Item Style

Size Specify size by using percentages whenever
possible. When sizing with a percentage is
not possibe, set the size to 323 pixels wide
by 175 pixels tall.

Subtitles Put subtitles on the left side.

Dates Put dates on the right side.

Legends Center legends below the chart.

Lines in line charts Display horizontal lines only. Do not display
vertical lines.

Axis line color Keep axis lines set to black.

Grid line color Keep grid lines set to gray (hex value
D9D9D9).

Lists (tables) Display a maximum of 10 lines.
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Appendix C. Reports and reporting schemas by product

The reporting schemas in the Campaign Report Package can be customized in the
following ways.
v Add contact or response metrics
v Add custom campaign, offer, or cell attributes
v Add response types
v Configure the audience level for performance reports
v Create reporting schemas for additional audience levels.

The following table maps the individual IBM Cognos BI reports provided in the
Campaign Reports Package to the reporting schemas that support them.

Campaign
Views schema

Campaign
Custom
Attributes
schema

Campaign
Perform- ance
schema

Offer Perform-
ance schema

Campaign
Offer
Response
Breakout

Offer Contact
Status
Breakout

What If Offer
Financial
Summary
report

X X X

Campaign
Detailed Offer
Response
Breakout

X X X

Offer Response
Breakout,
Dashboard
version

X X X

Campaign
Financial
Summary by
Offer (Actual)

X X X

Campaign
Return on
Investment
Compar- ison

X X X

Campaign
Offer Perform-
ance by Month

X X

Campaign
Perform- ance
Compar- ison

X X

Campaign
Response Rate
Compar- ison

X X

Campaign
Perform- ance
Compar- ison
with Revenue

X X

© Copyright IBM Corp. 1999, 2012 103



Campaign
Views schema

Campaign
Custom
Attributes
schema

Campaign
Perform- ance
schema

Offer Perform-
ance schema

Campaign
Offer
Response
Breakout

Offer Contact
Status
Breakout

Campaign
Perform- ance
Compar- ison
by Initiative

X X

Campaign
Perform- ance
Summary by
Cell

X X

Campaign
Perform- ance
Summary by
Cell with
Revenue

X X

Campaign
Perform- ance
Summary by
Cell and
Initiative

X X

Campaign
Perform- ance
Summary by
Offer

X X

Campaign
Perform- ance
Summary by
Offer with
Revenue

X X

Campaign
Revenue
Compar- ison
by Offer

X X

Campaign
Summary

X

Offer
Campaign
Listings

X

Offer Perform-
ance Metrics

X X

Offer
Performan- ce
by Day

X X

Offer
Responses for
Last 7 Days

X X

Offer Perform-
ance Compar-
ison

X X

Offer Response
Rate Compar-
ison

X X
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Campaign
Views schema

Campaign
Custom
Attributes
schema

Campaign
Perform- ance
schema

Offer Perform-
ance schema

Campaign
Offer
Response
Breakout

Offer Contact
Status
Breakout

Offer Perform-
ance Summary
by Campaign

X X X

The following reports rely on the standard set of custom contact and response
metric attributes that are provided in Campaign:
v What If Offer Financial Summary
v Campaign Detailed Offer Response Breakout
v Campaign Financial Summary by Offer (Actual)
v Campaign Performance Comparison with Revenue
v Campaign Performance Summary by Cell with Revenue
v Campaign Performance Summary by Offer with Revenue

eMessage Reports and Reporting Schemas
The following table maps the individual IBM Cognos BI reports provided in the
eMessage Reports Package to the IBM reporting schemas that support them.

Mailing Performance Schema

Message Overview report X

Detailed Link report X

Detailed Link by Cell report X

Detailed Bounce report X

A/B Testing Performance
Report

X

Interact Reports and Reporting Schemas
You can customize the reporting schemas in the Interact Report Package in the
following ways:
v Specify calendar time periods for performance reports
v Configure the audience level for performance reports
v Create additional performance reporting schemas for additional audience levels

The following table maps the individual IBM Cognos BI reports provided in the
Interact Reports Package to the IBM reporting schemas that support them.
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Interactive
View schema

Interact
Performance
View schema

Interactive
Channel /
Campaign
Deployment
History

Interact
Runtime
View schema

Interact
Learning
View schema

Campaign -
Interactive
Channel
Deployment
History

X X

Campaign -
Interactive
Cell
Performance
Over Time

X X X

Campaign -
Interactive
Cell
Performance
by Offer

X X X

Campaign -
Interactive
Offer
Performance
Over Time

X X X

Campaign -
Interactive
Offer
Performance
by Cell

X X X

Campaign -
Interactive
Offer
Learning
Details

X X

Interactive
Cell Lift
Analysis

X X X X

Interactive
Channel -
Channel
Deployment
History

X X

Interactive
Channel -
Channel
Event
Activity
Summary
report

X X
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Interactive
View schema

Interact
Performance
View schema

Interactive
Channel /
Campaign
Deployment
History

Interact
Runtime
View schema

Interact
Learning
View schema

Interactive
Channel -
Channel
Interaction
Point
Performance
Summary

X X X

Interactive
Channel -
Channel
Treatment
Rule
Inventory

X

Interactive
Segment Lift
Analysis

X X X

Interaction
Point
Performance

X X X
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Contacting IBM technical support

If you encounter a problem that you cannot resolve by consulting the
documentation, your company’s designated support contact can log a call with
IBM technical support. To ensure that your problem is resolved efficiently and
successfully, you collect information before you log your call.

If you are not a designated support contact at your company, contact your IBM
administrator for information.

Information to gather

Before you contact IBM technical support, gather the following information:
v A brief description of the nature of your issue.
v Detailed error messages that you see when the issue occurs.
v Detailed steps to reproduce the issue.
v Related log files, session files, configuration files, and data files.
v Information about your product and system environment, which you can obtain

as described in "System information."

System information

When you call IBM technical support, you might be asked to provide information
about your environment.

If your problem does not prevent you from logging in, much of this information is
available on the About page, which provides information about your IBM
applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, you can obtain the version number of any IBM application by viewing
the version.txt file that is located under the installation directory for each
application.

Contact information for IBM technical support

For ways to contact IBM technical support, see the IBM Product Technical Support
website: (http://www.ibm.com/support/entry/portal/open_service_request).

Note: To enter a support request, you must log in with an IBM account. If
possible, this account must be linked to your IBM customer number. To learn more
about associating your account with your IBM customer number, see Support
Resources > Entitled Software Support on the Support Portal.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information about the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
170 Tracer Lane
Waltham, MA 02451
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
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been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at www.ibm.com/legal/copytrade.shtml.

Privacy Policy and Terms of Use Considerations
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. A cookie is a piece of data that a web site can
send to your browser, which may then be stored on your computer as a tag that
identifies your computer. In many cases, no personal information is collected by
these cookies. If a Software Offering you are using enables you to collect personal
information through cookies and similar technologies, we inform you about the
specifics below.

Depending upon the configurations deployed, this Software Offering may use
session and persistent cookies that collect each user’s user name, and other
personal information for purposes of session management, enhanced user usability,
or other usage tracking or functional purposes. These cookies can be disabled, but
disabling them will also eliminate the functionality they enable.

Various jurisdictions regulate the collection of personal information through
cookies and similar technologies. If the configurations deployed for this Software
Offering provide you as customer the ability to collect personal information from
end users via cookies and other technologies, you should seek your own legal
advice about any laws applicable to such data collection, including any
requirements for providing notice and consent where appropriate.

IBM requires that Clients (1) provide a clear and conspicuous link to Customer’s
website terms of use (e.g. privacy policy) which includes a link to IBM’s and
Client’s data collection and use practices, (2) notify that cookies and clear gifs/web
beacons are being placed on the visitor’s computer by IBM on the Client’s behalf
along with an explanation of the purpose of such technology, and (3) to the extent
required by law, obtain consent from website visitors prior to the placement of
cookies and clear gifs/web beacons placed by Client or IBM on Client’s behalf on
website visitor’s devices

For more information about the use of various technologies, including cookies, for
these purposes, See IBM’s Online Privacy Statement at: http://www.ibm.com/
privacy/details/us/en section entitled “Cookies, Web Beacons and Other
Technologies."
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