
IBM Contact Optimization
Version 9 Release 0
January 15, 2013

Release Notes

���



Note
Before using this information and the product it supports, read the information in “Notices” on page 9.

This edition applies to version 9, release 0, modification 0 of IBM Contact Optimization and to all subsequent
releases and modifications until otherwise indicated in new editions.

© Copyright IBM Corporation 2003, 2013.
US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.



Contents

System requirements and compatibility 1
New features and changes in version 9.0.0 . . . . 1

Using Campaign with multiple browser windows 2
Fixed defects . . . . . . . . . . . . . . 3
Known issues . . . . . . . . . . . . . . 3
Known limitations . . . . . . . . . . . . 5

Contacting IBM technical support . . . 7

Notices . . . . . . . . . . . . . . . 9
Trademarks . . . . . . . . . . . . . . 11
Privacy Policy and Terms of Use Considerations . . 11

© Copyright IBM Corp. 2003, 2013 iii



iv IBM Contact Optimization: Release Notes



System requirements and compatibility

This section provides the following information for this release of IBM® Contact
Optimization:
v Where to find system requirement and compatibility information
v Changes in support for third-party software

Contact Optimization operates as part of the IBM EMM suite of products.

Contact Optimization version 9.0.0 requires Campaign 9.0.0.

You can upgrade to Contact Optimization 9.0.0 from Contact Optimization version
8.5 or later. For instructions, see the IBM Contact Optimization Installation Guide.

Contact Optimization supports 64-bit operating systems only for production
installations.

Where to find complete system requirement and compatibility
information

For a list of IBM EMM product versions compatible with this product and a list of
third-party requirements for this product, see the Recommended Software
Environments and Minimum System Requirements document. This document is posted
under Detailed System Requirements on the IBM Support Portal website:
(http://support.ibm.com).

Note: To access the IBM EMM documentation from the Support Portal, you must
log in with an IBM account. This account must be linked to your IBM customer
number. To learn more about associating your account with your IBM customer
number, see Support Resources > Entitled Software Support on the Support
Portal.

You can also access this document by selecting Help > Product documentation
when you are logged in to IBM EMM.

New features and changes in version 9.0.0
The following new features and changes are introduced in version 9.0.0 of IBM
Contact Optimization.

IBM Unica® Optimize renamed

IBM Unica Optimize is now known as IBM Contact Optimization.

The default installation directory is renamed to ContactOptimization.

Optimize sessions are now labeled Contact Optimization sessions.

ContinueOnGenerationLoopError

There is a new configuration property, ContinueOnGenerationLoopError. You can
use ContinueOnGenerationLoopError to continue a Contact Optimization session if
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you receive the The generation loop was unable to eliminate all slack and
surplus variables error. See the IBM Contact Optimization Troubleshooting Guide for
more details.

Flowchart changes

The IBM Campaign flowchart workspace is redesigned to change the look and feel
and improve usability.

The framework is now based on a Dojo component instead of Active-X.

The redesign includes changes to the appearance of flowchart and report
components, including toolbars, dialog boxes, progress indicators, and related
controls. The overall functionality is unchanged. However, some minor
functionality is different. For details, see the IBM Campaign Release Notes and the
IBM Campaign User's Guide.

Russian language support

The Russian language is now supported. For information about setting locale
preferences, see the IBM Marketing Platform Administrator's Guide.

Using Campaign with multiple browser windows
To use multiple browser windows with IBM Campaign 9.0.0, you must use File >
New Session to open additional Internet Explorer windows.

Internet Explorer 9.0 (32-bit) on Windows Vista or Windows 7 clients is the only
supported browser for IBM Campaign 9.0.0 flowcharts.

If you want to log in to IBM Campaign multiple times to view side-by-side
information, you must use the following method to open multiple browser
sessions.

Important: Do not use any other method to open multiple browser sessions. For
example, do not use a new tab in Internet Explorer; do not open another browser
session from the Start menu or desktop icon; and do not use File > New Window
in Internet Explorer. If you use these methods, IBM Campaign treats the new
browser instance as the same browser session. Use of these methods can confuse or
corrupt information that is shown in the application.
1. Open Internet Explorer 9 from the Start menu or desktop icon.
2. Log in to IBM Campaign.
3. In the browser window that you opened in Step 1, select File > New Session in

the Internet Explorer menu bar.
A new Internet Explorer instance opens.

4. In the new browser window, log in to Campaign as the same or different user.

Remember: You must disable any pop-up blockers in your browser or browser
add-ons, such as toolbars. Pop-up blockers prevent the flowchart window from
opening.
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Fixed defects
This section lists defects that are fixed in IBM Contact Optimization version 9.0.0.
The defects are sorted by defect number then by incident number (if applicable).

Issue ID Description

DEF063320 Top third of "All Optimize Sessions" title was truncated in Chinese, Japanese, and Korean
locales

RTC11540, PMR47204 Optimize server crash due to FEC Min/Max rule on AIX®

Known issues
This section lists known issues in Contact Optimization 9.0.0.

Issue Issue ID Description

Create Contact Optimization session
fails with multi-byte audience level
name.

DEF023178 If a non-English language with multiple-byte characters is
used to name an audience level, Contact Optimization fails
to create Contact Optimization sessions that contain that
audience level. To work around this issue, use English or
single-byte character sets to name your audience levels.

Running a Create Segment process on
an unmapped segment membership
table can impact the results of the
Contact Optimization session.

DEF050437 If you have not mapped an audience level system table to a
segment membership table, running the Create Segment
process against the table populates the system table, but not
the segment membership table. This results in inaccurate
optimization results. If you map the system and segment
membership tables later, you must rerun the Create Segment
process.

Error messages for the
ACOOptAdmin utility do not display
according to non-English locales.

DEF051284 When you run the ACOOptAdmin command-line utility in
a locale other than English, error messages do not display
according to the specified locale. The error messages display
only in English.

Contact Optimization listener does
not automatically use the same
non-English locale that is used by
Campaign listener.

DEF051876 In installations where Campaign and Contact Optimization
are installed with a non-English locale, the Contact
Optimization listener always starts in English instead of the
installed locale.

To work around this issue, in the command window or
batch file (ACOServer.bat or ACOServer.sh) used to start the
Contact Optimization listener, set LANG=xx_XX as follows.

v Brazilian Portuguese - pt_BR

v French - fr_FR

v German - de_DE

v Italian - it_IT

v Japanese - ja_JP

v Korean - ko_KR

v Simplified Chinese - zh_CN

v Spanish - es_ES

On UNIX systems, use the following commands.

LANG=xx_XX

export LANG
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Issue Issue ID Description

ACOOptAdmin fails with
NoClassDefFoundError error.

DEF054145 Unable to run ACOOptAdmin when Contact Optimization
is installed in a path that contains directory names with
spaces.

Workaround - In ACOOptAdmin.bat specify the values for the
variables OPTIMIZE_HOME and JAVA_HOME with double
quotation marks.

Contact Optimization session run
fails to start with specific non-ascii
user credentials.

DEF054275 Contact Optimization session fails to start if the Marketing
Platform user name or password contains the Euro (€)
symbol. This behavior happens on UNIX platforms only.

Workaround - Do not use the Euro symbol in the Marketing
Platform user name and password.

unprocessables_sessionid.csv might
contain some customers who receive
offers.

DEF054841 In some scenarios, a few of the customers who get offers
might be present in the unprocessables_sessionid.csv file.

Contact Optimization session fails
with TRYING TO REMOVE STALE
PROPOSED RECORDS FROM PCT error.

DEF057685,
INC62199

In some scenarios, the Contact Optimization session
attempts to create indexes on the PCT that already exist.

Incorrect optimization result with
Custom Capacity rule in specific
circumstances.

DEF058362 A customer that satisfies the following criteria might receive
fewer offers than wanted:

v The customer has an even number of proposed
transactions.

v Each of these transactions has the same score.

v This score is a low value.

Some labels display incorrectly in
Japanese, Chinese, and Korean.

DEF059595 Some translated labels are displaying incorrectly. For
example, when you edit the score matrix manually, the
vertical label on the right side of the table displays upside
down. Also, for optimization rules that contain customers in
the segment, the segment label displays on two lines.

Offer filtering summary report
displays an incorrect count of
Proposed Contacts that are removed
by each Custom Capacity rule.

DEF059805 The Offer Summary Report displays incorrect counts in the
"Removed By This Rule" column for Custom Capacity rules
if the participating Flowchart for this Contact Optimization
session contains multiple contact dates and multiple offers
that are made to each customer on different channels.

Contact Optimization session fails if
there are conflicting rules.

DEF060267 If you create conflicting rules in your Contact Optimization
session, you are not warned and the session fails. The only
notification is in the log file: (9232) [E] [INTERFACE]
ERROR: The generation loop was unable to eliminate all
slack and surplus variables: CODE 999: Extended Error.

Issues with offer version query
builder.

DEF060676 There are several minor issues with the offer version query
builder:

v For custom attributes with the Form Element Type of
Select Box, the offer version query builder does not use
the select box. You must enter the value manually.

v When the group level is removed, the subgroup
conditions are added to the parent condition, and vice
versa.

v All arithmetic operators are displayed for a string
variable, but only equal and not equal apply.

v Defined length validations for attributes are not verified
upon input for conditions.
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Issue Issue ID Description

Offer version rules that contain dates
do not provide expected optimization
results.

DEF061554 If you create an offer version condition that includes a date,
such as the offer parameter "valid end date" equals
"12/31/2011", Contact Optimization does not return the
expected result.

Contact Optimization session run
fails with a Response XML is missing
the data xml element error.

DEF061116 If you receive this error, contact Technical Support. Also,
send your Contact Optimization server logs for analysis.

Rule exceptions that span calendar
years give incorrect results.

DEF061639 If you create a rule exception to a Min/Max # Offers
capacity rule that spans calendar years, such as 07/01/2011
to 06/30/2012, Contact Optimization does not return the
expected result.

Known limitations
This section lists known limitations in Contact Optimization 9.0.0.

Issue Number Description

Negative scores cause
inaccurate rules crediting.

If you use negative scores, rule crediting in the Offer
Filtering Summary report might not be accurate.

Offers with negative scores are given to meet minimum
requirements only.

Cells that are linked to TCS
with offer assignments do
not appear in Optimize
process.

DEF027481, DEF061355 If the Optimize process is connected to one or more cells
and the upstream cells are later linked to top-down cells
defined in the Target Cell Spreadsheet process (TCS), the
offers that are assigned in the TCS do not automatically
appear in the Optimize process. Link to any top-down cells
in the TCS before you connect those cells to an Optimize
process. Otherwise, you must either manually assign the
same offers within the Optimize process, or delete the
Optimize process and re-create it.

Unattended installation
clears installer properties file.

DEF042448 When you run the IBM EMM installer in unattended
mode, the installer properties files are deleted. Before you
run the IBM EMM installer in unattended mode for the
first time, make backup copies of all the .properties files
under the IBM EMM installation directory. Restore the
.properties files each time that you run the installer in
unattended mode.

Running the ACOOptAdmin
utility with one-way SSL
requires more setup.

DEF046832 You cannot use the ACOOptAdmin utility with one-way SSL
until you register a security certificate, specify a host name
and domain, and configure SSL_Options in the
ACOOptAdmin.bat file.

Channel is a required offer
attribute.

DEF051136 Any offer that is optimized within IBM Contact
Optimization must include a channel offer attribute (for
example, any offer template that is used with IBM
Campaign must have the "channel" offer attribute
included). Channel can be a hidden offer attribute if you
choose. For more information about setting offer template
attributes, see the IBM Campaign Administrator’s Guide.

Contact Optimization session
performance degrades if you
set the logging level to ALL.

DEF054539 If you set your logging level to ALL, it takes longer for
your Contact Optimization session to run because of the
high volume of data that is written to the log file. Set your
logging level to ALL only if you are trying to determine
the cause of unexpected results or other errors.
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Issue Number Description

Unable to run the session in
first attempt when
unica_acosvr process
stopped.

DEF055010 If you use the kill command to stop unica_acosvr, the
next time you attempt to run a Contact Optimization
session, it might fail with the following error An unknown
communication failure has occurred with the IBM
Optimize server process.

Workaround - Run the Contact Optimization session again
to complete it successfully.

Repeated starts and stops of
a Contact Optimization
session might cause the
session to hang or the
Contact Optimization server
process to crash.

DEF057799 If you start and stop a Contact Optimization session
several times with the Contact Optimization UI, the
ACOOptAdmin utility, and again with the UI, the session
run might hang or the Contact Optimization server process
might crash. This behavior is not consistently reproducible,
but has been observed on Solaris.

Any customer with a score
equal to zero is removed by
any Min/Max # Offers
Capacity rule.

DEF060320, INC68786 Do not use scores equal to zero in Contact Optimization
sessions.
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Contacting IBM technical support

If you encounter a problem that you cannot resolve by consulting the
documentation, your company’s designated support contact can log a call with
IBM technical support. To ensure that your problem is resolved efficiently and
successfully, you collect information before you log your call.

If you are not a designated support contact at your company, contact your IBM
administrator for information.

Information to gather

Before you contact IBM technical support, gather the following information:
v A brief description of the nature of your issue.
v Detailed error messages that you see when the issue occurs.
v Detailed steps to reproduce the issue.
v Related log files, session files, configuration files, and data files.
v Information about your product and system environment, which you can obtain

as described in "System information."

System information

When you call IBM technical support, you might be asked to provide information
about your environment.

If your problem does not prevent you from logging in, much of this information is
available on the About page, which provides information about your IBM
applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, you can obtain the version number of any IBM application by viewing
the version.txt file that is located under the installation directory for each
application.

Contact information for IBM technical support

For ways to contact IBM technical support, see the IBM Product Technical Support
website: (http://www.ibm.com/support/entry/portal/open_service_request).

Note: To enter a support request, you must log in with an IBM account. If
possible, this account must be linked to your IBM customer number. To learn more
about associating your account with your IBM customer number, see Support
Resources > Entitled Software Support on the Support Portal.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information about the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
170 Tracer Lane
Waltham, MA 02451
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
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been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at www.ibm.com/legal/copytrade.shtml.

Privacy Policy and Terms of Use Considerations
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. A cookie is a piece of data that a web site can
send to your browser, which may then be stored on your computer as a tag that
identifies your computer. In many cases, no personal information is collected by
these cookies. If a Software Offering you are using enables you to collect personal
information through cookies and similar technologies, we inform you about the
specifics below.

Depending upon the configurations deployed, this Software Offering may use
session and persistent cookies that collect each user’s user name, and other
personal information for purposes of session management, enhanced user usability,
or other usage tracking or functional purposes. These cookies can be disabled, but
disabling them will also eliminate the functionality they enable.

Various jurisdictions regulate the collection of personal information through
cookies and similar technologies. If the configurations deployed for this Software
Offering provide you as customer the ability to collect personal information from
end users via cookies and other technologies, you should seek your own legal
advice about any laws applicable to such data collection, including any
requirements for providing notice and consent where appropriate.

IBM requires that Clients (1) provide a clear and conspicuous link to Customer’s
website terms of use (e.g. privacy policy) which includes a link to IBM’s and
Client’s data collection and use practices, (2) notify that cookies and clear gifs/web
beacons are being placed on the visitor’s computer by IBM on the Client’s behalf
along with an explanation of the purpose of such technology, and (3) to the extent
required by law, obtain consent from website visitors prior to the placement of
cookies and clear gifs/web beacons placed by Client or IBM on Client’s behalf on
website visitor’s devices

For more information about the use of various technologies, including cookies, for
these purposes, See IBM’s Online Privacy Statement at: http://www.ibm.com/
privacy/details/us/en section entitled “Cookies, Web Beacons and Other
Technologies."
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