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Chapter 1. System requirements and compatibility

IBM® Marketing Operations operates as part of the IBM EMM suite of products.
v Marketing Operations version 9.0.0 requires IBM Marketing Platform 9.0.0.
v For reporting, Marketing Operations 9.0.0 uses the 9.0.0 version of the Marketing

Operations and the Marketing Operations/Campaign reports packages.

You can upgrade to Marketing Operations 9.0.0 from any 8.x. or 7.5.x version as
follows.

Table 1. Supported upgrade paths for Marketing Operations 9.0.0

Source version Upgrade path

8.x.x Upgrade to version 9.0.0.

7.5.x You must upgrade to Marketing Operations 8.5.0 before you
can upgrade to Marketing Operations 9.0.0.

For instructions, see the IBM Marketing Operations Installation Guide. For
information about upgrading to version 8.5.0, see the IBM Marketing Operations 8.5
Installation Guide.

Where to find complete system requirement and compatibility
information

For a list of IBM EMM product versions compatible with this product and a list of
third-party requirements for this product, see the Recommended Software
Environments and Minimum System Requirements document. This document is posted
under Detailed System Requirements on the IBM Support Portal website:
(http://support.ibm.com).

Note: To access the IBM EMM documentation from the Support Portal, you must
log in with an IBM account. This account must be linked to your IBM customer
number. To learn more about associating your account with your IBM customer
number, see Support Resources > Entitled Software Support on the Support
Portal.

You can also access this document by selecting Help > Product documentation
when you are logged in to IBM EMM.

For more information
Different people in your organization use IBM Marketing Operations to accomplish
different tasks. Information about Marketing Operations is available in a set of
guides, each of which is intended for use by team members with specific objectives
and skill sets.
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Table 2. Guides in the Marketing Operations documentation set

If you See Audience

v Plan and manage projects

v Establish workflow tasks,
milestones, and personnel

v Track project expenses

v Get reviews and approvals for
content

v Produce reports

IBM Marketing Operations User's Guide v Project managers

v Creative designers

v Direct mail marketing managers

v Design templates, forms,
attributes, and metrics

v Customize the user interface

v Define user access levels and
security

v Implement optional features

v Configure and tune Marketing
Operations

IBM Marketing Operations
Administrator's Guide

v Project managers

v IT administrators

v Implementation consultants

v Create marketing campaigns

v Plan offers

v Implement integration between
Marketing Operations and
Campaign

v Implement integration between
Marketing Operations and IBM
Digital Recommendations

IBM Marketing Operations and IBM
Campaign Integration Guide

v Project managers

v Marketing execution specialists

v Direct marketing managers

v Learn about new system features

v Research known issues and
workarounds

IBM Marketing Operations Release Notes Everyone who uses Marketing
Operations

v Install Marketing Operations

v Configure Marketing Operations

v Upgrade to a new version of
Marketing Operations

IBM Marketing Operations Installation
Guide

v Software implementation
consultants

v IT administrators

v Database administrators

Create custom procedures to
integrate Marketing Operations with
other applications

IBM Marketing Operations Integration
Module and the API JavaDocs
available when you click Help >
Product Documentation in Marketing
Operations, and then download the
IBM <version>PublicAPI.zip file

v IT administrators

v Database administrators

v Implementation consultants

Learn about the structure of the
Marketing Operations database

IBM Marketing Operations System
Schema

Database administrators
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Table 2. Guides in the Marketing Operations documentation set (continued)

If you See Audience

Need more information while you
work

v Get help and search or browse the
User's, Administrator's, or Installation
guides: Click Help > Help for this
page

v Access all of the Marketing
Operations guides: Click Help >
Product Documentation

v Access guides for all IBM
Enterprise Marketing Management
(EMM) products: Click Help > All
IBM EMM Suite Documentation

Everyone who uses Marketing
Operations
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Chapter 2. New features and changes in version 9.0.0

IBM Marketing Operations 9.0.0 contains new features for calculating and
monitoring the health of projects, defining and tracking why approvals are denied,
and accessing frequently used features quickly. The 9.0.0 release includes changes
to the Marketing Operations user interface. The 9.0.0 release also includes updates
to the out of office and data migration features introduced by the 8.6 release.

Monitoring overall project health

In addition to the statuses that indicate the lifecycle stage of a project, IBM
Marketing Operations now calculates a health status for projects. One of the
following health statuses can be calculated for a project:
v Healthy
v Warning
v Critical
v Unknown

To assess the overall health of a project objectively, Marketing Operations compares
project data to thresholds for key performance indicators (KPIs). For example, a
project with <1% of its tasks overdue and 0% of its milestones overdue is Healthy.
However, if more than 5% of its tasks, or 3% of its milestones, are overdue, the
project is in a Critical status.

System administrators define the rules for project health status calculations and
associate them with specific project templates, and therefore with the projects that
use those templates. Administrators also configure the automated calculations to
run every day and periodically throughout each day. For projects that they own,
users can initiate the health status calculation as needed during the day.

To review the health status of projects, project owners and participants can:
v Subscribe to daily email notifications that list the results of the automated daily

calculation.
v Click Operations > Projects and view a project list. The new Project Health

column shows the status that is calculated during the most recent automated
periodic update.

v View detailed information for a project and click its new Health Status tab.
v Add the new Health Status portlet to the dashboard.

To facilitate analysis, project health status reports are available to compare the
statuses that are calculated for different projects within a month or trending over
time.

For information about implementing project health rules, see the IBM Marketing
Operations Administrator's Guide. For information about using different methods to
monitor project health, see the IBM Marketing Operations User's Guide.

Requiring a reason when an approval is denied

As the outcome of an approval, users select one of these options:
v Approved
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v Approved with Changes
v Denied

Users can now be required to select a Deny reason when they reject items they
receive for approval. Organizations define their own reasons in the new Approval
Deny Reason defined list. This feature can be enabled separately for stand-alone
approvals and for approval tasks. The new Deny Reason Analysis Report gives
administrators metrics on the reasons that users select over time, or for a specific
project or stand-alone approval.

For information about configuring the approval process, see the IBM Marketing
Operations Administrator's Guide. For information about working with approvals,
see the IBM Marketing Operations User's Guide.

Adding Quick Links to the dashboard

A new type of Marketing Operations portlet, Quick Links, is available in the 9.0
release. When added to the dashboard, each Quick Links portlet provides
single-click access to such frequently used options as Create New Project and Add
Invoice.

For more information about this new portlet, see the IBM Marketing Operations
User's Guide.

Option for new projects to replace workflow

In addition to project templates, a Marketing Operations installation can maintain a
set of independent workflow template components. While a project is still in Not
Started status, users can assess whether the workflow supplied by the template is
adequate, or if a different workflow provides a better starting point. With the
project Workflow tab in edit mode, users can now select the new Tools > Import
and save workflow option to replace all spreadsheet rows and values with data
from a workflow template. After work on a project begins, this option is no longer
available.

Enhanced user interface presentation

The 9.0 release includes several enhancements to the way that Marketing
Operations presents options and information. In this release, most of the
enhancements affect the project Workflow tab, but other updates affect projects,
requests, and other object types. For information about how to use the new user
interface controls, see the IBM Marketing Operations User's Guide.

Toolbar icons and options updated

The toolbar that displays when a project Workflow tab is in spreadsheet view
mode or in edit mode now includes a revised layout and new icons. The new
design consolidates similar actions. For example, the edit mode toolbar now
includes a single Add Row icon instead of three different icons. When users click

Add Row ( ), a list displays the three row types: Task, Approval, or Stage. The
new design also provides an identifying text label below each icon.

Distinguishing stages from tasks
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To differentiate stages from tasks on a workflow spreadsheet, the rows for stages
now display with a shaded background.

Task status icons updated

New icons are now used to identify the status of each task in a workflow
spreadsheet:

v Active

v Skipped

v Finished

New Change Status control for projects and requests

When users select a project or request, the user interface control for making status
changes is now a drop-down list. This new Change Status control displays on the
right side of the page, above the tabs. On the listing page, and for all other object

types, users continue to click the Status icon ( ) to make status changes.

New status icons for all object types

To make the status of object type instances more prominent, a new set of
color-coded icons display next to the status. For example:

In Progress

Enhanced data migration features

When an administrator selects Settings > Marketing Operations Settings > Data
Migration, each listed object type is now a hyperlink to another page in the user
interface. Administrators can use these links to access information about existing
marketing object types, templates, teams, and so on before they export or import
the associated metadata.

In addition, the metadata for the project health rules that are defined on a
Marketing Operations system can now be exported in an archive file and imported
into another system that is running the same version of Marketing Operations.

For information about exporting and importing metadata, see the IBM Marketing
Operations Administrator's Guide.

Enhanced out of office features

Project and request owners can now track team members or request recipients who
are out of the office on the People tab. The selected delegate and start date also
display. Administrators can produce the new Out of Office Users and Delegation
Summary to track this information for all users who have the out of office
parameter set.

For information about projects and the People tab, see the IBM Marketing
Operations User's Guide. For information about producing administrative reports,
see the IBM Marketing Operations Administrator's Guide.
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Redesigned properties files

In the 9.0 release, three locale-specific properties files replace the individual XML
files that previously stored data for different types of data.

Table 3. Data stored by the new properties files

Type of data Properties file

Standard marketing object
types, such as plans,
programs, and projects

<MarketingOperations_Home>/messages/com/ibm/umo/
ext/UMOConfigurationMessages_<locale>.properties

Custom marketing object
types

<MarketingOperations_Home>/messages/com/ibm/umo/
ext/UMOMktObjectConfigurationMessages_<locale>.properties

System error and warning
messages

<MarketingOperations_Home>/messages/com/ibm/umo/
ext/UMOMessages_<locale>.properties

The UMOConfigurationMessages_<locale>.properties and
UMOMktObjectConfigurationMessages_<locale>.properties files contain ui and
list parameters for each marketing object type in the system. These parameters
define the labels and strings that identify marketing object types in the user
interface. To customize these labels and strings for your organization,
administrators edit the files for the default locale. For organizations that support
multiple locales, administrators edit the file for each supported locale to provide
localized translations. These new files replace the <object>sui.xml and
<object>list.xml files.

The localized UMOMessages_<locale>.properties files contain the text of system
messages. Changes to these files are not recommended. These files replace the
<MarketingOperations_Home>/messages/<name>.xml files.

For information about customizing the IBM Marketing Operations user interface,
see the IBM Marketing Operations Administrator's Guide.

Supporting API operations on folders

The IBM Marketing Operations API now includes support for operations on
folders.
v The IPlanAPI interface now provides methods for creating, finding, and listing

folders.
v The new FolderHandle class can be used for persistent references to folder

objects.

For information about the Marketing Operations API, see the IBM Marketing
Operations Integration Module.

8 IBM Marketing Operations: Release Notes



Chapter 3. New features for IBM Marketing Operations-
Campaign systems

For IBM Marketing Operations systems that integrate with IBM Campaign and that
enable features for offers, the 9.0 release includes integration with IBM Digital
Recommendations, enhancements to the creative URL attribute type, and
enhancements to the API.

Integrating with IBM Digital Recommendations

This feature is available for organizations that also use IBM Digital
Recommendations, formerly known as IBM Coremetrics® Intelligent Offer.

Administrators can now configure offer templates so that users can select category
IDs and names that are supplied from an IBM Digital Recommendations system,
rather than entering those values manually. To configure the offer template,
administrators populate the new Coremetrics® Clients defined list with Client IDs
and names from an implementation of IBM Digital Recommendations.
Administrators then supply the URL for the IBM Digital Recommendations
instance and one or more valid Client IDs.

For information about integrating IBM Marketing Operations with IBM Digital
Recommendations, see the IBM Marketing Operations and Campaign Integration
Guide.

Enhanced attribute type for Creative URL

A "Creative URL" is a link to a digital asset, such as a product logo, brand image,
marketing research document, or document template. When an offer template
includes a custom form with the Creative URL offer attribute, users select a digital
asset from the Marketing Operations asset libraries to include in each offer. In
release 9.0, Marketing Operations now provides a standard Creative URL attribute
type. When you create a new Creative URL attribute, this new attribute type
provides the user interface controls for users to select an asset, and then to display
a hyperlink to that asset.

The new Creative URL attribute type is only available for use with the standard
Creative URL attribute.

When published to Campaign, the attribute type for the Creative URL offer
attribute changes to Text Field - String.

For information about using the Creative URL attribute type, see the IBM
Marketing Operations and Campaign Integration Guide.

Supporting API operations on offers

The IBM Marketing Operations API now includes support for operations on offers.
v The IPlanAPI interface now provides methods for creating, discovering, and

modifying offers.
v The new OfferStateEnum enumerated data type defines valid offer states.
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For information about the Marketing Operations API, see the IBM Marketing
Operations Integration Module.
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Chapter 4. Fixed defects

The following defects are fixed in IBM Marketing Operations version 9.0.0.

Table 4. Defects corrected in Marketing Operations version 9.0.0

Issue ID Description

INC72647, ENH11460 The maximum length restriction no longer applies to the Project Description field that is
available when users create and edit projects, or to the Comments field that is available
when users create and edit project requests.

ENH11677 By default, workflow approval alerts now contain links to the project name and code.
Stand-alone approvals include "Linked Project: None" in the alert message.

INC50183, INC62678,
DEF061415

The duplication of Marketing Operations user groups and subgroups that sometimes
occurred after synchronizing users with Marketing Platform is fixed. The user group
hierarchy now displays correctly.

In addition, selection list controls in the Marketing Operations user interface now show
user groups in alphabetical order.

INC55525 Approvals with an attached password-protected PDF file, or a PDF with any security
settings, can now be finished. Previously, the status of approvals with secure PDF
attachments could not be changed.

INC55906, INC59729 When a workflow task is skipped, the owner of the next task is now alerted that the task
can begin. Previously, the next task owner was only alerted when a task was finished.

PMR45166, INC70242 For assets, the maximum length of the Keywords and Usage fields is increased to 1024
characters.

INC66360, DEF059946 When the Auto Create option is selected for a form attribute with the Single Select Object
Reference attribute type, the Template ID list now includes templates in folders as well as
templates at the root level. Previously, only templates at the root level could be selected.

INC63115, DEF057902 Workflow task URL attachments can now be accessed from either the Workflow tab or the
Attachments tab. Previously, the URL on the Attachments tab was incorrect and resulted in
a 404 error.

INC55417, DEF055123 When a request is approved, the values that are supplied for all custom attributes are now
correctly transferred to the project. Previously, if the project template included the same
attribute in more than one form, any value that was entered for the request was
overwritten by the default value when the request became a project.

INC69970, DEF060549 The listGridRow() method in the Marketing Operations API now maps specified search
criteria to database queries with the advanced search framework. Previously, in-memory
filtering was used to search for grid rows, which could result in performance issues.

INC49458, DEF056812 The project Analysis tab now reports every attachment that is sent as an email attachment.
Previously, the Analysis tab reported the email history for attachments to the project, but
not for attachments to project tasks.

INC62484, DEF057825 When users configure calendar settings and enable color coding, the attributes that can be
selected now also identify the form and template, in the format <attribute name>
(<form_name>, <template_ID>). Previously, shared attributes that were on more than one
form or template were included in this list multiple times, but only the attribute name
displayed.

INC37409, DEF041215 When project workflow tasks display in the calendar view, only tasks that are specified to
be shown are included. Previously, all tasks were included on the calendar, even for
projects that were created from a template that used the API-enabled workflow hiding
feature.
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Table 4. Defects corrected in Marketing Operations version 9.0.0 (continued)

Issue ID Description

INC70706, DEF060903 The calculation that determines the Forecast/Actual End date for a workflow task from the
entered Forecast/Actual Start date now correctly applies daylight saving time. Previously,
when the Forecast/Actual Start date was supplied as the date on which the time change
occurred, the Forecast/Actual End date was calculated as one day later than expected.

INC50638, DEF052708 When Marketing Operations is accessed from a Macintosh Safari browser, icons on the
right side of the window display without requiring scrolling. Previously, the width of the
Marketing Operations pages was not sized to the width of the browser window.

ENH11698 When the status of a project is changed to Completed or Cancelled, a new option, Cancel
all task/approvals linked to the project which are not completed/cancelled, displays.
When selected, all of the Pending or Not Started tasks, and all of the Active, In Progress, or
On Hold approvals for the project, are also Completed or Cancelled.

ENH06030, ENH06031 Task owners can no longer edit workflow tasks in a project that is in Completed or
Cancelled status. In addition, task owners cannot reassign tasks in the owner task list for
Cancelled projects.

DEF063732, ENH07609 The attachments that are listed on the Attachments tab of each object type are now sorted
in descending order by date added.

ENH11438 When all of the dependencies for a task are in Finished or Skipped status, the task is
"ready to start". Users can now subscribe to notifications for tasks that are ready to start.
Previously, tasks that were ready to start when they were assigned did not generate
notifications.

INC58219, DEF056149 Values that are entered for a custom form attribute with the Single-Select attribute type are
now sorted in ascending alphabetical order.

INC58216, DEF056991 When two users change the status of a project at the same time, the system now does an
edit check and displays an error message to one of the users.

INC51297, ENH09685,
DEF060056

The system now renders comments that entered with Adobe markup consistently.
Previously, comments that were entered before an approval was completed displayed
differently than comments entered after the approval was complete.

INC70718, DEF060824 For Marketing Operations systems that are configured with Tivoli® Access Manager, the
calendar view now displays approvals correctly.

INC72179, DEF061057 Assets that are modified after creation by a different user now display both the name of
the creator and the name of the modifier correctly.

INC72033, DEF061172 When a request has two recipients, and both are teams, members of both teams are now
notified. Previously, only the members of the first team received the request notifications.

DEF062153 In a project template, apostrophes can now be included in rules that are built on the
Request tab. Previously, when a rule contained an apostrophe, it did not display properly.

DEF062303, DEF062319 When the API is used to populate the Target End date for a workflow task without also
providing the Target Start date, automated date recalculations now complete correctly.

In addition, Target End dates are now calculated correctly based only on the Target Start
date. Previously, if the API was used to populate the Target Start date and initiate date
calculations, the Target End date was calculated incorrectly.

DEF062443 Forms that contain attributes with either the Single-Select or Yes or No attribute type can
now be exported and then reimported successfully. Previously, forms with these attributes
could not be reimported.

DEF063032 When a form that is in use by an offer template is edited, the error message that displays
in French locales is in French. Previously, the error message was in Italian.

DEF063582 In systems that integrate Marketing Operations with Campaign, Marketing Operations now
displays an error message when campaigns do not fulfill defined conditions. Previously,
the trigger did not prevent campaign creation and failed to display an error message.
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Table 4. Defects corrected in Marketing Operations version 9.0.0 (continued)

Issue ID Description

DEF063615 The project People tab now displays members and roles correctly when it is populated by
the API. Previously, excessive rows of "unassigned" members were displayed on the People
tab when the members and reviewers were populated with the IPlanAPI.setMembersByRole
and IPlanAPI.setReviewersByRole API methods.

5762 On the project People tab, groups are now sorted for all users. Previously, groups were not
sorted in the display for users who were restricted by the User Visibility security option.

Chapter 4. Fixed defects 13
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Chapter 5. Known issues

This table contains known issues in IBM Marketing Operations version 9.0.0.

Table 5. Known issues in Marketing Operations version 9.0.0

Issue Issue ID Description

Error on Return to
Previous Page

1054 An error results when a user with no security permissions clicks Return to
Previous Page on the Dashboard.

Invoices can be added
through QuickLinks

1082 The QuickLinks portal can include an Add Invoice link. This link is
presented to, and is usable by, users who do not have permission to access
the Financial Management module.

Project health status
reports display blank

2500, 9071 When the Project Health (Monthly) or Project Health (Trend) report is
requested for a large number of projects (>750), a blank report page can
display instead of an error message. A blank page can also display when
users cancel the Project Health (Trend) report.

Dialog for selecting
project templates for
health rules is not
localized

9314 The dialog for selecting project templates for health rules displays the
default rule in English for a user with the Spanish locale setting.

Project health reports
require DB2®

5317 The Project Health (Monthly) and Project Health (Trend) reports result in
exception errors when run in an environment that created the Cognos®

data source with OLE DB.

Workaround: modify the data source and re-create it with SQLserver using
the Microsoft Native Client option.

Horizontal scroll bar not
provided for deny reason

1011 When an administrator maps deny reasons for approvals to templates, the
Deny reason list box does not display the full value.

Errors in history that is
shown on approval
Analysis tab

1095 The response history for a stand-alone approval that is denied displays
incorrectly on the Analysis tab. The status changes are not sequenced
correctly, and the Status Changed message displays as "Waiting to Denied"
rather than "Denied".

Dropdown lists
incomplete for the Out
Of Office Users and
Delegation Summary

1030 The dropdown list controls for Projects/Requests and Approvals on the
Out Of Office Users and Delegation Summary page do not present all of
the available values. This issue occurs when multiple projects, requests, or
approvals have the same name: only the most recently added item
displays in the list.

User cannot add
approver after a
workflow template is
imported

1818 This issue applies to workflow templates that have the Project/Approval
Owner can add and/or delete approvers option cleared for any approval,
and that are imported into one Marketing Operations system into another.

When such a template is imported, the system-defined approver settings
are not imported from the source system. Because the Project/Approval
Owner can add and/or delete approvers option is cleared, users cannot
add or remove approvers for those approvals.

To work around this issue, verify that the Project/Approval Owner can
add and/or delete approvers option is selected in the workflow templates
you import, and add any required users.

Workflow template
import into project does
not validate values

6381 The system does not validate the values in a workflow template when it is
imported into a project template or instance.
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Table 5. Known issues in Marketing Operations version 9.0.0 (continued)

Issue Issue ID Description

View in XML Format
not working for project
health reports

5323 An error occurs when users select the View in XML Format option for the
Project Health (Monthly) and Project Health (Trend) reports.

Error occurs when
templates are moved

1923 An error occurs when a template is repeatedly moved between different
folders.

Error occurs when the
Calendar is invoked

1209 An error can occur when a user views the list of Active Projects and
Requests and then attempts to view the calendar.

Dates on import
workflow template
dialog are not localized

6182 When a user attempts to import a workflow template into a project or
project template, a list of the workflow templates displays. The creation
dates that display for the templates are in the format for the system locale,
rather than for the user locale.

Blank page displays on
dialog if project status is
changed twice

1031 When a user changes the status of a project, the system initiates the
process. If the same or another user immediately attempts to change the
project status again, the dialog is not refreshed correctly and a blank page
displays.

Error for installation
under the pt_BR locale

9311 If the pt_BR locale is selected during the installation of Marketing
Operations, an error occurs.

Lock is not released if
approval is closed with
icon

6058 When a user is in spreadsheet view mode on the project Workflow tab and
opens an approval task, the system locks the approval. If the user clicks
the dialog close icon (X) to close the approval, the lock remains in effect.
As a workaround, users can click Cancel to close this dialog.

Require reason for
denying an approval
feature cannot be
disabled

N/A When Marketing Operations is configured to require a reason when users
deny an approval, users must select a value for the deny reason. After
users begin to use this feature, the system cannot be reconfigured to
disable this feature.

My Health Portlet does
not show latest data on
refresh

3545, 5503 The Percentage Completed value is not updated in the My Health Portlet
when users click Refresh. In addition, an error can occur when users click
Refresh for this portlet.

Project name is not
displayed in report

5489 The Project Health (Monthly) report displays only the first 48 characters of
project names as labels on the X axis. However, project names in multibyte
character sets that are longer than 48 characters do not display.

Report title is not
localized

6236 The Project Health (Monthly) report (drilldown) includes a title that is not
correctly localized. It includes the words "Health Report" in English.

Template names are not
localized in filter

9327 The Project Health (Monthly) report includes a drop-down list for Project
Templates. The project template names in this list are not localized and
display in English.

Non-fatal error during
upgrade to 9.0 can be
ignored

13681 During an upgrade from IBM Marketing Operations version 8.x to 9.0.0
using either manual or automatic database setup, a non-fatal error can be
reported. This error can occur when the config_migration utility imports
the new Marketing Operations configuration properties into Marketing
Platform. This error has no functional effect and can be ignored.

Presentation of workflow
icons

7367, 7572,
9200, 9235

The space that is allocated for the labels of icons on the project Workflow
tab is not large enough for the text labels of every supported language. As
a workaround for labels that are difficult to read because of this problem,
place your cursor over the icon to see a tooltip.

In addition, icons display in two rows at the top of the project Workflow
tab rather than as a single horizontal toolbar.

16 IBM Marketing Operations: Release Notes



Table 5. Known issues in Marketing Operations version 9.0.0 (continued)

Issue Issue ID Description

NOT EXISTS produces
duplicate results in DB2
v10.1

N/A In systems that use DB2 v10.1, the NOT EXISTS operator produces
duplicate results. Results can be incorrect for queries that include a NOT
EXISTS clause.

As a workaround, you can set the DB2_ANTIJOIN registry parameter to NO
and restart the DB2 server. For example,

<DB2-HOME>\BIN>db2set DB2_ANTIJOIN=NO

Returning to the Task list
results in an error

12741 When you click Operations > Tasks and select a task, the project displays
on the left side of the window and task details open in a dialog on the
right. When you click Return to the Task List on the dialog, an error
results.

Adding a custom
marketing object instance
to an approval results in
an error

13604 When you add an approval and click Add item(s) to approve, you can
specify different types of objects. If you select one of the custom marketing
objects on your system, an error results when you save the new approval.

Cloning a project that
has a custom form on
the Summary tab can
result in an error

13606 An error occurs when users attempt to clone a project that has all of the
following characteristics:

v The project is created from a project template that includes a custom
form on the Summary tab.

v The custom form includes an attribute with the Decimal attribute type.

v No default value is supplied for the Decimal attribute.

Subgroup authentication DEF022909,
INC20721

Creating an Admin subgroup in IBM Marketing Platform does not
automatically add the users in that subgroup as Marketing Operations
administrators. You must specifically grant Admin access to the subgroup.

Legacy metrics that are
mapped to response
history retain deleted
values

DEF046008,
INC55503

If the response history table is cleared in Campaign, any metrics in
Marketing Operations that are mapped to the response history table retain
those deleted values.

Wrong database and port
information are
populated on the
installer screen

DEF060953 During the upgrade to version 8.6, the default values that display on the
Marketing Platform and Marketing Operations installation screens are not
valid. Variables added for the 8.6 release cause this problem.

As a workaround, you can use:

-DUNICA_REPLAY_DIR="D:\<MarketingOperations_Home>\qa\plan85\
UMO85_31Oct\installers"

or, edit installer.properties to add:

UNICA_REPLAY_DIR=D:\\<MarketingOperations_Home>\\qa\\plan85\\
UMO85_31Oct\\installers
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Table 5. Known issues in Marketing Operations version 9.0.0 (continued)

Issue Issue ID Description

Upgraded server issue DEF063700 After the upgrade to version 8.6, the Internet Explorer browser can render
certain user interface controls incorrectly. These problems include:

v The icon for Clone this project, Rename folder, or Add offer list dos not
display

v Shared attributes in forms are not accessible

v Offer folders cannot be moved

To resolve these problems, reset your personal settings in Internet
Explorer:

1. In Internet Explorer, select Tools > Internet options.

2. Click the Advanced tab.

3. Click Reset.

4. Select Delete personal settings and then click Reset.

5. Restart Internet Explorer.

Out of office delegation
does not apply to ready
to start tasks

DEF061374 Marketing Operations users can now define out of office settings,
including specifying delegates for their activities. When all of the
dependencies for a task are in Finished or Skipped status, the task is
"ready to start". Tasks that are assigned to a user who is out of the office
when they become ready to start are reassigned to the delegate
automatically. However, tasks that are ready to start and then manually
assigned to a user who is out of the office are not automatically reassigned
to the delegate.

Unsupported operand
for project advanced
search

DEF061734 /
DOC00615

On the Projects list page, performing an advanced search on a
Single-Select - Database attribute or Multiple-Select - Database attribute
can result in an error. The error occurs if the attribute has an ID or
Display column with a type of bigInt through the lookup table.

Exception while loading
My Task portlet

DEF061982 /
DOC00616

An error can occur when a user with numerous assigned tasks displays a
dashboard that includes the My Tasks portlet and multiple other portlets.

After security import,
sequence of roles
changes

DEF062118 If security metadata is exported and then imported into the same system,
the sequence of the roles changes.

Approval sent to
reviewers with same out
of office delegates

DEF062180 /
DOC00624

If more than one user designates the same individual as the out-of-office
delegate for approvals, an unanticipated situation can occur. When all of
those users are out of the office and an approval is sent to them, that
approval is delegated for the first out-of-office user only. For subsequent
out-of-office users, delegation fails and the message "Delegated user is
already a reviewer of the approval" displays.

Using different user
interface controls for
approvals results in
different prompting

DEF062770 /
DOC00641

When an approval with the "If approval is edited/resubmitted, approval
owner selects the reviewers who need to re-approve" rule is denied by a
reviewer and resubmitted through workflow, the system prompts for
reviewers as expected. However, if the approval is resubmitted through
the task pane at the right side of the page, the system resubmits the
approval to all reviewers immediately without prompting.

Exception error for
rollup metrics in
program metrics
templates

DEF044430 /
DOC00335

If no metric groups are defined, and a metric with Roll-up selected is
added directly to a program metrics template, an error occurs. To avoid
this error, either:

v Create a metric group for the affected program template.

v In addition to selecting Roll-up for the metric, define a formula for it
that includes the ROLLUP aggregator.
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Chapter 6. Known issues in integrated Marketing
Operations-Campaign systems

This table contains known issues that affect IBM Marketing Operations systems
that are integrated with Campaign in version 9.0.0.

Table 6. Known issues in integrated Marketing Operations-Campaign version 9.0.0

Issue Issue ID Description

System does not display
error or warning on
category selection if
selected client ID has no
categories

8437 If edits are made to the Coremetrics URL or Coremetrics Client
IDs for the template in an offer template after offer instances
exist, no warning displays when users work with one of the offer
instances.

Client ID and category
ID not required to
create offer instances

3391 If an offer template includes a valid Coremetrics URL and client
ID for an IBM Digital Recommendations system, users can create
offer instances from the template without selecting a client ID or
category ID.

IBM Digital
Recommendations
attributes display in
advanced search

5468 In an advanced search, if a user selects an offer template that does
not include values for IBM Digital Recommendations settings,
those attributes display in the search results.

Unable to publish TCS
by user with Chinese
locale

8053 An exception error occurs when users who have Chinese set as
their locale attempt to publish a target cell spreadsheet.

For installations that
enabled offer
integration in 8.5,
publishing a template
with channel and
channel type attributes
deletes all values for
those attributes in
Campaign

DEF063702 This issue affects integrated Marketing Operations-Campaign
systems that enabled offer integration in version 8.5. After the
upgrade to 8.6, publishing a template with channel and channel
type attributes deletes all values that exist in Campaign for those
attributes from the database attribute table. After such an import
occurs, you must manually add the deleted values back: in
Campaign use the Attribute Settings link in the Admin Section, or
use the Form Editor in Marketing Operations and republish.

Integrated
Campaign-Marketing
Operations budget costs
display quarterly data
only

DEF054904,
DEF055000

This problem occurs due to the database design changes done for
the Financial Planning module in the Marketing Operations 8.2.0
release. To manually (report upgrade cases) change the Campaign
Offer Financial Comparison:

1. Open the report in Report Studio.

2. Edit the Report Query.

3. Edit the Budget Total query item definition to pull from
Campaign Project by Offer > Campaign Project > Budget Total

4. Change aggregation to be Total/None.

5. Edit the Committed Total query item (in Report query) to pull
from Campaign Project by Offer > Campaign Project >
Committed Total.

6. Change aggregation to be Total/None.
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Table 6. Known issues in integrated Marketing Operations-Campaign version 9.0.0 (continued)

Issue Issue ID Description

Precision can change for
currency attribute after
offer import

DEF060846 When you import an offer template that includes a currency
attribute, the precision for that attribute is reset based on the
currency locale of the server. For example, when an attribute with
a precision of other than 2 is imported to a server with a currency
locale of en_US, the precision of the attribute is set to 2 in
Marketing Operations.

Error while working
with published folder if
folder permission
denied

DEF060881,
DEF060882

If a Campaign security policy specifically denies the Edit folder or
Move folder permission for a role, an error occurs when a user
with that role attempts to edit or move a published folder in
Marketing Operations.

Application asks to
publish destination
folder while moving
offer in Redraft state

DEF060940 If an offer folder is created in Marketing Operations but not
published, and then a user moves a published offer into that
folder, the system prompts to publish the folder. This prompt also
displays if an offer that is in Redraft status is moved into an
unpublished folder. However, this prompt does not display if an
offer that is in Draft status is moved into an unpublished folder.

Note: Offers in Redraft status were previously published to
Campaign; therefore, they have the same effect on unpublished
offer lists as published offers do.

Forms can be edited
even after offer
instances are created

DEF061105 After you add a form to an offer template and use that template to
create offers, a message indicates that the form cannot be edited.
However, this limitation applies only to certain parameters on the
form: specifically, you can no longer add or delete attributes, or
edit the options, name, description, or default values.

Publishing a smart offer
list does not publish
draft offers

DEF061212 /
DOC00592

If a query is used to populate an unpublished smart offer list, and
then the status of one of the included offers changes to Draft,
when the offer list is published the Draft offer is not also
published.

Note: Offer lists that use a query search only in Campaign for
offers to include. The query does not search in Marketing
Operations for offers that are not published. As a result,
publishing an offer list does not publish offers.

Exception while trying
to publish a folder into
different partition

DEF061274 When an offer folder created in a partition by one Marketing
Operations user is published to Campaign by another user who
does not have privileges to that partition, an error results.

Exception on setting
offer saved search as
the Marketing
Operations home page

DEF061337 /
DOC00595

In a saved search for offers, you can navigate to the directory level
and then set the resulting page as the home page. However, each
time you log in, the home page displays search results in the root
directory, rather than in the specific subdirectory selected.

Status of offer templates
not included in
template import

DEF061371 When you import an offer template in to Marketing Operations,
the status of the template is not imported. As a result, templates
that are retired in Campaign are available for use in creating
offers.

No edit check on
expiration date less than
effective date

DEF061838 If you create an offer template that includes standard offer
attributes and you provide an Effective Date and an Expiration
Date, Marketing Operations does not verify that the Effective Date
is before the Expiration Date.

Marketing Operations
does not display
associated product
information for offers

DEF062333 When you import offer data and metadata into Marketing
Operations, offers do not display the Relevant Products that are
associated with them in Campaign.
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Table 6. Known issues in integrated Marketing Operations-Campaign version 9.0.0 (continued)

Issue Issue ID Description

Unable to publish offer
if underlying template
and form are changed
but not published

DEF062814 /
DOC00642

When you change the default value for an offer attribute that is
already in use, you must publish both the form that the attribute is
on and the offer template that includes the form. Otherwise, when
a user creates an offer from the template and attempts to publish
that offer, an error occurs.

Offer folder reimport
issue

DEF062944 If a network or other issue interrupts the import of offer data and
metadata from Campaign to Marketing Operations, you can begin
the import process again. However, if the failure occurred during
the import of offer folders, the error message
"FOLDER_WITH_SAME_NAME_ALREADY_PRESENT" displays.

Deleted folders can
continue to display

DEF063069 When the root folder of a set of hierarchical offer folders is
deleted, that folder and its contents are removed from the
database. However, the folder can continue to display in the user
interface due to browser caching, and an error can occur if a user
clicks to select that folder.
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Chapter 7. Known limitations

This table contains known limitations in IBM Marketing Operations version 9.0.0.

Table 7. Known limitations in Marketing Operations version 9.0.0

Issue Issue ID Description

Multiple scroll bars for
dashboard portlets

3066 If you reduce the size of the browser window, dashboard portlets can
display with two scroll bars. Both Marketing Operations and Marketing
Platform add the scroll bar control.

Projects and subprojects
must be cleared manually

5817 When you request the Project Health (Monthly) report, you can select
the Projects and Sub Projects to include. If you select a value in either
of these lists, and then want to make other selections, you must clear all
of the projects or subprojects before you make your other selections.

Groups do not upgrade in
custom forms with
database table names that
use uppercase

DEF058551 This limitation applies to installations that upgrade from 7.5.x to 8.5 and
then to 9.0 (a two-step process). Custom forms that include attributes in
custom groups and that include an uppercase character in the form table
name do not upgrade correctly. The custom groups are deleted and the
attributes are moved to the default group.

Users cannot add
marketing objects in
languages other than
English

DEF057079 Marketing Operations does not allow multibyte characters in the
marketing object type name.

Unable to add forms or
templates with
non-English characters in
the form name, form
attribute name, or table
name fields

DEF057100 Form and template fields with non-English characters cannot be saved.

The task pane allows
users to edit the Summary
tab even if the project is
canceled or completed

DEF057121 If a project is canceled or completed on the Summary tab while the task
pane is open at the right side of the page, you can continue to edit
project forms in the task pane, even though it is no longer active.

Offers are not available in
the Marketing Object
Type dropdown when
adding a SSOR/MSOR
attribute

DEF059340 Marketing Operations version 8.5 has a default marketing object 'Offers'
(uap_sys_default_offer_comp_type) for integration with Campaign's
offer management. If a single-select object reference attribute referring to
the marketing object type "Offers" is created with the auto-create option,
it causes problems since some essential fields (for example: Campaign
offer code) are not generated with the auto-created offers. To avoid these
subsequent problems, the SSOR and MSOR attributes are not allowed to
refer to Offers. Offers are not made available in the 'Marketing Object
Type' dropdown while adding a SSOR/MSOR attribute.

Primary key violation
when a legacy metrics
template is mapped to
new template

DEF057563 In Marketing Operations version 8.5.0, the external metrics editor was
moved into the application. Metrics templates created in version 8.5.0
must specify a type, which corresponds to plans, programs, or projects.

Although Marketing Operations keeps legacy metrics templates for use
with plan, program, or project templates created before version 8.5.0,
these legacy metrics templates cannot be used in new object templates
because they do not have this type information. When creating new
plan, program, or project templates, users must select a metrics template
that has the same type. If users need to use a legacy metrics template in
a new object template, they must recreate it using the new internal
metrics configuration feature.
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Table 7. Known limitations in Marketing Operations version 9.0.0 (continued)

Issue Issue ID Description

Default dates on the grid
do not always localize
correctly

DEF057605,
DEF040170

The date selection control for grids is not localized for non-English
locales, so the default value for a grid date attribute is not always
populated for some non-English language locales (such as Japanese).

A reviewer who has not
yet responded cannot
continue an "On Hold"
Approval from right task
pane

DEF057650 If a reviewer has not responded to an approval in the On Hold state,
then the task pane on the right cannot be used to continue that approval.
The Approve, Approve w/changes, and Deny buttons display for the
approval in the task pane, but the continue and cancel buttons do not
display. In contrast, an approver who has already responded to the
approval can continue it from right pane.

This scenario occurs because the buttons on the right pane are driven by
the role of the user: Approver or Approval owner. If the approver and
the owner are the same user, approver actions take precedence.

Formulas for computing
metrics must be in
English

DEF057660 When adding metrics to metrics templates, the user can specify them as
Planned or Rollup. If the user enters a formula in the Computed by
Formula field, the formula must be in English. An error results if a user
enters a translated string instead of ROLLUP.

Metrics formulas are not
validated

DEF057726 If an invalid formula is specified for a metric, an exception error results
when Marketing Operations finalizes values entered on the Tracking tab
of an object instance that uses the metric. Please see the product
documentation for information about valid operators and operands.

Limitations in importing
offer templates

DEF059793 Offer templates are not imported in the following cases.

v An offer template with the same ID exists.

v An offer template with the same ID was published and deleted.

v Any form with same name is used in an offer template.

Exception when
comments exceed the
defined limit

DEF062980 A database exception occurs when a user enters a text string into a field
that exceeds the limit imposed by the database. For example, on a
system that uses a DB2 database, an attempt to save a project description
of longer than 1,048,576 results in an error. This limitation is imposed by
the database server.

Safari browser downloads
data migration files
directly to downloads
folder

DEF063699 When you perform a data migration import while using Marketing
Operations with the Safari browser, you are not prompted for a
destination folder. Imported files are downloaded directly to the folder
designated for downloads in Safari.
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Chapter 8. IBM Marketing Operations Reports Package

About the IBM Marketing OperationsReports Package

The IBM Marketing Operations Reports Package delivers an IBM Cognos model, a
set of IBM Cognos reports, and a set of IBM Cognos report portlets.

Specification documents for the provided reports are installed automatically along
with the Reports Package, in the ReportsPackMarketingOperations/
cognos<version>/docs/ path.

To access the following cross-object reports after the Marketing Operations Reports
Package is installed, click Analytics > Operational Analytics:
v Marketing Activity Report
v Overdue Milestone Report
v Program Tasks and Milestones
v Project Health (Monthly)
v Project Health (Trend)
v Project On Time Analysis
v Project Performance Crosstab (Custom)
v Project Performance Summary
v Project Performance Summary (Custom)
v Project Tasks
v Resource Task Load
v Resource Utilization Summary
v System Programs
v System Projects
v System Users
v Task On Time Analysis
v Vendor Spend Summary
v Deny Reason Analysis Report for Workflow Approvals
v Deny Reason Analysis Report for Standalone Approvals

To access single-object reports, click the object name then on the Analysis tab use
the Report Type list. The single-object reports available from the Analysis tab are:

For plans:

v Budget Summary by Quarter

For programs:

v Invoice Summary List
v Budget Summary by Quarter

For projects:

v All revisions
v Approval Responses
v Invoice Summary List
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v Marketing Object Cross-Reference
v Approval and Compliance Listing
v Budget Summary by Quarter
v Detailed Expense Breakout

For teams:

v Revision History
v Work Assigned to Team
v Work Assigned to Team Member

Administrators can review and enable report portlets by clicking Settings >
Dashboard Portlets. Users create dashboards and add report portlets to them on
the Dashboard tab.
v My Approval Summary
v My Task Summary
v Budget by Project Type
v Completed Projects by Quarter
v Forecast by Project Type
v Marketing Financial Position
v Projects Requested and Completed
v Spend by Project Type
v Manager Approval Summary
v Projects by Project Type
v Projects by Status
v Manager Task Summary
v My Tasks
v Approvals Awaiting Action
v My Active Projects
v My Requests
v My Alerts
v Projects Over Budget
v Manage My Tasks
v My Project Health

New features and changes

The monthly and trend reports for Project Health, the Deny Reason Analysis
Reports for workflow and stand-alone approvals, and the My Project Health report
portlet are new in this release.

Known issues

There are no known issues in this release.
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Chapter 9. IBM Marketing Operations-Campaign Reports
Package

About the IBM Marketing Operations-Campaign Reports Package

The IBM Marketing Operations-Campaign Reports Package delivers a set of reports
that combine information from both Marketing Operations and Campaign. The
reports in this package retrieve data from the Campaign system tables. To use
these reports, you must enable Marketing Operations-Campaign integration and
install both the IBM Campaign Reports Package and the IBM Marketing
Operations Reports Package.

Specification documents for the provided reports are installed automatically along
with this Reports Package, in the ReportsPackCampaignMarketingOperations/
cognos<version>/docs/ path.

The reports package contains the following IBM Cognos reports.
v Campaign Cell Financial Comparison
v Campaign Offer Financial Comparison
v Campaign Offer by Channel Financial Comparison

You can run these reports as cross-object reports by clicking Analytics >
Operational Analytics, or as single-object project reports by clicking a project
name, then on the Analysis tab use the Report Type list.

New features and changes

There are no new features or changes to the IBM Cognos reports in this release.

Known issues

Table 8. Known issues in IBM Marketing Operations-Campaign Reports Package

Issue Issue ID Description

Campaign Offer
Financial Comparison
report is displayed
blank if campaign is
assigned an offer with
no attribute

DEF046423 If a campaign project's linked campaign contains a flowchart
configured with cells assigned to an offer that has no offer
attributes, the report is displayed blank. For this report to display
correctly, offers assigned to cells must contain the following
attributes:

v Offer fixed cost

v Offer fulfillment cost

v Response revenue
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Chapter 10. Contacting IBM technical support

If you encounter a problem that you cannot resolve by consulting the
documentation, your company’s designated support contact can log a call with
IBM technical support. Use the information in this section to ensure that your
problem is resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your IBM
administrator for information.

Information to gather

Before you contact IBM technical support, gather the following information:
v A brief description of the nature of your issue.
v Detailed error messages that you see when the issue occurs.
v Detailed steps to reproduce the issue.
v Related log files, session files, configuration files, and data files.
v Information about your product and system environment, which you can obtain

as described in "System information."

System information

When you call IBM technical support, you might be asked to provide information
about your environment.

If your problem does not prevent you from logging in, much of this information is
available on the About page, which provides information about your installed IBM
applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, you can obtain the version number of any IBM application by viewing
the version.txt file that is located under the installation directory for each
application.

Contact information for IBM technical support

For ways to contact IBM technical support, see the IBM Product Technical Support
website: (http://www.ibm.com/support/entry/portal/open_service_request).

Note: To enter a support request, you must log in with an IBM account. If
possible, this account must be linked to your IBM customer number. To learn more
about associating your account with your IBM customer number, see Support
Resources > Entitled Software Support on the Support Portal.

© Copyright IBM Corp. 2002, 2012 29

http://www.ibm.com/support/entry/portal/open_service_request


30 IBM Marketing Operations: Release Notes



Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information about the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM websites are provided for
convenience only and do not in any manner serve as an endorsement of those
websites. The materials at those websites are not part of the materials for this IBM
product and use of those websites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
170 Tracer Lane
Waltham, MA 02451
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
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been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at www.ibm.com/legal/copytrade.shtml.

Privacy Policy and Terms of Use Considerations
IBM Software products, including software as a service solutions, (“Software
Offerings”) may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. A cookie is a piece of data that a web site can
send to your browser, which may then be stored on your computer as a tag that
identifies your computer. In many cases, no personal information is collected by
these cookies. If a Software Offering you are using enables you to collect personal
information through cookies and similar technologies, we inform you about the
specifics below.

Depending upon the configurations deployed, this Software Offering may use
session and persistent cookies that collect each user’s user name, and other
personal information for purposes of session management, enhanced user usability,
or other usage tracking or functional purposes. These cookies can be disabled, but
disabling them will also eliminate the functionality they enable.

Various jurisdictions regulate the collection of personal information through
cookies and similar technologies. If the configurations deployed for this Software
Offering provide you as customer the ability to collect personal information from
end users via cookies and other technologies, you should seek your own legal
advice about any laws applicable to such data collection, including any
requirements for providing notice and consent where appropriate.

IBM requires that Clients (1) provide a clear and conspicuous link to Customer’s
website terms of use (e.g. privacy policy) which includes a link to IBM’s and
Client’s data collection and use practices, (2) notify that cookies and clear gifs/web
beacons are being placed on the visitor’s computer by IBM on the Client’s behalf
along with an explanation of the purpose of such technology, and (3) to the extent
required by law, obtain consent from website visitors prior to the placement of
cookies and clear gifs/web beacons placed by Client or IBM on Client’s behalf on
website visitor’s devices

For more information about the use of various technologies, including cookies, for
these purposes, See IBM’s Online Privacy Statement at: http://www.ibm.com/
privacy/details/us/en section entitled “Cookies, Web Beacons and Other
Technologies."
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