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Contacting IBM Unica technical support

If you encounter a problem that you cannot resolve by consulting the
documentation, your company’s designated support contact can log a call with
IBM® Unica technical support. Use the information in this section to ensure that
your problem is resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your IBM
Unica administrator for information.

Information you should gather

Before you contact IBM Unica technical support, you should gather the following
information:
v A brief description of the nature of your issue.
v Detailed error messages you see when the issue occurs.
v Detailed steps to reproduce the issue.
v Related log files, session files, configuration files, and data files.
v Information about your product and system environment, which you can obtain

as described in "System Information" below.

System information

When you call IBM Unica technical support, you might be asked to provide
information about your environment.

If your problem does not prevent you from logging in, much of this information is
available on the About page, which provides information about your installed IBM
Unica applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, you can obtain the version number of any IBM Unica application by
viewing the version.txt file located under each application’s installation directory.

Contact information for IBM Unica technical support

For ways to contact IBM Unica technical support, see the IBM Unica Product
Technical Support website: (http://www.unica.com/about/product-technical-
support.htm).

© Copyright IBM Corp. 2002, 2011 v
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Chapter 1. Introduction to the integration

IBM Unica Marketing Operations and Campaign can be integrated so features from
both products are more tightly coupled.

After integration, you manage campaigns, projects, offers, and Target Cell
Spreadsheets in Marketing Operations, for use within Campaign.

Why integrate IBM Unica Marketing Operations and IBM Unica
Campaign?

When you integrate Marketing Operations and Campaign, you can take advantage
of all of the Marketing Operations project management features to create your
campaign and then execute the campaign in Campaign. Integration eliminates the
need to enter cell information in both products.

In addition, when you integrate, you can use the robust grid features in Marketing
Operations to create and manage the Target Cell Spreadsheet.

About integration with IBM Unica Marketing Operations
Campaign can be integrated with Marketing Operations to use its marketing
resource management features to create, plan, and approve campaigns.

When Campaign is integrated with Marketing Operations, many of the tasks
previously performed in a stand-alone Campaign environment are performed in
Marketing Operations. These tasks include:
v Working with campaigns:

– Creating campaigns
– Viewing, moving, and deleting campaigns
– Working with campaign summary details

v Managing offers (if offer integration is enabled):
– Creating offer templates
– Defining offer attributes
– Creating, editing, approving, and retiring offers

v Working with Target Cell Spreadsheets
v Assigning offers to cells
v Specifying control cells
v Creating and populating custom campaign attributes
v Creating and populating custom cell attributes

The tasks listed above are explained in the Marketing Operations-Campaign
Integration Guide.

The following tasks are performed in Campaign in both stand-alone and integrated
environments:
v Creating flowcharts
v Running flowcharts
v Detailed analysis of campaigns/offers/cells

© Copyright IBM Corp. 2002, 2011 1



v Reporting on Campaign performance (depending on the reporting pack
installed)

Overview of the data transfer between IBM Unica Marketing Operations
and IBM Unica Campaign

There are three main areas of data transfer: campaign data, cell data (in the TCS),
and offer data. The transfer of data between the products is primarily one-way,
from Marketing Operations to Campaign.

When integration is enabled, the campaign name and code are the same as the
project name and code. The campaign project in Marketing Operations is
automatically linked to the corresponding campaign in Campaign. Users can move
from project to campaign and back again by clicking a single button.

Integration eliminates the need for duplicate data entry. Marketing Operations
provides a single view of all data and a single location to enter and edit data. You
can view and edit shared data only in Marketing Operations. Marketing
Operations users control when data that is required for campaign execution is
published (pushed to Campaign).

The transfer of data must be initiated by Marketing Operations. Campaign can
respond to requests for data (for example, retrieval of cell status information or
campaign metrics) and can receive data from Marketing Operations (for example,
campaign or TCS data), but cannot send data to Marketing Operations if the data
has not been requested.

The three main areas of data transfer are described below.

Campaign data transfer

In Marketing Operations, you can define any number of custom campaign
attributes and place them on a campaign project template, along with standard
campaign attributes. You can enter data for these attributes in Marketing
Operations and manually publish the data to Campaign, where these campaign
attributes are available as generated fields within the flowchart and for reporting
and analytics. The Marketing Operations user controls when a campaign is created
in Campaign and when campaign attribute data is published to Campaign.
Campaign always uses the last set of published campaign attributes.

Cell data transfer

The second major area of data transfer is the Target Cell Spreadsheet. The TCS
manages cell-level information for target and control cells, including cell names,
cell codes, assigned offers, control cell linkages, and custom cell attributes. The
transfer of cell definitions from Marketing Operations to Campaign and the
transfer of cell status back to Marketing Operations can be iterative. Companies
often require several cycles before cell definitions and counts are finalized, rows of
the TCS are individually approved, and the campaign is ready to be run.

Offer data transfer

The third major area of data transfer is offer data. Offer templates and instances
are created in Marketing Operations. When a new offer is created in Marketing
Operations, the offer state is Draft. The state Published pushes the offer instance to
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Campaign. The first publish creates the offer in Campaign; subsequent publishing
updates the offer instance in Campaign.

Differences between integrated and stand-alone IBM Unica Campaign
When Campaign is integrated with Marketing Operations, the Campaign
installation differs from a stand-alone installation in the following ways:
v The only way to create or access campaigns (other than campaigns created

before you enabled integration) is through the corresponding Marketing
Operations project. The All Campaigns page in Campaign displays only
campaigns created before integration was enabled.

v The Target Cell Spreadsheet and custom cell attributes are created, viewed, and
managed solely in Marketing Operations. Custom cell attributes are defined in a
campaign project template, so each type of campaign can have different custom
cell attributes or have custom attributes appear in a different order. (In
stand-alone Campaign, all campaigns have the same cell attributes in the same
order.)

v The TCS can be top-down or bottom-up. Bottom-up cells are allowed for
Campaign Marketing Operations integration when MO_UC_BottomupTargetCells
is set to yes (Unica > Campaign > partitions > partition[n] > server > internal).

v Flowcharts can be executed in Production mode even if they are not linked to
top-down cells in the TCS.

v The campaign Summary tab does not exist in Campaign. The campaign
summary information displays in the Campaign Summary section of the
Summary tab in the campaign project in Marketing Operations. The offer and
segment information displays in a new Segments/Offers tab in Campaign. Since
you manage campaign project templates in Marketing Operations, each
campaign template can have a different set of campaign custom attributes
organized on one or more tabs within the project. You also can take advantage
of the more robust attribute features in Marketing Operations for layout,
required versus optional attributes, conditional drop-down lists, dynamic data
values from database tables, and so on. (In stand-alone Campaign, all campaigns
have the same custom campaign attributes in the same order.)

v If offer integration is enabled, you use Marketing Operations to create offer
templates and to create, modify, approve, publish, or retire offers. Approved
offers are then published to Campaign for use. Note that offer integration is a
separate option from campaign integration. When campaign integration is
enabled, offer integration may also be enabled. For more information, see
“Enabling offer integration in Marketing Operations” on page 38.

Differences between integrated and stand-alone IBM Unica Marketing
Operations

If campaign integration is enabled, campaign project management is performed in
Marketing Operations and is tightly coupled with Campaign. If offer integration is
also enabled, offer lifecycle management is performed in Marketing Operations
and offers are published to Campaign for use.

Campaign project management

If campaign integration is enabled, users can create projects using campaign project
templates.
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In a stand-alone installation, campaign project templates are not available to users
for creating new projects. In a stand-alone installation you can create project
templates for administering marketing campaigns, but there is no link to a
corresponding campaign, no Target Cell Spreadsheet, no integration with offers,
and no metrics passing for campaign contacts and responders.

With an integrated installation, campaign projects have icons and links that initiate
data transfers with Campaign or enable you to easily navigate to and from the
corresponding campaign in Campaign.

Offer lifecycle management

If campaign integration is enabled, then you can also enable offer integration. If
offer integration is enabled (Settings > Configuration > Unica > Platform), offer
lifecycle management is performed exclusively in Marketing Operations. You use
Marketing Operations to create offer templates and to create, modify, approve,
publish, or retire offers. Approved offers can be published to Campaign for use.

License and permission issues for IBM Unica Marketing Operations
and IBM Unica Campaign integration

When Marketing Operations and Campaign are integrated, every person involved
in the design, creation, and execution of the campaign needs a Marketing
Operations license. Even team members who work exclusively in Campaign (such
as the flowchart developer) need a Marketing Operations license so they can
receive workflow notifications and access campaigns. (In an integrated
environment, the only way to access a campaign is through Marketing Operations.)

Some actions in a Marketing Operations campaign project require a Campaign
permission. You can create a role in Campaign that grants these permissions and
assign the role to users who work in Marketing Operations. The following table
lists the actions and the required permissions.

Action Required Campaign permission

Create linked campaign Create Campaign

Update linked campaign Edit campaign

Publish TCS Manage campaign target cells

Get cell run status Manage campaign target cells

Search for and assign
offers in TCS

View offer summary

Import metrics Analyze campaign

Disabling or re-enabling integration
Although it is possible to disable integration after it has been enabled, it is best to
avoid this action if possible.

Disabling UMO-UC integration

If you disable Marketing Operations and Campaign integration, Campaign reverts
to its stand-alone behavior and appearance. However, there are several important
issues to keep in mind:
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v To access flowcharts associated with integrated campaigns after you disable the
integration, you must publish all campaigns in Marketing Operations before you
turn off the integration. The campaigns will be available in the top-level folder in
Campaign.

v If you disable the integration, there will be no navigation link between campaign
projects and campaigns. Users can still access their campaign projects, but the
icons for creating and updating campaigns will be disabled and the buttons for
publishing TCS data and getting cell status will not be available. Campaign
project templates will not be included in the list of templates users see when
creating a new project.

v If you want to re-enable integration, contact IBM Unica technical support to
discuss the implications. Any changes you made to the campaign during the
time integration was disabled will be overwritten the first time you update the
campaign or publish the TCS from within Marketing Operations after
re-enabling the integration.

Disabling Offer integration

Try to avoid turning offer integration off after it has been enabled, as this action
can lead to inconsistent data. For example, if an offer is created in Marketing
Operations and published to Campaign, and then offer integration is turned off,
that offer may then be modified in Campaign. If offer integration is turned on
again, that change will not be synchronized with Marketing Operations, so
Marketing Operations will not have the updated offer information. The transfer of
data between the products is primarily one way, from Marketing Operations to
Campaign.
Related tasks:
“Enabling offer integration in Marketing Operations” on page 38
“Configuration Settings for an Integrated Deployment” on page 7
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Chapter 2. Integrating Marketing Operations and Campaign

The workflow for integrating IBM Unica Marketing Operations and Campaign
consists of the following steps.

You must complete these steps before users can create campaign projects or
campaign project requests.
1. Install both Marketing Operations and Campaign. For details, see the IBM

Unica Marketing Operations Installation Guide and the IBM Unica Campaign
Installation Guide.

2. Adjust the configuration settings to support an integrated deployment. See
“Configuration Settings for an Integrated Deployment.”

3. Design the attributes, forms, and campaign project templates and offer
templates you need.

4. Create the shared attributes.
5. Create the forms and local attributes, including the form that contains the

Target Cell Spreadsheet.
6. Create a metrics map file that associates Campaign contact and response counts

with Marketing Operations metrics.
7. Create the campaign project and offer templates.

Configuration Settings for an Integrated Deployment

When Marketing Operations and Campaign are integrated, you can use Marketing
Operations to create, plan, and approve campaigns. If you also enable offer
integration, you can use Marketing Operations to perform offer lifecycle
management tasks as well.

To enable integration with Campaign, set the following properties on the Settings
> Configuration page.
v Unica > Platform

– IBM Unica Marketing Operations - Campaign integration: True. Enable
integration, so you can use Marketing Operations to create, plan, and approve
campaigns. (MO_UC_integration must be enabled; see below.)

– IBM Unica Marketing Operations - Offer integration: True. Enable the
ability to use Marketing Operations to perform offer lifecycle management
tasks. (IBM Unica Marketing Operations - Campaign integration must be
enabled.)

v Unica > Campaign > partitions > partition[n] > server > internal.
If your Campaign installation has multiple partitions, set these properties for
each partition where you want to enable integration:
– MO_UC_integration: Yes. Enable integration for this partition.

Note: If you plan to set any of the following three options to Yes, you must
set MO_UC_integration to Yes. The following three options apply only if
MO_UC_integration is enabled.
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– MO_UC_BottomUpTargetCells: Set this property to Yes to allow bottom-up
cells for Target Cell Spreadsheets on this partition. When set to Yes, both
top-down and bottom-up target cells are visible, but bottom-up target cells
are read only.

– Legacy_campaigns: Set this property to Yes if you want to enable access to
campaigns created before enabling integration, including campaigns created
in Affinium Campaign 7.x and linked to Affinium Plan 7.x projects.

– IBM Unica Marketing Operations - Offer integration: Set this property to
Yes if you want to enable offer integration for this partition.

v Unica > Marketing Operations > umoConfiguration > campaignIntegration

– defaultCampaignPartition: When Marketing Operations and Campaign are
integrated, this parameter specifies the default Campaign partition if the
campaign-partition-id is not defined in the project template. The default is
partition1.

– webServiceTimeoutInMilliseconds: Added for Web Service integration API
calls. This parameter is used as a timeout for web services API calls.

Related concepts:
“Disabling or re-enabling integration” on page 4

Designing your campaign templates, forms, and attributes
Before you begin creating objects in Marketing Operations, you should plan your
campaign project templates and the forms and attributes they require.

When you complete the design process, you should have a list of attributes to
create and details about the attributes, such as whether the attributes are shared or
local, whether users will select from data supplied by a table or enter data directly,
and what constraints are needed on the field. Campaign attributes and cell
attributes must be shared attributes. Form and grid attributes must be shared if
they are used by multiple forms.

Designing campaign project templates
You can create as many campaign project templates as you want. For example, you
may want to create a separate campaign project template for each type of
campaign you run.

In general, you should create a separate template for each unique combination of
forms you need. For example, if you need to gather different information to define
your target cells for some campaigns, you need to create different versions of the
Target Cell Spreadsheet and associate them with different templates. Similarly, if
some custom campaign attributes are relevant only for certain types of campaigns,
you can create different campaign project templates to make different custom
campaign attributes available and control their display order and organization on
tabs.

Designing the Target Cell Spreadsheet and other forms
By default, projects have the following tabs: Summary, People, Workflow, Tracking,
Attachments, and Analysis. If the Financial Management module is installed,
projects also have a Budget tab.

In a campaign project, the Summary tab includes a set of fields for basic campaign
information. You cannot remove or reorder these basic campaign attributes.
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If you want to enable users to enter additional information about the project, you
must create forms and add the forms to the project template. Each form displays
on the Summary tab or on an additional tab in projects created using that
template.

All campaign project templates must have a TCS form. Other forms are optional.

Campaign Summary section

All campaign projects contain a Campaign Summary section on the Summary tab.
This section contains the following default campaign attributes:

Attribute Field Description

Campaign description Text field

Campaign start date Date field

Campaign end date Date field

Campaign objective Text field

Campaign initiative Text field

Campaign security policy Drop-down list with all the security policies defined
for Campaign

The default campaign attributes do not display in the list of campaign attributes on
the Shared Attributes page in the Administrative Settings and cannot be edited.

About Target Cell Spreadsheets
The Target Cell Spreadsheet is an editable grid that specifies the type of
information users must enter to define the target and control cells for a campaign
when IBM Unica Marketing Operations-Campaign integration is enabled. Each
column on the TCS defines a particular item of information. Each column
corresponds to an attribute.

A TCS contains default attributes that are automatically passed to Campaign. In
addition to these default attributes, you can create and add an unlimited number
of custom attributes.

Cell attributes and grid attributes

A TCS can contain attributes that get passed to IBM Unica Campaign (cell
attributes) and attributes that display only in IBM Unica Marketing Operations
(grid attributes).

Use cell attributes for information you need to pass to Campaign. For example,
attribute values you want to include in an output list, contact history, or report
must be created as cell attributes.

Use grid attributes for descriptions, calculations, and data that is not needed in
Campaign.

Target Cell Spreadsheets and forms

You create a TCS on a form. (The form can contain other attributes in addition to
the TCS.) When you place a TCS grid component on a form, it contains the default
cell attributes. You cannot delete the default attributes.
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Transfer of cell attribute data

The information in the default attributes is passed automatically to Campaign
when a user links a flowchart cell to the TCS row. Custom cell attributes are
available automatically in Campaign as IBM Unica Campaign Generated Fields in
contact processes. For details on Generated Fields, see the IBM Unica Campaign
User Guide.

Target Cell Spreadsheets and templates

A campaign project template can contain only one TCS.

Default cell attributes

The default cell attributes appear in all Target Cell Spreadsheets. They do not
appear in the list of cell attributes on the Shared Attributes page in the
Administrative Settings.

Table 1. Default cell attributes

Name

Value required
for publishing
TCS Description

Cell Name Yes Text field

Cell Code No Text field

Description No Text field

Is Control Cell Yes Drop-down list with Yes and No

Control Cell No Drop-down list of control cells

Assigned Offers No A selection control you can use to select one or more
offers or offer lists

Is Approved No Drop-down list with Yes and No. This column
appears only if Approval required is checked in the
corresponding campaign project template.

Flowchart No Read-only field that displays the name of the
flowchart in which the cell is used

Last Run No Read-only field that displays the date and time the
flowchart containing this cell was last run

Actual Count No Read-only field that shows the last run count for
this cell (count of unique audience IDs in the cell)

Run Type No Read-only field showing the run type for the last
run for the flowchart that contains this cell
(production or test; flowchart, branch, or process
box)

You can edit only the following properties for a default cell attribute:
v Display name
v Description
v Help text
v Sortable
v Sort type
v Alignment

10 IBM Unica Marketing Operations and Campaign: Integration Guide



Designing attributes
Each item of information that users can enter for a project must have a
corresponding attribute on a tab in the template.

Campaign project templates can include the following types of shared attributes:
v Use form attributes for information for use only in Marketing Operations

outside of a grid.
v Use grid attributes for information for use only in Marketing Operations in a

grid (including TCS grids).
v Use campaign attributes for information outside of a grid that must be shared

with Campaign.
v Use cell attributes for information in the TCS that must be shared with

Campaign.
v Use offer attributes for information to be placed on an offer template, for offers

to be shared with Campaign. Offer attributes are synchronized with Campaign
when the offer template is published to Campaign.

To view or define shared attributes, choose Settings > Marketing Operations
Settings > Template Configuration > Shared Attributes.

Note: Default attributes that cannot be edited are not listed on the Shared
Attributes page. For example, default cell attributes appear in all Target Cell
Spreadsheets but not on the Shared Attributes page. Campaign, cell, and offer
attributes must be shared attributes. Form and grid attributes must be shared if
they are used by multiple forms.

Information that you want to display in campaign, cell, or offer performance
reports must be gathered by an attribute that gets passed to Campaign (a
campaign, cell, or offer attribute).

Campaign attributes
Campaign attributes are IBM Unica Marketing Operations attributes that
correspond to IBM Unica Campaign attributes when Marketing
Operations-Campaign integration is enabled. Marketing Operations includes a set
of default campaign attributes that correspond with standard attributes in
Campaign.

You can also create custom campaign attributes in Marketing Operations when
Marketing Operations and Campaign are integrated. When users create the linked
campaign for a campaign project from a template that includes custom campaign
attributes, the corresponding attributes are created in Campaign. If users change
the data they enter in a field created by a campaign attribute after they create the
linked campaign, they must update the campaign in order to send the new
information to Campaign. You should use campaign attribute descriptions and
form descriptions to inform users which fields require them to update the
campaign.

Campaign attributes are shared attributes. You create them from the Administrative
Settings in Marketing Operations.

Cell attributes
Cell attributes are IBM Unica Marketing Operations attributes that map to IBM
Unica Campaign for use in Target Cell Spreadsheets. Marketing Operations
includes a set of default cell attributes that are included in every TCS.
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You can also create custom cell attributes in Marketing Operations. When users
create the linked campaign for a campaign project from a template that includes
custom cell attributes, the corresponding cell attributes are created automatically in
Campaign.

Cell attributes are shared attributes. You create them from the Administrative
Settings in Marketing Operations.

Offer attributes

The following table describes the standard offer attributes that are delivered with
Campaign.

Table 2. Standard offer attributes

Attribute Display Name Attribute Internal Name Form Element Type

Average Response Revenue AverageResponseRevenue Text Field - Numeric

Channel Type ChannelType Select Box - String

Channel Channel Select Box - String

Cost Per Offer CostPerOffer Text Field - String

Duration ExpirationDuration Text Field - Numeric

Effective Date EffectiveDate Text Field - Date

Expiration Date ExpirationDate Text Field - Date

Fulfillment Cost FulfillmentCost Text Field - Currency

Attribute types not available for campaign and cell attributes
Only attribute types that exist in both IBM Unica Marketing Operations and IBM
Unica Campaign are available for campaign and cell attributes. The following
Marketing Operations attribute types are not available.
v Multi-select–Database
v User select
v External database
v URL field
v Single-select object reference
v Object attribute field references
v Multi-select object reference
v Graphical reference

In addition, the single-select and single-select–database types are available for
campaign attributes but not cell attributes.

Note: For single-select–database attributes, IBM Unica Marketing Operations
passes the lookup value (not the display value) of the selection to IBM Unica
Campaign. You determine the lookup value and the display value when you create
the lookup table.

There is no attribute type that corresponds to the "Modifiable drop-down list" that
is available for custom attributes in stand-alone IBM Unica Campaign.
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To create a shared attribute
1. Select Settings > Marketing Operations Settings.
2. Click Template Configuration.
3. Click Shared Attributes.

The screen contains one section for each category of shared attribute.
4. Click the Create Attribute link for the attribute category for the attribute you

want to create.
The Create a New Shared Attribute window displays.

5. Define the attribute.
6. Click Save and Exit to create the attribute and return to the Shared Attributes

screen or click Save and Create Another to create the attribute and display the
attribute screen for a new attribute.
You can create another attribute of the same or a different category.

7. On the Shared Attributes screen, click Enable in the row for each new attribute
to make it available for use on a form.

To create a TCS

Before you create a TCS, you must create any custom cell attributes that you want
to include. Cell attributes map to IBM Unica Campaign and can only be created as
shared attributes.
1. Select Settings > Marketing Operations Settings.
2. Under Other Options, click Template Configuration.
3. Under Template Components, click Forms.
4. At the Form Definitions screen, click Create New Form.
5. Fill out the Form Properties tab and click Save Changes. The Add an Element

tab displays.
6. Click Create New Grid.
7. In the Attribute Type field, select Editable Grid from the drop-down list.
8. Select the Is TCS check box.
9. Complete the remaining options and click Save and Exit.

The grid component for the TCS displays in the Form Attributes list in the
Custom Attributes list box.

10. Select the grid component for the TCS and drag it onto the group header on
the form.
The default cell attributes display on the grid.

11. Add any attributes you want to the TCS. You can do either of the following.
v Import custom cell attributes and add them to the TCS to create additional

columns that get passed to IBM Unica Campaign.
v Create or import grid attributes and add them to the TCS to create

additional columns that display only in IBM Unica Marketing Operations.
12. Click Save and Exit to save the TCS and return to the Form Definitions list

page.
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Related concepts:
“Assigning offers and offer lists to cells when offer integration is enabled” on page
40
“Completing the TCS” on page 28

Mapping IBM Unica Campaign contact and response counts to
Marketing Operations metrics

If you want users to be able to import contact and response counts into Marketing
Operations, you must map contact count and the response types to Marketing
Operations metrics.

Note: Campaign passes data to Marketing Operations for one audience level only,
the audience level that is mapped to the UA_ContactHistory, UA_ResponseHistory,
and UA_DtlContactHist system tables. The audience level can be any audience
level, with any number of audience key fields of any data type or name. For
details on audience levels, see the Campaign documentation.

The response types are stored in the UA_UsrResponseType system table in the
Campaign database. To map a metric to a response type, you must know the name
of the response type.

The mappings are stored in an XML file.

To map IBM Unica Campaign contact and response counts to
Marketing Operations metrics

1. In Campaign, modify the list of response types in the UA_UsrResponseType
table if necessary to include the response types you want to track.

2. Edit the Marketing Operations metrics file being used by your system to
include metrics that correspond to contact count and the response types.

3. Create a map file that associates the Marketing Operations metrics with contact
count and the response types.

4. Add the map file to Marketing Operations.
5. Create a campaign template and select the map file from the Metric Data

Mapping drop-down list.

The contact and response data is mapped to metrics for all projects created using
that template.

About the metrics data mapping file
The metrics data mapping file must use the container elements
<metric-data-mapping> and </metric-data-mapping>.

The next line in the mapping file must be the following:
<datasource type="webservice">
<service-url>CampaignServices</service-url>
</datasource>

The actual mappings must be contained by the elements <metric-data-map> and
</metric-data-map>.
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metric

Use the <metric> element to define the metric in a mapping. The <metric> element
has no value but must contain the child element <data-map-column>. The
<metric> element has the following attributes:

Attribute Description

id The internal name of the metric

dimension-id The number of the column into which the value from Campaign
should be placed. Columns are numbered from left to right. The first
column is column 0.

data-map-column

Use the <data-map-column> element to define the data source (either contact count
or a response type) in a mapping. The <data-map-column> element must be
contained by the <metric> element that defines the metric to which contact count
or this response type is mapped. The <data-map-column> element has no value
but has the following attributes:

Attribute Description

id The data source to be mapped to the metric. For contact count, use
contactcount. For a response type, use
responsecount_ResponseTypeName.

type This value should always be number.

To add a data mapping

Use a text or XML editor to create or edit a data mapping file. After you have a
data mapping file, you add it to Marketing Operations using the following
procedure.
1. Select Settings > Marketing Operations Settings.
2. Click Template Configuration > Data Mapping.
3. Click Add a data mapping.

The Upload Data Mapping dialog box appears.
4. Enter a name.

This is the display name for the data mapping file.
5. Browse to the XML file that defines the data mapping.
6. Click Continue.

Data Mapping Definitions page

The Data Mapping Definitions page allows you to map data betweenMarketing
Operations projects and campaigns in Campaign. Use the Data Mapping link from
the Template Configuration page to configure data mapping.

The Data Mapping Definitions page contains the following columns:

Column Description

Name The name of the data mapping file.
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Column Description

Type Campaign Metrics Import: maps Marketing Operations project metrics
to Campaign contact and response counts.

If you have map files from previous versions, you may see other
values in the Type column.

Used By A list of templates that use this data map.

Note: You cannot create a map file within Marketing Operations; use a text or
XML editor to create and edit the necessary map files.

To edit a data mapping

If you want to update a data mapping file, you must first edit the XML file, and
then re-load it back into Marketing Operations.
1. Open the data mapping XML file in a text editor and make your changes.
2. Select Settings > Marketing Operations Settings.
3. Click Template Configuration > Data Mapping.
4. Click the file name you are updating.

The Update Data Mapping dialog box appears.
5. Select File, and browse to the XML file.
6. Click Continue.

You will be prompted to overwrite the existing file.
7. Click:

v Save to overwrite the existing file with the newer version, or
v Cancel to leave the previous version of the file.

Campaign project templates
If IBM Unica Marketing Operations is integrated with IBM Unica Campaign,
campaign project templates guide users in creating a campaign project.

You indicate that a template is a campaign project template by completing the
options on the Campaign tab for the template. Specifically, you must specify a
Target Cell Spreadsheet. If you want to import Campaign contact and response
metrics, you must specify a metric map file.

To create a campaign project template

Before you can create a campaign project template, you must create the custom
campaign attributes, TCS form, and metric map file you want to use in this
template.
1. Select Settings > Marketing Operations Settings.
2. Under Other Options, click Template Configuration > Templates.
3. In the Project Templates section, click Add Template.
4. Complete the Properties tab and click Save Changes.

Additional tabs display.
5. Click the Campaign tab and select the Campaign Project Template checkbox.
6. Complete the remaining fields on the Campaign tab and click Save Changes.
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If you want to require TCS approval, select the Approval Required checkbox.
See “About approving the TCS” on page 34.

7. Complete the remaining tabs, saving each one. For more information about
these tabs and template creation, read about building or editing a template in
the IBM Unica Marketing Operations Administrator's Guide.
The template displays in the list of project templates on the Templates page.

8. Click Enabled in the row for the template to make it available to users when
they create projects.

Project template Campaign tab

Use this tab to set up communication from IBM Unica Marketing Operations to
IBM Unica Campaign if integration is enabled. It contains the following settings.

Field Description

Campaign Project
template

Select this check box to mark this template as a campaign project
template and display the other Campaign Integration fields.

TCS Form Select the form that contains the Target Cell Spreadsheet to use for
projects created from this template. The drop-down list contains all
published forms that contain a TCS.

Metric Data
Mapping

XML file containing the data map for sending metrics from a IBM
Unica Campaign campaign to a IBM Unica Marketing Operations
project for reporting purposes.

TCS Form
Display Name

The name to display for the selected form on the TCS tab.

Partition ID The Partition ID identifies the partition of the IBM Unica Campaign
instance in which to create the campaigns that correspond to the
campaign projects created using this template.

The default value is partition1, which is correct if Campaign is
installed to a single partition. If Campaign is installed on multiple
partitions, you can specify the partition to use for creating campaigns.

IBM Unica Marketing Operations allows you to specify any partition.
Make sure you specify a partition to which you have access and for
which integration is enabled.

For more information on setting up Campaign partitions, the IBM
Unica Campaign Installation guide.

Show TCS tab in
request

Select the check box to display the TCS when the template is used to
request a project. If the check box is clear, the TCS displays only in
campaign projects and not in requests.

Approval
Required

Select the check box to require approval for all the target cells created
in the template. If unchecked, the TCS grid will not show the approval
column or approve all and deny all. If you upgrade to version 8.2, all
upgraded campaign templates will have Approval Required
unchecked.

For more information, see “About approving the TCS” on page 34.

Note: Once you create a project using the template, you cannot change a
non-campaign template to a campaign template or vice versa. The Campaign
Project template option is disabled.
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The following options are also disabled once a project is created using the
template:
v TCS Form

v TCS Form Display Name

v Partition ID

v Show TCS tab in Request

v Approval Required

You can only change the values for these options if you first delete all of the
projects that were created using this template.

Installing the Marketing Operations and Campaign Integration reports
package

The Marketing Operations and Campaign Integration Reports Package contains
several IBM Cognos reports that query and display information from both the
Campaign system tables and the Marketing Operations system tables.

This report package is dependent on the Campaign report package because the
Campaign segments of the integrated reports rely on the reporting schemas from
the Campaign Report Package.

Installation prerequisites for the integration report package
Before you can install the Marketing Operations and Campaign Integration Report
Package, the following configuration steps must be completed.
v Reporting must be set up for the Campaign system. See the "Installing reporting"

chapter from either of the Campaign installation guides.
v Reporting must be set up for the Marketing Operations system. See the

"Installing reporting" chapter from the Marketing Operations Installation Guide.
v The integration of the two Unica applications must be fully configured.

Additionally, for the sample reports from the integration report package to work
correctly, the following must be true.
v The Campaign system must have the standard custom Campaign attributes

loaded.
v The Marketing Operations system must have the sample templates loaded, most

importantly, the sample Campaign Project template. Additionally, the Campaign
Project template must use the corresponding sample Campaign Project metric
file.

v The Financial Management module must be enabled on the Marketing
Operations system.

When these prerequisites are met, continue with the procedures in this section.

Step 1: Run the Unica installer on the IBM Cognos 8 BI
system

1. On the IBM Cognos 8 BI system that runs the Cognos Content Manager,
download the Marketing Operations and Campaign Integration Report Package
installer to the same directory to which you previously downloaded the other
report package installers.
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2. Run the IBM Unica installer. (It will launch the sub-installer for the report
package.)

3. In the first Products window, ensure that the report package option is selected.
4. In the Marketing Platform Database Connection window, verify that the

information about how to connect to the Marketing Platform system tables is
correct.

5. When the report package installer takes over and displays its installation
options, select the IBM Cognos package for IBM Unica [product] option. This
installation option copies the reports archive and reporting model to the
Cognos machine. You import this archive manually later.

Step 2: Import the reports folder in Cognos Connection

The IBM Unica application reports are in the zip file the report package installer
copied to the Cognos machine. Use the guidelines in this procedure to import the
reports zip file into Cognos Connection.
1. Navigate to the Unica\ReportsPackCampaignMarketingOperations\Cognos8

directory.
2. Copy the reports archive .zip file (IBM Unica Reports for Marketing

Operations and Campaign.zip) to the directory where your Cognos
deployment archives are saved. In a distributed IBM Cognos environment,
this is a location on the system running the Content Manager.
The default location is the deployment directory under your IBM Cognos
installation and it is specified in the Cognos Configuration tool installed with
the Cognos Content Manager. For example: cognos\deployment.

3. Locate the Unica\ReportsPackCampaignMarketingOperations\Cognos8\
CampaignMarketingOperationsModel subdirectory.

4. Copy the entire subdirectory to any place on the system running Cognos
Framework Manager that Framework Manager has access to.

5. Open Cognos Connection.
6. From the Welcome page, click Administer Cognos Content.

If your Welcome page is turned off, turn it back on in the Cognos Connection
user preferences.

7. Click the Configuration tab.
8. Select Content Administration.

9. Click the New Import button on the toolbar .
10. Follow these guidelines as you step through the New Import Wizard:

a. Select the reports archive that you copied in the previous procedure.
b. In the Public folders content list, select all the options, including the

package itself (the blue folder).
c. If you do not want users to access the package and its entries yet, select

Disable after import. You do this when you want to test the reports before
you make them available to the Unica application users.

Step 3: Enable internal links in the reports

The IBM Unica application reports have standard links. To enable these links to
work properly, you must configure the Cognos firewall as described in “Step 5:
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Configure the IBM Cognos application's firewall,” and you must configure the
redirect URL in the Cognos data model (the .cpf file) for the IBM Unica application
reports, as follows.
1. From Cognos Framework Manager, browse to the productNameModel

subdirectory you copied into the Framework Manager directory structure and
select the .cpf file. For example, CampaignModel.cpf.

2. Select Parameter Maps > Environment.
3. Right click Environment and select Edit Definition.
4. In the Redirect URL section, select the Value field. Edit the server name and

port number so they are correct for the IBM Marketing system, leaving the rest
of the URL intact. The host name should include the domain name.
For example, for Campaign:
http://serverX.ABCompany.com:7001/Campaign/
redirectToSummary.do?external=true&

For example, for Marketing Operations:
http://serverX.ABCompany.com:7001/plan/callback.jsp?

5. Save the model and publish the package:
a. From the navigation tree, expand the Packages node of the model.
b. Right click the package instance and select Publish Package.

Step 4: Verify the data source names and publish

When you publish the model from Framework Manager to the Cognos content
store, the name specified as the data source for the reports in the model must
match the name of the data source you created in Cognos Connection. If you used
the default data source names as described in “Step 6: Create the IBM Cognos data
sources for the IBM Unica application databases” on page 21, the data source
names match. If they do not, you must change the name of the data source in the
model.
1. In Cognos Connection, determine the name(s) of the data source(s) you created.
2. In Framework Manager, select the Open a Project option.
3. Browse to the productNameModel subdirectory you copied into the Framework

Manager directory structure and select the .cpf file. For example,
CampaignModel.cpf.

4. Expand the Data Sources entry and examine the name(s) of the data sources.
Do they match what you named them in Cognos Connection?
a. If they match, you are finished with this procedure.
b. If they do not match, select the data source instance and edit the name in

the Properties section. Save your changes.
5. Publish the package to the Cognos content store

Step 5: Configure the IBM Cognos application's firewall

To configure the IBM Cognos firewall, you specify the IBM Unica system as a valid
domain or host and disable validation.
1. In Cognos Configuration, select Security > IBM Cognos Application Firewall.
2. Set Enable CAF validation to false.
3. In the valid domains or hosts property, enter the fully qualified machine host

name, including the domain and the port, for the system where the Marketing
Platform is running.
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Important: If you have a distributed IBM Unica Marketing environment, you
must do this for every machine on which an IBM Unica product that renders
Cognos reports is installed (for example, the Marketing Platform, which has
dashboards; Campaign; and Marketing Operations).
For example:
serverXYZ.mycompany.com:7001

4. Save the configuration.
5. Restart the IBM Cognos service.

Step 6: Create the IBM Cognos data sources for the IBM Unica
application databases

The IBM Cognos applications need their own data sources that identify the IBM
Unica application databases – that is, the source of the data for the reports. The
IBM Cognos data models provided in the IBM Unica reports packages are
configured to use the following data source names:

IBM Unica application Cognos data source name(s)

Campaign CampaignDS

eMessage eMessageTrackDS

Interact InteractDTDS for the design time database

InteractRTDS for the runtime database

InteractLearningDS for the learning database

Marketing Operations MarketingOperationsDS

Leads LeadsDS for the data mart tables

Use the following guidelines to create Cognos data sources for the IBM application
databases:
v Use the Administration section of Cognos Connection.
v Use the default data source names that are shown in the table above. That way

you can avoid having to alter the data model.
v The database type you select must match that of the IBM application database.

Use the Cognos documentation and help topics to determine how to fill out
database-specific fields.

v Be sure that you identify the IBM Unica application database and not the
Cognos content store.

v When you configure the Signon section, select the Password and Create a
Signon that the Everyone group can use options.

v The user credentials you specify in the Signon section should be those of the
database user for the IBM Unica application database.

v Consult the table above and ensure that you create all the data sources required
by the data model for the reports you are configuring. For example, the
reporting data for Interact is located in three databases so you must create
separate Cognos data sources for each one.

v If the Campaign system has more than one partition, create separate data
sources for each partition. For example, if Campaign is configured for multiple
partitions, create a separate Campaigndata source for each partition.
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v Verify that you have configured each data source correctly by using the Test
Connection feature.

If you have any questions about configuring Cognos data sources, see the IBM
Cognos 8 Administration and Security Guide, "Chapter 6: Data Sources and
Connections" and the Cognos online help.
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Chapter 3. Creating a campaign in an integrated environment

The workflow for creating a campaign when Marketing Operations and Campaign
are integrated consists of the following tasks.

In many organizations, the tasks required to create a marketing campaign are
shared by multiple people.
1. Using the appropriate template, create a campaign project.

Depending on your permissions, you can create the project directly or request
a project and wait for it to be accepted.

2. Complete any information that is missing on the project tabs.
3. Create the linked campaign for the project.

Once this step is completed, the Implementation/Planning button ( )
appears, so you can navigate from a campaign project to its linked campaign
and vice versa.

4. Complete the TCS to define the control and target cells for the campaign and
the assigned offers for target cells.

5. Publish the TCS to Campaign.
6. Create the flowcharts for the campaign, linking cells created in the flowchart

with the appropriate target and control cells defined in the TCS.
7. (Optional: If TCS approval is required.) Do a test run of the flowchart to

generate cell counts.
8. (Optional: If TCS approval is required.) Update the cell status from within the

TCS for review.
9. (Optional: If TCS approval is required.) When all information for a cell (for

example, the count) is appropriate, approve that cell (row) in the TCS.
10. (Optional: If TCS approval is required.) Repeat the process of publishing the

TCS and updating cell status until all cells in use by the flowchart have been
approved.

11. When all necessary TCS rows for the flowchart to run are prepared, publish
the TCS a final time.

12. Start the production flowchart run for the campaign.

About campaign projects
If your IBM Unica Marketing Operations system is integrated with IBM Unica
Campaign, you can create campaign projects.

A campaign project collects the information related to developing a marketing
campaign and executing it through Campaign.

A campaign project can contain any features available to projects, including
subprojects. Campaign projects also contain a TCS tab with a Target Cell
Spreadsheet and an additional Campaign Summary section of the Summary tab.

In a campaign project, you synchronize the project's campaign, offer, contact
history, and response history data with Campaign.
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About project codes and campaign codes
When you create a campaign project, you must specify a project name and code.
The same name and code are used as the campaign name and code when you click
the Create Linked Campaign icon to create the campaign in IBM Unica Campaign.

The code must be unique in both IBM Unica Marketing Operations and IBM Unica
Campaign. The system checks the uniqueness of the code before creating the
project or saving the project if you have changed the code.

To add a project

When adding a project, note the following.
v To add a project, you must have the proper security permission.
v If you add a project, you are the owner of the project.
v You can add other team members (some of whom can also be project owners).
v You may also add a project in response to a project request.
1. Select Operations > Projects.

2. Click the Add a Project icon ( ).
3. Select a template for your project.

A IBM Unica Marketing Operations administrator sets up templates that
correspond to the types of projects that fit your organization’s needs. You must
select a template configured as a campaign project template to access any of the
IBM Unica Marketing Operations and IBM Unica Campaign integration
features.

4. Click Continue.
5. Fill in the fields in the wizard and continue clicking Next and filling out the

required fields until you reach the Attachments screen.
You can click Finish on any of the wizard pages; IBM Unica Marketing
Operations automatically saves all default values for non-mandatory attributes
in the remaining steps. You can also click Save and Duplicate on any of the
wizard pages; Marketing Operations automatically the current project with
default values for non-mandatory attributes in the remaining steps, and you
then see the Summary tab of a new project with data already populated.

6. Do one of the following.
v Click Finish to save the project. The project Summary tab is displayed.
v If you need to create another project that is similar to the one you have just

created, click Save and Duplicate. The current project is saved, and you then
see the Summary tab of a new project, with data already populated. You
should change the default name, and then you can edit the new project as
needed.

7. Do one of the following if you want your project or projects to be active.

v If you created a single project, click the Status icon ( ) and select
Start.

v If you created multiple projects, click the Actions icon ( ), select All
Projects and Requests to see your draft projects, and start them.
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The tabs in a project differ depending on the template you used. A typical project
contains project summary information, strategy, workflow, including a schedule of
tasks and deliverables, tracking of expenses and resources, and attachments of
documents related to the project. When IBM Unica Campaign is integrated with
Marketing Operations, a campaign project also contains a Target Cell Spreadsheet
tab.

Campaign Summary section

The Campaign Summary section of the project Summary tab defines basic
information about the campaign for this project.

Field Description

Campaign
Description

Enter a description of the campaign.

Campaign Start
Date

The date on which the campaign starts.

You can manually enter the date or click the drop-down arrow to
display a calendar from which you can select a date. If the field
contains a date, you can click the forward or back arrows to change the
date.

You cannot create the linked campaign if this field is empty.

Campaign End
Date

The date on which the campaign ends.

You can manually enter the date or click the drop-down arrow to
display a calendar from which you can select a date. If the field
contains a date, you can click the forward or back arrows to change the
date.

You cannot create the linked campaign if this field is empty.

Campaign
Objective

Enter the objectives of the campaign.

Campaign
Initiative

Enter the initiative under which the campaign falls.

Campaign
Security Policy

Select a security policy from the drop-down list of all the security
policies defined for Campaign.

You can select any policy, even policies in which you do not have a
role. If you put a campaign into the wrong policy, it will not be visible
to the desired end users.

You cannot create the linked campaign if there is no security policy
specified.

To add a request

Adding a request is the first step in requesting a project. After you add the request
you must submit it.

Your request pages differ depending on the template you use. A typical request can
contain the following sections:
v Summary information about the request
v Tracking information
v Attachments that are part of the request.
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1. Select Operations > Projects.

2. Click the Add Request icon ( ).
3. Select a template for your request.

Your administrator sets up project templates that correspond to the types of
projects that fit the needs of your organization. You must select a template
configured as a campaign project template to create a project that uses any of
the IBM Unica Marketing Operations and IBM Unica Campaign integration
features.

4. Click Continue.
5. Fill in the fields in the wizard and continue clicking Next and filling out the

required fields until you complete your request, then click Finish.
Note the following.
v You configure the request recipients in the wizard. Depending on the

template you chose, some of the recipients may already have been set up.
Also, depending on your permissions and the way the template was set up,
you may or may not be able to change the recipients, their roles, sequence
order, and how long they have to respond (duration).

v Recipients may be assigned a sequence number that determines the order in
which they receive and must approve the request.

v Recipients may be assigned a duration that determines how long they have
to respond.

6. When you have finished configuring your request, do one of the following.
v Click Finish to save the request. The request Summary tab is displayed.
v If you need to create another request that is similar to the one you have just

created, click Save and Duplicate. The current request is saved, and you
then see the Summary page of a new request, with data already populated.
You should change the default name, and then you can edit the new request
as needed.

7. Do one of the following if you want your request or requests to be active.

v If you created a single request, click the Status icon ( ) and select
Submit.

v If you created multiple requests, submit them as described in “To change the
status of projects and requests.”

When the last required recipient approves the request, IBM Unica Marketing
Operations creates the project.

To change the status of projects and requests

You can change the status of one or more projects or requests. Your change must
meet the following prerequisites; if it does not, you will see a warning message
that describes the possible problems.
v The new status must be a valid transition from the existing status.
v You must have appropriate permissions to make the change. If you are accepting

or rejecting a project request, you must be an appropriate approver.
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Your administrator can set up IBM Unica Marketing Operations to send an alert to
owners and members of a process when its status changes.
1. On the Projects and Requests list page, select the checkbox next to each item

whose status you want to change.
Note that, although you can select items across multiple pages, your changes
are applied only for the selected items on the page you are viewing when you
select the new status.

2. Click the Status icon ( ) and select the desired status. A dialog box
appears in which you can add comments.

3. Enter any comments, and click Continue to close the dialog box and apply the
new status.

About special characters
Names of objects in Campaign can have specific requirements. Some special
characters are not supported in any Campaign object names. In addition, some
objects have specific naming restrictions.

Note: If you pass object names to your database (for example, if you use a user
variable that contains a flowchart name), you must ensure that the object name
contains only characters supported by your particular database. Otherwise, you
will receive a database error.

Creating a linked campaign
You must specify the campaign start date, campaign end date, and campaign
security policy in a campaign project before you can create the linked campaign for
the project.

The user who clicks the Create Linked Campaign icon automatically becomes the
owner of the campaign in Campaign. You cannot change campaign ownership.
Ownership may grant specific permissions, depending on the security
configuration setup in Campaign.

You must have the Create Campaign permission in Campaign to create the linked
campaign.

All campaigns linked to Marketing Operations projects are created in the root
folder.

To create a linked campaign
1. Select Operations > Projects.
2. Click the project for which you want to create the campaign.

The project Summary tab displays.

3. Click the Create Linked Campaign icon ( ) in the left-hand toolbar.

The campaign is created in Campaign and any shared information (except
information in the TCS) is automatically published to Campaign.
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The Create Linked Campaign icon changes to the Update Campaign icon (

) once the campaign is created. The Implementation/Planning button (

) appears to the right of the project tabs. Click it to navigate to the campaign
and click it again to return to the project.

Updating a linked campaign
After a linked campaign is created from a campaign project, you must update the
linked campaign any time you change the value for a field (outside the TCS)
whose data gets passed to Campaign. By default, these fields are in the Campaign
Summary section of the project's Summary tab. Your template creator may have
created other fields on other tabs whose data also is passed to Campaign. When in
doubt, consult your template creator.

You must have the Edit Campaign permission in Campaign to update the
campaign.

Data in the TCS gets sent to Campaign when you publish the TCS.

To update a linked campaign
1. Open the campaign project for the linked campaign.

2. On the Summary tab, click the Update Campaign icon ( ).

Completing the TCS
You define all of the target and control cells for your campaign and assign offers in
the Target Cell Spreadsheet. Your TCS must contain all cell definitions for your
entire campaign. Multiple flowcharts in a campaign can link to cells in the TCS,
but each TCS row can only be linked to one flowchart cell. For example, you may
have cells defined for wave one of a campaign that is delivered through email and
different cells defined for wave two delivered through the call center. Wave one
and wave two may be implemented in different flowcharts and the cells can share
the same attribute values (for example, cell code) if they represent the same group
of audience IDs in both flowcharts.

Each row must have values in the Cell Name and Is Control Cell? columns or the
row will not save. If you do not provide a cell code, one is automatically generated
when you publish the TCS. If you provide a code, it must meet the cell code
format requirements configured in Campaign. If the allowDuplicateCellCodes
configuration parameter is set to FALSE, cell codes must be unique within a
flowchart. If you delete the cell code for a row in the TCS and republish the TCS,
Campaign creates a new cell code for the row. Any existing link between that cell
and a flowchart persists.

The TCS is an editable grid, so you enter data in it just as you would in any other
editable grid. You can copy and paste TCS rows.

Additions or changes you make to the TCS are not visible in Campaign until you
click Publish on the TCS.
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If you delete a row that is linked to a flowchart cell and republish the TCS, any
flowchart cell that is linked to that TCS row becomes unlinked, although no data is
lost. If that cell is input to a contact process (a Call List, Mail List, or Optimize
process box), you must link the flowchart cell to another TCS row before you can
run the flowchart in production mode.
Related tasks:
“To create a TCS” on page 13
“Offer workflow in an integrated system” on page 38

About editing grid data
When you work with grids in edit mode, you can add rows, delete rows, and edit
existing data. In a single editing session, you can perform all of these tasks if you
have the proper permissions.

Permissions

You must have the following permissions to work with grids. Ask your
administrator if you need help.
v To add a row, you must have the View Tab, Edit Tab, Edit Grid, and Add Grid

Row permissions for the tab with the grid.
v To edit a row, you must have the View Tab, Edit Tab, and Edit Grid

permissions for the tab with the grid.
v To copy and paste a row, you must have the View Tab, Edit Tab, and Edit Grid

permissions for the tab with the grid.
v To delete a row, you must have the View Tab, Edit Tab, Edit Grid Row, and

Delete Grid row permissions for the tab with the grid.

Locked data

The system prevents you from editing a row that is currently being edited by
another user. For a Target Cell Spreadsheet, the entire grid is locked for editing
instead of individual grid rows.

Revision history

Marketing Operations maintains an audit log for grids. The audit log contains the
user details and the time it was saved. This information is available on the
Analysis tab.

To add new grid rows

To add a row, you must have the View Tab, Edit Tab, and Add grid row
permissions for the tab with the grid.

Also, ensure that all required columns are visible in your current grid view.
Otherwise, you receive an error when trying to save any new rows.
1. Navigate to the grid you want to update.
2. Click Edit.
3. Select a row.

Select the row above the location for your new row.
4. Click Add Row.

Marketing Operations adds a new row below the selected row.
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Note: If you did not select a row, the new row is appended to end of the
current page.

5. Click an empty field in the new row and enter or select values.
6. After you have added all your data, click Save.

Note the following:
v After you add a row, Marketing Operations warns you if you leave the page

without saving your work.
v All the cells of newly added rows are either blank or filled with default data as

specified during the form definition.
v If you select multiple rows before adding a row, the new row is added after the

selected block.
v If you add multiple rows before saving, all new rows must pass validation, or

none of the new rows are saved.
v If you hide a required column while you are adding data, you receive an error

when you attempt to save. You must make all required columns visible, and
then retry to add your data.

v When you save the new data, note that the position of newly added rows may
change; the order of rows is dependent on the sort column for the grid.

To edit grid rows

To edit a row, you must have the View Tab, Edit Tab, and Edit grid row
permissions for the tab with the grid.
1. Navigate to the grid you want to update.
2. Click Edit to change from view mode to edit mode.
3. Navigate to the page that contains the data to edit, then double-click in any

field to change its value.

Note: If the row is currently in use by another user, the system displays a
message saying that you cannot edit the row. In this case, you can edit another
row.
An editor appears for the specific data type of the selected field. For example, if
you select a date field, the date picker displays.

4. After you have made all your changes, click Save to save your work and return
to view mode.

To delete grid rows

To delete a row, you must have the View Tab, Edit Tab, and Delete grid row
permissions for the tab with the grid.

You can delete one or several rows of grid data during an editing session. Before
you can delete a row permanently, the system prompts you to confirm your
selections.
1. Navigate to the grid that contains the data you want to delete.
2. Select a row to delete, then click the delete icon.

A message describing the row(s) that are marked for deletion appears.
3. Repeat step 2 until all rows you want to delete are marked.
4. Click Save to remove the rows you marked for deletion.
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If any of the selected rows are currently in use by another user, the system
displays a message saying that you cannot delete the row. Any selected rows
that are not in use are deleted.

Publishing the TCS
To make the cell definitions and offer assignments in the TCS available to
Campaign, you must publish the TCS. Anytime you make subsequent updates to
any data in the TCS, you must publish the TCS again to make those changes
visible to Campaign. To publish the TCS, you must have the Manage Campaign
Target Cells permission in Campaign. A flowchart cannot link any cells to the TCS
rows until the TCS is published.

Every row in the TCS must have a value for the Cell Name and Is Control Cell
columns before you can publish the TCS.

Although publishing the TCS makes the data available to the flowchart in
Campaign, you cannot start a production run of a particular flowchart until all the
linked rows in the TCS are approved. You can start a test run of a flowchart at any
time.

If the data in the TCS changes, you must publish the TCS again to update the data
available to Campaign.

If the TCS contains data that has not been published, the Publish button label is
red.
Related tasks:
“Offer workflow in an integrated system” on page 38

To publish the TCS

Every row must have a value for the Cell Name and Is Control Cell? columns
before you publish the TCS. If the TCS contains unpublished data, the Publish
button label is red.
1. Open the project that contains the TCS.
2. Click the Target Cell Spreadsheet tab.
3. Click Publish.

To access a campaign in IBM Unica Campaign

The Implementation button displays only if the linked campaign for the project
exists.
1. Open the corresponding campaign project in Marketing Operations.

2. Click the Implementation button ( ) to the right of the Analysis tab.

Updating cell status in the TCS
Updating cell status imports run results for the cells in the TCS from Campaign
into Marketing Operations. When you update cell status, Marketing Operations
imports the latest run results. The results of previous runs are irretrievably lost.
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You can only update cell status if one or more cells are linked to a flowchart. You
must have the Manage Campaign target cells permission in Campaign to update
the cell status.

When you update the cell status, Marketing Operations places the imported
information in the following read-only fields of the TCS:

Field Description

Flowchart Name of the flowchart in which the cell is used

Last Run Date and time of the last run for the flowchart containing this cell

Actual Count Number of unique audience IDs in the cell during the last run

Run Type Run type for the last run of the flowchart that contains this cell
(production or test; flowchart, branch, or process box)

To update cell status data in the TCS
1. Open the project whose cell count data you want to update.
2. Click the Target Cell Spreadsheet tab.
3. Click Get cell status.

About flowcharts
You use flowcharts to perform a sequence of actions on your data for executing
your campaign logic. Campaigns are made up of one or more flowcharts.
Flowcharts are made up of processes, which you configure to perform the data
manipulation, contact list creation, or contact and response tracking required for
your campaign. In effect, the processes are how you define and implement a
campaign.

Note: Working with flowcharts requires the appropriate permissions. For
information on permissions, see the IBM Unica Campaign Administrator's Guide.

Creating flowcharts
You can add a new flowchart to your campaign either by creating a new one, or
copying an existing one.

Copying an existing flowchart may save time because you can start with a
completed flowchart and modify it to meet your needs.

To facilitate constructing flowcharts, you can use pre-configured flowchart
templates to quickly create common campaign logic or process box sequences. You
can also save and reuse other objects such as queries, table catalogs, triggers,
custom macros, user variables, and definitions of derived fields.

About flowchart names
There are restrictions in the use of special characters in flowchart names. For
details, see Appendix A of the Campaign User Guide.

To create a new flowchart

Note: If you are creating an interactive flowchart, see the IBM Unica Interact
documentation for information.
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1. In the campaign or session to which you want to add a flowchart, click the
Add a Flowchart icon.
The Flowchart Properties page appears.

2. Enter a name and description for the flowchart.

Note: Flowchart names have specific character restrictions. For details, see
“About special characters” on page 27.

Note: Under Flowchart Type, Standard Batch Flowchart is the only option
unless you are a licensed user of Interact. If you have installed a licensed
version of Interact, you can also select Interactive Flowchart.

3. Click Save and Edit Flowchart.
The Flowchart page displays the process palette and a blank flowchart
workspace.

4. Add processes to your flowchart.
A flowchart typically begins with one or more Select or Audience processes to
define the customers or other marketable entities with which to work.

Important: Be sure to click Save frequently while adding and configuring the
processes in your flowchart.

5. Click Save or Save and Exit when you have finished creating your flowchart.

About processes
For details on creating processes, see the chapters "Working with Processes" and
"Campaign Processes" in the Campaign User Guide.

Testing flowcharts
You can conduct a test run on a flowchart or branch if you do not want to output
data or update any tables or files. However, note that triggers execute on
completion of both test and production runs.

When testing processes, branches, or flowcharts, note that global suppression is
applied.

Note: A best practice is to conduct test runs on processes and branches as you are
building flowcharts, so that you can troubleshoot errors as they occur. Also,
remember to save each flowchart before you run or test it.

To test run a flowchart
1. On a flowchart page in Edit mode, click the Run icon and select Test Run

Flowchart.
The flowchart runs in test mode. Data is not written to any tables.
Each process displays a blue checkmark when it has run successfully. If there
are errors, the process displays a red "X".

2. Click Save and Exit to save the flowchart.
You can also click Save to save the flowchart and leave it open for editing.
If you click Save and Exit before the flowchart has finished running, the
flowchart will continue running and save when it finishes. If you or another
user re-open the flowchart while it is still running, any changes made to the
flowchart are lost. For this reason, always save a flowchart before running it.
To pause the run, right click on the process box and select Run > Pause. To
stop the run, right click on the process box and select Run > Stop.
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3. Click the Analysis tab on the Campaign toolbar and view the Campaign
Flowchart Status Summary report to determine if there were any errors in the
flowchart run.

About approving the TCS
If the project was created using a template on which the Approval Required
checkbox is selected, then every row in the TCS linked to a flowchart must be
approved before that flowchart can be executed in production mode in Campaign.
If you run the flowchart in production mode and one or more rows on the TCS
associated with this flowchart have not been approved, Campaign generates an
error.

If necessary, you can approve each row on a TCS individually. You can approve
rows as soon as they are complete and correct, even if other rows on the TCS are
not yet ready to be approved.

If the project was created using a template on which the Approval Required
checkbox is not selected, then approval is not required for top-down cells in the
TCS. In this case, the TCS grid will not show the approval column or approve all
and deny all. Leaving the approval required checkbox unselected saves time if
campaigns do not require TCS approval.

Note: By default, Approval Required is unchecked. However, if you upgraded to
Marketing Operations 8.5, all upgraded campaign templates will have Approval
Required checked.

Import and Export

If Approval Required is selected, the is approved column will export.

If Approval Required is not selected, the is approved column will not export and
onlymatching CSV files will import.

To approve an individual TCS row
1. Open the project that contains the TCS.
2. Click the Target Cell Spreadsheet tab.
3. Click the Edit icon.
4. Double-click the Is Approved column for the row you want to approve.

The No/Yes drop-down list displays.
5. Click Yes.
6. When you are through editing the TCS, click the Save and Exit icon.

To approve all rows in a TCS
1. Open the project that contains the TCS.
2. Click the Target Cell Spreadsheet tab.
3. Click Approve All.

To deny approval to all TCS rows
1. Open the project that contains the TCS.
2. Click the Target Cell Spreadsheet tab.
3. Click Deny All.
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Running flowcharts
You can choose to run an entire flowchart, a branch, or an individual process in
the flowchart. For best results, conduct test runs as you are building flowcharts, so
that you can troubleshoot errors as they occur, and be sure to save each flowchart
before you test or run it.

Important: For flowcharts containing contact processes, note that each production
run of a flowchart can generate contact history only once. To generate multiple
contacts from the same list of IDs, snapshot out the list of IDs and read from the
list for each flowchart run.

Note: Users with Administrative privileges can access the Monitoring page, which
displays all running flowcharts and their statuses, and provides controls to
suspend, resume, or stop flowchart runs.

To run a flowchart
1. If you are viewing a flowchart, you can run it by clicking the Run icon and

selecting Run This.
If you are editing a flowchart, click the Run icon and select Save and Run
Flowchart.

2. If the flowchart has already been run, click OK on the confirmation window.
Data from the run is saved to the appropriate system tables. Each process
displays a blue checkmark when it has run successfully. If there are errors, the
process displays a red "X".

3. Click Save and Exit to save the flowchart.
You can also click Save to save the flowchart and leave it open for editing.
You must save the flowchart once after running to view the results of the run
in any reports. Once you have saved the flowchart, results of repeated runs are
immediately available.

Note: If you click Save and Exit before the flowchart has finished running, the
flowchart will continue running and save when it finishes.

4. Click the Analysis tab on the Campaign toolbar and view the Campaign
Flowchart Status Summary report to determine if there were any errors in the
flowchart run.

Importing response and contact history
If your campaign project has a Tracking tab, the template creator mapped contact
and response metrics in Campaign with metrics in Marketing Operations. You can
import the metric data into the campaign project.

You must have the Analyze campaign permission in Campaign to import metrics.

To import metrics from a campaign
1. Navigate to the Tracking tab of the campaign project whose metrics you want

to import.
2. Click Import Values.

The IBM Unica Campaign metrics are displayed on the Import Values page.
The information imported depends on the metrics the template creator defined.
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IBM Unica Marketing Operations captures and displays the last date of import,
shown as External Sources Last Refreshed Date Time at the bottom of the
table.

3. Click Save and Finish to update the metrics on the Tracking tab and close the
Import Values page.

If necessary, manually update metrics that you imported.

Integration reports

When the Marketing Operations and Campaign integration report pack is installed,
the following reports are available.

Report Description

Campaign Cell
Financial
Comparison

A Cognos report that displays budget, revenue, and ROI information
for each campaign and each cell within the campaign. This report
requires the Marketing Operations Financial Management module.

Campaign Offer
by Channel
Financial
Comparison

A Cognos report that displays budget, revenue, and ROI information
for each campaign, each channel within the campaign, and each offer
within the channel. This report requires the Marketing Operations
Financial Management module.

Campaign Offer
Financial
Comparison

A Cognos report that displays budget, revenue, and ROI information
for each campaign and each offer within the campaign. This report
requires the Marketing Operations Financial Management module.
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Chapter 4. Managing offers and offer templates in an
integrated system

If offer integration is enabled, you create offers in Marketing Operations, then
publish them for use in Campaign. In this way, you can set up offers before they
are assigned to cells in Campaign. Offers are based on templates, which are also
created in Marketing Operations.

When offer integration is enabled:
v You create and manage offers using the Operations menu instead of the

Campaign menu.
v You create and manage offer templates using Marketing Operations Settings

instead of Campaign Settings.
v You use Marketing Operations to assign offers and offer lists to output cells in

the Target Cell Spreadsheet (TCS) form of a campaign project.

Summary of offer integration features
The following list summarizes the offer integration features for IBM Unica
Campaign and IBM Unica Marketing Operations.

New "offer" marketing object type

Offers are available in Marketing Operations 8.5.0 as a system-defined marketing
object. Users cannot define offers manually.

Offer states

Offers have the following states.
v Draft: Whenever the new offer instance is created, the state of the offer is Draft.
v Published: The state Published pushes the offer instance to Campaign. The first

publish creates the offer in Campaign; subsequent publishing updates the offer
instance in Campaign.

v Redraft: Once the offer is Published, it cannot be edited. To edit a published offer,
the user can redraft the offer, which changes it to the Draft state. User can then
edit the offer and publish changes.

v Retire: Only Published offers can be Retired. Once the offer is Retired, it is not
available for the future use and cannot be edited or changed to any other state.

Create new offer instances from offer templates

Offer instances can be created in Marketing Operations from templates published
to Campaign. The offer instance also has the attributes Campaign Security Policy
and Campaign Offer code.

Offer approvals

Marketing Operations provides a check box for offer approval. Offers can only be
published to Campaign if they are approved.
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Static and dynamic attributes shared with Campaign

Marketing Operations has pre-defined offer standard attributes populated in case
offer integration with Campaign is enabled. A new category for custom offer
attribute is available in the Shared Attributes, which can be edited from Marketing
Operations.

Offer codes automatically generated

In Marketing Operations, the offer code is generated by the Default code generator.
Users cannot modify the offer code generator. In the wizard mode of offer creation,
the check box “Auto-generate on save” creates the offer code automatically. If the
check box is selected, the offer code is generated from Campaign. If the check box
is not selected, validation is made for the valid offer code.

Ability to use Marketing Operations offer management or stay
with current solution

Offer integration is a separate option from campaign integration. When campaign
integration is enabled, offer integration may also be enabled. For more information,
see “Configuration Settings for an Integrated Deployment” on page 7.

Enabling offer integration in Marketing Operations
Offer integration is a separate option from campaign integration. When campaign
integration is enabled, offer integration may also be enabled.

Enable offer integration if you want to manage offers and offer templates in
Marketing Operations rather than Campaign.

Note: If you upgraded from a previous version, and you enable offer integration,
you must use Campaign to edit any legacy offers. You cannot edit legacy offers in
Marketing Operations, although you can select them in the Target Cell
Spreadsheet.
1. Confirm that you have enabled integration in both Marketing Operations and

the appropriate Campaign partitions, as explained in “Configuration Settings
for an Integrated Deployment” on page 7.

2. For the Platform configuration settings (Settings > Configuration > Unica >
Platform), confirm that IBM Unica Marketing Operations - Campaign
integration is set to True. (This option must be set to True in order to enable
Offer integration.)

3. Set IBM Unica Marketing Operations - Offer integration to True.

Avoid turning offer integration off, once you have enabled it.
Related concepts:
“Disabling or re-enabling integration” on page 4

Offer workflow in an integrated system
This topic provides a high-level overview of the workflow for offer creation when
offer integration is enabled.

When offer integration is enabled, you create offer templates and offers in
Marketing Operations and publish the offers for use in Campaign. All of the
following tasks are performed in Marketing Operations.
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1. Create a form, including any offer-specific attributes. (Choose Settings >
Marketing Operations Settings > Template Configuration > Forms.)

2. Place the form on an offer template. (Choose Settings > Marketing Operations
Settings > Template Configuration > Templates, create or open an offer
template, then click the Tabs tab and select the form.)

3. Create an offer based on the offer template. (Choose Operations > Offer, click
the Add Offer icon, select an offer template, then use the wizard to create the
offer.) You may also want to create offer lists.

4. Publish the offer.
5. Add the offer to output cells in the Target Cell Spreadsheet form in the

campaign project.
(When Campaign is integrated with Marketing Operations, a campaign project
includes a Target Cell Spreadsheet tab. Double-click the Assigned Offers
column in the TCS to search or browse for offers.)

6. Publish the TCS.

The offer is now available in Campaign. The attribute information is automatically
passed to Campaign when a user links a flowchart cell to the TCS row.
Related concepts:
“Managing offers when offer integration is enabled” on page 40
“Managing offer templates and attributes when offer integration is enabled”
“Assigning offers and offer lists to cells when offer integration is enabled” on page
40
“Completing the TCS” on page 28
“Publishing the TCS” on page 31

Managing offer templates and attributes when offer integration is
enabled

In an integrated system, you access offer templates from Marketing Operations
Settings (instead of Campaign Settings).

Follow the guidelines below to manage offer templates and attributes in an
integrated environment.
v To work with offer templates: Choose Settings > Marketing Operations

Settings > Template Configuration > Templates. You can then configure
templates and template components as you normally would. For example, you
can add, edit, disable, delete, and perform other template operations.

v To work with offer attributes: Choose Settings > Marketing Operations
Settings > Template Configuration > Shared Attributes. Use the Offer
Attribute section to create or edit offer attributes. For example, use the Create a
Offer Attribute link to define a custom attribute, or click any listed
system-defined or custom attribute to edit it. Offer attributes are intended for
information placed on an offer template, for offers to be shared with Campaign.
Offer attributes are synchronized with Campaign when the offer template is
published to Campaign. Although you can add Marketing Operations attributes
to offers (attributes that are required only for planning in Marketing Operations),
those attributes are not synchronized with Campaign.

For more information about offer templates and attributes, see the IBM Unica
Campaign Administrator's Guide.
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Related tasks:
“Offer workflow in an integrated system” on page 38

Managing offers when offer integration is enabled
In an integrated system, you access offers using Operations > Offer (instead of
Campaign > Offers), then perform operations as you normally would.

Follow the guidelines below to manage offers in an integrated environment.
v To create an offer: Choose Operations > Offer, click the Add Offer icon, select

an offer template, then use the wizard to create the offer. You can check the "Is
Approved" checkbox to approve the offer when you create it, or you can
approve it later. Offers are created in the campaign root folder. An offer is
always in one of four states: Draft, Published, Redraft, or Retire. When an offer
is created, its state is Draft. To make it available in Campaign, you must approve
and then publish the offer.

v To approve an offer: Choose Operations > Offer, click the offer link, and check
the Is Approved box. Then you can publish the offer.

v To publish an offer: Only approved offers may be published. Choose Operations
> Offer, check the box next to the offer, click the Status icon, and select Publish
Selected. This action pushes the offer instance to Campaign. Published offers
can be selected for use in a Target Cell Spreadsheet.

v To edit an offer: A published offer cannot be edited until you change it to the
Draft state: Choose Operations > Offer, check the box next to the published
offer, click the Status icon, and select Re-draft Selected. Now you can edit the
offer, then publish the changes.

v To retire an offer: Only published offers can be retired. A retired offer is not
available for future use and cannot be edited or changed to any other state. To
retire an offer, choose Operations > Offer, check the box next to the published
offer, click the Status icon, and select Retire Selected.

For more information about offers, see the IBM Unica Campaign User's Guide.

Related tasks:
“Offer workflow in an integrated system” on page 38

Assigning offers and offer lists to cells when offer integration is
enabled

In an integrated environment, use Marketing Operations to assign offers and offer
lists to output cells in a Target Cell Spreadsheet (TCS).

The TCS appears in Marketing Operations as part of a campaign project. If you
double-click the Assigned Offers column for a row when the TCS is in edit mode,
you can search or browse for offers. When you publish the TCS, the offers are
automatically assigned to cells when you select them in a contact process box in
the flowchart. In this way, the TCS cells are linked to flowchart cells. This is
known as "top-down" management. Note that additions or changes to the TCS are
not visible in Campaign until you click Publish on the TCS. Bottom-up target cells
are allowed if MO_UC_BottomUpTargetCells is set to Yes (Unica > Campaign >
partitions > partition[n] > server > internal).
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Related tasks:
“To create a TCS” on page 13
“Offer workflow in an integrated system” on page 38
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
170 Tracer Lane
Waltham, MA 02451
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
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been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at “Copyright and
trademark information” at www.ibm.com/legal/copytrade.shtml.
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