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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.8 requires Unica Platform 12.1.8.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this

product, see the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some
information not being properly displayed. If you use a lower resolution, maximize the browser window to see
more content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead,
use the controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function
properly. For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms.
For more information, see the Recommended Software Environments and Minimum System Requirements
document.

« The correct browser and versions must be used. For more information, see the Recommended Software
Environments and Minimum System Requirements document.

- Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do
not open another browser session from the Start menu or desktop icon; and do not use File > New Window in

Microsoft Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their

hands on the product functionality.
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Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the
Unica Journey User Guide

Find out about the known issues and limitations

Unica Journey Release Notes

Learn about the structure of the Unica Journey system

tables

Unica Journey System Schema

Installation and configuration of Unica Journey

Unica Journey Installation Guide

Upgradation and configuration of Unica Journey

Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task

Documentation

Installation and configuration of Unica Link

Unica Link Installation Guide

Installing Unica Link connector app for Journey

Unica Link Installation Guide

Installing Unica Link connector — MailChimp

Unica Link Mailchimp Connector User Guide

Installing Unica Link connector — Mandrill

Unica Link Mandrill Connector User Guide

Installing Unica Link connector — Twilio

Unica Link Twilio Connector User Guide

Installing Unica Link connector — Salesforce

Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task

Documentation

Integration of Unica Campaign and Unica Journey

Unica Campaign Administration Guide and Unica Cam-

paign User Guide

Integration of Unica Campaign and Unica Interact

Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey

Unica Journey User Guide

Integration of Unica Centralized Offer Management and

Unica Journey

Unica Journey User Guide

Table 4. Get Help

Task

Documentation

Unica Journey documentation

You can get Unica Journey product documentation while
you logged in Help > Product documentation.
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Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.

Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per
your requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system, application server etc., is not
exactly same support with Unica Journey. Please refer to Recommended Software Environments and Minimum
System Requirements guide.

For example, If your existing Unica products are installed on stack as below:

» Operating System - AIX 7.2 TL5
« Application Server - WebSphere
 Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended Software Environments
and Minimum System Requirements guide and it would be compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.8, you can complete your upgrade and then install Unica
Journey 12.1.8.

Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:

Google Chrome and Microsoft Edge configuration

Recently, the browsers Google Chrome and Microsoft Edge updated a security fix and this security fix affects the

access of Unica applications. We have received some issues from our customers like:

« issues with Ul
- getting logged out from Unica
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These issues are observed due to the change of behavior in browsers after applying the security fix. Applying the
security fix automatically enables Origin-keyed Agent Clusters by default. If the setting Origin-keyed Agent Clusters
by default is enabled automatically, it prevents changes in document referrer and domain values so that malicious
websites cannot execute any type of impersonation. The setting Origin-keyed Agent Clusters by default existed

earlier as well, but was not enabled by default.

If you update Google Chrome or Microsoft Edge to the latest version, you will observe the earlier mentioned issues.
Because of how Unica is designed and because the Unica suite is deployed over multiple JVMs, it is essential that
you disable the Origin-keyed Agent Clusters by default setting for Unica to function correctly and to provide a good

user experience.

As a solution, we recommend that you perform the steps mentioned in the following Knowledge Base article: https://
support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185.

Note: The update to Microsoft Edge browser is very recent and the Knowledge Base article is not yet updated
for the Microsoft Edge browser.

The CliffsNotes solution is as follows:

1. Open your browser and navigate to one of the following URLs based on your browser:
- Google Chrome: chrome://flags/#origin-agent-cluster-default
o Microsoft Edge: edge://flags/#origin-agent-cluster-default
2. From the dropdown of the highlighted parameter Origin-keyed Agent Clusters by default, select bi sabl ed.
3. At the bottom of the page, click the Apply Changes button.
4. Log out of Unica applications, log back in, and verify if everything is working as expected.


https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
chrome://flags/#origin-agent-cluster-default
edge://flags/#origin-agent-cluster-default

Chapter 2. Prerequisites for Unica Journey Installation or

Upgrade

Before installing Unica Journey version 12.1.8, you have to ensure that a few prerequisites are met.

If a you are a new user, and if you have HCL OneDB, MariaDB, DB2 or Microsoft SQL Server as the database, you can

directly install Unica Journey 12.1.8. Ensure that Unica Platform version 12.1.8 is operating correctly.

The supported upgrade path for Unica Journey 12.1.8 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-

topics in the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

«12.1.x
*12.1.0.x

In case of Microsoft SQL Server,
MariaDB and OneDB, the base ver-
sion is 12.1.0.3 and later.

In case on Db2 Base version should
be 12.1.5

In case of Oracle, the upgrade path

can be:

*+121x-12.1.8
+121.0x-12.1.8

In case of Microsoft SQL Server,
MariaDB and OneDB, the upgrade
path should be:

+12.1.0.3-12.1.8

In case of DB2, the upgrade path
should be:

*121.4-12.1.8

1. Upgrade Unica Marketing
Platform to 12.1.8

2. Run upgrade Unica Journey
to 12.1.8 installer

3. Configure Journey applica-
tion

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on existing

Unica environment when you have

OneDb and DB2 databases

system tables as SqlServer,MariaDB,

In place upgrade to Unica Journey
12.1.8

1. Upgrade Unica Marketing
Platform and required Uni-
ca products to 12.1.8 except
Journey.

2. Run clean installer of Unica
Journey 12.1.8

3. Configure Journey applica-
tion

4. Deploy Journey application

5. Run Journey application
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Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-
topics in the second column. (continued)

In case of Postgres, the base Unica | Upgrade not applicable
1. Upgrade Unica Marketing

Journey can be: 12.1.8
Platform and required Uni-
ca products to 12.1.8 except
Journey.

2. Run clean installer of Unica
Journey 12.1.8

3. Configure Journey applica-
tion.

4. Deploy Journey application.

5. Run Journey application.

Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.8. If Journey is already installed
and the Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server,
OneDB, DB2, MariaDB or PostgreSQL database then you can install Journey version 12.1.8 directly as
clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other
components, for example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.8

In Unica Journey 12.1.8, we have introduced some new features, and we have made changes to some existing

features or functionality.
The following list mentions the new features, and the changes to existing features, in Unica Journey 12.1.8:

PostgreSQL support for Journey

In version 12.1.8, Unica Journey introduces compatibility by adding support for Postgres as the SystemDB. This
enhancement provides users with the flexibility to seamlessly integrate Unica Journey with Postgres, offering a robust

and scalable solution for managing system databases.

Link Multiple partitions support

Journey now supports Link multi partition.

Support latest version of facebook graph api and google apis
Link Connectors - Latest facebook Graph and Google API support

Applicable to connectors -

» Facebook

- Google

Support the latest version of facebook graph APIs and Google APIs.

Note:

1. User need to manually add/update LinkedIn Version in LinkedIn connection as ->202304
2. User need to manually add/update Facebook version in Facebook connection as ->v17 e.g. https:/

graph.facebook.com/v17.0.


https://graph.facebook.com/v17.0
https://graph.facebook.com/v17.0

Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.8:

Defect ID Known Issue

HMA-361368 Journey rejected the correct emails - Validation error. This issue was for
@hcl.software domain and is fixed.

HMA-352328 Inconsistent (12.1.4) - sales setup - Some time Journey is not getting copied




Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.8:

Defect ID Known Issue

HMA-363543 Loop - when user modify the loop end points or after deleting loop adds again in
paused journey journey is not getting republished.

HMA-363278 pre: DB2-Rest TP stats showing special characters

HMA-363337
Observing java.lang.ArraylndexOutOfBoundsException error for com.hcl.journey-
.engine.scheduler.transformers.JourneyAudienceReportTransformer.

HMA-363277
DB2 -(inconsistent) Link Salesforce goals count is not updating on goals page.

HMA-363193 Data cleanup - for stop audiences when audiences are in Pausedaudiences table
- data is not getting cleaned up.

HMA-362217 Pre12.1.7 - Journey settings is lost for partition setting in case of Imported Jour-
neys.

HMA-362161 Pre12.1.7 - Imported Journey is expected to be created inside folder when folder
is selected and imported but it gets created in Journeys list screen.

HMA-362126 Postgres - Error observed when trying to create Duplicate copy for Imported
Journey.

HMA-362107 Pre12.1.7 - Journey settings is lost for partition setting when created from Tem-
plates.

HMA-361192 Director Multipartition setup - Journey Uploaded/Output files count shown is not
partition specific.

HMA-361899 For Pre-nodbspecific PostgreSQL — When milestone date condition is import-
ed in Journey, the Milestone conditions are store value as "Invalid date". Hence,
milestones do not work on imported Journeys.
Work around
Manually edit the milestones value.

HMA-359255 QueryTimeoutException is observed and journey delete scenario gets stuck
when large data is present in all the tables.
Work around
User needs to create the following indexes in the mentioned database tables:
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Defect ID

Known Issue

« create index MY_UJR_IDX_LAF on LoopAudienceFlow(audienceld);

« create index MY_UJR_IDX_BIDADM on BatchIDAudiencedataMap(audi-
enceld);

« create index MY_UJR_IDX_JAG on JourneyAudienceGoal(audienceld);

« create index MY_UJR_IDX_ARHD on AudienceResponseHTTPDetail(audi-
enceResponseld);

« create index MY_UJR_IDX_ARMD on AudienceResponseMetaData(audi-
enceResponseld);

« create index MY_UJR_IDX_ARI on AudienceResponselnteraction(audi-
enceResponseld);

« create index MY_UJR_IDX_AR on AudienceResponse(audienceld);

« create index MY_UJR_IDX_JAF on JourneyAudienceFlow(audienceld);

« create index MY_UJR_IDX_AWS on AudienceWaitState(audienceld);

« create index MY_UJR_IDX_JDRM on JourneyDeliverResponseMaster(au-
dienceld);

« create index MY_UJR_IDX_JAM on JourneyAudienceMilestone(audience-
Id);




Chapter 6. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated
support contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is
resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System

information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which

provides information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for a

ver si on. t xt file that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support


https://www.hcltech.com/products-and-platforms/contact-support
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