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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.7 requires Unica Platform 12.1.7.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this product, see

the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some

information not being properly displayed. If you use a lower resolution, maximize the browser window to see more

content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the

controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function properly.

For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms. For

more information, see the Recommended Software Environments and Minimum System Requirements document.

» The correct browser and versions must be used. For more information, see the Recommended Software

Environments and Minimum System Requirements document.

« Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do not

open another browser session from the Start menu or desktop icon; and do not use File > New Window in Microsoft

Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their hands on

the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the

Unica Journey User Guide
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Table 1. Get up and running (continued)

Task Documentation

Find out about the known issues and limitations Unica Journey Release Notes
Learn about the structure of the Unica Journey system Unica Journey System Schema
tables

Installation and configuration of Unica Journey Unica Journey Installation Guide
Upgradation and configuration of Unica Journey Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide

Installing Unica Link connector app for Journey Unica Link Installation Guide

Installing Unica Link connector — MailChimp Unica Link Mailchimp Connector User Guide
Installing Unica Link connector — Mandrill Unica Link Mandrill Connector User Guide
Installing Unica Link connector — Twilio Unica Link Twilio Connector User Guide
Installing Unica Link connector — Salesforce Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task Documentation

Integration of Unica Campaign and Unica Journey Unica Campaign Administration Guide and Unica Campaign
User Guide

Integration of Unica Campaign and Unica Interact Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey Unica Journey User Guide

Integration of Unica Centralized Offer Management and Unica Journey User Guide

Unica Journey

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product documentation while you

logged in Help > Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.
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Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per your

requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system, application server etc., is not
exactly same support with Unica Journey. Please refer to Recommended Software Environments and Minimum System
Requirements guide.

For example, If your existing Unica products are installed on stack as below:

» Operating System - AIX 7.2 TL5
« Application Server - WebSphere
« Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended Software Environments and

Minimum System Requirements guide and it would be compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.7, you can complete your upgrade and then install Unica

Journey 12.1.7.
Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:

Google Chrome and Microsoft Edge configuration

Recently, the browsers Google Chrome and Microsoft Edge updated a security fix and this security fix affects the access of
Unica applications. We have received some issues from our customers like:

« issues with Ul
« unable to edit flowcharts
- getting logged out from Unica

These issues are observed due to the change of behavior in browsers after applying the security fix. Applying the security

fix automatically enables Origin-keyed Agent Clusters by default. If the setting Origin-keyed Agent Clusters by default
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is enabled automatically, it prevents changes in document referrer and domain values so that malicious websites cannot
execute any type of impersonation. The setting Origin-keyed Agent Clusters by default existed earlier as well, but was not
enabled by default.

If you update Google Chrome or Microsoft Edge to the latest version, you will observe the earlier mentioned issues. Because
of how Unica is designed and because the Unica suite is deployed over multiple JVMs, it is essential that you disable the
Origin-keyed Agent Clusters by default setting for Unica to function correctly and to provide a good user experience.

As a solution, we recommend that you perform the steps mentioned in the following Knowledge Base article: https://

support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185.

Note: The update to Microsoft Edge browser is very recent and the Knowledge Base article is not yet updated for the
Microsoft Edge browser.

The CliffsNotes solution is as follows:

1. Open your browser and navigate to one of the following URLs based on your browser:

> Google Chrome: chrome://flags/#origin-agent-cluster-default

> Microsoft Edge: edge://flags/#origin-agent-cluster-default
2. From the dropdown of the highlighted parameter Origin-keyed Agent Clusters by default, select bi sabl ed.
3. At the bottom of the page, click the Apply Changes button.

4. Log out of Unica applications, log back in, and verify if everything is working as expected.


https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0107185
chrome://flags/#origin-agent-cluster-default
edge://flags/#origin-agent-cluster-default

Chapter 2. Prerequisites for Unica Journey Installation or

Upgrade

Before installing Unica Journey version 12.1.7, you have to ensure that a few prerequisites are met.

About this task

If a you are a new user, and if you have HCL OneDB, MariaDB, DB2 or Microsoft SQL Server as the database, you can directly

install Unica Journey 12.1.7. Ensure that Unica Platform version 12.1.7 is operating correctly.

The supported upgrade path for Unica Journey 12.1.7 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in

the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

*+12.1.x
*12.1.0.x

In case of Microsoft SQL Server,
MariaDB and OneDB, the base version
is 12.1.0.3 and later.

In case on Db2 Base version should be
12.1.5

In case of Oracle, the upgrade path can
be:

*121.x>12.1.7
*+12.1.0x»12.1.7

In case of Microsoft SQL Server,
MariaDB and OneDB, the upgrade path
should be:

+121.0.3>12.1.7

In case of DB2, the upgrade path should
be:

+121.45121.7

1. Upgrade Unica Marketing
Platform to 12.1.7

2. Run upgrade Unica Journey to
12.1.7 installer

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on
existing Unica environment

when you have system tables as
SqlServer,MariaDB,0ONeDb and Db2

databases

In place upgrade to Unica Journey
12.1.7

1. Upgrade Unica Marketing
Platform and required Unica
products to 12.1.7 except
Journey.

2. Run clean installer of Unica
Journey 12.1.7

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application
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Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.7. If Journey is already installed and the
Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server, OneDB,

DB2 or MariaDB database then you can install Journey version 12.1.7 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other components, for
example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.7

In Unica Journey 12.1.7, we have introduced some new features, and we have made changes to some existing features or

functionality.
The following list mentions the new features, and the changes to existing features, in Unica Journey 12.1.7:
Journey to support multiple partitions

Unica Journey introduces support for Multi Partition. Partitions provide a way to secure data associated with different
groups of users and Business Units. Once Unica Journey is configued to operate with multiple partitions, each partition
appears to application users as a separate instance of the application and they can view and manage data and resources

associated with their partition.
Journey-Support for additional REST elements in Journey Ul

Unica Journey now supports adding additional elements dynamically while configuring REST API requests providing a way to
add custom name/value pairs and QUERY PARAMETERS, HEADERS, etc

Confluent Kafka with Unica Journey
Unica Journey now supports Confluent Kafka as part of its technology stack.

As a journey designer, | should be able to specify the variable or place holder for data definiiton fields in query parameters,
headers and url path in the rest touch point configuration

This feature now allows specifying the variable or place holder for data definition fields in query parameters, headers and
url path in the rest touch point configuration. The placeholders will be replaced by actual values during Journey Execution -
providing a way to customize the query parameters, headers and url paths for each audience.

Journey-Integrate Mobile Push Channel with Link

Unica Journey introduces Mobile Push messaging using Unica Link connector leveraging third party vendors like Batch.com.
With this new feature, Journey now supports Push Messaging through Unica Deliver or using the Unica Link connector.

Journey-Full Pll data Masking and Data Logs masking

Journey now provides a way to mask/hide the personal identifiable information data (PII) for a regular user from viewing it.
Once configured, details page with processing details showing audience data is blocked completely along with disabling of
deep links in the popups showing stats.

Journey-Establish a Secure REST API Connection
Unica Journey now supports Secure REST API connections
Journey-Delete Journey

Unica Journey now supports deleting Completed journeys - this allows removing completed journeys and associated
audience data and responses.
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[Performance] Ability to flag if the audience is to be considered New / Update / as per dedup check

With the intention to optimize audience deduplication process, Journey engine supports certain optional hints, which can be
supplied along with the audience message. With this - both at data level and at audience level - Journey optimizes Dedup to

handle only Inserts or Updates based on user setting in the json.
Journey-Duplicate data definition DD

Unica Journey now supports creating a new copy of an existing Data Definition.
Journey-Support for additional Methods in REST touchpoint

REST API touchpoint now supports PUT/PATCH methods

Journey-Support to add headers in REST

Support for adding Headers to REST calls is now available

Journey-Support for custom request query parameters in REST

REST API touchpoint now supports customer Request Query parameters.
Journey-Show Data Definition and Entry Source codes in Journey

Data Definition and Entry Source codes are now displayed along with their names making it easier to track them where

names are similar. Hyperlinks of these codes makes it easy to navigate to their details page
Journey - Unica products communication with internalServer URL from Platform

Unica supports using Internal URL for Platform now providing a more secure way of communication with Unica products
including Unica Journey

User data (audience + response) cleanup on live journey

Audience data can now be purged from the database based on configurations in the Journey application. When enabled,
audience data older than the configured days will be purged from the system thus providing a way to maintain the data
growth in the backend database.



Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.7:

Defect ID Known Issue

HMA-359192 Unable to input 3 digits value for Delay expression

HMA-358455 Journey Under integrations > Categories > Database > Create Connection, no
response is coming

HMA-358336 No data follow through Rest APl Touch Point when the Journey is re-publish after
pausing

HMA-358166 Delay in showing accepted record details/result page in Journey

HMA-355487 Missing data at Journey when paused and republish journey while the data still
flowing from campaign

HMA-355401 Unica Journey Archival Performance Improvement

HMA-354657 Unica Journey code does not support Rest-Endpoint API call over SSL

HMA-352234 Journey eye preview Error Deliver : Something went wrong on the Deliver side. Please
contact Deliver administrator.

11
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Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.7:

Defect ID

Known Issue

HMA-360381

Delete Journey - If rest TP is having responses, journey is not getting deleted

HMA-354530

LOOP- Interation counts available on kafka topics are not get added on iteration wise

on deliver TP stats

HMA-359421

If you add an invalid password for the generated certificates, REST Touchpoint does

not process the data.

HMA-348450

Loop - audience accepted time is showing always same in all iteration on loop stats

HMA-356986

In case of a REST Touchpoint, the GET API key operation is not executing because of

an authorization error.

HMA-360403

Delete Journey does not work for DB2 if data is processed through it .

Work around

Schema name must be replaced with actual schema name on which schema the

script will run.

Script is as below, highlighted text should replace with actual schema name:

DECLARE

CURSOR c_syscate_ref IS

SELECT ref.* from syscat.references ref

WHERE ref.tabname IN ('EMAILUNSUBSCRIBEDLIST', 'ENDJOURNEYAUDIENCE',
' JOURNEYAUDIENCES', 'JOURNEYAUDIENCEMILESTONE')

AND ref.REFTABSCHEMA='TESTUSER' AND ref.REFTABNAME IN ('AUDIENCERESPONSE',

'JOURNEYS', 'JOURNEYMILESTONE' );
r_syscate_ref c_syscate_ref%rowtype;
BEGIN
IF NOT c_syscate_ref%isopen THEN OPEN c_syscate_ref;
END IF;
LOOP
FETCH c_syscate_ref INTO r_syscate_ref;
EXIT WHEN c_syscate_ref%notfound;
EXECUTE IMMEDIATE 'ALTER TABLE ' || r_syscate_ref.tabname || ' DROP
CONSTRAINT ' || r_syscate_ref.constname;
END LOOP;
CLOSE c_syscate_ref;
END&&

HMA-360359

Pre - Dedup_End_Audience=No flag- audiences getting rejected in multiple of

accepted records

HMA-360094

REGBB- If journey having milestone and try to update journey name its showing erro

HMA-359891

REGBB- Some times on deliver email tp after click not showing Publish view
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Defect ID Known Issue

HMA-359811 W & W : Cluster - When user do engine services starts and stop in proper sequnce also
at certain time while starting any secondary node its showing server1 instead of 2

HMA-359786 Data_clean- Mileston- After running cleaning script milestone count is not getting
updated, though audience data gets deleted

HMA-359692 Mobile Push Channel with Link performance needs improvement

HMA-358913 Cluster setup - If Journey Web is up and running Journey engines not getting started

HMA-358869 Installation - Cluster - showing warning message in installation logs while installation
Engine

HMA-357508 After configuring Rest TP with post method and some headers, not saving response
mapping fields

HMA-355590 Incorrect formation in application.properties on windows

HMA-355496 Publish touchpoint - audiences count issue with multiple journeys being
paused/re-published

HMA-355002 Listing pages for journey on New Ul not displayed with ISAM login method

HMA-353676 Decision Split processing tps needs improvement if complex rule builder is used

HMA-352729 Full-audiences_POC_build - All audiences are not getting inserted into
JourneyAudiences table

HMA-352728 Audience processing with dedup needs improvement and consistency

HMA-352525 Observing database errors for insertion into audiences table during longevity runs

HMA-359255 QueryTimeoutException is observed and journey delete scenario gets stuck when

large data is present in all the tables.
Work around

User needs to create the following indexes in the mentioned database tables:

« create index MY_UJR_IDX_LAF on LoopAudienceFlow(audienceld);

« create index MY_UJR_IDX_BIDADM on BatchIDAudiencedataMap(audienceld);

« create index MY_UJR_IDX_JAG on JourneyAudienceGoal(audienceld);

« create index MY_UJR_IDX_ARHD on
AudienceResponseHTTPDetail(audienceResponseld);

« create index MY_UJR_IDX_ARMD on
AudienceResponseMetaData(audienceResponseld);

« create index MY_UJR_IDX_ARI on
AudienceResponselnteraction(audienceResponseld);

« create index MY_UJR_IDX_AR on AudienceResponse(audienceld);

13
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Defect ID

Known Issue

« create index MY_UJR_IDX_JAF on JourneyAudienceFlow(audienceld);

« create index MY_UJR_IDX_AWS on AudienceWaitState(audienceld);

« create index MY_UJR_IDX_JDRM on
JourneyDeliverResponseMaster(audienceld);

« create index MY_UJR_IDX_JAM on JourneyAudienceMilestone(audienceld);

HMA-358913

Cluster setup - If Journey Web is up and running Journey engines not getting started

HMA-354578

SalesForce Goals - Goals set for Salesforce counting failuer count also




Chapter 6. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated support
contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is resolved efficiently
and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which provides

information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for aver si on. t xt file

that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support
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