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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.6 requires Unica Platform 12.1.6.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this product, see

the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some

information not being properly displayed. If you use a lower resolution, maximize the browser window to see more

content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the

controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function properly.

For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms. For

more information, see the Recommended Software Environments and Minimum System Requirements document.

» The correct browser and versions must be used. For more information, see the Recommended Software

Environments and Minimum System Requirements document.

« Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do not

open another browser session from the Start menu or desktop icon; and do not use File > New Window in Microsoft

Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their hands on

the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the

Unica Journey User Guide
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Table 1. Get up and running (continued)

Task Documentation

Find out about the known issues and limitations Unica Journey Release Notes
Learn about the structure of the Unica Journey system Unica Journey System Schema
tables

Installation and configuration of Unica Journey Unica Journey Installation Guide
Upgradation and configuration of Unica Journey Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide

Installing Unica Link connector app for Journey Unica Link Installation Guide

Installing Unica Link connector — MailChimp Unica Link Mailchimp Connector User Guide
Installing Unica Link connector — Mandrill Unica Link Mandrill Connector User Guide
Installing Unica Link connector — Twilio Unica Link Twilio Connector User Guide
Installing Unica Link connector — Salesforce Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task Documentation

Integration of Unica Campaign and Unica Journey Unica Campaign Administration Guide and Unica Campaign
User Guide

Integration of Unica Campaign and Unica Interact Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey Unica Journey User Guide

Integration of Unica Centralized Offer Management and Unica Journey User Guide

Unica Journey

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product documentation while you

logged in Help > Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.
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Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per your

requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system, application server etc., is not
exactly same support with Unica Journey. Please refer to Recommended Software Environments and Minimum System
Requirements guide.

For example, If your existing Unica products are installed on stack as below:

» Operating System - AIX 7.2 TL5
« Application Server - WebSphere
« Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended Software Environments and

Minimum System Requirements guide and it would be compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.6, you can complete your upgrade and then install Unica

Journey 12.1.6.
Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:



Chapter 2. Prerequisites for Unica Journey Installation or

Upgrade

Before installing Unica Journey version 12.1.6, you have to ensure that a few prerequisites are met.

About this task

If a you are a new user, and if you have HCL OneDB, MariaDB, or Microsoft SQL Server as the database, you can directly

install Unica Journey 12.1.6. Ensure that Unica Platform version 12.1.6 is operating correctly.

The supported upgrade path for Unica Journey 12.1.6 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in

the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

*+12.1.x
*12.1.0.x

In case of Microsoft SQL Server,
MariaDB and OneDB, the base version
is 12.1.0.3 and later.

In case on Db2 Base version should be
12.1.5

In case of Oracle, the upgrade path can
be:

*+12.1.x>12.1.6
*+12.1.0x>12.1.6

In case of Microsoft SQL Server,
MariaDB and OneDB, the upgrade path
should be:

+12.1.0.3>12.1.6

In case of DB2, the upgrade path should
be:

+121.4512.1.6

1. Upgrade Unica Marketing
Platform to 12.1.6

2. Run upgrade Unica Journey to
12.1.6 installer

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on
existing Unica environment

when you have system tables as
SqlServer,MariaDB,0ONeDb and Db2

databases

In place upgrade to Unica Journey
12.1.6

1. Upgrade Unica Marketing
Platform and required Unica
products to 12.1.6 except
Journey.

2. Run clean installer of Unica
Journey 12.1.6

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application
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Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.6. If Journey is already installed and the
Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server, OneDB

or MariaDB database then you can install Journey version 12.1.6 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other components, for
example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.6

In Unica Journey 12.1.6, we have introduced some new features, and we have made changes to some existing features or

functionality.

The following list mentions the new features, and the changes to existing features, in Unica Journey 12.1.6:

» New Platform Navigation - Platform-Open Journey in same window of Unica
Journey is now part of Unica Ul and is launched and managed within the same window like Campaign and other
products. It is no longer launched in a separate screen.

 Kerberos Authentication support for KAFKA in Journey

Journey now supports Kerberos Authentication for KAFKA.

« Improve data ingestion timing in journey engine
Various improvements were done to the Journey db to improve data ingestion including tracking status in separate
table, indexes, avoiding redundant data transformations, and other enhancements.

« When Contact Central is unreachable, improve retry mechanism for handling waiting stage audiences and showing
meaningful error message
Journey integration with Contact Central is improved with retry mechanism when Contact Central is unreachable.

+ DS Rule builder Ul Enhancement
Journey's Decision Split touchpoint now supports creating complex rules based on Data Definition fields and pre-

defined set of macros like Add, Subtract, Comparing strings, Date calculations. This allows making more complex

calculations when deciding on the audience' next path.

« Journey-Full Pll data Masking and Data Logs masking

Journey now supports fully masking Pl data in the Journey Audience screen and also in the log files. Partial masking

of data is also supported.



Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.6:

Defect ID Known Issue

HMA-353135 Non Released version of .jar file in Journey WAR

HMA-352669 Journey not sending the records properly to kafka-link

HMA-352962 Journey Dedup setting - discards records instead of updating

HMA-352226 Journey eye preview Error Deliver : Something went wrong on the Deliver side. Please
contact Deliver administrator.
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Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.6:

Defect ID Known Issue

HMA-359796 Incorrect event ids in audienceresponseeventmaster

HMA-355198 cluster - 1216 - engagement split not processing data after getting responses also

HMA-348450 Loop - audience accepted time is showing always same in all iteration on loop stats

HMA-355188 1216_Cluster -Import Journey export Journey is not working

HMA-349054 DB2-specific database file is not available within the / ddl / di scover _sql _fil es/
folder.

HMA-348752 (Imported Journey)Engagement Split should be greyed out when configured
ES-Whatsapp touchpoint is deleted

HMA-349354 Event change for Engagement Split configuration done for paused Journey state
should be allowed as this change is done before Publish state

HMA-349383 Audience accepted time is showing always same in all iteration on loop stats

HMA-349494 EngineScript.sh start command does not start the engine

HMA-352777 Engagement Split warning message always displays wait time of 30 mins irrespective
of time set for 'Engagement_Split_Waittime' variable.

HMA-354338 NPN - Performance is very slow, Journeys listing loads in more than a min when
launched.

HMA-354578 SalesForce Goals - Goals set for Salesforce counting failuer count also

HMA-354760 NBO- View mode of Email touchpoint partially displays mapped Interactive channel
fields

HMA-354762 Inconsistent (facebook) - Some times after copying journey with Facebook TP,
Faceboolk TP configurations gets lost

HMA-354809 REGBB - EngagementSplit configuration persists and journey gets published too when
mapped WhatsApp touchpoint is deleted for Copied and Imported Journey

HMA-350649 ComplexBuilder-Numeric- On Decision split with Numeric type function
#SUM(SCustomerlD 10,20 ) is not null - not working

HMA-338279 SMS delivered from Journey do not send latest URL configured in SMS template in
deliver

HMA-355004 If user selects only engine, templates and kafka its showing error in journey
installation log
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Defect ID Known Issue

HMA-355002 Listing pages for journey on New Ul not displayed with ISAM login method

HMA-354994 SQL exceptions in engine logs for REST TP when jouney field is not mapped with API
response field

HMA-348238 Updating Data Definition for existing Journey is giving 500 internal server
error(12.1.3/12.1.5)

HMA-355068 Cluster -1216- If user stops the services of any secondery node - primary and other

secondary node stops processing records and gets hanged

11
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Chapter 6. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated support
contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is resolved efficiently
and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which provides

information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for aver si on. t xt file

that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support
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