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Chapter 1. System requirements and compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.5 requires Unica Platform 12.1.5.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party requirements for this product, see

the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following requirements:

« For an improved user experience, use at least a 21-i nch screen.

« For an improved user experience, set your screen resolution to 1600x900. Lower resolutions can result in some

information not being properly displayed. If you use a lower resolution, maximize the browser window to see more

content.

- A mouse is best for navigating in the user interface.

« Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the

controls that are in the user interface.

« If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey might not function properly.

For best results, disable pop-up blocker software while running Unica Journey.

« Ensure that the technical environment meets the minimum system requirements and the supported platforms. For

more information, see the Recommended Software Environments and Minimum System Requirements document.

» The correct browser and versions must be used. For more information, see the Recommended Software

Environments and Minimum System Requirements document.

« Clear the browser cache after installation. This only needs to be done once, after the application is updated.

Important: Do not use any other method to open multiple sessions. For example, do not open a new tab; do not

open another browser session from the Start menu or desktop icon; and do not use File > New Window in Microsoft

Internet Explorer. These methods can corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and developers to get their hands on

the product functionality.

Table 1. Get up and running

Task

Documentation

Find out about the new features in the product

For the first release, all new features are available in the

Unica Journey User Guide
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Table 1. Get up and running (continued)

Task Documentation

Find out about the known issues and limitations Unica Journey Release Notes
Learn about the structure of the Unica Journey system Unica Journey System Schema
tables

Installation and configuration of Unica Journey Unica Journey Installation Guide
Upgradation and configuration of Unica Journey Unica Journey Upgrade Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide

Installing Unica Link connector app for Journey Unica Link Installation Guide

Installing Unica Link connector — MailChimp Unica Link Mailchimp Connector User Guide
Installing Unica Link connector — Mandrill Unica Link Mandrill Connector User Guide
Installing Unica Link connector — Twilio Unica Link Twilio Connector User Guide
Installing Unica Link connector — Salesforce Unica Link Salesforce Connector User Guide

Table 3. Integrate Unica Journey with other HCL products

Task Documentation

Integration of Unica Campaign and Unica Journey Unica Campaign Administration Guide and Unica Campaign
User Guide

Integration of Unica Campaign and Unica Interact Unica Interact Administration Guide

Integration of Unica Deliver with Unica Journey Unica Journey User Guide

Integration of Unica Centralized Offer Management and Unica Journey User Guide

Unica Journey

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product documentation while you

logged in Help > Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan Journey installation.
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Note: Unica Journey does not support Silent-mode installation.

Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of these integration as per your

requirements. Please refer to documentation map section for appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system, application server etc., is not
exactly same support with Unica Journey. Please refer to Recommended Software Environments and Minimum System
Requirements guide.

For example, If your existing Unica products are installed on stack as below:

» Operating System - AIX 7.2 TL5
« Application Server - WebSphere
« Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended Software Environments and

Minimum System Requirements guide and it would be compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.5, you can complete your upgrade and then install Unica

Journey 12.1.5.
Where to find documentation

You can find the documentation here.

* PDFs:
« Online Help:
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Upgrade

Before installing Unica Journey version 12.1.5, you have to ensure that a few prerequisites are met.

About this task

If a you are a new user, and if you have HCL OneDB, MariaDB, or Microsoft SQL Server as the database, you can directly

install Unica Journey 12.1.5. Ensure that Unica Platform version 12.1.5 is operating correctly.

The supported upgrade path for Unica Journey 12.1.5 are as follows:

Table 5. This table describes the topics that are included in the Unica Journey Upgrade Guide and the list of sub-topics in

the second column.

Base Journey version

Upgrade path

Tasks to be performed

In case of Oracle, the base Unica
Journey can be:

*+12.1.x
*12.1.0.x

In case of Microsoft SQL Server,
MariaDB and OneDB, the base version
is 12.1.0.3 and later.

In case on Db2 Base version should be
12.1.4

In case of Oracle, the upgrade path can
be:

*+12.1.x>12.1.5
*+12.1.0x->12.1.5

In case of Microsoft SQL Server,
MariaDB and OneDB, the upgrade path
should be:

+12.1.0.3>12.1.5

In case of DB2, the upgrade path should
be:

+121.45121.5

1. Upgrade Unica Marketing
Platform to 12.1.5

2. Run upgrade Unica Journey to
12.1.5 installer

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application

Clean Installing Journey on
existing Unica environment

when you have system tables as
SqlServer,MariaDB,0ONeDb and Db2

databases

In place upgrade to Unica Journey
12.1.5

1. Upgrade Unica Marketing
Platform and required Unica
products to 12.1.5 except
Journey.

2. Run clean installer of Unica
Journey 12.1.5

3. Configure Journey application

4. Deploy Journey application

5. Run Journey application
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Note:

1. If Journey is not already installed on an existing Unica environment with Oracle database, install Unica
Journey version 12.1.0 and upgrade to Unica Journey version 12.1.5. If Journey is already installed and the
Journey version is 12.1.0, follow the upgrade path mentioned in the earlier table.

2. If you do not have Journey already installed on existing Unica environment with either MS SQL Server, OneDB

or MariaDB database then you can install Journey version 12.1.5 directly as clean install.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:

1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also, stop all other components, for
example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application server.

4. Stop the application server and clean the application server cache.

5. Back up the Unica Platform and Unica Journey database and file system directory to any temporary directory.



Chapter 3. New features and changes in version 12.1.5

In Unica Journey 12.1.5, we have introduced some new features, and we have made changes to some existing features or

functionality.

The following list mentions the new features, and the changes to existing features, in Unica Journey 12.1.5:

« Interactive WhatsApp support along with multiple branches support in Engagement split

Journey supports WhatsApp conversational messaging via Deliver. In Journey we need some way to check if this is
normal communication or two way. Depending on that the Engagement split control will have the options to check for
the replies of this communication.

 Journey support backward loop

As a marketer when a user is on draft Journey canvas user should able to configure Loop. Depending on decision or
Engagement split coditions user should able to do send email and other activities in Journey in loop for fixed number

of times.

« Take user out of Published Journey
Marketer will be able to stop audiences matching a specified condition in a particular journey.
Customers can use this feature to stop the Journey for certain audiences.

This feature is accessible from the Journey Canvas. Use the Stop Audience feature to create rules that stops certain

audiences matching the rule.



Chapter 4. Fixed Defects

The following table lists the defects fixed in Unica Journey 12.1.5:

Defect ID Known Issue

HMA-348439 Data Specific-Intermittent-REGRR- Upgrade 1213 to 1215 (Oracle) - journeys created
on old versions are not getting copied

HMA-349475 Journey date condition is not working appropriately in Delay

HMA-349474 Journey converts numeric to exponential value when the number is length more than
7

HMA-349472 Improving performance of delay control in Journey

HMA-349469 One of the Email Control can not be deleted in it has responses in v12.1.1

HMA-349467 Date with expression not in effect in Delay control randomly in Journey

HMA-349466 Not able to fetch the Deliver email template in Journey when Proxy is used on
v12.1.0.4

HMA-349465 OOM error while trying to start the Journey engine after kept Idle for 20-25 days

HMA-349464 Journey 12.1.0.4_IF01 war doesn't deploy

HMA-349462 Inv12.1.3 it is possible to use the same Email Deliver template several times in
Journey however this is not possible in v12.1.1

HMA-349450 In Dockerised 12.1.4 version, Journey Engine not able to create TOPICs.

HMA-344797 Upgrade 12.1.3 to 1214- On Performance tab showing multiple email links for deliver
email

HMA-344635 Deliver SMS - After adding PF fields in SMS template in Deliver - in journey user not
getting mapping fields and even not getting sms

HMA-344863 Journey Cluster - journey with data dedup and decision split having waiting period is
not processing dedup data

HMA-344312 REGRR-CIF- If user modify the DD in configured external source its configured fields
are not getting reset

HMA-344209 Deliver -LP - If user modify the LP, these changes are not getting in effected in Journey

HMA-344196 Deliver LP - Some times deliver is not sending LP data to Journey, its sending blank

HMA-343975 Need headers for the email field mapping and landing page field mapping while
configuring email communication

HMA-343927 In Deliver if user adds LP in Email communication after assigning it in Journey - Then
in actual email User is not getting LP
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Defect ID

Known Issue

HMA-325833

EngineScript.sh and engineStatus.sh should be converted to dos2unix form and

spaces removed from command mentioned




Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.5:

Defect ID Known Issue

HMA-359796 Incorrect event ids in audienceresponseeventmaster

HMA-349891 Deliver responses - When deliver response event is error then audience responses are
not captured by Journey TPs

HMA-349826 v12.1.5 : Journey : Journey installation failed with 1 Non-fatal error for DB2 database

HMA-349633 REGBB - Multiple responses for same offer is not getting added on UNICA_CH_RH
Topic, hence in campaign table multiple responses are not getting added for same
offer

HMA-349611 Inconsistent - Loop - User is not able to configure loop end point on edges

HMA-349539 User cannot save a Journey if the exit branch of a Loop start control enters the Loop
end control.

HMA-349494 EngineScript.sh start command does not start the engine

HMA-349435 Pause rule count and subsequent execution fails with larger audiences data set with
JDBC errors

HMA-349369 Upgrade FP4- 1215 - Email weekly link event goal link is not getting on goals page

HMA-349363 WhatsApp Interactive - In Interactive whats app "contact" event not getting quick

HMA-349354 (#573)Event change for Engagement Split configuration done for paused Journey
state should be allowed as this change is done before Publish state

HMA-349300 NBO- View mode of Email touchpoint does not shows the interact field mapping with
journey Field

HMA-349054 DB2-specific database file is not available within the / ddl / di scover _sql _fil es/
folder.

HMA-349044 TPS of audiences processing gets degraded with increase in loop iterations

HMA-348752 PRE - (#583) (Imported Journey)Engagement Split should be greyed out when
configured ES-Whatsapp touchpoint is deleted

HMA-348608 Pass count on loop touchpoint is incorrect along with count for each iteration and
Iteration/loop count inside the loop touchpoint More option is incorrect

HMA-348604 Time taken for opening contacts/responses page of all touchpoints is very high

HMA-348546 Pause audiences processing speed needs improvement

HMA-348514 Pagination is taking time in Audiences Stopped window for large data

11
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Defect ID Known Issue

HMA-348485 Engagement split contacts/responses processing needs improvement

HMA-348450 Loop - audience accepted time is showing always same in all iteration on loop stats.

HMA-348431 Not able to delete the newly added path for paused journey with engagement split and
whats app touchpoint

HMA-348255 In case of Loop control, if the user deletes the Decision Split after pausing the Journey
then data available in Loop is not getting processed to the next Touchpoint.

HMA-348248 Loop - Some times if user tries to configure loop as forward loop Ul is getting
distorted

HMA-348246 Degradation observed for publish touchpoint

HMA-348238 Updating Data Definition for existing Journey is giving 500 internal server
error(12.1.3/12.1.5)

HMA-342112 LandingPage - Attributes getting is response is different for Check box and radio
button type fields

HMA-330092 This is valid for windows installation only.

Post Journey installation, Journey admin user must ensure paths are properly

populated in below files. Here expectation is to have 2 forwards slashes and not one.
Expected -\\

Actual -\

application.properties from Web

application.properties from engine

server.properties from KafkaStandalone config

zookeeper.properties from KafkaStandalone config




Chapter 6. Before you contact HCL technical support

If you encounter a problem that you cannot resolve by referring the documentation, your company's designated support
contact can log a call with HCL technical support. Use these guidelines to ensure that your problem is resolved efficiently
and successfully.

If you are not a designated support contact at your company, contact your HCL administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

« A brief description of the nature of your issue.

« Detailed error messages that you see when the issue occurs.

« Detailed steps to reproduce the issue.

« Related log files, session files, configuration files, and data files.

« Information about your product and system environment, which you can obtain as described in "System information."

System information
When you call HCL technical support, you might be asked to provide information about your environment.

If your problem does not prevent you from logging in, much of this information is available on the About page, which provides

information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not accessible, check for aver si on. t xt file

that is located under the installation directory for your application.

Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support
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