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Chapter 1. System requirements and
compatibility

Unica Journey is part of the Unica suite of products. Unica Journey version 12.1.0.4 requires

Unica Platform 12.1.0.4.

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with Unica Journey and a list of third-party

requirements for this product, see the Recommended Software Environments and Minimum

System Requirements document.

You can also access this document by selecting Help > Product documentation when you

are logged in to Unica.

Prerequisites for using Unica Journey

Before you begin using Unica Journey, confirm that your environment meets the following

requirements:

• For an improved user experience, use at least a 21-inch screen.

• For an improved user experience, set your screen resolution to 1600x900. Lower

resolutions can result in some information not being properly displayed. If you use a

lower resolution, maximize the browser window to see more content.

• A mouse is best for navigating in the user interface.

• Do not use the browser controls to navigate. For example, avoid using the Back and

Forward buttons. Instead, use the controls that are in the user interface.

• If pop-up blocker (ad blocker) software is installed on the client machine, Unica Journey

might not function properly. For best results, disable pop-up blocker software while

running Unica Journey.

• Ensure that the technical environment meets the minimum system requirements and

the supported platforms. For more information, see the Recommended Software

Environments and Minimum System Requirements document.
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• The correct browser and versions must be used. For more information, see the

Recommended Software Environments and Minimum System Requirements

document.

• Clear the browser cache after installation. This only needs to be done once, after the

application is updated.

Important:  Do not use any other method to open multiple sessions. For example, do

not open a new tab; do not open another browser session from the Start menu or desktop

icon; and do not use File > New Window in Microsoft Internet Explorer. These methods can

corrupt information that is shown in the application.

Unica Journey documentation roadmap

Unica Journey provides documentation that helps users like marketers, administrators, and

developers to get their hands on the product functionality.

Table 1. Get up and running

Task Documentation

Find out about the new features in the

product

For the first release, all new features are

available in the Unica Journey User Guide

Find out about the known issues and

limitations

Unica Journey Release Notes

Learn about the structure of the Unica

Journey system tables

Unica Journey System Schema

Installation and configuration of Unica

Journey

Unica Journey Installation Guide

Table 2. Installing and Configuring Unica Link

Task Documentation

Installation and configuration of Unica Link Unica Link Installation Guide
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Task Documentation

Installing Unica Link connector app for

Journey

Unica Link Installation Guide

Installing Unica Link connector – MailChimp Unica Link Mailchimp Connector User

Guide

Installing Unica Link connector – Mandrill Unica Link Mandrill Connector User Guide

Installing Unica Link connector – Twilio Unica Link Twilio Connector User Guide

Installing Unica Link connector – Salesforce Unica Link Salesforce Connector User

Guide

Table 3. Integrate Unica Campaign with other HCL products

Task Documentation

Integration of Unica Campaign and Unica

Journey

Unica Campaign Administration Guide and

Unica Campaign User Guide

Integration of Unica Campaign and Unica

Interact

Unica Interact Administration Guide

Integration of Unica Deliver with Unica

Journey

Unica Journey User Guide

Table 4. Get Help

Task Documentation

Unica Journey documentation You can get Unica Journey product

documentation while you logged in Help >

Product documentation.

Unica Journey when installed with other Unica suite products

Before you start installation of Unica Journey you can refer to below sections to plan

Journey installation.
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Unica Journey delivery engines for Email

Unica Journey supports Unica Deliver and Unica Link for email delivery. You can use any of

these integration as per your requirements. Please refer to documentation map section for

appropriate documents to refer on this integration.

Unica Journey stack support

Unica suite product support to third party software like databases, operating system,

application server etc., is not exactly same support with Unica Journey. Please refer to

Recommended Software Environments and Minimum System Requirements guide.

For example, If your existing Unica products are installed on stack as below:

• Operating System - AIX 7.1

• Application Server - WebSphere

• Database - DB2

You can install Unica Journey on supported environments as mentioned in Recommended

Software Environments and Minimum System Requirements guide and it would be

compatible with existing Unica products.

Upgrading Unica products and Installing Journey

If you are upgrading from older Unica product version to 12.1.0.4, you can complete your

upgrade and then install Unica Journey 12.1.0.4.

Where to find documentation
You can find the documentation here.

• PDFs: http://doc.unica.com/products/index.php?

showFolder=RW50ZXJwcmlzZQ==&folder=aW50ZXJhY3QvMTJfMV8w

• Online Help: https://help.hcltechsw.com/unica/Interact/en/12.1.0/index.html

http://doc.unica.com/products/index.php?showFolder=RW50ZXJwcmlzZQ==&folder=aW50ZXJhY3QvMTJfMV8w
http://doc.unica.com/products/index.php?showFolder=RW50ZXJwcmlzZQ==&folder=aW50ZXJhY3QvMTJfMV8w
https://help.hcltechsw.com/unica/Interact/en/12.1.0/index.html


Chapter 2. Prerequisites for Unica Journey
Installation or Upgrade

Before installing Unica Journey version 12.1.0.4, you have to ensure that a few prerequisites

are met.

If a you are a new user, and if you have HCL OneDB, MariaDB, or Microsoft SQL Server as the

database, you can directly install Unica Journey 12.1.0.4. Ensure that Unica Platform version

12.1.0.4 is operating correctly.

The supported upgrade path for Unica Journey 12.1.x.x are as follows:

Source

Version
Upgrade path to 12.1.0.3 Prerequisites for Oracle Database

12.1.0 Directly upgrade to 12.1.0.4 If you are upgrading Unica Journey from

version 12.1.0 to 12.1.0.4, ensure that Unica

Platform and Unica Journey version 12.1.0

are operating correctly.

12.1.0.1 Directly upgrade to 12.1.0.4 If you are upgrading Unica Journey from

version 12.1.0.1 to 12.1.0.4, ensure that Unica

Platform, and Unica Journey version 12.1.0

and 12.1.0.1 are operating correctly.

12.1.0.2 Directly upgrade to 12.1.0.4 If you are upgrading Unica Journey from

version 12.1.0.2 to 12.1.0.4, ensure that Unica

Platform, and Unica Journey version 12.1.0

and 12.1.0.2 are operating correctly.

12.1.0.3 Directly upgrade to 12.1.0.4 If you are upgrading Unica Journey from

version 12.1.0.3 to 12.1.0.4, ensure that Unica

Platform, and Unica Journey version 12.1.0

and 12.1.0.3 are operating correctly.

To prerequisites for installation, or upgrade, of Unica Journey are as follows:
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1. Ensure that all users are logged out.

2. Stop Unica Journey, Unica Platform, and all applications that are deployed with it. Also,

stop all other components, for example Journey Engine, Kafka server, etc.

3. Undeploy Unica Platform and Unica Journey web application from the application

server.

4. Stop the application server and clean the application server cache. For more

information, see Cleaning the Apache Tomcat application server cache (on page

6).

5. Back up the Unica Platform and Unica Journey database and file system directory to

any temporary directory.

Cleaning the Apache Tomcat application server cache

1. Access the Instance location used for Unica Journey. For example, /opt/Tomcat/

instance1.

2. Delete the contents of the folders webapps and work.



Chapter 3. New features and changes in
version 12.1.0.4

In Unica Journey 12.1.0.4, we have introduced some new features, and we have made

changes to some existing features or functionality.

The following list mentions the support for new platforms, in Unica Journey 12.1.0.4:

• Supports IBM WebSphere Application Server and Red Hat JBoss Enterprise Application

Platform.

• Supports Kafka on windows operating system. To configure Kafka on

Windows operating system, see https://support.hcltechsw.com/csm?

id=kb_article&sysparm_article=KB0085551.

The following list mentions the new features, and the changes to existing features, in Unica

Journey 12.1.0.4:

• Milestone Analysis

◦ Milestones Analysis tab provides details like drop between milestones, the average

time taken to achieve milestones, and overall milestone status, even if a goal is not

added.

◦ On hover, you can view the number and percent drops.

◦ There are two views with a toggle switch to change the view.

• Enhancement to Integrate WhatsApp Channel with Deliver

Marketer can send a message, and on runtime, the message is delivered to the

WhatsApp number of the user.

• Enhanced the ability to export report

Journey Analysis tab exports Journey performance to a PDF file and marketers can

share it for approval, etc.

• Add Database Support to execute SQL via Link so that marketers can call link

connector for type DB, which allows queries to be executed in the Journey flow.

• Journey supports GDPR and CCPA Compliance for the following databases:

https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551
https://support.hcltechsw.com/csm?id=kb_article&sysparm_article=KB0085551


Unica Journey V12.1.0.4 Release Notes | 3 - New features and changes in version 12.1.0.4 | 8

◦ MariaDB

◦ SQL Server

◦ OneDB

• LinkedIn response streamlining

LinkedIn responses are modified and the following responses are available on the

configured LinkedIn touchpoint:

◦ Audience size

◦ Matched count

◦ Audience status

Unica Link sends the responses to Journey and depending on the response from

Unica Link, the Audience size, Matched count, and Audience status will be available on

LinkedIn Touchpoint.



Chapter 4. Fixed Defects

The following defects were fixed in Unica Journey version 12.1.0.4.

Issue ID Defect

HMA-320706 Journey is mono partition. "Access Denied " Error displayed for

user from different partitions while accessing the Journey

HMA-320622 (Regbb) While editing the non frequency based goal it should

not allow to select checkbox 'mark journey as completed' when

target and actual goal target is same

HMA-320585 Incorrect counts observed for stats view for journey

HMA-320300 Target object must not be null error observed for performance

runs with MariaDB

HMA-320207 Document Defect : In journey "Recommended Software

Environments and Minimum System Requirements" document ,

either first section should be of Journey or for each products

should be specified.

HMA-319576 Milestone reorder is not working for pause and republish

HMA-315896 Localization Issues with journey application

HMA-320456 Db specific database information should be available in Engine

application.properties file

HMA-321141 When there are leading and trailing spaces in milestone name ,

it is getting added as new milestone

HMA-320870 License - Entitlement consumption shown on license details

page is not as per Usage report for journey

HMA-311595 Some times kafka is getting stopped and not getting restart

again



Chapter 5. Known issues

The following table lists the known issues in Unica Journey 12.1.0.4:

Issue ID Known Issue

HMA-325591 While upgrading journey for Oracle DB to Fixpack FP4 - installer

is not taking backup of log4j.properties in GDPR folder

HMA-320980 Sort by date does not show latest in journey can date be spelt

out as india and america format is confusing

HMA-320721 Observing ignite error when sending large number of audiences

for processing

HMA-320932 (License) If Link License not available then data is not

processed by journey but not showing any valid message/error

why data data not getting processed

HMA-320720 On Goal analysis page its showing one extra record for period

specific date/last 3 months /last 12 months/ last 30 days

HMA-320719 Historic goal page count mismatch issue

HMA-320703 On goal analysis page - Last generated on information is not as

per journey time zone

HMA-312551 Engine - \ is not getting replaced by /

HMA-320872 Journey encryption utility is not capable of doing encryption of

special characters like - $ &

HMA-325643 Help context sensitive Help - Journey 12.1.0 Fp4 New pages

HMA-325450 GDPR- installer is not doing backup of log4j.properties in GDPR

HMA-325222 GDPR - User not able to delete the user data from Published

Kafka topic, CSV files created by Publish touchpoints, and file

type entry sources using GDPR tool
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Issue ID Known Issue

HMA-325188 GDPR- MSSQL - After deleting records using GDPR tool - on

Goal historical page and performance page its showing old

records

HMA-325185 GDPR- MSSQL - After deleting records using GDPR tool -

On canvas touchpoint count and start point count getting

mismatch

HMA-324952 FR- Translation - On Milestone Analysis page some strings are

getting truncated and not in center of funnel

HMA-324769 FP4 : Required restart of JourneyEngine to take place changes

from the log4j2.xml

HMA-324657 For frequency based goals, responses before goal creation are

considered

HMA-324592 Translation-FR - On milestone analysis page some strings are

not translated

HMA-324278 FP4 - Zookeeper Jar needs to be upgraded from 3.4.13 to

3.5.09

HMA-324230 On Goal analysis page X-axis date format is not consistent with

other date format on same page

HMA-323788 Installer - DB Username property for journey and journey

reports is not updated by Installer in Install logs

HMA-323713 KafkaInstanceAlreadyExists Exception found in web logs while

staring journey web on WAS setup

HMA-323095 Nomenclature of Upgrade folder structure should be displayed

like upgrade wise.

HMA-323023 Response time on Audiences tab inside journey is high with

large number of audiences
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Issue ID Known Issue

HMA-322999 Journey gives 'Internal server error' frequently with JBOSS

HMA-324043 Export Report - Audience Tab - y-axis values are different in

graph on UI and report

HMA-324036 Export Report - Audience Tab - circles are not shown on edges

of graph for last 12 months timeframe in report

HMA-325833 EngineScript.sh and engineStatus.sh should be converted to

dos2unix form and spaces removed from command mentioned



Chapter 6. Before you contact HCL technical
support

If you encounter a problem that you cannot resolve by referring the documentation, your

company's designated support contact can log a call with HCL technical support. Use these

guidelines to ensure that your problem is resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your HCL

administrator for information.

Information to gather

Before you contact HCL technical support, gather the following information:

• A brief description of the nature of your issue.

• Detailed error messages that you see when the issue occurs.

• Detailed steps to reproduce the issue.

• Related log files, session files, configuration files, and data files.

• Information about your product and system environment, which you can obtain as

described in "System information."

System information

When you call HCL technical support, you might be asked to provide information about your

environment.

If your problem does not prevent you from logging in, much of this information is available

on the About page, which provides information about your installed HCL applications.

You can access the About page by selecting Help > About. If the About page is not

accessible, check for a version.txt file that is located under the installation directory for

your application.
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Contact information for HCL technical support

For ways to contact HCL technical support, see the HCL technical support website:

https://www.hcltech.com/products-and-platforms/contact-support

https://www.hcltech.com/products-and-platforms/contact-support
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