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Chapter 1. IBM Campaign v9.1.1 system requirements and
compatibility

IBM® Campaign is part of the IBM EMM suite of products. Campaign version 9.1.1
requires Marketing Platform 9.1.1. You can upgrade to Campaign 9.1.1 (including
eMessage) from version 9.1.

Where to find complete system requirement and compatibility
information

For a list of IBM EMM product versions compatible with this product and a list of
third-party requirements for this product, see the Recommended Software
Environments and Minimum System Requirements document. This document is posted
under Detailed System Requirements on the IBM Support Portal website:
(http://support.ibm.com).

Note: To access the IBM EMM documentation from the Support Portal, you must
log in with an IBM account. This account must be linked to your IBM customer
number. To learn more about associating your account with your IBM customer
number, see Support Resources > Entitled Software Support on the Support
Portal.

You can also access this document by selecting Help > Product documentation
when you are logged in to IBM EMM.

Prerequisites for using IBM Campaign
Before you begin using IBM Campaign, confirm that your environment meets the
following requirements.
v For an improved user experience, use at least a 21" screen.
v For an improved user experience, set your screen resolution to 1600 x 900.

Lower resolutions can result in some information not being properly displayed.
If you use a lower resolution, maximize the browser window to see more
content.

v A mouse is best for navigating in the user interface.
v Do not use the browser controls to navigate. For example, avoid using the Back

and Forward buttons. Instead, use the controls that are in the user interface.
v If pop-up blocker (ad blocker) software is installed on the client machine, IBM

Campaign might not function properly. For best results, disable pop-up blocker
software while running IBM Campaign.

v Ensure that the technical environment meets the minimum system requirements
and the supported platforms.*

v The correct browser and versions must be used.*
v Clear the browser cache after upgrading or applying any fix pack. This only

needs to be done once, after the application is updated.
v If you use Internet Explorer (IE) with IBM Campaign or any module that uses

Campaign flowcharts (eMessage, Contact Optimization, Interact, Distributed
Marketing): To log in multiple times to view side-by-side information, open IE
and log in to IBM EMM. Then select File > New Session in the IE menu bar. In
the new IE browser window, log in to IBM EMM as the same or a different user.
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Important: Do not use any other method to open multiple sessions. For
example, do not open a new tab; do not open another browser session from the
Start menu or desktop icon; and do not use File > New Window in IE. These
methods can corrupt information that is shown in the application.

*For details on the items indicated by an asterisk, see the IBM Enterprise Marketing
Management (EMM) Recommended Software Environments and Minimum System
Requirements.
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Chapter 2. New features and changes in IBM Campaign 9.1.1

IBM Campaign version 9.1.1 includes the following new features and changes.

IBM ExperienceOne Knowledge Center

Starting with version 9.1.1, you can view product documentation in IBM
ExperienceOne Knowledge Center, which includes documentation for all of the
products in the ExperienceOne family. Use IBM ExperienceOne Knowledge Center
to:
v search across all documentation for a particular product.
v search across all of the products in the suite.
v bookmark topics.
v share links to specific topics.
v access IBM support and educational resources.

You can view common tasks, troubleshooting, and support documentation the
same way you have in prior releases by using the Help menu in each product,
including Help > Product documentation or Help > Help for this page. To get
documentation on all other IBM products, use the IBM Knowledge Center at
http://www.ibm.com/support/knowledgecenter/.

New and discontinued platform support

For a list of newly supported and discontinued platforms, see the document
Recommended Software Environments and Minimum System Requirements.

Note: For details about newly added z/OS support for DB2 as a user database, see
Preparing DB2 on z/OS user datasources for Campaign in the IBM Campaign Installation
Guide.

Listener clustering and load balancing

You can install or upgrade IBM Campaign in a clustered listener configuration.

By implementing the back-end Campaign Analytics server on multiple physical
machines, you allow for automatic failover and load balancing using a round robin
approach based on administrator-defined values for priority and weight.

Clustering involves the use of multiple listeners for the purpose of high availability
and load balancing. Clustered listeners ensure that failover occurs automatically
from one machine to another. Additionally, clustered listeners provide parallel
processing and load balancing for improved performance.

Single-listener configuration changes have also been implemented: Auto-restart of
listener, auto-reconnect and re-establish existing UI and running sessions on
back-end server.

For information about listener clustering, see the following documents:
v IBM Campaign Installation Guide -or- IBM Campaign Upgrade Guide

v IBM Campaign Administrator's Guide
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The following topics in the IBM Campaign Administrator's Guide provide details
about clustered listener configurations:

Chapter and Topics Description

Chapter 11: Trigger
administration

v Campaign trigger utility
syntax and options

There are some differences in how you use the trigger utility
with a clustered listener configuration. For example, if you
run unica_actrg remotely, best practice is to specify the server
and port of the master listener.

Chapter 12: Logging
administration

v IBM Campaign log file
names and locations

v Viewing and configuring
Campaign listener and
master listener logs

In addition to log files in the following locations:

<Campaign_home>/logs
<Campaign_home>/partitions/partition[n]/logs

clustered listeners also have log files in the following
locations:

<campaignSharedHome>/logs
<campaignSharedHome>/partitions/partition[n]/logs

campaignSharedHome is a network location that all clustered
nodes can access. The location is specified during installation
and is configurable at Campaign|campaignClustering.

Each listener records events in its own log file. Additionally,
there is a masterlistener.log at <campaignSharedHome>/logs.

Chapter 16: IBM Campaign
listeners

This chapter provides complete information about clustered
and unclustered listeners. It is highly recommended that you
read all of the topics in this chapter.

Chapter 17: IBM Campaign
utilities

v Campaign Server
Manager commands
(unica_svradm)

In general, you use the Campaign utilities in a clustered
listener environment the same way that you use them in a
single-node environment. However, there are some differences
to be aware of.

v For a summary of how to use to utilities in a clustered
environment, see the topic Utilities for clustered listeners in
Chapter 16: IBM Campaign listeners.

v For details on each utility, see Chapter 17: IBM Campaign
utilities. The major changes were to unica_svradm.

v When you run unica_svradm in a clustered listener
environment, the default connection is to the master
listener. When you are connected to the master listener, the
following commands affect all of the nodes in the cluster:
Loglevel, Refresh, Shutdown, Status, Version. For example,
the Status command displays the status of all nodes in the
cluster; and the Shutdown command gracefully shuts down
a listener cluster.

v The unica_svradm Refresh command is new. Use it to
refresh the configuration on the master listener after
making configuration changes.

Chapter 19: Configuration
properties for IBM
Campaign

v Campaign|unicaACListener: The following properties are
ignored for a clustered listener configuration: serverHost,
serverPort, useSSLForPort2, serverPort2. Instead, set these
properties for each individual node.

v Campaign|unicaACListener|node [n]: There is one child
node for each listener in a clustered configuration.

v Campaign|campaignClustering: These properties pertain
only to a clustered listener configuration.
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Web application clustering

You can create a clustered web application environment in WebLogic or IBM
WebSphere Application Server to use with Campaign. A clustered environment
helps deliver high availability and scalability. For more information, see the IBM
Campaign 9.1.1 Installation Guide.

New option [-d <service_dependencies>] for unica_aclsnr utility

-d <service_dependencies> is an optional argument that tells the Microsoft
Windows operating system to wait until the services in <service_dependencies>
are completely started before launching the Campaign listener. The most common
case for this is when the web application server that runs IBM Campaign is also
installed as a service, because the web application server must be fully launched
and running before you launch the Campaign listener. To specify multiple services,
use a comma-separated list. Use the Service name defined in Windows Services.

Annotations for flowcharts

You can annotate a flowchart to communicate with other users of the flowchart
and clarify the intention and functionality of processes. Annotations appear as
yellow sticky notes. Annotations give users the ability to share information about
the work they do in a flowchart. Use them to highlight specific capabilities or
reasons for using specific logic in a flowchart. For details, see Annotating flowcharts
in the IBM Campaign User's Guide.

Move to front or send to back of flowchart process connections

Use Overlap Connections on the View menu to specify whether process
connections (the lines between processes in a flowchart) overlap flowchart process
boxes or are hidden behind flowchart process boxes. This configuration is per
flowchart and it persists on a flowchart level.

Flowcharts open in embedded mode

In the previous release, the flowchart opened in a separate browser window. After
consulting with customers, the majority wanted the flowchart to open within the
Campaign window, as it was in earlier versions. Therefore, the flowchart is
embedded again. The result is no more separate windows or hidden windows.

Redesign of Campaign reports

As part of the revised look-and-feel and user experience, reports have been
redesigned. This change accommodates reports on the dashboard (with or without
Cognos) and the listing reports in Campaign. The reports are easier to read and
understand. They use harmonious colors and an interactive, uncluttered style. Pie
charts with numbers have been implemented.

Generate random samples for record selection

To force a Select or Sample process to select a different random set of records each
time it runs, enter a zero (0) as the Random Seed. A value of 0 ensures that a
different random set of records will be selected each time the process runs. This
generates a true random sample with each run of the flowchart. The Segment
process does not include a Random Seed control. To make the Segment process
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select a different random set of records each time it runs, set the Random Seed to 0
in the upstream process that provides input.

In prior releases, random samples always generated the same random set of
records for each subsequent run of the process (unless the input to the process
changes). You can still opt for this behavior, by clicking the Pick button next to the
Random Seed field to randomly select a new seed value. This is important if you
intend to use the process results for modeling purposes, because different
modeling algorithms must be compared across the same set of records to
determine each model's effectiveness.

For more information, see Changing the random seed for record selection in the IBM
Campaign User's Guide

List of relevant products for an offer

There is a minor change to the user interface when you edit the list of relevant
products for an offer (when you choose Campaign > Offers, open an offer, and
click Edit Query). The Add a Condition list on the left side of the Select Products
dialog no longer includes AND labels, which were misleading. When multiple
conditions are added in a single step, they are combined as an AND. When
conditions are added one at a time, they are OR'd. For documentation, read about
changing the list of relevant products for an offer in the IBM Campaign User's
Guide.

New configuration property:
httpCompressionForResponseLength

Use httpCompressionForResponseLength under
Campaign|partitions|partition1|server|optimization to enable and configure
compression for HTTP responses from the Web application to the browser. This
property can improve page load and interaction times by reducing the amount of
data sent over HTTP. Units KB. Default value 100. A value of 0 disables it. For
details, see the IBM Campaign Administrator's Guide.

New configuration property: cellCodeBulkCreation

For cellCodeBulkCreation under
Campaign|partitions|partition[n]|server|systemCodes, a value of TRUE
improves performance of the cell code generation utility during bulk creation of
cell codes. A value of TRUE also improves performance when copying flowcharts,
templates, and process boxes. If cell code generation seems to take a long time for
Segment, Sample, and Decision process boxes, or for the target cell spreadsheet, set
the value to TRUE. The default setting is FALSE to support existing customized
implementations. If you are using a legacy custom-made cell code generation
utility, leave this property as FALSE until you implement a new custom utility.
Then you can change its value to TRUE. If you are not using a custom cell code
generation utility, change the value to TRUE to take advantage of the efficiency
improvements.

Integration with IBM Opportunity Detect

When Opportunity Detect is integrated with Campaign, data about customer
transactions produced by Opportunity Detect can be used in your Campaign
flowcharts. Configuring the integration is described in the IBM Campaign
Administrator's Guide.
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Improvements to the Segment process box
v The # of Segments field now prevents invalid entries, such as negative numbers

or fractions.
v To avoid impacting performance, you can now enter no more than 1000 in the #

of Segments field.
v In previous releases, it was possible to delete all segments from the Segment

process box. On deleting the last segment, a new segment was created. Now it is
not possible to delete the last segment. If Segment by Query is selected, and
there is only one segment available, the Remove button on the Segment tab is
disabled.

Pre-upgrade check utility

Before you upgrade to v9.1.1, use the preUpgradeTool utility to identify any issues
or inconsistencies in the file system and database. Running the utility is optional
but recommended. For instructions, see the IBM Campaign Upgrade Guide.

Grid performance improvement for process boxes

Performance has been optimized for all process boxes by using bulk
insert/delete/update methods instead of adding, deleting, or updating elements in
loop. This change results in performance improvements when the data in the grids
is large.

System tables change

A new system table was added: UA_AnnotationInfo. This table contains data for
flowchart annotations that users create and edit. One row is written to this table
each time a new annotation is created or updated and the flowchart is saved. A
maximum of one annotation is allowed for each process box. For details, see the
IBM Campaign System Tables Data Dictionary.
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Chapter 3. Fixed defects in IBM Campaign 9.1.1

The following defects were fixed in Campaign 9.1.1.

Table 1. Campaign fixed defects

Issue ID Description

Security testing on Campaign 9.1.0.0
uncovered XSS security vulnerabilities

171720 The security vulnerabilities have been addressed.

In a flowchart Segment box, segments
reshuffle incorrectly after clicking a
column to sort

171725 Import a template from the template library when
editing a flowchart, click a column to sort, save and exit.
Return to the Segment process box and the segments did
not have the correct queries.

Not all tables showing in table mappings 171733 Under certain scenarios, not all tables were showing in
the table mapping screen.

"There appears to be some problem with
server communication" message observed
after clicking Save and Exit in a running
flowchart

171738 The message appeared when you ran a flowchart and
immediately clicked Save and Exit. This issue occurred
due to pending requests when a flowchart window was
closed.

Issues with Remove function caused 10404
unica_acsvr crash and other issues

171745 Certain scenarios when configuring a Segment process
box (for example, changing the number of segments in a
Segment by Query) caused incorrect results and led to a
unica_acsvr process crash.

Toolbar still accessible after deleting
processes or connections in a flowchart

171746 After deleting flowchart processes or connections, the
toolbar was still accessible and you could click buttons
such as Save. This caused 10024 Connection errors and
10025 Process not found errors. The toolbar is now
inaccessible (greyed out) in these scenarios.

Input cell not saved when manually
typing in cell

171756 When changing an input cell in a Segment process box,
if you manually changed the name of the input cell,
pressed Tab, then clicked OK, the new input cell was
not saved.

In a Segment process box, the segment
order is not saved when using the Up and
Down buttons to move segments within
the list

172500 Segment reordering was not saved when moving
segments with the Up and Down buttons in a Segment
process box.

Using the unica_svradm utility Run
command with -s returns error 11107

172507 Using the Run -s command to specify a synchronous run
caused error 11107 "Server campaign context internal."
The flowchart ran but could not be used with an
external scheduler because unica_svradm RUN -s
immediately exited with an error instead of returning
when the flowchart run succeeded.

Unable to map history tables for certain
audience levels

174316 Under certain scenarios, it was impossible to map
history tables for certain audience levels and contact
history was not written for the audience levels.

unica_svradm often returns 1719 error 172514 When running a complex flowchart with unica_svradm
in synchronous mode, the flowchart completed
successfully but an error did not allow downstream
processes to run. The error was: RUN error 1719:
INTERNAL ERROR: Communication request has timed
out.

© Copyright IBM Corp. 1998, 2015 9



Table 1. Campaign fixed defects (continued)

Issue ID Description

Unable to click OK in Segment process
box after removing a segment from the
Segment tab

172515 Due to this issue, changes could not be saved after
removing a segment from the Segment tab.

Documentation defect: Using CreateSeg
process box with "Save Run Results"
disabled is not correct.

172516 For flowcharts that create artifacts that you want to save,
you must set Campaign | partitions | partition[n] |
server | flowchartRun | saveRunResults to TRUE. For
example, if you have flowcharts that include CreateSeg
processes, you must save run results. If you do not save
run results, the strategic segments will not persist. The
documentation has been updated to include this
information, which was missing.

Changes made to field names from Admin
> Tables do not appear in the Select box.

133653 If you then try to specify a query in the Select box using
'Select All IDs with' and select the changed field name,
you get error "12608: Internal Error: Invalid field name
specified" when you click Profile.

Not possible to map history tables for an
audience level whose name includes a
space

170465 After upgrading from 8.2 to 9.1, the History tables were
not mapped for an audience level that had a space in the
name. For example, Billing Account.

Tracking contact history at a different
audience level does not work in 9.0

173451 When the audience level was switched during contact
history logging (Mail List or Call List), the contact
process was unconfigured and could not be
reconfigured. This issue occurred in a flowchart that was
created in 8.6 after upgrading to 9.0.

Reordering cells on the General tab of a
process box may result in cells being
assigned to incorrect target cells

95412 If you reordered the cells on the General tab in a process
box where the flowchart cells were linked to "Top Down"
target cells, clicked Save, and reopened the process box,
sometimes the flowchart cells were linked to different
TCS cells.

10404 error in flowcharts with In-DB
Optimization enabled

169951 Error 10404 was observed when running a flowchart
with Global Suppression Strategic Segments when
In-database optimization was enabled. A Select process
box was used with Merge/Purge.

Functionality loss: Newly added Offer
parameters do not appear in 2nd or later
input cell for multiple input cell Mail List
processes

170463 You cannot assign different offer parameter values to
individual input cells of a multiple-input-cell Mail List
process. The first input cell shows all offer parameters on
the Parameters tab, but the 2nd or later input cell is
missing some offer parameters. Therefore, you cannot
assign values to those parameters for those input cells.

Missing parameters of offer when editing
by cells

170464 When you assign one offer to two or more different cells
and try to edit offer parameters by cells, some
parameters of the offer are missing.

acer_tables_upgrade_db2.sql in 9.1.0.2
CampaignReports Pack is syntactically
incorrect

170590 In the 9.1.0.2 Campaign reports pack installer, the
upgrade script for DB2 contained syntax errors.

Security Defect - SQL injection with
Campaign 9.1.0.0

171719 The security defect has been addressed.

Selected derived field under Based on
drop-down of advanced setting window
should open in Edit mode.

9055 When clicking the button to see the details of a derived
field added on the MORE section, the derived field
should open in edit mode. Instead a Create Derived
Field window opens. Users can select the derived field
from the drop-down.
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Table 1. Campaign fixed defects (continued)

Issue ID Description

Nodes swap places in a Select process box. 7275 When you select a derived field in a Select process, then
close the Derived Fields dialog, the User Variables and
Derived Fields items change position in the list of
Available Fields.

The server might crash when running the
Collect Flowchart data functionality.

8019 If a text value is entered in the date field on the Collect
Flowchart data functionality, the server process might
crash.

Warning message about offer being used
in List appears twice while deleting active
offers.

36267 The message "WARNING: The "Offer Offer1" offer(s) has
been used in one or more offer lists. Deleting this offer
will automatically remove it from these offer lists. Do
you want to continue?" appears twice.

Date handling with Oracle for offer
templates with very old dates.

65446 Offer templates that contain very old dates (such as 214)
cannot be saved. An exception occurs stating that the
supplied value is not a valid instance of data type
datetime.

The defined decimal places in a custom
attribute are ignored in Maillist.

66057 Using an Offer Custom Attribute in a Mail List, the
number of decimal place specified in the Custom
Attribute definition are ignored.

Select PB fails with Error 11528 when
configured using a Custom macro created
based on Dimension Table.

71062 A custom macro that is based on a dimension table can
result in process errors, such as Error 11528 for a Select
process, because the custom macro base table name is
prepended to the selected field name, along with the
dimension table name.

Difficult to assign a control cell to a target
cell on Treatment tab of Mail List process
if offer is assigned first to the target cell.

71065 When you click the control cell grid cell to assign a
target cell, the target cell select becomes a small thin line
which makes it difficult to select. This only happens if
you assign a control cell to a target cell that is at the top
of the dialog. Click again in the dialog and the
drop-down list will appear.

SPSS Model PB is failing with error 18009. 81309 This issue occurs only with models that have fewer than
20 records.

Error when changing the model Type from
Predictive to Association.

93877 This also occurs if you click the Data tab. Data is
scanned automatically and hence on executing the SPSS
Model process the results are incorrect.

Non ASCII characters are truncated from
offer name.

93906 This is a display issue only. When you click Link to IBM
eMessage Digital assets on the offer page to see the
associated asset, non-ASCII characters are truncated from
the offer name.

JS error when adding flowchart. 106625 This happens only when Interact is installed AND the
option 'Display a notification about every script error' is
enabled in the Browsing section of the Advanced tab for
Internet Options in Internet Explorer 9 and 10. By
default this option is not enabled.

Mapped table/file node not displayed in
Create Derived field window launched
from Extract tab of Extract PB.

106626 Workaround: Create the derived field from the Source
tab of the Extract process and it will be available on the
Extract tab.
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Chapter 4. Known issues in IBM Campaign 9.1.1

Campaign 9.1.1 includes the following known issues.

Table 2. Campaign known issues

Issue ID Description

Exporting output to a file does not
add extra column, when extra field
is added for subsequent execution

175918 When a new column (output field) is added to a pre-existing
output file in the Extract process box, the title (field name) of
the column does not get written to the file but the data gets
written correctly. The workaround is to create a new output
file when more fields need to be added to the extracted data.

Setting
defaultBehaviorWhenOutputToFile
to Create New File does not work if
export file is changed

175825 When defaultBehaviorWhenOutputToFile is set to Create
New File, it works only when you select a new output file for
the first time. If you try to change the existing output file and
select a new output file, then the option Append to Existing
Data gets selected by default. It can be changed manually to
Create New File.

11532 Length Exceed Error occurs
when input 22 DBCS characters into
User Variable Name

176876 If you input more than 21 DBCS characters into a User
Variable Name, the following error message occurs: 11532
Length Exceed Error: User Variable Name exceeds 64
characters for UserVar at location[0]

Extracted fields from a top-level
Segment process box are not
displayed on the Derived field
window of the Select process box.

177300 The Segment process box exported fields should appear under
the Extract node on the Derived field window of the Select
process box.

In a Segment process box, segments
reshuffle incorrectly after changing
Segment by field to Segment by
query.

177430 This issue occurs only when fields are sorted repeatedly,
several times. It does not occur if you just perform this action
once or twice. When segments are moved up or down and
you change between Segment by query and Segment By
field, segments are reshuffled incorrectly. For example, the
query of segment 1 is displayed for segment 3.

Resize_Maillist_Parameter_Assign
Value: Drop-down list does not
revert to inactive state when user
clicks outside of the drop-down
arrow

147356 This issue occurs only on Internet Explorer. It affects
drop-down lists that use a tree selection widget.

Cognos reports do not work with
Campaign in French

164028 You can change the product language for the specific user by
setting the product language to match the language of the
application report package. To set the product language, open
the Cognos connection, and under User Preferences set the
corresponding product language. You should not change the
content language. If the content language is changed, then the
corresponding xpath for the reports should also be changed.

Non-fatal error in
Campaign_Install.log

178526 You can safely ignore the following error in the
Campaign_Install.log. The error is logged if you interrupt
and then restart the Campaign installation.
"com.unica.install.ia.custom.ManagerReadConfigurationStatus:
ERRORAdditional Notes: ERROR - class
com.unica.install.ia.custom.ManagerReadConfiguration
NonfatalInstallException The processing instruction target
matching "[xX][mM][lL]" is not allowed."
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Table 2. Campaign known issues (continued)

Issue ID Description

Mail List process box gets
unconfigured with error "31606:
History table are changed" on
Flowchart run.

NA 1. There is no issue if the history tables are mapped prior to
building a flowchart and adding a Mail List process. 2) If you
do not follow step 1, you can still map the history tables after
the error appears. If you edit the flowchart and configure the
process box, the process will run.

Message when running installer in
UNIX console mode

NA When running the installer in UNIX console mode, an
informational message indicates that the installer .bin file was
not found. You can ignore this message.

Unable to open flowcharts after
migrating non-ASCII data

NA After migrating non-ASCII data to Campaign 8.6, in some
cases you cannot open Campaign flowcharts on the target
system. Session flowcharts open successfully. To work around
this issue, remigrate the campaigns in overwrite mode. You
can then open the flowcharts.

Hot keys are not implemented on
most of the windows

2968 In the Dojo implementation it is not possible to use keyboard
shortcuts to activate certain functions. Instead the user must
click buttons.

Summary file option in Maillist
should be disabled when Export to
File is unchecked.

13460 When the Export to File option is unchecked on the
Fulfillment tab of the Mail List process box, the Summary File
option is enabled but should not be.

There should be a way to map DCH
from UI when field name for CH
table is changed.

13502 There should be a way to map the UA_DtlContactHistory
table after changing a column name in the
UA_ContactHistory table. To map UA_DtlContactHistory,
change the source table's column name accordingly (so the
Source Table fields and Required Fields match) and then map
the table.

Information related to associated
products does not appear in offer on
Marketing Operations.

TT
DEF062333

When an offer created in Campaign with products associated
with it is imported in Marketing Operations, information
about the associated products is not available in Marketing
Operations.

If it was not mapped initially, the
IBM Digital Analytics translation
table is not available in the Segment
process box.

TT
DEF063392

No translation table or any other user table is available in the
Segment process box, if the translation table was not mapped
initially.

Clicking "Return to previous page"
distorts the UI in some cases.

75262 Use the links within the products to navigate in IBM EMM
products, rather than the browser controls.

Campaign Upgrade logs show error
related to Optimize in the log files.

90944 When upgrading, if you see the following warnings, you can
ignore them, as they are harmless:

WARN upgradeTool.AC80UpgradeTask [1014] - Unable to
find param: Affinium | Campaign | partitions | partition1 |
Optimize | DisplayFormat

WARN upgradeTool.AC80UpgradeTask [1028] - Unable to
find param: Affinium | Campaign | partitions | partition1 |
Optimize | AlgorithmTuning | ConflictPredictionPercentage

Even if no changes are done to the
Extract PB a message "Process run
results will be lost, Continue ?" is
displayed.

90956 If you open an Extract process configuration dialog and click
OK without making any changes, this message appears. The
message should not appear when no changes have been
made.

Campaign and Interact upgrade
script.

90970 Unwanted class name is displayed on upgrade script
execution: "com.ibm.net.SocketKeepAliveParameters". There is
no impact on functionality. You can ignore these messages.
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Table 2. Campaign known issues (continued)

Issue ID Description

Campaign upgrade script execution
completed with errors related to
drop statements.

102958 During upgrades, there is a message "Unable to execute all
SQL updates successfully, please check the log file for details."
This is related to the following drop statements and does not
impact the upgrade script execution: DROP TABLE
UA_OfferSuppression DROP TABLE UA_RespTypeMapping.
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Chapter 5. Known limitations in IBM Campaign 9.1.1

Campaign 9.1.1 includes the following known limitations.

Table 3. Campaign known limitations

Issue ID Description

Web application clustering
constraints.

NA Web application clustering is supported only for stand-alone Campaign
(not integrated with other products). For example, do not configure a
clustered web application environment if you currently use eMessage,
Interact, Contact Optimization or Marketing Operations. Only Sticky
sessions are supported. No session replication is done, as the focus is
on scalability. Failover is not implemented.

Flowchart annotations NA Annotations are not affected by zoom. You cannot resize annotations.
Annotations do not appear in the panning area. Annotations can be
moved out of the flowchart window and the only way to access them
is to move the associated process box in the direction of the annotation,
then drag the annotation back to the main flowchart area and move the
process box back to its original position. If an annotation overlaps a
process box, drag the annotation to another position.

DB2 10.5 BLU for user DB: no
indexing requirement for temp
tables in Campaign datasource

176377 DB2 10.5 (with BLU feature ON) does not require indexing in
Campaign. Campaign has certain properties for datasources, such as
TempTablePreTruncateRunScript, TempTablePostExecutionSQL, and
PostTempTableCreateRunScript, where you can provide SQL or scripts
to create indexes on user database tables. If you are using DB2 10.5 as
a customer database, with the BLU feature ON, you do not need to
configure any of these temp table properties.

Dialog behavior NA In certain cases, it is necessary to click twice in order to activate a field
or change a field value.

Unused configuration property NA The monitorEnabledForEmessage configuration property in
Campaign|monitoring is not currently used.

Relevant products limitation NA When offer management is performed from IBM Marketing Operations,
the "relevant products" functionality, which relates product IDs to
offers, is not available.

Blank or incorrect results from
derived fields in a Mail List
process. This can occur in a
process box that uses a derived
field that calls a Generated
field (UCGF) that changes
value.

NA Do not use a UCGF in a Mail List derived field if the UCGF is not
constant. Also, from the Parameters tab, do not create a derived field to
call a UCGF to populate offer attributes.

For details, see the following Tech Note: http://
g01zciwas018.ahe.pok.ibm.com/support/dcf/
preview.wss?host=g01zcidbs003.ahe.pok.ibm.com&db=support/swg/
istech.nsf&unid=C4A93DC0ED188D6985257A6B00699C45
&taxOC=SSCKNRB&MD=2012/08/31%2015:08:35&sid=

Profiling a Campaign
Generated Field (UCGF) does
not yield correct results.

NA Some UCGFs have a value according to the cell or the offer being
processed. For cell-related UCGFs, only the value associated with the
first cell appears during profiling.

The default value for a custom
cell attribute does not appear
when you open the Target Cell
Spreadsheet.

NA Although the default value is not initially displayed, it will be used.
The value can be displayed or changed by clicking or opening and
editing the custom cell attribute in the TCS.

UA_UsrResponseType.Name
Name field cannot contain
restricted string.

NA The UA_UsrResponseType.Name field cannot contain a left
parenthesis followed by a single quote.
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Table 3. Campaign known limitations (continued)

Issue ID Description

Use unique TempTablePrefix
for each data source when
mapping multiple data sources
to same physical database.

NA If you mapped multiple data sources in Campaign to the same physical
database, and you use the same TempTablePrefix for more than one of
the data sources, when you use the cleanup utility to delete orphaned
temp tables, it may falsely identify temp tables as orphaned, when they
are in fact legitimate temp tables defined from a different Campaign
data source.

Any deleted temp tables will automatically be recreated when you
rerun affected flowcharts, but as a best practice, use a unique
TempTablePrefix for each data source when mapping multiple data
sources to the same physical database.

If the data sources defined in Campaign map to different schemas in
the database, another solution is to ensure that the database user who
runs the cleanup utility does not have privileges to drop tables in other
schemas in the same database.

WebLogic 11g and AIX® 6.1 or
higher

NA If you use the combination of WebLogic 11g and AIX 6.1 or higher, a
manual workaround is required to address classloading issues in
WebLogic. The workaround involves removing the xercesImpl.jar file
from the Campaign.war file, and repackaging it before deploying. Full
details are included in the installation steps in the Campaign Installation
Guide.

Several dialog boxes cannot be
resized

11162 Most dialog boxes can now be resized but several dialogs that might
not contain a large amount of data or are not commonly used cannot
be resized or maximized.

Error 19024: Cannot delete
segment folder if the segment
was deleted from the folder.

17202 A segment that is deleted from a folder remains as an inactive segment
in the folder. Folders with inactive segments cannot be deleted. This is
working as intended.

If the same flowchart is edited
in multiple locales, undesired
behavior can occur.

18991 This situation occurs only if two (or more) users with different
language settings edit the same flowchart. Users with different locales
should not edit the same flowchart that was created by a user with a
different locale since this can lead to undesired behavior. The preferred
approach is to create and edit flowcharts with users having the same
language settings.

Copy and paste behavior in
process boxes and other
dialogs

84147 For security reasons, some browsers do not allow applications to copy
and paste via the Clipboard. This affects the General tab of the
Segment process configuration and other areas of the application where
copy and paste might be used.

Campaign utilities 161323 The error "Login failed. Error 10553" can occur if you try to log in to
the Campaign utilities when the IBM Marketing Platform | Security |
login method is set to Windows integrated login or Web access
control. To avoid this issue, change the login type to LDAP or IBM
Marketing Platform prior to using the Campaign utilities.

Process box connection arrow
changes direction

201968,
200241

If two process boxes are moved very close together in a flowchart, the
direction of the connection arrow changes. This limitation affects the
visual representation of the arrow. The process data flow is not
affected. The workaround is to move the process boxes farther apart so
the arrowhead changes back to the correct direction.
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Chapter 6. IBM Campaign Reports Package

The Campaign Reports Package delivers reporting schemas that you can use to
track campaign, offer, and cell performance. To use the Reports Package, Campaign
must be integrated with IBM Cognos®

For more information, see the IBM EMM Reports Installation and Configuration Guide
that is supplied with IBM Marketing Platform.

The IBM Campaign Reports Package contains the following items:
v Schemas that are registered with IBM Marketing Platform during installation.

They describe the attributes and metrics that represent the product's reporting
schema and include:
– Base schemas that are the basis of the reporting schema (with no custom

attributes)
– Custom versions of most of the base schemas that rely on the preconfigured

custom attributes for Campaign
– Templates that you can use to create new schemas

v IBM Cognos customizable model and reports to be deployed on an IBM Cognos
BI Server

v Reference documentation that describes the IBM Cognos model and the reports.
Documentation can be found in the directory ReportsPackCampaign\cognos10\
CampaignDocs.

The Campaign reports retrieve data from one data source: the Campaign system
tables.

Reporting Schemas

The following reporting schemas are provided:
v Campaign Views provides the standard attribute views of the Campaign system

tables (campaign, offer, cell, and so on).
v Campaign Custom Attributes is for reporting on custom attributes of campaigns,

offers, and cells.
v Campaign Performance is used by reports that display performance

measurements starting at the campaign level over all time or various periods of
time (days, months, and so on).

v Offer Performance is used by reports that display performance measurements
starting at the offer level over all time or various periods of time (days, months,
and so on).

v Campaign Offer Response Breakout is used by reports that show campaign and
offer responses based on response types.

v Campaign Offer Contact Status Breakout is used for measurement of campaign
and offer contacts based on contact status.

The custom schemas extend the last five of the listed schemas to include the
default, preconfigured response types, custom attributes, and so on.
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Templates

If you have additional audience levels, you can create additional reporting schemas
for them with the following templates:
v Campaign Views
v Campaign Custom Attributes
v Campaign Performance
v Offer Performance
v Campaign Offer Response Breakout
v Campaign Offer Contact Status Breakout

Reports

The reports package contains Cognos example reports that can be accessed from
the Analytics menu or the Analysis tab for a campaign or offer. Reports can also be
displayed in portlets on the Dashboard.

The following campaign-specific example reports are available from the Campaign
Analysis tab:
v Campaign Detailed Offer Response Breakout
v Campaign Financial Summary by Offer (Actual)
v Campaign Offer Performance by Month
v Campaign Performance Summary by Cell
v Campaign Performance Summary by Cell with Revenue
v Campaign Performance Summary by Offer
v Campaign Performance Summary by Cell and Offer
v Campaign Performance Summary by Cell and Offer (with Revenue)

The following offer example reports are available from the Offer Analysis tab:
v "What If" Offer Financial Summary
v Offer Performance by Day
v Offer Performance Summary by Campaign

The following cross-object example reports include information about multiple
objects in Campaign. These reports are available from the Campaign Analytics
page.
v "What If" Offer Financial Summary
v Campaign Detailed Offer Response Breakout
v Campaign Financial Summary by Offer (Actual)
v Campaign Offer Performance by Month
v Campaign Performance Comparison
v Campaign Performance Comparison (with Revenue)
v Campaign Performance Comparison by Initiative
v Campaign Performance Summary by Cell
v Campaign Performance Summary by Cell (with Revenue)
v Campaign Performance Summary by Cell by Initiative
v Campaign Performance Summary by Offer
v Campaign Performance Summary by Offer (with Revenue)
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v Campaign Performance Summary by Cell and Offer
v Campaign Performance Summary by Cell and Offer (with Revenue)
v Campaign Summary
v Offer Campaign Listings
v Offer Performance by Day
v Offer Performance Comparison
v Offer Performance Metrics
v Offer Performance Summary by Campaign

The following campaign-specific example report portlets are available on
dashboard pages:
v Campaign Response Rate Comparison
v Campaign Return on Investment Comparison
v Campaign Revenue Comparison by Offer
v Offer Response Breakout
v Offer Response Rate Comparison
v Offer Responses for Last 7 Days

Chapter 6. IBM Campaign Reports Package 21



22 IBM Campaign: Release Notes v9.1.1



Chapter 7. IBM Campaign documentation roadmap

IBM Campaign provides documentation and help for users, administrators, and
developers.

Table 4. Get up and running

Task Documentation

Find out about new features, known issues, and
limitations

IBM Campaign Release Notes

Learn about the structure of the Campaign
system tables

IBM Campaign System Tables and Data Dictionary

Install or upgrade Campaign One of the following guides:

v IBM Campaign Installation Guide

v IBM Campaign Upgrade Guide

Implement the IBM Cognos reports provided
with Campaign

IBM EMM Reports Installation and Configuration Guide

Table 5. Configure and use Campaign

Task Documentation

v Adjust configuration and security settings

v Prepare Campaign for users

v Run utilities and perform maintenance

v Learn about integrations

IBM Campaign Administrator's Guide

v Create and deploy marketing campaigns

v Analyze campaign results

IBM Campaign User's Guide

Improve flowchart performance IBM Campaign Tuning Guide

Use Campaign functions IBM Macros for IBM EMM User's Guide

Table 6. Integrate Campaign with other products

Task Documentation

Integrate with eMessage The IBM Campaign Installation and Upgrade guides explain how to
install and prepare eMessage components in the local
environment. The IBM eMessage Startup and Administrator's Guide
explains how to connect to the hosted messaging resources. The
IBM Campaign Administrator's Guide explains how to configure
offer integration.

Integrate with Digital Analytics IBM Campaign Administrator's Guide

Integrate with IBM SPSS® Modeler Advantage
Marketing Edition

IBM Campaign and IBM SPSS Modeler Advantage Marketing Edition
Integration Guide

Integrate with Marketing Operations IBM Marketing Operations and IBM Campaign Integration Guide

Integrate with Opportunity Detect IBM Opportunity Detect User's Guide

Integrate with Silverpop Engage IBM Campaign and IBM Silverpop Engage Integration Guide
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Table 7. Develop for Campaign

Task Documentation

Develop custom procedures with the API v IBM Campaign Services API Specification

v JavaDocs in devkits\CampaignServicesAPI

Develop Java™ plug-ins or command-line
executables to add validation to Campaign

v IBM Campaign Validation PDK Guide

v JavaDocs in devkits\validation

Table 8. Get help

Task Instructions

Open online help 1. Choose Help > Help for this page to open a context-sensitive
help topic.

2. Click the Show Navigation icon in the help window to
display the full help.

Obtain PDFs Use any of the following methods:

v Choose Help > Product Documentation to access Campaign
PDFs.

v Choose Help > All IBM EMM Suite Documentation to access
all available documentation.

v Access all documentation during the installation process from
the IBM EMM installer.

Get support Go to http://www.ibm.com/ and click Support & downloads to
access the IBM Support Portal.
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Before you contact IBM technical support

If you encounter a problem that you cannot resolve by consulting the
documentation, your company's designated support contact can log a call with
IBM technical support. Use these guidelines to ensure that your problem is
resolved efficiently and successfully.

If you are not a designated support contact at your company, contact your IBM
administrator for information.

Note: Technical Support does not write or create API scripts. For assistance in
implementing our API offerings, contact IBM Professional Services.

Information to gather

Before you contact IBM technical support, gather the following information:
v A brief description of the nature of your issue.
v Detailed error messages that you see when the issue occurs.
v Detailed steps to reproduce the issue.
v Related log files, session files, configuration files, and data files.
v Information about your product and system environment, which you can obtain

as described in "System information."

System information

When you call IBM technical support, you might be asked to provide information
about your environment.

If your problem does not prevent you from logging in, much of this information is
available on the About page, which provides information about your installed IBM
applications.

You can access the About page by selecting Help > About. If the About page is not
accessible, check for a version.txt file that is located under the installation
directory for your application.

Contact information for IBM technical support

For ways to contact IBM technical support, see the IBM Product Technical Support
website: (http://www.ibm.com/support/entry/portal/open_service_request).

Note: To enter a support request, you must log in with an IBM account. This
account must be linked to your IBM customer number. To learn more about
associating your account with your IBM customer number, see Support Resources
> Entitled Software Support on the Support Portal.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
B1WA LKG1
550 King Street
Littleton, MA 01460-1250
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM's suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
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platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at "Copyright and
trademark information" at www.ibm.com/legal/copytrade.shtml.

Privacy Policy and Terms of Use Considerations
IBM Software products, including software as a service solutions, ("Software
Offerings") may use cookies or other technologies to collect product usage
information, to help improve the end user experience, to tailor interactions with
the end user or for other purposes. A cookie is a piece of data that a web site can
send to your browser, which may then be stored on your computer as a tag that
identifies your computer. In many cases, no personal information is collected by
these cookies. If a Software Offering you are using enables you to collect personal
information through cookies and similar technologies, we inform you about the
specifics below.

Depending upon the configurations deployed, this Software Offering may use
session and persistent cookies that collect each user's user name, and other
personal information for purposes of session management, enhanced user usability,
or other usage tracking or functional purposes. These cookies can be disabled, but
disabling them will also eliminate the functionality they enable.

Various jurisdictions regulate the collection of personal information through
cookies and similar technologies. If the configurations deployed for this Software
Offering provide you as customer the ability to collect personal information from
end users via cookies and other technologies, you should seek your own legal
advice about any laws applicable to such data collection, including any
requirements for providing notice and consent where appropriate.

IBM requires that Clients (1) provide a clear and conspicuous link to Customer's
website terms of use (e.g. privacy policy) which includes a link to IBM's and
Client's data collection and use practices, (2) notify that cookies and clear gifs/web
beacons are being placed on the visitor's computer by IBM on the Client's behalf
along with an explanation of the purpose of such technology, and (3) to the extent
required by law, obtain consent from website visitors prior to the placement of
cookies and clear gifs/web beacons placed by Client or IBM on Client's behalf on
website visitor's devices

For more information about the use of various technologies, including cookies, for
these purposes, See IBM's Online Privacy Statement at: http://www.ibm.com/
privacy/details/us/en section entitled "Cookies, Web Beacons and Other
Technologies."
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