Unica Campaign V12.1.1 Release Notes
Contents

Chapter 1. Release Notes for version 12.1.1................................................................. 1
  System requirements and compatibility................................................................. 1
  ................................................................................................................................. 1
  ................................................................................................................................. 2
New features and changes............................................................................................. 7
Fixed defects................................................................................................................... 8
Known issues in Campaign............................................................................................... 11
Known issues in Optimize............................................................................................... 13
Known limitations in Campaign...................................................................................... 13
Known limitations in Optimize...................................................................................... 14
Chapter 1. Release Notes for version 12.1.1

Contains information about new features, defect fixes, and known issues in Unica Campaign and Optimize that HCL releases as part of a scheduled software release.

System requirements and compatibility

Unica Campaign is part of the Unica suite of products. Unica Campaign version 12.1.1 requires Unica Platform 12.1.1

Where to find complete system requirement and compatibility information

For a list of Unica product versions compatible with this product and a list of third-party requirements for this product, see the Recommended Software Environments and Minimum System Requirements document.

You can also access this document by selecting Help > Product documentation when you are logged in to Unica.

Prerequisites for using Unica Campaign

Before you begin using Unica Campaign, confirm that your environment meets the following requirements.

- For an improved user experience, use at least a 21” screen.
- For an improved user experience, set your screen resolution to 1600 x 900. Lower resolutions can result in some information not being properly displayed. If you use a lower resolution, maximize the browser window to see more content.
- A mouse is best for navigating in the user interface.
- Do not use the browser controls to navigate. For example, avoid using the Back and Forward buttons. Instead, use the controls that are in the user interface.
- If pop-up blocker (ad blocker) software is installed on the client machine, Unica Campaign might not function properly. For best results, disable pop-up blocker software while running Unica Campaign.
• Ensure that the technical environment meets the minimum system requirements and the supported platforms.*
• The correct browser and versions must be used.*
• Clear the browser cache after upgrading or applying any fix pack. This only needs to be done once, after the application is updated.
• If you use Internet Explorer (IE) with Unica Campaign or any module that uses Unica Campaign flowcharts (Unica Deliver, Unica Optimize, Unica Interact, Unica Collaborate): To log in multiple times to view side-by-side information, open IE and log in to Unica. Then select **File > New Session** in the IE menu bar. In the new IE browser window, log in to Unica as the same or a different user.

**Important:** Do not use any other method to open multiple sessions. For example, do not open a new tab; do not open another browser session from the **Start** menu or desktop icon; and do not use **File > New Window** in IE. These methods can corrupt information that is shown in the application.

*For details on the items indicated by an asterisk, see the Unica Recommended Software Environments and Minimum System Requirements.

**Unica Campaign documentation roadmap**

Unica Campaign provides documentation and help for users, administrators, and developers.

<table>
<thead>
<tr>
<th>Table 1. Get up and running</th>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Find out about new features, known issues, and limitations</td>
<td>Unica Campaign Release Notes</td>
<td></td>
</tr>
<tr>
<td>Learn about the structure of the Unica Campaign system tables</td>
<td>Unica Campaign System Tables and Data Dictionary</td>
<td></td>
</tr>
<tr>
<td>Install or upgrade Unica Campaign</td>
<td>One of the following guides:</td>
<td></td>
</tr>
</tbody>
</table>
### Table 1. Get up and running (continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
</table>
| • Unica Campaign Installation Guide  
• Unica Campaign Upgrade Guide | |
| Unica Insights Reports for Unica Campaign | Unica Insights Installation and Configuration Guide |
| Implement the IBM Cognos® reports provided with Unica Campaign | Unica Reports Installation and Configuration Guide |

### Table 2. Configure and use Unica Campaign

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
</table>
| • Adjust configuration and security settings  
• Prepare Unica Campaign for users  
• Run utilities and perform maintenance  
• Learn about integrations | Unica Campaign Administrator’s Guide |
| • Create and deploy marketing campaigns  
• Analyze campaign results | Unica Campaign User’s Guide |
| Improve flowchart performance | Unica Campaign Tuning Guide |
| Use Unica Campaign functions | Macros for HCL Unica |

### Table 3. Integrate Unica Campaign with other HCL products

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrate with Acoustic</td>
<td>Campaign and Acoustic Integration Guide for IBM Marketing Cloud</td>
</tr>
</tbody>
</table>
### Table 3. Integrate Unica Campaign with other HCL products (continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrate with Coremetrics</td>
<td><em>Unica Campaign Administrator's Guide:</em> How to configure the integration</td>
</tr>
<tr>
<td></td>
<td>Unica Campaign User's Guide: Targeting IBM Digital Analytics segments in Campaigns</td>
</tr>
<tr>
<td>Integrate with Unica Plan</td>
<td>Unica Plan and Unica Campaign Integration Guide</td>
</tr>
<tr>
<td>Integrate with Opportunity Detect</td>
<td><em>Unica Campaign Administrator's Guide:</em> How to configure the integration</td>
</tr>
<tr>
<td>Integrate with Unica Deliver</td>
<td><em>Unica Campaign Installation and Upgrade guides:</em> How to install and prepare Deliver components in the local environment.</td>
</tr>
<tr>
<td></td>
<td>Unica Deliver Startup and Administrator’s Guide: How to connect to the hosted messaging resources.</td>
</tr>
<tr>
<td></td>
<td>Unica Campaign Administrator’s Guide: How to configure offer integration.</td>
</tr>
<tr>
<td>Integrate with IBM SPSS Modeler Advantage</td>
<td>*Unica Campaign and IBM SPSS Modeler Advantage Enterprise Marketing Management Edition Integration Guide</td>
</tr>
<tr>
<td>Integrate with IBM WeatherFX</td>
<td>You can integrate IBM WeatherFX with Campaign so that you can pull weather events into your marketing campaigns. Unica Campaign version 9 and version 10 users can integrate with WeatherFX by using the UBX toolkit.</td>
</tr>
</tbody>
</table>
# Integrate Unica Campaign with other HCL products (continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrate with Unica Director.</td>
<td><em>Unica Director Installation Guide:</em> You can integrate Unica Director with Campaign so that you can get status of all the running/completed/failed flowcharts, migrate Campaigns from one Unica Campaign environment to other, download/delete flowchart logs etc.</td>
</tr>
<tr>
<td>Integrate with Journey</td>
<td>Unica Campaign can integrate with Journey so that a continuous communication with users can be established based on the inputs from Campaign. Refer Campaign Administrators guide &gt; Unica Campaign and Unica Journeys integration</td>
</tr>
<tr>
<td>Integrate with Link</td>
<td>Unica Campaign uses Link capabilities of connectors which include the configuration and provisioning to connect to any delivery channel. Refer Campaign Administrators guide &gt; Unica Campaign and Unica Link integration</td>
</tr>
</tbody>
</table>

**Note:** Additional integrations may be available that are not listed in this table. See Product tools and utilities for Unica Campaign.

---

# Develop for Unica Campaign

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the REST API</td>
<td>See the Unica Campaign REST API</td>
</tr>
</tbody>
</table>
| Use the SOAP API   | • See the Unica Campaign SOAP API Specification  
|                    | • JavaDocs in `devkits\CampaignServicesAPI` |
### Table 4. Develop for Unica Campaign (continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Documentation</th>
</tr>
</thead>
</table>
| Develop Java™ plug-ins or command-line executables to add validation to Unica Campaign | • See the Unica Campaign Validation PDK Guide  
• Java-docs in `devkits/validation` |

### Table 5. Get help

<table>
<thead>
<tr>
<th>Task</th>
<th>Instructions</th>
</tr>
</thead>
</table>
| Open online help | When using the Unica Campaign application:  
1. Choose Help > Help for this page to open a context-sensitive help topic.  
2. Click the Show navigation icon in the help window to display the full help.  
You must have web access to view context-sensitive online help. Contact Support for more information about accessing and installing Knowledge Center locally for offline documentation. |
| Get PDFs | When using the Unica Campaign application:  
• Choose Help > Product documentation to access Unica Campaign PDFs.  
• Choose Help > All Unica documentation to access all product PDFs.  
• Click the links for PDFs during the installation process. |
New features and changes in version 12.1.1

Unica Campaign 12.1.1 includes a number of new features and changes. These are listed underneath.

For a list of newly supported and discontinued platforms, see the Recommended Software Environments and Minimum System Requirements guide.

Upgrade Paths

- Supported upgrade path via installers: 12.1.0 -> 12.1.1 and 12.1.0.x -> 12.1.1
- Customers prior to 11.1.x must perform Fast upgrade to 12.1 and then upgrade to 12.1.1

Fast Upgrade

Unica Campaign 12.1 supports the fast upgrade approach. This approach allows upgrades from version 8.6 onwards to version 12.1. This helps customers bypassing the multi-step upgrade. The Fast Upgrade approach is also useful in reducing upgrade downtime. The approach is provided for Unica Platform, Campaign, Optimize, Plan, Interact for upgrade from 8.6.x version onwards. For details, see the Fast Upgrade documentation released with version 12.1. After version 12.1, we can perform in_place upgrade till version 12.1.1.

Optimize Campaign Decoupling

In V12.1.1 Unica Campaign suite, user can decouple campaigns from the Optimize session without having to modify flowchart

Custom DB Function

Unica Campaign V12.1.1 supports custom DB functions for ORACLE, DB2, Oracle ODBC and MSSQL

Concurrent flowchart access depiction

When users access a flowchart already in edit mode they will get status on flowchart toolbar <user name> is working. On clicking the edit button in the flowchart toolbar, user will
get a message Flowchart is in use by user <user name>. Do you still want to continue? If you click OK, changes made by user <user name> will be lost.

**Campaign support for Journey CH/RH**

Unica Campaign V12.1.1 supports Contact History and Response history from Unica Journey.

**Campaign REST APIs to share segments with other tools**

New REST API provided to query strategic segments related data from third party tools.

**Return cell counts from flowchart and process box APIs**

New REST API provided to query status of process boxes in a flowchart and related cell counts

**Kafka as output data source**

Snapshot process box can be configured to export selected fields in JSON format to a Kafka. This provides a way for third party tools to consume data from a flowchart

**Insights- Enhance reports from Campaign product**

Enhanced UI of Insights reports under Campaign Analytics. With this change, reports are consistent visually and properly spaced to improve readability.

**Send time optimization**

Unica Open Insights provides the best hour of day for the email recipients based on their past interactions. This information can be used in the upcoming Deliver campaigns. For more details on implementing send time optimization, see the Unica Campaign User Guide.

**Fixed defects in Unica Campaign V12.1.1**

The following defects were fixed in Unica Campaign 12.1.1.

<table>
<thead>
<tr>
<th>Issue ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HMA-323311</td>
<td>Phishing via Content Spoofing</td>
</tr>
<tr>
<td>Incident ID</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td>HMA-326516</td>
<td>Process box configuration and Flowchart options are Blank-12.1.1</td>
</tr>
<tr>
<td>HMA-270339</td>
<td>Screen jumps in certain cell selections in IE11</td>
</tr>
<tr>
<td>HMA-135346</td>
<td>Campaign Waterfall report shows unknown for segment counts</td>
</tr>
<tr>
<td>HMA-322073</td>
<td>Not able to use table field as integer value in ADD_MONTHS macro</td>
</tr>
<tr>
<td>HMA-222618</td>
<td>Error Control cell not linked to any target</td>
</tr>
<tr>
<td>HMA-327746</td>
<td>No warning/error message on UI while deleting optimize session linked to flowchart</td>
</tr>
<tr>
<td>HMA-218314</td>
<td>Defect to fix 10404 error</td>
</tr>
<tr>
<td>HMA-318518</td>
<td>Parameter, ‘SegmentTablePostExecutionSQL’, is missing in MariaDB datasource.</td>
</tr>
<tr>
<td>HMA-291963</td>
<td>Browse table in table mapping feature not to be used</td>
</tr>
<tr>
<td>HMA-325862</td>
<td>Flowchart log process count doesn't match UI result</td>
</tr>
<tr>
<td>HMA-326477</td>
<td>Installer - Campaign configuration change for campaign_log4j.xml</td>
</tr>
<tr>
<td>HMA-90239</td>
<td>SCROLLING ISSUES WHILE MAPPING TABLES</td>
</tr>
<tr>
<td>HMA-319040</td>
<td>Inconsistent Date Format</td>
</tr>
<tr>
<td>HMA-310769</td>
<td>Current_date() macro is not compatible with impala datasource</td>
</tr>
<tr>
<td>Issue ID</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HMA-319036</td>
<td>Error in exporting data to Cloudera data-source via snapshot</td>
</tr>
<tr>
<td>HMA-325765</td>
<td>Blank process box page when followed specific path for Non en_US locale</td>
</tr>
<tr>
<td>HMA-329369</td>
<td>Stored Cross-Site Scripting in Cell Code in TCS</td>
</tr>
<tr>
<td>HMA-326014</td>
<td>Some of the Process boxes cross out after indicating successful flowchart run</td>
</tr>
<tr>
<td>HMA-325486</td>
<td>UBX download ETL: Could not obtain WebSphere Liberty transaction manager</td>
</tr>
<tr>
<td>HMA-326748</td>
<td>Tables are highlighted in blue to appear as they are selected even when they are not within Select process box</td>
</tr>
<tr>
<td>HMA-327010</td>
<td>Problems with Segment process after upgrade to 12.1.0.FP4</td>
</tr>
<tr>
<td>HMA-328565</td>
<td>Problem with SSL and kafka</td>
</tr>
<tr>
<td>HMA-328513</td>
<td>unica_acsesutil processes are running out of control; spawning indefinitely over time eventually crashing the server</td>
</tr>
<tr>
<td>HMA-322608</td>
<td>advSrchAgent.sh fails with error, &quot;Error: Partition specified is not correct!&quot;</td>
</tr>
<tr>
<td>HMA-325071</td>
<td>UCGF.rundate value when used in string concat function gives null output</td>
</tr>
<tr>
<td>HMA-324058</td>
<td>Missing *spring_update.xml files for Campaign 12.1.0.0 fast upgrade guide.</td>
</tr>
<tr>
<td>HMA-323759</td>
<td>&quot;OPEN JDK 1.8.0.275&quot; incompatibility issues during UNICA 12.x upgrade</td>
</tr>
<tr>
<td>Issue ID</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HMA-246488</td>
<td>DOCUMENT DEFECT REGARDING CLASS LOADER SETTINGS</td>
</tr>
<tr>
<td>HMA-325067</td>
<td>CODE 10634: Incompatible sort order detected.</td>
</tr>
</tbody>
</table>

**Known issues in Unica Campaign V12.1.1**

Unica Campaign 12.1.1 includes the following known issues.

<table>
<thead>
<tr>
<th>Issue ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HMA-326854</td>
<td>Incorrect date format written to UA_OFFERHISTATTRIB from mail list process box</td>
</tr>
<tr>
<td>HMA-331085</td>
<td>Documentation - Docker : Use -async option while running ACOOptAdmin utility</td>
</tr>
<tr>
<td>HMA-330431</td>
<td>Campaign Offer reports show incorrect data when SAME offer is used in Campaign as well as Journey</td>
</tr>
<tr>
<td>HMA330613</td>
<td>DOC Help URL is not working for English,French and German locales.</td>
</tr>
<tr>
<td>HMA-330562</td>
<td>Docker : Campaign kafka template is missing for Docker</td>
</tr>
<tr>
<td></td>
<td>For resolution on this, please contact HCL Unica support team.</td>
</tr>
<tr>
<td>HMA-326516</td>
<td>Process box configuration and Flowchart options are Blank.</td>
</tr>
<tr>
<td>HMA-330433</td>
<td>User is not able to login to platform after upgrade to 12.1.1 in case Deliver is configured.</td>
</tr>
</tbody>
</table>
Resolution

Execute below query on Platform database:

```sql
select * from usm_role_role_map where role_id = (select ID from usm_role where name='Deliver_admin' and application=101 and partition_id=<>)
```

Specify actual partition id in above query, default for partition1, partition id =1, it varies for multiple partitions.

If above result in more than one row, contact HCL support to help in executing below delete query - delete one of the duplicate record of *D*eliver_admin role by running below query:

```sql
delete from usm_role_role_map where role_id = (select ID from usm_role where name='Deliver_admin' and application=101 and partition_id=<>) and parent_role_id=<partition_id>
```

For example, for partition id =1,

```sql
delete from usm_role_role_map where role_id = (select ID from usm_role where name='Deliver_admin' and application=101 and partition_id=1) and parent_role_id=1
```

HMA-306326

JNDI creation for Campaign installer with Informix database and Websphere application server is not creating JNDI with correct details. Create JNDI connection
Unica Campaign V12.1.1 Release Notes

<table>
<thead>
<tr>
<th>Issue ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HMA-306329</td>
<td>JNDI creation for Campaign installer with Informix database and Tomcat application server is not creating JNDI with correct details. Create JNDI connection manually in Tomcat with Informix referring to the Campaign Installation guide.</td>
</tr>
</tbody>
</table>

**Known issues in Optimize V12.1**

No known issues for Optimize V12.1.1

**Known limitations in Unica Campaign V12.1.1**

Unica Campaign 12.1.1 includes the following known limitations.

<table>
<thead>
<tr>
<th>Issue ID</th>
<th>Description</th>
</tr>
</thead>
</table>
| HMA-330347 | Users can use Sankey flowchart to view waterfall information. This solution is offered with certain limitations:
For huge flowcharts, with approximately 50+ process boxes, clearly displaying all process boxes and related flow is difficult. The information or labels may get overlapped and thus look cluttered. Users are advised to use zoom in and zoom out feature along with scrollbars to navigate to area of interest for better picture. |
| HMA-291963 | Browse table in table mapping feature not to be used |
Known limitations in Unica Optimize V12.1.1

No known limitations for Optimize V12.1.1